Class file ProtegeOWL has a wrong version 49.0, it should be 48.0

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Class file ProtegeOWL has a wrong version 49.0, it should be 48.0

nini-2

 

Dear all,

 

I use J2sdk 1.5 and Protégé 3.2 beta.

I could not create an OWLModel using ProtegeOWL.createJenaOWLModelFromURI(URI).

At the compile time, the error says class file ProtegeOWL has a wrong version 49.0, it should be 48.0.

Any solution is wanted!!

 

nini

*****************************************************
Nwe Ni Tun
Knowledge Engineering Laboratory
School of Information Science
Japan Advanced Institute of Science and Technology
www: http://www.jaist.ac.jp/~nitun/index.html
*****************************************************

 

Reply | Threaded
Open this post in threaded view
|

Re: Class file ProtegeOWL has a wrong version 49.0, it should be 48.0

Nick Drummond
This is because you are mixing old and new libraries.

Make sure all of the libraries you compile with for 3.2 are compiled
using jdk 1.5

Nick

nini wrote:

>  
>
> Dear all,
>
>  
>
> I use J2sdk 1.5 and Protégé 3.2 beta.
>
> I could not create an OWLModel using
> ProtegeOWL.createJenaOWLModelFromURI(URI).
>
> At the compile time, the error says class file ProtegeOWL has a wrong
> version 49.0, it should be 48.0.
>
> Any solution is wanted!!
>
>  
>
> nini
>
> *****************************************************
> Nwe Ni Tun
> Knowledge Engineering Laboratory
> School of Information Science
> Japan Advanced Institute of Science and Technology
> www: http://www.jaist.ac.jp/~nitun/index.html 
> <http://www.jaist.ac.jp/%7Enitun/index.html>
> *****************************************************
>
>  
>

--

Nick Drummond

http://www.cs.man.ac.uk/~drummond/ <http://www.cs.man.ac.uk/%7Edrummond/>
-------------------------------------------------------------------------
To unsubscribe go to http://protege.stanford.edu/community/subscribe.html