Fact++ pugin does not install

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Fact++ pugin does not install

Henk Matthezing

Hello everyone

 

I recently downloaded and installed Protégé 4 build 111 (beta)

On startup I get the error message that the fact++ plugin does not install:

 

ERROR Could not install plugin in file/directory named plugins\uk.ac.manchester.cs.owl.factplusplus.jar  org.protege.editor.core.BundleManager[Start Level Event Dispatcher]

org.osgi.framework.BundleException: No Bundle-NativeCode match

 

I saw a message in this list archive with the same kind of problem for an AMD64/Win2003 conf. dated may 8 2008

 

I’m running P4 on

Windows Vista home Premium V 6.0 SP1 (build 6001)

jdk1.5.0_08

CPU Intel Core Duo T2750

 

Below is today’s log file content with the error message

 

Anyone knows how to solve this or if this a bug still to be fixed?

 

TIA for your answer

Kind regards

Henk

 

-----------------------------------------------------------------------

Henk Matthezing

Koninklijke Bibliotheek / National Library of the Netherlands

Research & Development – PLANETS

POB 90407 – 2509 LK Den Haag / The Hague – The Netherlands

Phone: +31 70 31 40 248 – Mobile: +31 6 12 46 17 55

[hidden email]  –  http://www.kb.nl 

LinkedIn: http://www.linkedin.com/in/henkmatthezing

INFO  Starting Protege 4 OWL Editor (Version 4.0.111)  org.protege.editor.core.ProtegeApplication[Start Level Event Dispatcher]

INFO  Platform:  org.protege.editor.core.ProtegeApplication[Start Level Event Dispatcher]

INFO      Java: JVM 1.5.0_08-b03 Memory: 208M  org.protege.editor.core.ProtegeApplication[Start Level Event Dispatcher]

INFO      Language: nl, Country: NL  org.protege.editor.core.ProtegeApplication[Start Level Event Dispatcher]

INFO      Framework: Eclipse (1.4.0)  org.protege.editor.core.ProtegeApplication[Start Level Event Dispatcher]

INFO      OS: windows nt (unknown) (6.0)  org.protege.editor.core.ProtegeApplication[Start Level Event Dispatcher]

INFO      Processor: x86  org.protege.editor.core.ProtegeApplication[Start Level Event Dispatcher]

INFO  Installed plugin Pellet Reasoner  org.protege.editor.core.BundleManager[Start Level Event Dispatcher]

INFO  Installed plugin DL Query Tab  org.protege.editor.core.BundleManager[Start Level Event Dispatcher]

INFO  Installed plugin Owlviz Plug-in  org.protege.editor.core.BundleManager[Start Level Event Dispatcher]

INFO  Installed plugin owleditor  org.protege.editor.core.BundleManager[Start Level Event Dispatcher]

INFO  Installed plugin Protege SKOS plugin  org.protege.editor.core.BundleManager[Start Level Event Dispatcher]

INFO  Installed plugin The OWL API  org.protege.editor.core.BundleManager[Start Level Event Dispatcher]

ERROR Could not install plugin in file/directory named plugins\uk.ac.manchester.cs.owl.factplusplus.jar  org.protege.editor.core.BundleManager[Start Level Event Dispatcher]

org.osgi.framework.BundleException: No Bundle-NativeCode match

                at org.eclipse.osgi.framework.internal.core.Framework.noMatches(Framework.java:1666)

                at org.eclipse.osgi.framework.internal.core.Framework.selectNativeCode(Framework.java:1018)

                at org.eclipse.osgi.framework.internal.core.Framework.installWorkerPrivileged(Framework.java:920)

                at org.eclipse.osgi.framework.internal.core.Framework$1.run(Framework.java:794)

                at java.security.AccessController.doPrivileged(Native Method)

                at org.eclipse.osgi.framework.internal.core.Framework.installWorker(Framework.java:875)

                at org.eclipse.osgi.framework.internal.core.Framework.installBundle(Framework.java:789)

                at org.eclipse.osgi.framework.internal.core.BundleContextImpl.installBundle(BundleContextImpl.java:210)

                at org.protege.editor.core.BundleManager.installPlugins(BundleManager.java:95)

                at org.protege.editor.core.BundleManager.loadPlugins(BundleManager.java:47)

                at org.protege.editor.core.ProtegeApplication.loadPlugins(ProtegeApplication.java:265)

                at org.protege.editor.core.ProtegeApplication.initApplication(ProtegeApplication.java:160)

                at org.protege.editor.core.ProtegeApplication.start(ProtegeApplication.java:107)

                at org.eclipse.osgi.framework.internal.core.BundleContextImpl$2.run(BundleContextImpl.java:999)

                at java.security.AccessController.doPrivileged(Native Method)

                at org.eclipse.osgi.framework.internal.core.BundleContextImpl.startActivator(BundleContextImpl.java:993)

                at org.eclipse.osgi.framework.internal.core.BundleContextImpl.start(BundleContextImpl.java:974)

                at org.eclipse.osgi.framework.internal.core.BundleHost.startWorker(BundleHost.java:346)

                at org.eclipse.osgi.framework.internal.core.AbstractBundle.resume(AbstractBundle.java:350)

                at org.eclipse.osgi.framework.internal.core.Framework.resumeBundle(Framework.java:1118)

                at org.eclipse.osgi.framework.internal.core.StartLevelManager.resumeBundles(StartLevelManager.java:634)

                at org.eclipse.osgi.framework.internal.core.StartLevelManager.incFWSL(StartLevelManager.java:508)

                at org.eclipse.osgi.framework.internal.core.StartLevelManager.doSetStartLevel(StartLevelManager.java:282)

                at org.eclipse.osgi.framework.internal.core.StartLevelManager.dispatchEvent(StartLevelManager.java:468)

                at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:195)

                at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:297)

 

 

 


_______________________________________________
p4-feedback mailing list
[hidden email]
https://mailman.stanford.edu/mailman/listinfo/p4-feedback
Reply | Threaded
Open this post in threaded view
|

Re: Fact++ pugin does not install

Nick Drummond
Hi,

I think I've fixed it. I'll send you a version privately for you to test.

Cheers

Nick


2009/6/11 Henk Matthezing <[hidden email]>:

> Hello everyone
>
>
>
> I recently downloaded and installed Protégé 4 build 111 (beta)
>
> On startup I get the error message that the fact++ plugin does not install:
>
>
>
> ERROR Could not install plugin in file/directory named
> plugins\uk.ac.manchester.cs.owl.factplusplus.jar
> org.protege.editor.core.BundleManager[Start Level Event Dispatcher]
>
> org.osgi.framework.BundleException: No Bundle-NativeCode match
>
>
>
> I saw a message in this list archive with the same kind of problem for an
> AMD64/Win2003 conf. dated may 8 2008
>
>
>
> I’m running P4 on
>
> Windows Vista home Premium V 6.0 SP1 (build 6001)
>
> jdk1.5.0_08
>
> CPU Intel Core Duo T2750
>
>
>
> Below is today’s log file content with the error message
>
>
>
> Anyone knows how to solve this or if this a bug still to be fixed?
>
>
>
> TIA for your answer
>
> Kind regards
>
> Henk
>
>
>
> -----------------------------------------------------------------------
>
> Henk Matthezing
>
> Koninklijke Bibliotheek / National Library of the Netherlands
>
> Research & Development – PLANETS
>
> POB 90407 – 2509 LK Den Haag / The Hague – The Netherlands
>
> Phone: +31 70 31 40 248 – Mobile: +31 6 12 46 17 55
>
> [hidden email]  –  http://www.kb.nl
>
> LinkedIn: http://www.linkedin.com/in/henkmatthezing
>
> INFO  Starting Protege 4 OWL Editor (Version 4.0.111)
> org.protege.editor.core.ProtegeApplication[Start Level Event Dispatcher]
>
> INFO  Platform:  org.protege.editor.core.ProtegeApplication[Start Level
> Event Dispatcher]
>
> INFO      Java: JVM 1.5.0_08-b03 Memory: 208M
> org.protege.editor.core.ProtegeApplication[Start Level Event Dispatcher]
>
> INFO      Language: nl, Country: NL
> org.protege.editor.core.ProtegeApplication[Start Level Event Dispatcher]
>
> INFO      Framework: Eclipse (1.4.0)
> org.protege.editor.core.ProtegeApplication[Start Level Event Dispatcher]
>
> INFO      OS: windows nt (unknown) (6.0)
> org.protege.editor.core.ProtegeApplication[Start Level Event Dispatcher]
>
> INFO      Processor: x86  org.protege.editor.core.ProtegeApplication[Start
> Level Event Dispatcher]
>
> INFO  Installed plugin Pellet Reasoner
> org.protege.editor.core.BundleManager[Start Level Event Dispatcher]
>
> INFO  Installed plugin DL Query Tab
> org.protege.editor.core.BundleManager[Start Level Event Dispatcher]
>
> INFO  Installed plugin Owlviz Plug-in
> org.protege.editor.core.BundleManager[Start Level Event Dispatcher]
>
> INFO  Installed plugin owleditor
> org.protege.editor.core.BundleManager[Start Level Event Dispatcher]
>
> INFO  Installed plugin Protege SKOS plugin
> org.protege.editor.core.BundleManager[Start Level Event Dispatcher]
>
> INFO  Installed plugin The OWL API
> org.protege.editor.core.BundleManager[Start Level Event Dispatcher]
>
> ERROR Could not install plugin in file/directory named
> plugins\uk.ac.manchester.cs.owl.factplusplus.jar
> org.protege.editor.core.BundleManager[Start Level Event Dispatcher]
>
> org.osgi.framework.BundleException: No Bundle-NativeCode match
>
>                 at
> org.eclipse.osgi.framework.internal.core.Framework.noMatches(Framework.java:1666)
>
>                 at
> org.eclipse.osgi.framework.internal.core.Framework.selectNativeCode(Framework.java:1018)
>
>                 at
> org.eclipse.osgi.framework.internal.core.Framework.installWorkerPrivileged(Framework.java:920)
>
>                 at
> org.eclipse.osgi.framework.internal.core.Framework$1.run(Framework.java:794)
>
>                 at java.security.AccessController.doPrivileged(Native
> Method)
>
>                 at
> org.eclipse.osgi.framework.internal.core.Framework.installWorker(Framework.java:875)
>
>                 at
> org.eclipse.osgi.framework.internal.core.Framework.installBundle(Framework.java:789)
>
>                 at
> org.eclipse.osgi.framework.internal.core.BundleContextImpl.installBundle(BundleContextImpl.java:210)
>
>                 at
> org.protege.editor.core.BundleManager.installPlugins(BundleManager.java:95)
>
>                 at
> org.protege.editor.core.BundleManager.loadPlugins(BundleManager.java:47)
>
>                 at
> org.protege.editor.core.ProtegeApplication.loadPlugins(ProtegeApplication.java:265)
>
>                 at
> org.protege.editor.core.ProtegeApplication.initApplication(ProtegeApplication.java:160)
>
>                 at
> org.protege.editor.core.ProtegeApplication.start(ProtegeApplication.java:107)
>
>                 at
> org.eclipse.osgi.framework.internal.core.BundleContextImpl$2.run(BundleContextImpl.java:999)
>
>                 at java.security.AccessController.doPrivileged(Native
> Method)
>
>                 at
> org.eclipse.osgi.framework.internal.core.BundleContextImpl.startActivator(BundleContextImpl.java:993)
>
>                 at
> org.eclipse.osgi.framework.internal.core.BundleContextImpl.start(BundleContextImpl.java:974)
>
>                 at
> org.eclipse.osgi.framework.internal.core.BundleHost.startWorker(BundleHost.java:346)
>
>                 at
> org.eclipse.osgi.framework.internal.core.AbstractBundle.resume(AbstractBundle.java:350)
>
>                 at
> org.eclipse.osgi.framework.internal.core.Framework.resumeBundle(Framework.java:1118)
>
>                 at
> org.eclipse.osgi.framework.internal.core.StartLevelManager.resumeBundles(StartLevelManager.java:634)
>
>                 at
> org.eclipse.osgi.framework.internal.core.StartLevelManager.incFWSL(StartLevelManager.java:508)
>
>                 at
> org.eclipse.osgi.framework.internal.core.StartLevelManager.doSetStartLevel(StartLevelManager.java:282)
>
>                 at
> org.eclipse.osgi.framework.internal.core.StartLevelManager.dispatchEvent(StartLevelManager.java:468)
>
>                 at
> org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:195)
>
>                 at
> org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:297)
>
>
>
>
>
>
>
> _______________________________________________
> p4-feedback mailing list
> [hidden email]
> https://mailman.stanford.edu/mailman/listinfo/p4-feedback
>
>
_______________________________________________
p4-feedback mailing list
[hidden email]
https://mailman.stanford.edu/mailman/listinfo/p4-feedback