Fw: Problems importing an ontology from the OWL API

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Fw: Problems importing an ontology from the OWL API

Jesús Prieto
 
Hello,
 
I forward a message I think it was not answered:
 
----- Original Message -----
Sent: Monday, December 12, 2005 10:11 PM
Subject: Problems importing an ontology from the OWL API

Hello,
 
I have a problem while importing an ontology from the java API. I try to import http://localhost:8080/mgmt/PBMOntology.owl (an ontology which is located in a http server installed on my PC), and the importing process works well. But in the metadata tab I can see as imported URI "null//localhost:8080/mgmt/PBMOntology.owl". This is a problem because my plugin must check if this ontology is installed by means of its importing URI. I am using Protege 3.2 beta.
 
Best Regards, Jesus Prieto.
Reply | Threaded
Open this post in threaded view
|

Re: Fw: Problems importing an ontology from the OWL API

Matthew Horridge
Hi Jesus,

This item was fixed in the latest beta (I think there were some posts about it on the list and it's also in the bug tracker - sorry I didn't reply directly).

To do your imports, please use the ImportHelper class which is located in the model.util package - the ImportHelper class takes care of all the house keeping tasks that are needed (if some of these tasks were missed or were carried out in the wrong order, then the null problem occurred).

Cheers,

Matthew


On 25 Jan 2006, at 20:49, Jesús Prieto wrote:

 
Hello,
 
I forward a message I think it was not answered:
 
----- Original Message -----
Sent: Monday, December 12, 2005 10:11 PM
Subject: Problems importing an ontology from the OWL API

Hello,
 
I have a problem while importing an ontology from the java API. I try to import http://localhost:8080/mgmt/PBMOntology.owl (an ontology which is located in a http server installed on my PC), and the importing process works well. But in the metadata tab I can see as imported URI "null//localhost:8080/mgmt/PBMOntology.owl". This is a problem because my plugin must check if this ontology is installed by means of its importing URI. I am using Protege 3.2 beta.
 
Best Regards, Jesus Prieto.