JRELoadError on Mac

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

JRELoadError on Mac

Denes Nagy
Hi,

I did a clean install on my desktop (MacOS High Sierra), and when trying to start the protege app I get "JRELoadError".
I tried version 5.5 as well as version 5.2, but I still get the same error message.
I have a clean install of the newest JRE, and also tried the platform independent version, which gives me the following error message:

Starting bundle org.semanticweb.hermit 

Starting bundle uk.ac.manchester.cs.owl.explanation 

Starting bundle org.protege.owl.rdf 

Starting bundle org.protege.ontograf 

Starting bundle org.coode.browser 

Starting bundle org.protege.editor.owl.rdf 

Starting bundle swrltab-plugin 

Starting bundle org.coode.owlviz 

Starting bundle cellfie 

Starting bundle org.coode.dlquery 

Starting bundle code-generation 

Error starting file:/Users/denesakosnagy/Downloads/Protege-5.2-2.0/bundles/protege-common.jar 

org.osgi.framework.BundleException: Unresolved constraint in bundle org.protege.common [1]: Unable to resolve 1.0: missing requirement [1.0] osgi.wiring.package; (&(osgi.wiring.package=org.slf4j)(version>=1.7.0)(!(version>=2.0.0))) [caused by: Unable to resolve 10.0: missing requirement [10.0] osgi.ee; (&(osgi.ee=JavaSE)(version=1.5.0))]

at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4002) ~[org.apache.felix.main.jar:na]

at org.apache.felix.framework.Felix.startBundle(Felix.java:2045) ~[org.apache.felix.main.jar:na]

at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1299) ~[org.apache.felix.main.jar:na]

at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:304) ~[org.apache.felix.main.jar:na]

at java.base/java.lang.Thread.run(Thread.java:834) ~[na:na]


I really appreciate your help!
Denes

Dr. Dénes Ákos Nagy

Antal Bejczy Center for Intelligent Robotics
Óbuda University, Budapes, Hungary

_______________________________________________
protege-dev mailing list
[hidden email]
https://mailman.stanford.edu/mailman/listinfo/protege-dev
Reply | Threaded
Open this post in threaded view
|

Re: JRELoadError on Mac

Csongor Nyulas
Administrator
Hi Dénes,

I am not a Mac user, so I may not be the best person to debug this, but this could be due to trying to run Protege with the wrong version?
Both Protege 5.2 and 5.5 needs Java 8 to run. The platform specific distribution comes with JRE 8 bundled.

Csongor



On 3/11/19 4:25 PM, Denes Nagy wrote:
Hi,

I did a clean install on my desktop (MacOS High Sierra), and when trying to start the protege app I get "JRELoadError".
I tried version 5.5 as well as version 5.2, but I still get the same error message.
I have a clean install of the newest JRE, and also tried the platform independent version, which gives me the following error message:

Starting bundle org.semanticweb.hermit 

Starting bundle uk.ac.manchester.cs.owl.explanation 

Starting bundle org.protege.owl.rdf 

Starting bundle org.protege.ontograf 

Starting bundle org.coode.browser 

Starting bundle org.protege.editor.owl.rdf 

Starting bundle swrltab-plugin 

Starting bundle org.coode.owlviz 

Starting bundle cellfie 

Starting bundle org.coode.dlquery 

Starting bundle code-generation 

Error starting file:/Users/denesakosnagy/Downloads/Protege-5.2-2.0/bundles/protege-common.jar 

org.osgi.framework.BundleException: Unresolved constraint in bundle org.protege.common [1]: Unable to resolve 1.0: missing requirement [1.0] osgi.wiring.package; (&(osgi.wiring.package=org.slf4j)(version>=1.7.0)(!(version>=2.0.0))) [caused by: Unable to resolve 10.0: missing requirement [10.0] osgi.ee; (&(osgi.ee=JavaSE)(version=1.5.0))]

at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4002) ~[org.apache.felix.main.jar:na]

at org.apache.felix.framework.Felix.startBundle(Felix.java:2045) ~[org.apache.felix.main.jar:na]

at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1299) ~[org.apache.felix.main.jar:na]

at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:304) ~[org.apache.felix.main.jar:na]

at java.base/java.lang.Thread.run(Thread.java:834) ~[na:na]


I really appreciate your help!
Denes

Dr. Dénes Ákos Nagy

Antal Bejczy Center for Intelligent Robotics
Óbuda University, Budapes, Hungary

_______________________________________________
protege-dev mailing list
[hidden email]
https://mailman.stanford.edu/mailman/listinfo/protege-dev


_______________________________________________
protege-dev mailing list
[hidden email]
https://mailman.stanford.edu/mailman/listinfo/protege-dev