PROMPT tutoria failing in v3.1 and 3.2 beta

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

PROMPT tutoria failing in v3.1 and 3.2 beta

David Buttler

Hi All,

I have downloaded the recent builds of protege today to try out the
ontology mapping features of PROMPT.  I followed the instructions in the
PROMPT tutorial in both v3.1 and 3.2 beta (the beta version feels much
faster by the way, and produces fewer warnings).

However, in both versions I get to the point in the tutorial described
by the page "merging_slots.htm", and I get a NPE
at
edu.stanford.smi.protegex.prompt.MappingKnowledgeBase.findLocalMappingsFromClses
(line 654) [sorry, the full stack trace is not reproduced here as I
don't seem to be able to copy and paste from the terminal window opened]

Is there anything I can do to get around this?  Am I the only one to
encounter this particular bug?  I didn't see any similar bug recorded in
the last few months on the mailing lists.

Thanks for your help,
David Buttler

-------------------------------------------------------------------------
To unsubscribe go to http://protege.stanford.edu/community/subscribe.html

Reply | Threaded
Open this post in threaded view
|

Re: PROMPT tutoria failing in v3.1 and 3.2 beta

Timothy Redmond


There is a bug here and I opened a bug report for it.  I don't know  
why this happens yet.

-Timothy

--------------------------------
Timothy Redmond, PhD
Research Staff
Stanford Medical Informatics
Medical School Office Building X-215
251 Campus Drive
Stanford, CA 94305
E-mail: [hidden email]
Skype: stdotjohn


On Feb 13, 2006, at 3:33 PM, David Buttler wrote:

>
> Hi All,
>
> I have downloaded the recent builds of protege today to try out the
> ontology mapping features of PROMPT.  I followed the instructions  
> in the
> PROMPT tutorial in both v3.1 and 3.2 beta (the beta version feels much
> faster by the way, and produces fewer warnings).
>
> However, in both versions I get to the point in the tutorial described
> by the page "merging_slots.htm", and I get a NPE
> at
> edu.stanford.smi.protegex.prompt.MappingKnowledgeBase.findLocalMapping
> sFromClses
> (line 654) [sorry, the full stack trace is not reproduced here as I
> don't seem to be able to copy and paste from the terminal window  
> opened]
>
> Is there anything I can do to get around this?  Am I the only one to
> encounter this particular bug?  I didn't see any similar bug  
> recorded in
> the last few months on the mailing lists.
>
> Thanks for your help,
> David Buttler
>
> ----------------------------------------------------------------------
> ---
> To unsubscribe go to http://protege.stanford.edu/community/ 
> subscribe.html
>

-------------------------------------------------------------------------
To unsubscribe go to http://protege.stanford.edu/community/subscribe.html