Problem with Protege 4.3

classic Classic list List threaded Threaded
9 messages Options
Reply | Threaded
Open this post in threaded view
|

Problem with Protege 4.3

Marla Barrera
Hi:

I have a problem with Protege 4.3, when I want to execute a SPARQL query, it
appears the nex error: "SparqlReasonerException:
java.lang.IllegalArgumentException:
org.openrdf.query.parser.QueryParserFactory is not an ImageIO SPI class"

And with Ontograph, log shows this error: "NoClassDefFoundError:
sun/dc/path/PathException"

My computer uses Linux Mint 19 and Java 11 (I tried to install java 8 but I
cannot install it).

I am very thanful for your suggestions.

Thanks.

Marla B.



--
Sent from: http://protege-project.136.n4.nabble.com/Protege-User-f4659818.html
_______________________________________________
protege-user mailing list
[hidden email]
https://mailman.stanford.edu/mailman/listinfo/protege-user
Reply | Threaded
Open this post in threaded view
|

Re: Problem with Protege 4.3

samsontu
Protege 4.3 is not a supported software. Is there a reason you can’t use Protege 5.5?

With best regards,
Samson


On May 21, 2019, at 2:34 PM, Marla Barrera <[hidden email]> wrote:

Hi:

I have a problem with Protege 4.3, when I want to execute a SPARQL query, it
appears the nex error: "SparqlReasonerException:
java.lang.IllegalArgumentException:
org.openrdf.query.parser.QueryParserFactory is not an ImageIO SPI class"

And with Ontograph, log shows this error: "NoClassDefFoundError:
sun/dc/path/PathException"

My computer uses Linux Mint 19 and Java 11 (I tried to install java 8 but I
cannot install it).

I am very thanful for your suggestions.

Thanks.

Marla B.



--
Sent from: http://protege-project.136.n4.nabble.com/Protege-User-f4659818.html
_______________________________________________
protege-user mailing list
[hidden email]
https://mailman.stanford.edu/mailman/listinfo/protege-user


_______________________________________________
protege-user mailing list
[hidden email]
https://mailman.stanford.edu/mailman/listinfo/protege-user
Reply | Threaded
Open this post in threaded view
|

Re: Problem with Protege 4.3

Marla Barrera
Hi Samson:

Thanks for you response.

My computer uses a 32-bits platform, therefore, I donwloaded the Protege 5.5
platform-independent version, but when I tried to initiate through ./run.sh
command, it shows some errors, such as:

Error starting
file:/home/marlitalinda/Protege-5.5.0/bundles/protege-common.jar
Error starting
file:/home/marlitalinda/Protege-5.5.0/bundles/org.eclipse.equinox.supplement.jar
Error starting
file:/home/marlitalinda/Protege-5.5.0/bundles/org.eclipse.equinox.common.jar
Error starting
file:/home/marlitalinda/Protege-5.5.0/bundles/org.eclipse.equinox.registry.jar
Error starting
file:/home/marlitalinda/Protege-5.5.0/bundles/protege-editor-core.jar
Error starting
file:/home/marlitalinda/Protege-5.5.0/bundles/logback-core.jar
Error starting
file:/home/marlitalinda/Protege-5.5.0/bundles/jul-to-slf4j.jar
Error starting
file:/home/marlitalinda/Protege-5.5.0/bundles/logback-classic.jar
Error starting
file:/home/marlitalinda/Protege-5.5.0/bundles/org.eclipse.jgit.jar
Error starting
file:/home/marlitalinda/Protege-5.5.0/bundles/protege-editor-owl.jar
Error starting
file:/home/marlitalinda/Protege-5.5.0/bundles/owlapi-osgidistribution.jar
Error starting
file:/home/marlitalinda/Protege-5.5.0/bundles/log4j-over-slf4j.jar
Error starting
file:/home/marlitalinda/Protege-5.5.0/plugins/code-generation-2.0.0.jar
Error starting
file:/home/marlitalinda/Protege-5.5.0/plugins/rdf-library-3.0.0.jar
Error starting
file:/home/marlitalinda/Protege-5.5.0/plugins/ontograf-2.0.3.jar
Error starting
file:/home/marlitalinda/Protege-5.5.0/plugins/cellfie-2.1.0.jar
Error starting
file:/home/marlitalinda/Protege-5.5.0/plugins/existentialquery-2.0.0.jar
Error starting
file:/home/marlitalinda/Protege-5.5.0/plugins/owldoc-3.0.3.jar
Error starting
file:/home/marlitalinda/Protege-5.5.0/plugins/org.coode.dlquery-4.0.1.jar
Error starting
file:/home/marlitalinda/Protege-5.5.0/plugins/owlviz-5.0.3.jar
Error starting
file:/home/marlitalinda/Protege-5.5.0/plugins/sparql-query-plugin-3.0.0.jar
Error starting
file:/home/marlitalinda/Protege-5.5.0/plugins/swrltab-plugin-2.0.6.jar
Error starting
file:/home/marlitalinda/Protege-5.5.0/plugins/org.semanticweb.hermit-1.4.3.456.jar
Error starting
file:/home/marlitalinda/Protege-5.5.0/plugins/explanation-workbench-3.0.0.jar

And Protege 5.5  does not work.

Thanks for your attention and suggests :)

Marla B.



--
Sent from: http://protege-project.136.n4.nabble.com/Protege-User-f4659818.html
_______________________________________________
protege-user mailing list
[hidden email]
https://mailman.stanford.edu/mailman/listinfo/protege-user
Reply | Threaded
Open this post in threaded view
|

Re: Problem with Protege 4.3

samsontu
Which version of Java are you using? You should use Java 8.

With best regards,
Samson


On May 21, 2019, at 5:03 PM, Marla Barrera <[hidden email]> wrote:

Hi Samson:

Thanks for you response.

My computer uses a 32-bits platform, therefore, I donwloaded the Protege 5.5
platform-independent version, but when I tried to initiate through ./run.sh
command, it shows some errors, such as:

Error starting
file:/home/marlitalinda/Protege-5.5.0/bundles/protege-common.jar
Error starting
file:/home/marlitalinda/Protege-5.5.0/bundles/org.eclipse.equinox.supplement.jar
Error starting
file:/home/marlitalinda/Protege-5.5.0/bundles/org.eclipse.equinox.common.jar
Error starting
file:/home/marlitalinda/Protege-5.5.0/bundles/org.eclipse.equinox.registry.jar
Error starting
file:/home/marlitalinda/Protege-5.5.0/bundles/protege-editor-core.jar
Error starting
file:/home/marlitalinda/Protege-5.5.0/bundles/logback-core.jar
Error starting
file:/home/marlitalinda/Protege-5.5.0/bundles/jul-to-slf4j.jar
Error starting
file:/home/marlitalinda/Protege-5.5.0/bundles/logback-classic.jar
Error starting
file:/home/marlitalinda/Protege-5.5.0/bundles/org.eclipse.jgit.jar
Error starting
file:/home/marlitalinda/Protege-5.5.0/bundles/protege-editor-owl.jar
Error starting
file:/home/marlitalinda/Protege-5.5.0/bundles/owlapi-osgidistribution.jar
Error starting
file:/home/marlitalinda/Protege-5.5.0/bundles/log4j-over-slf4j.jar
Error starting
file:/home/marlitalinda/Protege-5.5.0/plugins/code-generation-2.0.0.jar
Error starting
file:/home/marlitalinda/Protege-5.5.0/plugins/rdf-library-3.0.0.jar
Error starting
file:/home/marlitalinda/Protege-5.5.0/plugins/ontograf-2.0.3.jar
Error starting
file:/home/marlitalinda/Protege-5.5.0/plugins/cellfie-2.1.0.jar
Error starting
file:/home/marlitalinda/Protege-5.5.0/plugins/existentialquery-2.0.0.jar
Error starting
file:/home/marlitalinda/Protege-5.5.0/plugins/owldoc-3.0.3.jar
Error starting
file:/home/marlitalinda/Protege-5.5.0/plugins/org.coode.dlquery-4.0.1.jar
Error starting
file:/home/marlitalinda/Protege-5.5.0/plugins/owlviz-5.0.3.jar
Error starting
file:/home/marlitalinda/Protege-5.5.0/plugins/sparql-query-plugin-3.0.0.jar
Error starting
file:/home/marlitalinda/Protege-5.5.0/plugins/swrltab-plugin-2.0.6.jar
Error starting
file:/home/marlitalinda/Protege-5.5.0/plugins/org.semanticweb.hermit-1.4.3.456.jar
Error starting
file:/home/marlitalinda/Protege-5.5.0/plugins/explanation-workbench-3.0.0.jar

And Protege 5.5  does not work.

Thanks for your attention and suggests :)

Marla B.



--
Sent from: http://protege-project.136.n4.nabble.com/Protege-User-f4659818.html
_______________________________________________
protege-user mailing list
[hidden email]
https://mailman.stanford.edu/mailman/listinfo/protege-user


_______________________________________________
protege-user mailing list
[hidden email]
https://mailman.stanford.edu/mailman/listinfo/protege-user
Reply | Threaded
Open this post in threaded view
|

Re: Problem with Protege 4.3

Campbell, James R
Version 8/Update 202
Jim

From: protege-user <[hidden email]> on behalf of Samson Tu <[hidden email]>
Sent: Thursday, May 23, 2019 11:36 AM
To: User support for WebProtege and Protege Desktop
Subject: Re: [protege-user] Problem with Protege 4.3
 
Non-UNMC email
Which version of Java are you using? You should use Java 8.

With best regards,
Samson


On May 21, 2019, at 5:03 PM, Marla Barrera <[hidden email]> wrote:

Hi Samson:

Thanks for you response.

My computer uses a 32-bits platform, therefore, I donwloaded the Protege 5.5
platform-independent version, but when I tried to initiate through ./run.sh
command, it shows some errors, such as:

Error starting
file:/home/marlitalinda/Protege-5.5.0/bundles/protege-common.jar
Error starting
file:/home/marlitalinda/Protege-5.5.0/bundles/org.eclipse.equinox.supplement.jar
Error starting
file:/home/marlitalinda/Protege-5.5.0/bundles/org.eclipse.equinox.common.jar
Error starting
file:/home/marlitalinda/Protege-5.5.0/bundles/org.eclipse.equinox.registry.jar
Error starting
file:/home/marlitalinda/Protege-5.5.0/bundles/protege-editor-core.jar
Error starting
file:/home/marlitalinda/Protege-5.5.0/bundles/logback-core.jar
Error starting
file:/home/marlitalinda/Protege-5.5.0/bundles/jul-to-slf4j.jar
Error starting
file:/home/marlitalinda/Protege-5.5.0/bundles/logback-classic.jar
Error starting
file:/home/marlitalinda/Protege-5.5.0/bundles/org.eclipse.jgit.jar
Error starting
file:/home/marlitalinda/Protege-5.5.0/bundles/protege-editor-owl.jar
Error starting
file:/home/marlitalinda/Protege-5.5.0/bundles/owlapi-osgidistribution.jar
Error starting
file:/home/marlitalinda/Protege-5.5.0/bundles/log4j-over-slf4j.jar
Error starting
file:/home/marlitalinda/Protege-5.5.0/plugins/code-generation-2.0.0.jar
Error starting
file:/home/marlitalinda/Protege-5.5.0/plugins/rdf-library-3.0.0.jar
Error starting
file:/home/marlitalinda/Protege-5.5.0/plugins/ontograf-2.0.3.jar
Error starting
file:/home/marlitalinda/Protege-5.5.0/plugins/cellfie-2.1.0.jar
Error starting
file:/home/marlitalinda/Protege-5.5.0/plugins/existentialquery-2.0.0.jar
Error starting
file:/home/marlitalinda/Protege-5.5.0/plugins/owldoc-3.0.3.jar
Error starting
file:/home/marlitalinda/Protege-5.5.0/plugins/org.coode.dlquery-4.0.1.jar
Error starting
file:/home/marlitalinda/Protege-5.5.0/plugins/owlviz-5.0.3.jar
Error starting
file:/home/marlitalinda/Protege-5.5.0/plugins/sparql-query-plugin-3.0.0.jar
Error starting
file:/home/marlitalinda/Protege-5.5.0/plugins/swrltab-plugin-2.0.6.jar
Error starting
file:/home/marlitalinda/Protege-5.5.0/plugins/org.semanticweb.hermit-1.4.3.456.jar
Error starting
file:/home/marlitalinda/Protege-5.5.0/plugins/explanation-workbench-3.0.0.jar

And Protege 5.5  does not work.

Thanks for your attention and suggests :)

Marla B.



--
Sent from: http://protege-project.136.n4.nabble.com/Protege-User-f4659818.html
_______________________________________________
protege-user mailing list
[hidden email]
https://mailman.stanford.edu/mailman/listinfo/protege-user


The information in this e-mail may be privileged and confidential, intended only for the use of the addressee(s) above. Any unauthorized use or disclosure of this information is prohibited. If you have received this e-mail by mistake, please delete it and immediately contact the sender.
_______________________________________________
protege-user mailing list
[hidden email]
https://mailman.stanford.edu/mailman/listinfo/protege-user
Reply | Threaded
Open this post in threaded view
|

Re: Problem with Protege 4.3

samsontu
Hi Jim,

Are you experiencing the same problem running Protege 5.5 on a 32-bit machine?

With best regards,
Samson


On May 23, 2019, at 11:03 AM, Campbell, James R <[hidden email]> wrote:

Version 8/Update 202
Jim

From: protege-user <[hidden email]> on behalf of Samson Tu <[hidden email]>
Sent: Thursday, May 23, 2019 11:36 AM
To: User support for WebProtege and Protege Desktop
Subject: Re: [protege-user] Problem with Protege 4.3
 
Non-UNMC email 
Which version of Java are you using? You should use Java 8.

With best regards,
Samson


On May 21, 2019, at 5:03 PM, Marla Barrera <[hidden email]> wrote:

Hi Samson:

Thanks for you response.

My computer uses a 32-bits platform, therefore, I donwloaded the Protege 5.5
platform-independent version, but when I tried to initiate through ./run.sh
command, it shows some errors, such as:

Error starting
file:/home/marlitalinda/Protege-5.5.0/bundles/protege-common.jar 
Error starting
file:/home/marlitalinda/Protege-5.5.0/bundles/org.eclipse.equinox.supplement.jar 
Error starting
file:/home/marlitalinda/Protege-5.5.0/bundles/org.eclipse.equinox.common.jar
Error starting
file:/home/marlitalinda/Protege-5.5.0/bundles/org.eclipse.equinox.registry.jar 
Error starting
file:/home/marlitalinda/Protege-5.5.0/bundles/protege-editor-core.jar
Error starting
file:/home/marlitalinda/Protege-5.5.0/bundles/logback-core.jar 
Error starting
file:/home/marlitalinda/Protege-5.5.0/bundles/jul-to-slf4j.jar 
Error starting
file:/home/marlitalinda/Protege-5.5.0/bundles/logback-classic.jar 
Error starting
file:/home/marlitalinda/Protege-5.5.0/bundles/org.eclipse.jgit.jar 
Error starting
file:/home/marlitalinda/Protege-5.5.0/bundles/protege-editor-owl.jar 
Error starting
file:/home/marlitalinda/Protege-5.5.0/bundles/owlapi-osgidistribution.jar 
Error starting
file:/home/marlitalinda/Protege-5.5.0/bundles/log4j-over-slf4j.jar 
Error starting
file:/home/marlitalinda/Protege-5.5.0/plugins/code-generation-2.0.0.jar 
Error starting
file:/home/marlitalinda/Protege-5.5.0/plugins/rdf-library-3.0.0.jar 
Error starting
file:/home/marlitalinda/Protege-5.5.0/plugins/ontograf-2.0.3.jar 
Error starting
file:/home/marlitalinda/Protege-5.5.0/plugins/cellfie-2.1.0.jar 
Error starting
file:/home/marlitalinda/Protege-5.5.0/plugins/existentialquery-2.0.0.jar 
Error starting
file:/home/marlitalinda/Protege-5.5.0/plugins/owldoc-3.0.3.jar 
Error starting
file:/home/marlitalinda/Protege-5.5.0/plugins/org.coode.dlquery-4.0.1.jar 
Error starting
file:/home/marlitalinda/Protege-5.5.0/plugins/owlviz-5.0.3.jar 
Error starting
file:/home/marlitalinda/Protege-5.5.0/plugins/sparql-query-plugin-3.0.0.jar 
Error starting
file:/home/marlitalinda/Protege-5.5.0/plugins/swrltab-plugin-2.0.6.jar 
Error starting
file:/home/marlitalinda/Protege-5.5.0/plugins/org.semanticweb.hermit-1.4.3.456.jar 
Error starting
file:/home/marlitalinda/Protege-5.5.0/plugins/explanation-workbench-3.0.0.jar 

And Protege 5.5  does not work.

Thanks for your attention and suggests :)

Marla B. 



--
Sent from: http://protege-project.136.n4.nabble.com/Protege-User-f4659818.html
_______________________________________________
protege-user mailing list
[hidden email]
https://mailman.stanford.edu/mailman/listinfo/protege-user


The information in this e-mail may be privileged and confidential, intended only for the use of the addressee(s) above. Any unauthorized use or disclosure of this information is prohibited. If you have received this e-mail by mistake, please delete it and immediately contact the sender. _______________________________________________
protege-user mailing list
[hidden email]
https://mailman.stanford.edu/mailman/listinfo/protege-user


_______________________________________________
protege-user mailing list
[hidden email]
https://mailman.stanford.edu/mailman/listinfo/protege-user
Reply | Threaded
Open this post in threaded view
|

Re: Problem with Protege 4.3

Campbell, James R
I have no 32 bit machine and these features were working fine on our last SNOMED CT load, leading me to suspect some setup feature.
Jim

From: protege-user <[hidden email]> on behalf of Samson Tu <[hidden email]>
Sent: Thursday, May 23, 2019 4:47 PM
To: User support for WebProtege and Protege Desktop
Subject: Re: [protege-user] Problem with Protege 4.3
 
Non-UNMC email
Hi Jim,

Are you experiencing the same problem running Protege 5.5 on a 32-bit machine?

With best regards,
Samson


On May 23, 2019, at 11:03 AM, Campbell, James R <[hidden email]> wrote:

Version 8/Update 202
Jim

From: protege-user <[hidden email]> on behalf of Samson Tu <[hidden email]>
Sent: Thursday, May 23, 2019 11:36 AM
To: User support for WebProtege and Protege Desktop
Subject: Re: [protege-user] Problem with Protege 4.3
 
Non-UNMC email 
Which version of Java are you using? You should use Java 8.

With best regards,
Samson


On May 21, 2019, at 5:03 PM, Marla Barrera <[hidden email]> wrote:

Hi Samson:

Thanks for you response.

My computer uses a 32-bits platform, therefore, I donwloaded the Protege 5.5
platform-independent version, but when I tried to initiate through ./run.sh
command, it shows some errors, such as:

Error starting
file:/home/marlitalinda/Protege-5.5.0/bundles/protege-common.jar 
Error starting
file:/home/marlitalinda/Protege-5.5.0/bundles/org.eclipse.equinox.supplement.jar 
Error starting
file:/home/marlitalinda/Protege-5.5.0/bundles/org.eclipse.equinox.common.jar
Error starting
file:/home/marlitalinda/Protege-5.5.0/bundles/org.eclipse.equinox.registry.jar 
Error starting
file:/home/marlitalinda/Protege-5.5.0/bundles/protege-editor-core.jar
Error starting
file:/home/marlitalinda/Protege-5.5.0/bundles/logback-core.jar 
Error starting
file:/home/marlitalinda/Protege-5.5.0/bundles/jul-to-slf4j.jar 
Error starting
file:/home/marlitalinda/Protege-5.5.0/bundles/logback-classic.jar 
Error starting
file:/home/marlitalinda/Protege-5.5.0/bundles/org.eclipse.jgit.jar 
Error starting
file:/home/marlitalinda/Protege-5.5.0/bundles/protege-editor-owl.jar 
Error starting
file:/home/marlitalinda/Protege-5.5.0/bundles/owlapi-osgidistribution.jar 
Error starting
file:/home/marlitalinda/Protege-5.5.0/bundles/log4j-over-slf4j.jar 
Error starting
file:/home/marlitalinda/Protege-5.5.0/plugins/code-generation-2.0.0.jar 
Error starting
file:/home/marlitalinda/Protege-5.5.0/plugins/rdf-library-3.0.0.jar 
Error starting
file:/home/marlitalinda/Protege-5.5.0/plugins/ontograf-2.0.3.jar 
Error starting
file:/home/marlitalinda/Protege-5.5.0/plugins/cellfie-2.1.0.jar 
Error starting
file:/home/marlitalinda/Protege-5.5.0/plugins/existentialquery-2.0.0.jar 
Error starting
file:/home/marlitalinda/Protege-5.5.0/plugins/owldoc-3.0.3.jar 
Error starting
file:/home/marlitalinda/Protege-5.5.0/plugins/org.coode.dlquery-4.0.1.jar 
Error starting
file:/home/marlitalinda/Protege-5.5.0/plugins/owlviz-5.0.3.jar 
Error starting
file:/home/marlitalinda/Protege-5.5.0/plugins/sparql-query-plugin-3.0.0.jar 
Error starting
file:/home/marlitalinda/Protege-5.5.0/plugins/swrltab-plugin-2.0.6.jar 
Error starting
file:/home/marlitalinda/Protege-5.5.0/plugins/org.semanticweb.hermit-1.4.3.456.jar 
Error starting
file:/home/marlitalinda/Protege-5.5.0/plugins/explanation-workbench-3.0.0.jar 

And Protege 5.5  does not work.

Thanks for your attention and suggests :)

Marla B. 



--
Sent from: http://protege-project.136.n4.nabble.com/Protege-User-f4659818.html
_______________________________________________
protege-user mailing list
[hidden email]
https://mailman.stanford.edu/mailman/listinfo/protege-user


The information in this e-mail may be privileged and confidential, intended only for the use of the addressee(s) above. Any unauthorized use or disclosure of this information is prohibited. If you have received this e-mail by mistake, please delete it and immediately contact the sender. _______________________________________________
protege-user mailing list
[hidden email]
https://mailman.stanford.edu/mailman/listinfo/protege-user


The information in this e-mail may be privileged and confidential, intended only for the use of the addressee(s) above. Any unauthorized use or disclosure of this information is prohibited. If you have received this e-mail by mistake, please delete it and immediately contact the sender.
_______________________________________________
protege-user mailing list
[hidden email]
https://mailman.stanford.edu/mailman/listinfo/protege-user
Reply | Threaded
Open this post in threaded view
|

Re: Problem with Protege 4.3

Marla Barrera
In reply to this post by samsontu
Hi everyone:

I tried to install Java 8 in my computer but I cannot make it. My computer
uses Java 11 I can to open Protege 4.3, I can use DL-Query and make my
ontologies... but I want to use SPARQL.

Thanks.



--
Sent from: http://protege-project.136.n4.nabble.com/Protege-User-f4659818.html
_______________________________________________
protege-user mailing list
[hidden email]
https://mailman.stanford.edu/mailman/listinfo/protege-user
Reply | Threaded
Open this post in threaded view
|

Re: Problem with Protege 4.3

Csongor Nyulas
Administrator
Hi Marla,

Can a sys admin or someone else help you install Java 8?

Unless you can install Java 8, or find a 64-bit machine, I am not sure
how we can help you through this list.

Best,
Csongor


On 5/27/19 10:02 AM, Marla Barrera wrote:

> Hi everyone:
>
> I tried to install Java 8 in my computer but I cannot make it. My computer
> uses Java 11 I can to open Protege 4.3, I can use DL-Query and make my
> ontologies... but I want to use SPARQL.
>
> Thanks.
>
>
>
> --
> Sent from: http://protege-project.136.n4.nabble.com/Protege-User-f4659818.html
> _______________________________________________
> protege-user mailing list
> [hidden email]
> https://mailman.stanford.edu/mailman/listinfo/protege-user


_______________________________________________
protege-user mailing list
[hidden email]
https://mailman.stanford.edu/mailman/listinfo/protege-user