Protégé 3.5 unable to launch with Java 8

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

Protégé 3.5 unable to launch with Java 8

Gunther Lachambre
Hi Stanford,

First, thank you for the unvaluable work on Protégé !

I was using Protégé 3.5 desktop on Windows 7 for a short time without any problem. Recently, my sys-admins have auto-updated Java to version 1.8.0_131. Now Protégé doesn't start anymore, showing an error message "Enable to run LaunchAnywhere: Windows 2 Error on JVM loading" (translation from the following message in french).
On Protégé 3.5 wiki page, it's indicated that Protégé requires Java 6. Are there known incompatibilities with Java 8 ?

Thanks for your response.

Regards,
--
Gunther LACHAMBRE
Chargé de mission Urbanisation et cartographies du SI

Direction du Système d'Information
Pôle Applications et Services Numériques


Campus de Beaulieu - Bât. 12D
263 avenue du Général Leclerc CS 74205 - 35042 Rennes Cedex

+33 (0)2 23 23 71 33
+33 (0)2 23 23 71 11




_______________________________________________
protege-user mailing list
[hidden email]
https://mailman.stanford.edu/mailman/listinfo/protege-user

smime.p7s (4K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Protégé 3.5 unable to launch with Java 8

Aparna Lalingkar
 

Hi Gunther,


Yes, Protege3.5 does now work in windows 7. To make it work you need to use VM or just use the upgrades version of protege. 

Regards,

Aparna



On Mon, Jun 12, 2017 at 10:45 AM, Gunther Lachambre <[hidden email]> wrote:
Hi Stanford,

First, thank you for the unvaluable work on Protégé !

I was using Protégé 3.5 desktop on Windows 7 for a short time without any problem. Recently, my sys-admins have auto-updated Java to version 1.8.0_131. Now Protégé doesn't start anymore, showing an error message "Enable to run LaunchAnywhere: Windows 2 Error on JVM loading" (translation from the following message in french).
On Protégé 3.5 wiki page, it's indicated that Protégé requires Java 6. Are there known incompatibilities with Java 8 ?

Thanks for your response.

Regards,
--
Gunther LACHAMBRE
Chargé de mission Urbanisation et cartographies du SI

Direction du Système d'Information
Pôle Applications et Services Numériques


Campus de Beaulieu - Bât. 12D
263 avenue du Général Leclerc CS 74205 - 35042 Rennes Cedex

+33 (0)2 23 23 71 33
+33 (0)2 23 23 71 11




_______________________________________________
protege-user mailing list
[hidden email]
https://mailman.stanford.edu/mailman/listinfo/protege-user



_______________________________________________
protege-user mailing list
[hidden email]
https://mailman.stanford.edu/mailman/listinfo/protege-user
Reply | Threaded
Open this post in threaded view
|

Re: Protégé 3.5 unable to launch with Java 8

Gunther Lachambre
Thanks Aparna,

It did work well on Windows 7, but it seems to be troubled by Java 8. I must use Protégé 3.5 as part of a solution with other products that require it.
Note that on a CentOS7 server in client-server mode, Protégé 3.5 runs well with Java 1.8.0_91...

Regards,
Gunther LACHAMBRE
Chargé de mission Urbanisation et cartographies du SI

Direction du Système d'Information
Pôle Applications et Services Numériques


Campus de Beaulieu - Bât. 12D
263 avenue du Général Leclerc CS 74205 - 35042 Rennes Cedex

+33 (0)2 23 23 71 33
+33 (0)2 23 23 71 11



Le 12/06/2017 09:51, Aparna Lalingkar a écrit :
 

Hi Gunther,


Yes, Protege3.5 does now work in windows 7. To make it work you need to use VM or just use the upgrades version of protege. 

Regards,

Aparna



On Mon, Jun 12, 2017 at 10:45 AM, Gunther Lachambre <[hidden email]> wrote:
Hi Stanford,

First, thank you for the unvaluable work on Protégé !

I was using Protégé 3.5 desktop on Windows 7 for a short time without any problem. Recently, my sys-admins have auto-updated Java to version 1.8.0_131. Now Protégé doesn't start anymore, showing an error message "Enable to run LaunchAnywhere: Windows 2 Error on JVM loading" (translation from the following message in french).
On Protégé 3.5 wiki page, it's indicated that Protégé requires Java 6. Are there known incompatibilities with Java 8 ?

Thanks for your response.

Regards,
--
Gunther LACHAMBRE
Chargé de mission Urbanisation et cartographies du SI

Direction du Système d'Information
Pôle Applications et Services Numériques


Campus de Beaulieu - Bât. 12D
263 avenue du Général Leclerc CS 74205 - 35042 Rennes Cedex

+33 (0)2 23 23 71 33
+33 (0)2 23 23 71 11




_______________________________________________
protege-user mailing list
[hidden email]
https://mailman.stanford.edu/mailman/listinfo/protege-user




_______________________________________________
protege-user mailing list
[hidden email]
https://mailman.stanford.edu/mailman/listinfo/protege-user


_______________________________________________
protege-user mailing list
[hidden email]
https://mailman.stanford.edu/mailman/listinfo/protege-user

smime.p7s (4K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Protégé 3.5 unable to launch with Java 8 [SOLVED]

Gunther Lachambre
In reply to this post by Gunther Lachambre
Hi all,

Here is the solution to the problem I submitted.

I just had to remove the reference to the Oracle Javapath from Windows 7 environment variables (delete "C:\ProgramData\Oracle\Java\javapath;" in "Path" variable).

Finally, Protégé 3.5 works fine with Java 8 on Windows 7.

Regards,
Gunther LACHAMBRE
Chargé de mission Urbanisation et cartographies du SI

Direction du Système d'Information
Pôle Applications et Services Numériques


Campus de Beaulieu - Bât. 12D
263 avenue du Général Leclerc CS 74205 - 35042 Rennes Cedex

+33 (0)2 23 23 71 33
+33 (0)2 23 23 71 11



Le 12/06/2017 09:45, Gunther Lachambre a écrit :
Hi Stanford,

First, thank you for the unvaluable work on Protégé !

I was using Protégé 3.5 desktop on Windows 7 for a short time without any problem. Recently, my sys-admins have auto-updated Java to version 1.8.0_131. Now Protégé doesn't start anymore, showing an error message "Enable to run LaunchAnywhere: Windows 2 Error on JVM loading" (translation from the following message in french).
On Protégé 3.5 wiki page, it's indicated that Protégé requires Java 6. Are there known incompatibilities with Java 8 ?

Thanks for your response.

Regards,
--
Gunther LACHAMBRE
Chargé de mission Urbanisation et cartographies du SI

Direction du Système d'Information
Pôle Applications et Services Numériques


Campus de Beaulieu - Bât. 12D
263 avenue du Général Leclerc CS 74205 - 35042 Rennes Cedex

+33 (0)2 23 23 71 33
+33 (0)2 23 23 71 11





_______________________________________________
protege-user mailing list
[hidden email]
https://mailman.stanford.edu/mailman/listinfo/protege-user


_______________________________________________
protege-user mailing list
[hidden email]
https://mailman.stanford.edu/mailman/listinfo/protege-user

smime.p7s (4K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Protégé 3.5 unable to launch with Java 8 [SOLVED]

Tania Tudorache

Thank you, Guenther, for submitting the solution that worked for you.


Protege 3.x works with all java versions, including 8. You can also run it using the run.bat file. You may need to edit it to adjust the Java runnable path, in case it is not the standard one.


Tania


From: protege-user <[hidden email]> on behalf of Gunther Lachambre <[hidden email]>
Sent: Monday, June 12, 2017 1:19:03 AM
To: [hidden email]
Subject: Re: [protege-user] Protégé 3.5 unable to launch with Java 8 [SOLVED]
 
Hi all,

Here is the solution to the problem I submitted.

I just had to remove the reference to the Oracle Javapath from Windows 7 environment variables (delete "C:\ProgramData\Oracle\Java\javapath;" in "Path" variable).

Finally, Protégé 3.5 works fine with Java 8 on Windows 7.

Regards,
Gunther LACHAMBRE
Chargé de mission Urbanisation et cartographies du SI

Direction du Système d'Information
Pôle Applications et Services Numériques


Campus de Beaulieu - Bât. 12D
263 avenue du Général Leclerc CS 74205 - 35042 Rennes Cedex

+33 (0)2 23 23 71 33
+33 (0)2 23 23 71 11



Le 12/06/2017 09:45, Gunther Lachambre a écrit :
Hi Stanford,

First, thank you for the unvaluable work on Protégé !

I was using Protégé 3.5 desktop on Windows 7 for a short time without any problem. Recently, my sys-admins have auto-updated Java to version 1.8.0_131. Now Protégé doesn't start anymore, showing an error message "Enable to run LaunchAnywhere: Windows 2 Error on JVM loading" (translation from the following message in french).
On Protégé 3.5 wiki page, it's indicated that Protégé requires Java 6. Are there known incompatibilities with Java 8 ?

Thanks for your response.

Regards,
--
Gunther LACHAMBRE
Chargé de mission Urbanisation et cartographies du SI

Direction du Système d'Information
Pôle Applications et Services Numériques


Campus de Beaulieu - Bât. 12D
263 avenue du Général Leclerc CS 74205 - 35042 Rennes Cedex

+33 (0)2 23 23 71 33
+33 (0)2 23 23 71 11





_______________________________________________
protege-user mailing list
[hidden email]
https://mailman.stanford.edu/mailman/listinfo/protege-user


_______________________________________________
protege-user mailing list
[hidden email]
https://mailman.stanford.edu/mailman/listinfo/protege-user