Protege 5.5.0 beta 7 & 8 freezes for about 2 minutes when saving

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Protege 5.5.0 beta 7 & 8 freezes for about 2 minutes when saving

Grove, Christian A. (Chris)

Hi,


I'm having an issue with both the Protege 5.5.0 beta 7 release and the beta 8 release now in which almost every time I make a small change and save the ontology, Protege freezes up and becomes unresponsive for about 2 minutes and my (Mac) Activity Monitor tells me that Protege is not responding. After two minutes, Protege appears to return to normal functioning.


This is happening exclusively on my 2017 iMac running macOS Mojave (10.14.2). This is not happening on my 2016 MacBook Pro running macOS High Sierra (10.13.6).


I can reproduce this just using the default empty ontology that opens when I open Protege. I go to Save my (blank) ontology, choose the default RDF-XML format and then Protege freezes for two minutes. If I don't make changes and then save again, it doesn't freeze up, but if I make any changes and then save it, Protege freezes for two minutes before resuming normal functioning.


Any thoughts?


Thanks,


Chris Grove


_______________________________________________
protege-user mailing list
[hidden email]
https://mailman.stanford.edu/mailman/listinfo/protege-user
Reply | Threaded
Open this post in threaded view
|

Re: Protege 5.5.0 beta 7 & 8 freezes for about 2 minutes when saving

Matthew Horridge-2
Administrator
Hi Chris,

Are you saving into a folder that has a lot of other files and/or nested sub-folders in it?

Cheers,

Matthew



On 15 Jan 2019, at 06:37, Grove, Christian A. (Chris) <[hidden email]> wrote:

Hi,

I'm having an issue with both the Protege 5.5.0 beta 7 release and the beta 8 release now in which almost every time I make a small change and save the ontology, Protege freezes up and becomes unresponsive for about 2 minutes and my (Mac) Activity Monitor tells me that Protege is not responding. After two minutes, Protege appears to return to normal functioning.

This is happening exclusively on my 2017 iMac running macOS Mojave (10.14.2). This is not happening on my 2016 MacBook Pro running macOS High Sierra (10.13.6).

I can reproduce this just using the default empty ontology that opens when I open Protege. I go to Save my (blank) ontology, choose the default RDF-XML format and then Protege freezes for two minutes. If I don't make changes and then save again, it doesn't freeze up, but if I make any changes and then save it, Protege freezes for two minutes before resuming normal functioning.

Any thoughts?

Thanks,

Chris Grove
_______________________________________________
protege-user mailing list
[hidden email]
https://mailman.stanford.edu/mailman/listinfo/protege-user


_______________________________________________
protege-user mailing list
[hidden email]
https://mailman.stanford.edu/mailman/listinfo/protege-user
Reply | Threaded
Open this post in threaded view
|

Re: Protege 5.5.0 beta 7 & 8 freezes for about 2 minutes when saving

Grove, Christian A. (Chris)

Hi Matthew,


Well, I've been saving to my Desktop (which, yes, has many other files and folders), as I didn't consider the save location as that important. Now that you point it out, I realize that if I save the ontology in a dedicated directory with nothing else in it, I don't see the problem. I suppose I'll just be careful from now on about where and how I save the ontology.


Thanks!


Chris


From: protege-user <[hidden email]> on behalf of Matthew Horridge <[hidden email]>
Sent: Tuesday, January 15, 2019 2:40:51 PM
To: User support for WebProtege and Protege Desktop
Cc: [hidden email]
Subject: Re: [protege-user] Protege 5.5.0 beta 7 & 8 freezes for about 2 minutes when saving
 
Hi Chris,

Are you saving into a folder that has a lot of other files and/or nested sub-folders in it?

Cheers,

Matthew



On 15 Jan 2019, at 06:37, Grove, Christian A. (Chris) <[hidden email]> wrote:

Hi,

I'm having an issue with both the Protege 5.5.0 beta 7 release and the beta 8 release now in which almost every time I make a small change and save the ontology, Protege freezes up and becomes unresponsive for about 2 minutes and my (Mac) Activity Monitor tells me that Protege is not responding. After two minutes, Protege appears to return to normal functioning.

This is happening exclusively on my 2017 iMac running macOS Mojave (10.14.2). This is not happening on my 2016 MacBook Pro running macOS High Sierra (10.13.6).

I can reproduce this just using the default empty ontology that opens when I open Protege. I go to Save my (blank) ontology, choose the default RDF-XML format and then Protege freezes for two minutes. If I don't make changes and then save again, it doesn't freeze up, but if I make any changes and then save it, Protege freezes for two minutes before resuming normal functioning.

Any thoughts?

Thanks,

Chris Grove
_______________________________________________
protege-user mailing list
[hidden email]
https://mailman.stanford.edu/mailman/listinfo/protege-user


_______________________________________________
protege-user mailing list
[hidden email]
https://mailman.stanford.edu/mailman/listinfo/protege-user