Protege 5-5 and Java 11

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Protege 5-5 and Java 11

Marla Barrera
Hi: I has Java 11 and linux Mint, I had tryed to install Protege 5.5., and I have the following error: WARNING: An illegal reflective access operation has occurred WARNING: Illegal reflective access by org.apache.felix.framework.util.SecureAction (file:/home/marlitalinda/Protege-5.5.0/protege/protege-desktop/target/protege-5.6.0-beta-1-SNAPSHOT-platform-independent/Protege-5.6.0-beta-1-SNAPSHOT/bin/org.apache.felix.main.jar) to method java.net.URLClassLoader.addURL(java.net.URL) WARNING: Please consider reporting this to the maintainers of org.apache.felix.framework.util.SecureAction WARNING: Use --illegal-access=warn to enable warnings of further illegal reflective access operations WARNING: All illegal access operations will be denied in a future release The OSGi framework has been initialised ------------------------------- Starting Bundles ------------------------------- Starting bundle org.protege.common Starting bundle org.eclipse.equinox.supplement Starting bundle org.eclipse.equinox.common Starting bundle org.eclipse.equinox.registry Starting bundle org.protege.editor.core.application Starting bundle org.apache.commons.io Starting bundle org.eclipse.equinox.supplement Starting bundle org.apache.servicemix.bundles.javax-inject Starting bundle org.eclipse.equinox.registry Starting bundle ch.qos.logback.core Starting bundle jul.to.slf4j Starting bundle org.eclipse.equinox.common Starting bundle ch.qos.logback.classic Starting bundle org.eclipse.jgit Starting bundle org.protege.editor.owl Starting bundle com.googlecode.javaewah.JavaEWAH Starting bundle org.protege.editor.core.application Starting bundle org.jsr-305 Starting bundle slf4j.api Starting bundle com.google.guava Starting bundle org.semanticweb.owl.owlapi Starting bundle org.apache.servicemix.bundles.aopalliance Starting bundle log4j.over.slf4j Starting bundle org.protege.common Error starting file:/home/marlitalinda/Protege-5.5.0/protege/protege-desktop/target/protege-5.6.0-beta-1-SNAPSHOT-platform-independent/Protege-5.6.0-beta-1-SNAPSHOT/bundles/protege-common.jar org.osgi.framework.BundleException: Unable to resolve org.protege.common [1](R 1.0): missing requirement [org.protege.common [1](R 1.0)] osgi.wiring.package; (&(osgi.wiring.package=org.slf4j)(version>=1.7.0)(!(version>=2.0.0))) [caused by: Unable to resolve slf4j.api [15](R 15.0): missing requirement [slf4j.api [15](R 15.0)] osgi.ee; (&(osgi.ee=JavaSE)(version=1.5.0))] Unresolved requirements: [[org.protege.common [1](R 1.0)] osgi.wiring.package; (&(osgi.wiring.package=org.slf4j)(version>=1.7.0)(!(version>=2.0.0)))] at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4111) ~[org.apache.felix.main.jar:na] at org.apache.felix.framework.Felix.startBundle(Felix.java:2117) ~[org.apache.felix.main.jar:na] at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1371) ~[org.apache.felix.main.jar:na] at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:308) ~[org.apache.felix.main.jar:na] at java.base/java.lang.Thread.run(Thread.java:834) ~[na:na] Error starting file:/home/marlitalinda/Protege-5.5.0/protege/protege-desktop/target/protege-5.6.0-beta-1-SNAPSHOT-platform-independent/Protege-5.6.0-beta-1-SNAPSHOT/bundles/org.eclipse.equinox.supplement.jar org.osgi.framework.BundleException: Unable to resolve org.eclipse.equinox.supplement [2](R 2.0): missing requirement [org.eclipse.equinox.supplement [2](R 2.0)] osgi.ee; (|(&(osgi.ee=JavaSE)(version=1.4.0))(&(osgi.ee=CDC/Foundation)(version=1.0.0))(&(osgi.ee=JavaSE)(version=1.3.0))) Unresolved requirements: [[org.eclipse.equinox.supplement [2](R 2.0)] osgi.ee; (|(&(osgi.ee=JavaSE)(version=1.4.0))(&(osgi.ee=CDC/Foundation)(version=1.0.0))(&(osgi.ee=JavaSE)(version=1.3.0)))] at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4111) ~[org.apache.felix.main.jar:na] at org.apache.felix.framework.Felix.startBundle(Felix.java:2117) ~[org.apache.felix.main.jar:na] at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1371) ~[org.apache.felix.main.jar:na] at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:308) ~[org.apache.felix.main.jar:na] at java.base/java.lang.Thread.run(Thread.java:834) ~[na:na] Error starting file:/home/marlitalinda/Protege-5.5.0/protege/protege-desktop/target/protege-5.6.0-beta-1-SNAPSHOT-platform-independent/Protege-5.6.0-beta-1-SNAPSHOT/bundles/org.eclipse.equinox.common.jar org.osgi.framework.BundleException: Unable to resolve org.eclipse.equinox.common [3](R 3.0): missing requirement [org.eclipse.equinox.common [3](R 3.0)] osgi.wiring.package; (osgi.wiring.package=org.eclipse.osgi.service.datalocation) [caused by: Unable to resolve org.eclipse.equinox.supplement [2](R 2.0): missing requirement [org.eclipse.equinox.supplement [2](R 2.0)] osgi.ee; (|(&(osgi.ee=JavaSE)(version=1.4.0))(&(osgi.ee=CDC/Foundation)(version=1.0.0))(&(osgi.ee=JavaSE)(version=1.3.0)))] Unresolved requirements: [[org.eclipse.equinox.common [3](R 3.0)] osgi.wiring.package; (osgi.wiring.package=org.eclipse.osgi.service.datalocation)] at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4111) ~[org.apache.felix.main.jar:na] at org.apache.felix.framework.Felix.startBundle(Felix.java:2117) ~[org.apache.felix.main.jar:na] at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1371) ~[org.apache.felix.main.jar:na] at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:308) ~[org.apache.felix.main.jar:na] at java.base/java.lang.Thread.run(Thread.java:834) ~[na:na] Error starting file:/home/marlitalinda/Protege-5.5.0/protege/protege-desktop/target/protege-5.6.0-beta-1-SNAPSHOT-platform-independent/Protege-5.6.0-beta-1-SNAPSHOT/bundles/org.eclipse.equinox.registry.jar org.osgi.framework.BundleException: Unable to resolve org.eclipse.equinox.registry [4](R 4.0): missing requirement [org.eclipse.equinox.registry [4](R 4.0)] osgi.wiring.package; (osgi.wiring.package=org.eclipse.osgi.service.debug) [caused by: Unable to resolve org.eclipse.equinox.supplement [2](R 2.0): missing requirement [org.eclipse.equinox.supplement [2](R 2.0)] osgi.ee; (|(&(osgi.ee=JavaSE)(version=1.4.0))(&(osgi.ee=CDC/Foundation)(version=1.0.0))(&(osgi.ee=JavaSE)(version=1.3.0)))] Unresolved requirements: [[org.eclipse.equinox.registry [4](R 4.0)] osgi.wiring.package; (osgi.wiring.package=org.eclipse.osgi.service.debug)] at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4111) ~[org.apache.felix.main.jar:na] at org.apache.felix.framework.Felix.startBundle(Felix.java:2117) ~[org.apache.felix.main.jar:na] at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1371) ~[org.apache.felix.main.jar:na] at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:308) ~[org.apache.felix.main.jar:na] at java.base/java.lang.Thread.run(Thread.java:834) ~[na:na] Error starting file:/home/marlitalinda/Protege-5.5.0/protege/protege-desktop/target/protege-5.6.0-beta-1-SNAPSHOT-platform-independent/Protege-5.6.0-beta-1-SNAPSHOT/bundles/protege-editor-core.jar org.osgi.framework.BundleException: Unable to resolve org.protege.editor.core.application [5](R 5.0): missing requirement [org.protege.editor.core.application [5](R 5.0)] osgi.wiring.package; (&(osgi.wiring.package=ch.qos.logback.classic.spi)(version>=1.1.0)(!(version>=2.0.0))) [caused by: Unable to resolve ch.qos.logback.classic [10](R 10.0): missing requirement [ch.qos.logback.classic [10](R 10.0)] osgi.wiring.package; (&(osgi.wiring.package=ch.qos.logback.core)(version>=1.1.0)(!(version>=2.0.0))) [caused by: Unable to resolve ch.qos.logback.core [8](R 8.0): missing requirement [ch.qos.logback.core [8](R 8.0)] osgi.ee; (&(osgi.ee=JavaSE)(version=1.6))]] Unresolved requirements: [[org.protege.editor.core.application [5](R 5.0)] osgi.wiring.package; (&(osgi.wiring.package=ch.qos.logback.classic.spi)(version>=1.1.0)(!(version>=2.0.0)))] at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4111) ~[org.apache.felix.main.jar:na] at org.apache.felix.framework.Felix.startBundle(Felix.java:2117) ~[org.apache.felix.main.jar:na] at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1371) ~[org.apache.felix.main.jar:na] at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:308) ~[org.apache.felix.main.jar:na] at java.base/java.lang.Thread.run(Thread.java:834) ~[na:na] Error starting file:/home/marlitalinda/Protege-5.5.0/protege/protege-desktop/target/protege-5.6.0-beta-1-SNAPSHOT-platform-independent/Protege-5.6.0-beta-1-SNAPSHOT/bundles/logback-core.jar org.osgi.framework.BundleException: Unable to resolve ch.qos.logback.core [8](R 8.0): missing requirement [ch.qos.logback.core [8](R 8.0)] osgi.ee; (&(osgi.ee=JavaSE)(version=1.6)) Unresolved requirements: [[ch.qos.logback.core [8](R 8.0)] osgi.ee; (&(osgi.ee=JavaSE)(version=1.6))] at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4111) ~[org.apache.felix.main.jar:na] at org.apache.felix.framework.Felix.startBundle(Felix.java:2117) ~[org.apache.felix.main.jar:na] at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1371) ~[org.apache.felix.main.jar:na] at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:308) ~[org.apache.felix.main.jar:na] at java.base/java.lang.Thread.run(Thread.java:834) ~[na:na] Error starting file:/home/marlitalinda/Protege-5.5.0/protege/protege-desktop/target/protege-5.6.0-beta-1-SNAPSHOT-platform-independent/Protege-5.6.0-beta-1-SNAPSHOT/bundles/jul-to-slf4j.jar org.osgi.framework.BundleException: Unable to resolve jul.to.slf4j [9](R 9.0): missing requirement [jul.to.slf4j [9](R 9.0)] osgi.wiring.package; (&(osgi.wiring.package=org.slf4j.spi)(version>=1.7.12)) [caused by: Unable to resolve slf4j.api [15](R 15.0): missing requirement [slf4j.api [15](R 15.0)] osgi.ee; (&(osgi.ee=JavaSE)(version=1.5.0))] Unresolved requirements: [[jul.to.slf4j [9](R 9.0)] osgi.wiring.package; (&(osgi.wiring.package=org.slf4j.spi)(version>=1.7.12))] at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4111) ~[org.apache.felix.main.jar:na] at org.apache.felix.framework.Felix.startBundle(Felix.java:2117) ~[org.apache.felix.main.jar:na] at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1371) ~[org.apache.felix.main.jar:na] at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:308) ~[org.apache.felix.main.jar:na] at java.base/java.lang.Thread.run(Thread.java:834) ~[na:na] Error starting file:/home/marlitalinda/Protege-5.5.0/protege/protege-desktop/target/protege-5.6.0-beta-1-SNAPSHOT-platform-independent/Protege-5.6.0-beta-1-SNAPSHOT/bundles/logback-classic.jar org.osgi.framework.BundleException: Unable to resolve ch.qos.logback.classic [10](R 10.0): missing requirement [ch.qos.logback.classic [10](R 10.0)] osgi.wiring.package; (&(osgi.wiring.package=ch.qos.logback.core)(version>=1.1.0)(!(version>=2.0.0))) [caused by: Unable to resolve ch.qos.logback.core [8](R 8.0): missing requirement [ch.qos.logback.core [8](R 8.0)] osgi.ee; (&(osgi.ee=JavaSE)(version=1.6))] Unresolved requirements: [[ch.qos.logback.classic [10](R 10.0)] osgi.wiring.package; (&(osgi.wiring.package=ch.qos.logback.core)(version>=1.1.0)(!(version>=2.0.0)))] at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4111) ~[org.apache.felix.main.jar:na] at org.apache.felix.framework.Felix.startBundle(Felix.java:2117) ~[org.apache.felix.main.jar:na] at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1371) ~[org.apache.felix.main.jar:na] at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:308) ~[org.apache.felix.main.jar:na] at java.base/java.lang.Thread.run(Thread.java:834) ~[na:na] Error starting file:/home/marlitalinda/Protege-5.5.0/protege/protege-desktop/target/protege-5.6.0-beta-1-SNAPSHOT-platform-independent/Protege-5.6.0-beta-1-SNAPSHOT/bundles/org.eclipse.jgit.jar org.osgi.framework.BundleException: Unable to resolve org.eclipse.jgit [11](R 11.0): missing requirement [org.eclipse.jgit [11](R 11.0)] osgi.wiring.package; (osgi.wiring.package=javax.crypto) Unresolved requirements: [[org.eclipse.jgit [11](R 11.0)] osgi.wiring.package; (osgi.wiring.package=javax.crypto)] at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4111) ~[org.apache.felix.main.jar:na] at org.apache.felix.framework.Felix.startBundle(Felix.java:2117) ~[org.apache.felix.main.jar:na] at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1371) ~[org.apache.felix.main.jar:na] at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:308) ~[org.apache.felix.main.jar:na] at java.base/java.lang.Thread.run(Thread.java:834) ~[na:na] Error starting file:/home/marlitalinda/Protege-5.5.0/protege/protege-desktop/target/protege-5.6.0-beta-1-SNAPSHOT-platform-independent/Protege-5.6.0-beta-1-SNAPSHOT/bundles/protege-editor-owl.jar org.osgi.framework.BundleException: Unable to resolve org.protege.editor.owl [12](R 12.0): missing requirement [org.protege.editor.owl [12](R 12.0)] osgi.wiring.package; (osgi.wiring.package=javax.annotation.processing) Unresolved requirements: [[org.protege.editor.owl [12](R 12.0)] osgi.wiring.package; (osgi.wiring.package=javax.annotation.processing)] at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4111) ~[org.apache.felix.main.jar:na] at org.apache.felix.framework.Felix.startBundle(Felix.java:2117) ~[org.apache.felix.main.jar:na] at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1371) ~[org.apache.felix.main.jar:na] at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:308) ~[org.apache.felix.main.jar:na] at java.base/java.lang.Thread.run(Thread.java:834) ~[na:na] Error starting file:/home/marlitalinda/Protege-5.5.0/protege/protege-desktop/target/protege-5.6.0-beta-1-SNAPSHOT-platform-independent/Protege-5.6.0-beta-1-SNAPSHOT/bundles/slf4j-api.jar org.osgi.framework.BundleException: Unable to resolve slf4j.api [15](R 15.0): missing requirement [slf4j.api [15](R 15.0)] osgi.ee; (&(osgi.ee=JavaSE)(version=1.5.0)) Unresolved requirements: [[slf4j.api [15](R 15.0)] osgi.ee; (&(osgi.ee=JavaSE)(version=1.5.0))] at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4111) ~[org.apache.felix.main.jar:na] at org.apache.felix.framework.Felix.startBundle(Felix.java:2117) ~[org.apache.felix.main.jar:na] at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1371) ~[org.apache.felix.main.jar:na] at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:308) ~[org.apache.felix.main.jar:na] at java.base/java.lang.Thread.run(Thread.java:834) ~[na:na] Error starting file:/home/marlitalinda/Protege-5.5.0/protege/protege-desktop/target/protege-5.6.0-beta-1-SNAPSHOT-platform-independent/Protege-5.6.0-beta-1-SNAPSHOT/bundles/owlapi-osgidistribution.jar org.osgi.framework.BundleException: Unable to resolve org.semanticweb.owl.owlapi [17](R 17.0): missing requirement [org.semanticweb.owl.owlapi [17](R 17.0)] osgi.wiring.package; (osgi.wiring.package=javax.crypto) Unresolved requirements: [[org.semanticweb.owl.owlapi [17](R 17.0)] osgi.wiring.package; (osgi.wiring.package=javax.crypto)] at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4111) ~[org.apache.felix.main.jar:na] at org.apache.felix.framework.Felix.startBundle(Felix.java:2117) ~[org.apache.felix.main.jar:na] at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1371) ~[org.apache.felix.main.jar:na] at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:308) ~[org.apache.felix.main.jar:na] at java.base/java.lang.Thread.run(Thread.java:834) ~[na:na] Error starting file:/home/marlitalinda/Protege-5.5.0/protege/protege-desktop/target/protege-5.6.0-beta-1-SNAPSHOT-platform-independent/Protege-5.6.0-beta-1-SNAPSHOT/bundles/log4j-over-slf4j.jar org.osgi.framework.BundleException: Unable to resolve log4j.over.slf4j [19](R 19.0): missing requirement [log4j.over.slf4j [19](R 19.0)] osgi.wiring.package; (&(osgi.wiring.package=org.slf4j.helpers)(version>=1.6.0)) [caused by: Unable to resolve slf4j.api [15](R 15.0): missing requirement [slf4j.api [15](R 15.0)] osgi.ee; (&(osgi.ee=JavaSE)(version=1.5.0))] Unresolved requirements: [[log4j.over.slf4j [19](R 19.0)] osgi.wiring.package; (&(osgi.wiring.package=org.slf4j.helpers)(version>=1.6.0))] at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4111) ~[org.apache.felix.main.jar:na] at org.apache.felix.framework.Felix.startBundle(Felix.java:2117) ~[org.apache.felix.main.jar:na] at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1371) ~[org.apache.felix.main.jar:na] at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:308) ~[org.apache.felix.main.jar:na] at java.base/java.lang.Thread.run(Thread.java:834) ~[na:na] The OSGi framework has been started

Sent from the Protege User mailing list archive at Nabble.com.

_______________________________________________
protege-user mailing list
[hidden email]
https://mailman.stanford.edu/mailman/listinfo/protege-user
Reply | Threaded
Open this post in threaded view
|

Re: Protege 5-5 and Java 11

Matthew Horridge-2
Administrator
Hi Marla,

You need to use Java 8 with Protege 5.5.0

Cheers,

Matthew


On Apr 26, 2019, at 16:43, Marla Barrera <[hidden email]> wrote:

Hi: I has Java 11 and linux Mint, I had tryed to install Protege 5.5., and I have the following error: WARNING: An illegal reflective access operation has occurred WARNING: Illegal reflective access by org.apache.felix.framework.util.SecureAction (file:/home/marlitalinda/Protege-5.5.0/protege/protege-desktop/target/protege-5.6.0-beta-1-SNAPSHOT-platform-independent/Protege-5.6.0-beta-1-SNAPSHOT/bin/org.apache.felix.main.jar) to method java.net.URLClassLoader.addURL(java.net.URL) WARNING: Please consider reporting this to the maintainers of org.apache.felix.framework.util.SecureAction WARNING: Use --illegal-access=warn to enable warnings of further illegal reflective access operations WARNING: All illegal access operations will be denied in a future release The OSGi framework has been initialised ------------------------------- Starting Bundles ------------------------------- Starting bundle org.protege.common Starting bundle org.eclipse.equinox.supplement Starting bundle org.eclipse.equinox.common Starting bundle org.eclipse.equinox.registry Starting bundle org.protege.editor.core.application Starting bundle org.apache.commons.io Starting bundle org.eclipse.equinox.supplement Starting bundle org.apache.servicemix.bundles.javax-inject Starting bundle org.eclipse.equinox.registry Starting bundle ch.qos.logback.core Starting bundle jul.to.slf4j Starting bundle org.eclipse.equinox.common Starting bundle ch.qos.logback.classic Starting bundle org.eclipse.jgit Starting bundle org.protege.editor.owl Starting bundle com.googlecode.javaewah.JavaEWAH Starting bundle org.protege.editor.core.application Starting bundle org.jsr-305 Starting bundle slf4j.api Starting bundle com.google.guava Starting bundle org.semanticweb.owl.owlapi Starting bundle org.apache.servicemix.bundles.aopalliance Starting bundle log4j.over.slf4j Starting bundle org.protege.common Error starting file:/home/marlitalinda/Protege-5.5.0/protege/protege-desktop/target/protege-5.6.0-beta-1-SNAPSHOT-platform-independent/Protege-5.6.0-beta-1-SNAPSHOT/bundles/protege-common.jar org.osgi.framework.BundleException: Unable to resolve org.protege.common [1](R 1.0): missing requirement [org.protege.common [1](R 1.0)] osgi.wiring.package; (&(osgi.wiring.package=org.slf4j)(version>=1.7.0)(!(version>=2.0.0))) [caused by: Unable to resolve slf4j.api [15](R 15.0): missing requirement [slf4j.api [15](R 15.0)] osgi.ee; (&(osgi.ee=JavaSE)(version=1.5.0))] Unresolved requirements: [[org.protege.common [1](R 1.0)] osgi.wiring.package; (&(osgi.wiring.package=org.slf4j)(version>=1.7.0)(!(version>=2.0.0)))] at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4111) ~[org.apache.felix.main.jar:na] at org.apache.felix.framework.Felix.startBundle(Felix.java:2117) ~[org.apache.felix.main.jar:na] at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1371) ~[org.apache.felix.main.jar:na] at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:308) ~[org.apache.felix.main.jar:na] at java.base/java.lang.Thread.run(Thread.java:834) ~[na:na] Error starting file:/home/marlitalinda/Protege-5.5.0/protege/protege-desktop/target/protege-5.6.0-beta-1-SNAPSHOT-platform-independent/Protege-5.6.0-beta-1-SNAPSHOT/bundles/org.eclipse.equinox.supplement.jar org.osgi.framework.BundleException: Unable to resolve org.eclipse.equinox.supplement [2](R 2.0): missing requirement [org.eclipse.equinox.supplement [2](R 2.0)] osgi.ee; (|(&(osgi.ee=JavaSE)(version=1.4.0))(&(osgi.ee=CDC/Foundation)(version=1.0.0))(&(osgi.ee=JavaSE)(version=1.3.0))) Unresolved requirements: [[org.eclipse.equinox.supplement [2](R 2.0)] osgi.ee; (|(&(osgi.ee=JavaSE)(version=1.4.0))(&(osgi.ee=CDC/Foundation)(version=1.0.0))(&(osgi.ee=JavaSE)(version=1.3.0)))] at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4111) ~[org.apache.felix.main.jar:na] at org.apache.felix.framework.Felix.startBundle(Felix.java:2117) ~[org.apache.felix.main.jar:na] at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1371) ~[org.apache.felix.main.jar:na] at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:308) ~[org.apache.felix.main.jar:na] at java.base/java.lang.Thread.run(Thread.java:834) ~[na:na] Error starting file:/home/marlitalinda/Protege-5.5.0/protege/protege-desktop/target/protege-5.6.0-beta-1-SNAPSHOT-platform-independent/Protege-5.6.0-beta-1-SNAPSHOT/bundles/org.eclipse.equinox.common.jar org.osgi.framework.BundleException: Unable to resolve org.eclipse.equinox.common [3](R 3.0): missing requirement [org.eclipse.equinox.common [3](R 3.0)] osgi.wiring.package; (osgi.wiring.package=org.eclipse.osgi.service.datalocation) [caused by: Unable to resolve org.eclipse.equinox.supplement [2](R 2.0): missing requirement [org.eclipse.equinox.supplement [2](R 2.0)] osgi.ee; (|(&(osgi.ee=JavaSE)(version=1.4.0))(&(osgi.ee=CDC/Foundation)(version=1.0.0))(&(osgi.ee=JavaSE)(version=1.3.0)))] Unresolved requirements: [[org.eclipse.equinox.common [3](R 3.0)] osgi.wiring.package; (osgi.wiring.package=org.eclipse.osgi.service.datalocation)] at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4111) ~[org.apache.felix.main.jar:na] at org.apache.felix.framework.Felix.startBundle(Felix.java:2117) ~[org.apache.felix.main.jar:na] at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1371) ~[org.apache.felix.main.jar:na] at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:308) ~[org.apache.felix.main.jar:na] at java.base/java.lang.Thread.run(Thread.java:834) ~[na:na] Error starting file:/home/marlitalinda/Protege-5.5.0/protege/protege-desktop/target/protege-5.6.0-beta-1-SNAPSHOT-platform-independent/Protege-5.6.0-beta-1-SNAPSHOT/bundles/org.eclipse.equinox.registry.jar org.osgi.framework.BundleException: Unable to resolve org.eclipse.equinox.registry [4](R 4.0): missing requirement [org.eclipse.equinox.registry [4](R 4.0)] osgi.wiring.package; (osgi.wiring.package=org.eclipse.osgi.service.debug) [caused by: Unable to resolve org.eclipse.equinox.supplement [2](R 2.0): missing requirement [org.eclipse.equinox.supplement [2](R 2.0)] osgi.ee; (|(&(osgi.ee=JavaSE)(version=1.4.0))(&(osgi.ee=CDC/Foundation)(version=1.0.0))(&(osgi.ee=JavaSE)(version=1.3.0)))] Unresolved requirements: [[org.eclipse.equinox.registry [4](R 4.0)] osgi.wiring.package; (osgi.wiring.package=org.eclipse.osgi.service.debug)] at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4111) ~[org.apache.felix.main.jar:na] at org.apache.felix.framework.Felix.startBundle(Felix.java:2117) ~[org.apache.felix.main.jar:na] at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1371) ~[org.apache.felix.main.jar:na] at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:308) ~[org.apache.felix.main.jar:na] at java.base/java.lang.Thread.run(Thread.java:834) ~[na:na] Error starting file:/home/marlitalinda/Protege-5.5.0/protege/protege-desktop/target/protege-5.6.0-beta-1-SNAPSHOT-platform-independent/Protege-5.6.0-beta-1-SNAPSHOT/bundles/protege-editor-core.jar org.osgi.framework.BundleException: Unable to resolve org.protege.editor.core.application [5](R 5.0): missing requirement [org.protege.editor.core.application [5](R 5.0)] osgi.wiring.package; (&(osgi.wiring.package=ch.qos.logback.classic.spi)(version>=1.1.0)(!(version>=2.0.0))) [caused by: Unable to resolve ch.qos.logback.classic [10](R 10.0): missing requirement [ch.qos.logback.classic [10](R 10.0)] osgi.wiring.package; (&(osgi.wiring.package=ch.qos.logback.core)(version>=1.1.0)(!(version>=2.0.0))) [caused by: Unable to resolve ch.qos.logback.core [8](R 8.0): missing requirement [ch.qos.logback.core [8](R 8.0)] osgi.ee; (&(osgi.ee=JavaSE)(version=1.6))]] Unresolved requirements: [[org.protege.editor.core.application [5](R 5.0)] osgi.wiring.package; (&(osgi.wiring.package=ch.qos.logback.classic.spi)(version>=1.1.0)(!(version>=2.0.0)))] at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4111) ~[org.apache.felix.main.jar:na] at org.apache.felix.framework.Felix.startBundle(Felix.java:2117) ~[org.apache.felix.main.jar:na] at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1371) ~[org.apache.felix.main.jar:na] at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:308) ~[org.apache.felix.main.jar:na] at java.base/java.lang.Thread.run(Thread.java:834) ~[na:na] Error starting file:/home/marlitalinda/Protege-5.5.0/protege/protege-desktop/target/protege-5.6.0-beta-1-SNAPSHOT-platform-independent/Protege-5.6.0-beta-1-SNAPSHOT/bundles/logback-core.jar org.osgi.framework.BundleException: Unable to resolve ch.qos.logback.core [8](R 8.0): missing requirement [ch.qos.logback.core [8](R 8.0)] osgi.ee; (&(osgi.ee=JavaSE)(version=1.6)) Unresolved requirements: [[ch.qos.logback.core [8](R 8.0)] osgi.ee; (&(osgi.ee=JavaSE)(version=1.6))] at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4111) ~[org.apache.felix.main.jar:na] at org.apache.felix.framework.Felix.startBundle(Felix.java:2117) ~[org.apache.felix.main.jar:na] at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1371) ~[org.apache.felix.main.jar:na] at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:308) ~[org.apache.felix.main.jar:na] at java.base/java.lang.Thread.run(Thread.java:834) ~[na:na] Error starting file:/home/marlitalinda/Protege-5.5.0/protege/protege-desktop/target/protege-5.6.0-beta-1-SNAPSHOT-platform-independent/Protege-5.6.0-beta-1-SNAPSHOT/bundles/jul-to-slf4j.jar org.osgi.framework.BundleException: Unable to resolve jul.to.slf4j [9](R 9.0): missing requirement [jul.to.slf4j [9](R 9.0)] osgi.wiring.package; (&(osgi.wiring.package=org.slf4j.spi)(version>=1.7.12)) [caused by: Unable to resolve slf4j.api [15](R 15.0): missing requirement [slf4j.api [15](R 15.0)] osgi.ee; (&(osgi.ee=JavaSE)(version=1.5.0))] Unresolved requirements: [[jul.to.slf4j [9](R 9.0)] osgi.wiring.package; (&(osgi.wiring.package=org.slf4j.spi)(version>=1.7.12))] at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4111) ~[org.apache.felix.main.jar:na] at org.apache.felix.framework.Felix.startBundle(Felix.java:2117) ~[org.apache.felix.main.jar:na] at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1371) ~[org.apache.felix.main.jar:na] at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:308) ~[org.apache.felix.main.jar:na] at java.base/java.lang.Thread.run(Thread.java:834) ~[na:na] Error starting file:/home/marlitalinda/Protege-5.5.0/protege/protege-desktop/target/protege-5.6.0-beta-1-SNAPSHOT-platform-independent/Protege-5.6.0-beta-1-SNAPSHOT/bundles/logback-classic.jar org.osgi.framework.BundleException: Unable to resolve ch.qos.logback.classic [10](R 10.0): missing requirement [ch.qos.logback.classic [10](R 10.0)] osgi.wiring.package; (&(osgi.wiring.package=ch.qos.logback.core)(version>=1.1.0)(!(version>=2.0.0))) [caused by: Unable to resolve ch.qos.logback.core [8](R 8.0): missing requirement [ch.qos.logback.core [8](R 8.0)] osgi.ee; (&(osgi.ee=JavaSE)(version=1.6))] Unresolved requirements: [[ch.qos.logback.classic [10](R 10.0)] osgi.wiring.package; (&(osgi.wiring.package=ch.qos.logback.core)(version>=1.1.0)(!(version>=2.0.0)))] at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4111) ~[org.apache.felix.main.jar:na] at org.apache.felix.framework.Felix.startBundle(Felix.java:2117) ~[org.apache.felix.main.jar:na] at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1371) ~[org.apache.felix.main.jar:na] at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:308) ~[org.apache.felix.main.jar:na] at java.base/java.lang.Thread.run(Thread.java:834) ~[na:na] Error starting file:/home/marlitalinda/Protege-5.5.0/protege/protege-desktop/target/protege-5.6.0-beta-1-SNAPSHOT-platform-independent/Protege-5.6.0-beta-1-SNAPSHOT/bundles/org.eclipse.jgit.jar org.osgi.framework.BundleException: Unable to resolve org.eclipse.jgit [11](R 11.0): missing requirement [org.eclipse.jgit [11](R 11.0)] osgi.wiring.package; (osgi.wiring.package=javax.crypto) Unresolved requirements: [[org.eclipse.jgit [11](R 11.0)] osgi.wiring.package; (osgi.wiring.package=javax.crypto)] at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4111) ~[org.apache.felix.main.jar:na] at org.apache.felix.framework.Felix.startBundle(Felix.java:2117) ~[org.apache.felix.main.jar:na] at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1371) ~[org.apache.felix.main.jar:na] at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:308) ~[org.apache.felix.main.jar:na] at java.base/java.lang.Thread.run(Thread.java:834) ~[na:na] Error starting file:/home/marlitalinda/Protege-5.5.0/protege/protege-desktop/target/protege-5.6.0-beta-1-SNAPSHOT-platform-independent/Protege-5.6.0-beta-1-SNAPSHOT/bundles/protege-editor-owl.jar org.osgi.framework.BundleException: Unable to resolve org.protege.editor.owl [12](R 12.0): missing requirement [org.protege.editor.owl [12](R 12.0)] osgi.wiring.package; (osgi.wiring.package=javax.annotation.processing) Unresolved requirements: [[org.protege.editor.owl [12](R 12.0)] osgi.wiring.package; (osgi.wiring.package=javax.annotation.processing)] at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4111) ~[org.apache.felix.main.jar:na] at org.apache.felix.framework.Felix.startBundle(Felix.java:2117) ~[org.apache.felix.main.jar:na] at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1371) ~[org.apache.felix.main.jar:na] at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:308) ~[org.apache.felix.main.jar:na] at java.base/java.lang.Thread.run(Thread.java:834) ~[na:na] Error starting file:/home/marlitalinda/Protege-5.5.0/protege/protege-desktop/target/protege-5.6.0-beta-1-SNAPSHOT-platform-independent/Protege-5.6.0-beta-1-SNAPSHOT/bundles/slf4j-api.jar org.osgi.framework.BundleException: Unable to resolve slf4j.api [15](R 15.0): missing requirement [slf4j.api [15](R 15.0)] osgi.ee; (&(osgi.ee=JavaSE)(version=1.5.0)) Unresolved requirements: [[slf4j.api [15](R 15.0)] osgi.ee; (&(osgi.ee=JavaSE)(version=1.5.0))] at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4111) ~[org.apache.felix.main.jar:na] at org.apache.felix.framework.Felix.startBundle(Felix.java:2117) ~[org.apache.felix.main.jar:na] at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1371) ~[org.apache.felix.main.jar:na] at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:308) ~[org.apache.felix.main.jar:na] at java.base/java.lang.Thread.run(Thread.java:834) ~[na:na] Error starting file:/home/marlitalinda/Protege-5.5.0/protege/protege-desktop/target/protege-5.6.0-beta-1-SNAPSHOT-platform-independent/Protege-5.6.0-beta-1-SNAPSHOT/bundles/owlapi-osgidistribution.jar org.osgi.framework.BundleException: Unable to resolve org.semanticweb.owl.owlapi [17](R 17.0): missing requirement [org.semanticweb.owl.owlapi [17](R 17.0)] osgi.wiring.package; (osgi.wiring.package=javax.crypto) Unresolved requirements: [[org.semanticweb.owl.owlapi [17](R 17.0)] osgi.wiring.package; (osgi.wiring.package=javax.crypto)] at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4111) ~[org.apache.felix.main.jar:na] at org.apache.felix.framework.Felix.startBundle(Felix.java:2117) ~[org.apache.felix.main.jar:na] at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1371) ~[org.apache.felix.main.jar:na] at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:308) ~[org.apache.felix.main.jar:na] at java.base/java.lang.Thread.run(Thread.java:834) ~[na:na] Error starting file:/home/marlitalinda/Protege-5.5.0/protege/protege-desktop/target/protege-5.6.0-beta-1-SNAPSHOT-platform-independent/Protege-5.6.0-beta-1-SNAPSHOT/bundles/log4j-over-slf4j.jar org.osgi.framework.BundleException: Unable to resolve log4j.over.slf4j [19](R 19.0): missing requirement [log4j.over.slf4j [19](R 19.0)] osgi.wiring.package; (&(osgi.wiring.package=org.slf4j.helpers)(version>=1.6.0)) [caused by: Unable to resolve slf4j.api [15](R 15.0): missing requirement [slf4j.api [15](R 15.0)] osgi.ee; (&(osgi.ee=JavaSE)(version=1.5.0))] Unresolved requirements: [[log4j.over.slf4j [19](R 19.0)] osgi.wiring.package; (&(osgi.wiring.package=org.slf4j.helpers)(version>=1.6.0))] at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4111) ~[org.apache.felix.main.jar:na] at org.apache.felix.framework.Felix.startBundle(Felix.java:2117) ~[org.apache.felix.main.jar:na] at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1371) ~[org.apache.felix.main.jar:na] at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:308) ~[org.apache.felix.main.jar:na] at java.base/java.lang.Thread.run(Thread.java:834) ~[na:na] The OSGi framework has been started

Sent from the Protege User mailing list archive at Nabble.com.
_______________________________________________
protege-user mailing list
[hidden email]
https://mailman.stanford.edu/mailman/listinfo/protege-user


_______________________________________________
protege-user mailing list
[hidden email]
https://mailman.stanford.edu/mailman/listinfo/protege-user