Protege BETA 5.0

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

Protege BETA 5.0

Dr. Kofi Nyamekye

Jennifer:

 

I tried to run Protégé BETA 5.0 just to see how it would work. Below is the screen shot of the first error  message that I got.  When I selected yes to download the “RacerPro reasoner file,” I got another error message.  Please see the second screen shot.

 

cid:image001.png@01CF5D46.B0FF50D0

 

 

 

 

 

What do both errors mean and how do I fix them? I am using Windows 7 Professional Version and I am running it as administrator. By the way, I downloaded BETA 5.0 from the link you gave to Mr. Altaf on April 14, 2014. Please see below, my email correspondence with Mr. Altaf.

 

Also, I noticed that with BETA 5.0, no installation is required to run it, after all the files are extracted to some folder. Is this the way for future versions of Protégé? Just for curiosity!

 

Best Regards,

 

Kofi

 

 

 

From: Dr. Kofi Nyamekye [[hidden email]]
Sent: Saturday, April 19, 2014 4:01 PM
To: 'User support for WebProtege and Protege Desktop'
Subject: RE: [protege-user] Help needed in Protege 4.3

 

Altaf:

 

Thanks. I will try it!

 

Best Regards,

 

Kofi

 

From: protege-user [[hidden email]] On Behalf Of Altaf
Sent: Saturday, April 19, 2014 3:58 PM
To: User support for WebProtege and Protege Desktop
Subject: Re: [protege-user] Help needed in Protege 4.3

 

Daer Dr. Kofi Nyamekye

 

I have downloaded and run it successfully. You can try also. For me it is working fine.

 

Regards

 

Altaf

 

On Sat, Apr 19, 2014 at 10:50 PM, Dr. Kofi Nyamekye <[hidden email]> wrote:

Jennifer:

 

Is there is a new version of Protégé – Protégé-5 –, based on the link that you provided in response to Altaf’s question on April 14, 2014?

 

http://protege.stanford.edu/download/protege/5.0/snapshots/protege-5.0.0-beta-05-2014_04_17.zip

 

Can we download and install it or wait until the final version is out?

 

Best Regards,

 

Kofi

 

 

From: protege-user [mailto:[hidden email]] On Behalf Of Csongor Nyulas
Sent: Saturday, April 19, 2014 3:31 PM
To:
[hidden email]
Subject: Re: [protege-user] Help needed in Protege 4.3

 

Dear Altaf,

As I have solved this "mystery" in my response to you from April 15th:
http://protege-project.136.n4.nabble.com/Display-problem-with-trees-in-Protege-4-3-tp4660203p4660252.html

The problem is that you mixed up the domain and range of the isToppingOf property.
Domain should be: PizzaTopping, and range should be: Pizza, because a pizza topping is a topping of a pizza, not vice-versa.
Once you make those changes the ontology will classify correctly.

Csongor

On 04/18/2014 06:44 PM, Altaf wrote:

Respected Jennifer Vendetti

 

Hoping that you will be fine.

 

I am very thankful for the detail answer and the NULLpointer exception is resolved. 

 

But if you can guide me in my second problem I would be very thankful to you. I am using the documentation "A Practical Guide To Building OWL Ontologies Using Protege 4 and CO-ODE Tools Edition 1.3". When I put the object restriction of "some" then the reasoner whatever I use Pellet, HermiT the restriction does not work and the inferred Classes hierarchy does not match to the desired logic. The example file is attached please find it as an attachment. 

 

Please guide me in this regards.

 

Best Regards

 

On Fri, Apr 18, 2014 at 11:58 PM, Jennifer Vendetti <[hidden email]> wrote:

Hello Altaf,



On 4/14/2014 11:00 AM, Altaf wrote:

I am using the protege 4.3 64 bit on Windows 7 enterprise edition. When I open the ontology I get NULL pointer exception. The log file is attached. Please find it as attachment.

 

Thank you for reporting the exception.  Someone reported the same exception in February of this year, but as of yet we've been unable to reproduce it locally.  Timothy added some defensive code in our GitHub repository.  I built a Protege distribution from the latest sources and put it out on our website:

http://protege.stanford.edu/download/protege/5.0/snapshots/protege-5.0.0-beta-05-2014_04_17.zip

If you're willing, you could download this Protege distribution and let us know if you still get the NullPointerException.  It's in the form of a ZIP file, so you'd have to unzip it to a location of your choice and use the appropriate batch file for your platform to run Protege, e.g., "run.bat" for Windows.

I've also entered a bug in our issue tracker:

https://github.com/protegeproject/protege/issues/34

Jennifer

_______________________________________________
protege-user mailing list
[hidden email]
https://mailman.stanford.edu/mailman/listinfo/protege-user



 

--


Altaf 

 

 

_______________________________________________
protege-user mailing list
[hidden email]
https://mailman.stanford.edu/mailman/listinfo/protege-user

 


_______________________________________________
protege-user mailing list
[hidden email]
https://mailman.stanford.edu/mailman/listinfo/protege-user



 

--


Altaf 

 


_______________________________________________
protege-user mailing list
[hidden email]
https://mailman.stanford.edu/mailman/listinfo/protege-user
Reply | Threaded
Open this post in threaded view
|

Re: Protege BETA 5.0

Jennifer Vendetti
Administrator
Hello Kofi.  It's easier for us if you could attach your Protege log file instead of screenshots.  On Windows, the log file is located here: C:\Users\<your-username>\.Protege\logs.

This is just a guess, but from your screen shots it looks like Protege is trying to check for an update for the RacerPro plug-in, and the update properties file for this plug-in is no longer available (http://www.racer-systems.com/protege/update.info).  What are the contents of the Protege plugins directory in your user directory, i.e.: C:\Users\<your-username>\.Protege\plugins?  Is there a JAR file in there for the RacerPro reasoner?  If so, could you send it to us?  I looked at the Racer website and it seems they no longer offer a Protege plug-in (at least that I could find).

As to your other question, there is not an official Protege 5.0 beta build available from our main website yet.  We provided a ZIP file on our mailing list because we wanted confirmation that we'd fixed an exception that we weren't able to reproduce locally [1].

Jennifer

[1] https://github.com/protegeproject/protege/issues/34


On 4/21/2014 8:39 AM, Dr. Kofi Nyamekye wrote:
I tried to run Protégé BETA 5.0 just to see how it would work. Below is the screen shot of the first error  message that I got.  When I selected yes to download the “RacerPro reasoner file,” I got another error message.  Please see the second screen shot.

 

cid:image001.png@01CF5D46.B0FF50D0

 

 

 

 

 

What do both errors mean and how do I fix them? I am using Windows 7 Professional Version and I am running it as administrator. By the way, I downloaded BETA 5.0 from the link you gave to Mr. Altaf on April 14, 2014. Please see below, my email correspondence with Mr. Altaf.

 

Also, I noticed that with BETA 5.0, no installation is required to run it, after all the files are extracted to some folder. Is this the way for future versions of Protégé? Just for curiosity!

 

Best Regards,

 

Kofi

 

 

 

From: Dr. Kofi Nyamekye [[hidden email]]
Sent: Saturday, April 19, 2014 4:01 PM
To: 'User support for WebProtege and Protege Desktop'
Subject: RE: [protege-user] Help needed in Protege 4.3

 

Altaf:

 

Thanks. I will try it!

 

Best Regards,

 

Kofi

 

From: protege-user [[hidden email]] On Behalf Of Altaf
Sent: Saturday, April 19, 2014 3:58 PM
To: User support for WebProtege and Protege Desktop
Subject: Re: [protege-user] Help needed in Protege 4.3

 

Daer Dr. Kofi Nyamekye

 

I have downloaded and run it successfully. You can try also. For me it is working fine.

 

Regards

 

Altaf

 

On Sat, Apr 19, 2014 at 10:50 PM, Dr. Kofi Nyamekye <[hidden email]> wrote:

Jennifer:

 

Is there is a new version of Protégé – Protégé-5 –, based on the link that you provided in response to Altaf’s question on April 14, 2014?

 

http://protege.stanford.edu/download/protege/5.0/snapshots/protege-5.0.0-beta-05-2014_04_17.zip

 

Can we download and install it or wait until the final version is out?

 

Best Regards,

 

Kofi

 

 

From: protege-user [mailto:[hidden email]] On Behalf Of Csongor Nyulas
Sent: Saturday, April 19, 2014 3:31 PM
To:
[hidden email]
Subject: Re: [protege-user] Help needed in Protege 4.3

 

Dear Altaf,

As I have solved this "mystery" in my response to you from April 15th:
http://protege-project.136.n4.nabble.com/Display-problem-with-trees-in-Protege-4-3-tp4660203p4660252.html

The problem is that you mixed up the domain and range of the isToppingOf property.
Domain should be: PizzaTopping, and range should be: Pizza, because a pizza topping is a topping of a pizza, not vice-versa.
Once you make those changes the ontology will classify correctly.

Csongor

On 04/18/2014 06:44 PM, Altaf wrote:

Respected Jennifer Vendetti

 

Hoping that you will be fine.

 

I am very thankful for the detail answer and the NULLpointer exception is resolved. 

 

But if you can guide me in my second problem I would be very thankful to you. I am using the documentation "A Practical Guide To Building OWL Ontologies Using Protege 4 and CO-ODE Tools Edition 1.3". When I put the object restriction of "some" then the reasoner whatever I use Pellet, HermiT the restriction does not work and the inferred Classes hierarchy does not match to the desired logic. The example file is attached please find it as an attachment. 

 

Please guide me in this regards.

 

Best Regards

 

On Fri, Apr 18, 2014 at 11:58 PM, Jennifer Vendetti <[hidden email]> wrote:

Hello Altaf,



On 4/14/2014 11:00 AM, Altaf wrote:

I am using the protege 4.3 64 bit on Windows 7 enterprise edition. When I open the ontology I get NULL pointer exception. The log file is attached. Please find it as attachment.

 

Thank you for reporting the exception.  Someone reported the same exception in February of this year, but as of yet we've been unable to reproduce it locally.  Timothy added some defensive code in our GitHub repository.  I built a Protege distribution from the latest sources and put it out on our website:

http://protege.stanford.edu/download/protege/5.0/snapshots/protege-5.0.0-beta-05-2014_04_17.zip

If you're willing, you could download this Protege distribution and let us know if you still get the NullPointerException.  It's in the form of a ZIP file, so you'd have to unzip it to a location of your choice and use the appropriate batch file for your platform to run Protege, e.g., "run.bat" for Windows.

I've also entered a bug in our issue tracker:

https://github.com/protegeproject/protege/issues/34

Jennifer

_______________________________________________
protege-user mailing list
[hidden email]
https://mailman.stanford.edu/mailman/listinfo/protege-user



 

--


Altaf 

 

 

_______________________________________________
protege-user mailing list
[hidden email]
https://mailman.stanford.edu/mailman/listinfo/protege-user

 


_______________________________________________
protege-user mailing list
[hidden email]
https://mailman.stanford.edu/mailman/listinfo/protege-user



 

--


Altaf 

 



_______________________________________________
protege-user mailing list
[hidden email]
https://mailman.stanford.edu/mailman/listinfo/protege-user


_______________________________________________
protege-user mailing list
[hidden email]
https://mailman.stanford.edu/mailman/listinfo/protege-user
Reply | Threaded
Open this post in threaded view
|

Re: Protege BETA 5.0

Jennifer Vendetti
Administrator
In reply to this post by Dr. Kofi Nyamekye
On 4/21/2014 8:39 AM, Dr. Kofi Nyamekye wrote:

 Also, I noticed that with BETA 5.0, no installation is required to run it, after all the files are extracted to some folder. Is this the way for future versions of Protégé? Just for curiosity!


When we do the first official 5.0 beta release, we plan to have all the usual means of installation available, i.e., a platform independent installer program, an OS X application bundle, and a plain ZIP file.

Jennifer


_______________________________________________
protege-user mailing list
[hidden email]
https://mailman.stanford.edu/mailman/listinfo/protege-user
Reply | Threaded
Open this post in threaded view
|

Re: Protege BETA 5.0

Dr. Kofi Nyamekye

Jennifer:

 

Thank you for letting me know!

 

Kofi

 

 

 

 

From: protege-user [mailto:[hidden email]] On Behalf Of Jennifer Vendetti
Sent: Wednesday, April 23, 2014 4:43 PM
To: User support for WebProtege and Protege Desktop
Subject: Re: [protege-user] Protege BETA 5.0

 

On 4/21/2014 8:39 AM, Dr. Kofi Nyamekye wrote:

 Also, I noticed that with BETA 5.0, no installation is required to run it, after all the files are extracted to some folder. Is this the way for future versions of Protégé? Just for curiosity!


When we do the first official 5.0 beta release, we plan to have all the usual means of installation available, i.e., a platform independent installer program, an OS X application bundle, and a plain ZIP file.

Jennifer


_______________________________________________
protege-user mailing list
[hidden email]
https://mailman.stanford.edu/mailman/listinfo/protege-user