Protege issue

classic Classic list List threaded Threaded
5 messages Options
LZ
Reply | Threaded
Open this post in threaded view
|

Protege issue

LZ
A couple of people I know reported difficulties in using Protege Desktop. 

"I downloaded and installed Protege desktop for Macs. I saved my owl file to my computer as well. What is happening is that while I am editing within Protege it will start to behave sluggishly then freeze up, I then have to close out and open my owl file again--it may be the version from twelve iterations ago...or the most recent, it's a toss up. The most recent freeze/crash, took all my work from this afternoon. I save after almost everything I input so there is no rhyme or reason for this to be happening that I can see other than Protege itself having issues. It is beyond frustrating.

I should have also mentioned that I'm using Protege 5.2.0. I tried an earlier version yesterday, and wasn't having any better success with it."

Please advise. Thanks. 

_______________________________________________
protege-user mailing list
[hidden email]
https://mailman.stanford.edu/mailman/listinfo/protege-user
Reply | Threaded
Open this post in threaded view
|

Re: Protege issue

Rafael Gonçalves
Hi Lei,

Can you tell us what operation you were doing before Protege crashed? Were there any errors in the console? 

To better help you, could you please post the Protege log (or a fragment of it) related to the editing session that caused Protege to crash?

Cheers,
Rafael

On Jun 30, 2017, at 01:58, Lei Zhang <[hidden email]> wrote:

A couple of people I know reported difficulties in using Protege Desktop. 

"I downloaded and installed Protege desktop for Macs. I saved my owl file to my computer as well. What is happening is that while I am editing within Protege it will start to behave sluggishly then freeze up, I then have to close out and open my owl file again--it may be the version from twelve iterations ago...or the most recent, it's a toss up. The most recent freeze/crash, took all my work from this afternoon. I save after almost everything I input so there is no rhyme or reason for this to be happening that I can see other than Protege itself having issues. It is beyond frustrating.

I should have also mentioned that I'm using Protege 5.2.0. I tried an earlier version yesterday, and wasn't having any better success with it."

Please advise. Thanks. 
_______________________________________________
protege-user mailing list
[hidden email]
https://mailman.stanford.edu/mailman/listinfo/protege-user


_______________________________________________
protege-user mailing list
[hidden email]
https://mailman.stanford.edu/mailman/listinfo/protege-user
LZ
Reply | Threaded
Open this post in threaded view
|

Re: Protege issue

LZ
Here is what she said.

"Sorry, I cleared the logs from yesterday this morning. However, you may convey to Protege that most issues occurred when creating object properties either while having Reasoner HermiT 1.3.8.413 running or right after I started it. I haven't crashed (yet) today, but I've stopped running the Reasoner altogether. I know that is not a best practice, but I am very wary of using it."

Another person said, "My ontology was deleted again, even after I re-installed Protege Desktop. Whenever I open the file all my classes are wiped out and the URI says "Anonymous ID". I can re-import the ontology from my hard drive, but I'm afraid it will keep deleting itself. I have checked my computer for malware, and this is not the problem."
Reply | Threaded
Open this post in threaded view
|

Re: Protege issue

samsontu
Hi,

Are your colleagues working with large ontologies? If that’s the case, the most likely problem is inadequate memory allocated to the java Protege process. See [1] for instruction on how to increase the memory allocation to the process.

If the ontologies are not large, it would be ideal if you/they can share it so that there is a chance of reproducing the problem.

As for Protege ‘deleting ontologies’, that’s most likely a problem in saving the ontology. After performing a ‘save’ operation, check to the log to see whether there is any error or exception. Open the OWL file in a text editor to verify that the ontology has been saved.

With best regards,
Samson

[1] https://protegewiki.stanford.edu/wiki/Setting_Heap_Size
On Jun 30, 2017, at 1:33 PM, LZ <[hidden email]> wrote:

Here is what she said.

"Sorry, I cleared the logs from yesterday this morning. However, you may
convey to Protege that most issues occurred when creating object properties
either while having Reasoner HermiT 1.3.8.413 running or right after I
started it. I haven't crashed (yet) today, but I've stopped running the
Reasoner altogether. I know that is not a best practice, but I am very wary
of using it."

Another person said, "My ontology was deleted again, even after I
re-installed Protege Desktop. Whenever I open the file all my classes are
wiped out and the URI says "Anonymous ID". I can re-import the ontology from
my hard drive, but I'm afraid it will keep deleting itself. I have checked
my computer for malware, and this is not the problem."



--
View this message in context: http://protege-project.136.n4.nabble.com/Protege-issue-tp4668993p4669001.html
Sent from the Protege User mailing list archive at Nabble.com.
_______________________________________________
protege-user mailing list
[hidden email]
https://mailman.stanford.edu/mailman/listinfo/protege-user

-- 
Samson Tu                                                      email: [hidden email]
Senior Research Engineer                              web: www.stanford.edu/~swt/
Center for Biomedical Informatics Research  phone: 1-650-725-3391
Stanford University                                          fax: 1-650-725-7944




_______________________________________________
protege-user mailing list
[hidden email]
https://mailman.stanford.edu/mailman/listinfo/protege-user
LZ
Reply | Threaded
Open this post in threaded view
|

Re: Protege issue

LZ
In reply to this post by LZ
Now a third person says, "My protégé software won't open. I finished my ontology, and then updated the plugins so I could run my queries. I closed the program and tried to re-open, but nothing happens. I've been troubleshooting for the past hour with no luck. Restarted the computer, etc. ... I have uninstalled and re-installed Protégé, including updating Java, and the program will not open. I don't know what else to do."