Question about protege swrltab-plugin

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

Question about protege swrltab-plugin

大侠
To who might read this,
    We are recently engaged in a project that needs to use swrl as a functional part, and we tried to download the protege swrltab-plugin from github, whose link is https://github.com/protegeproject/swrltab-plugin. However erro occurs when we are trying to get it built with Maven, it says could not resolve dependencies for project edu.stanford.swrl: swrltab-plugin: bundle:1.0.0. 
    We don't know what it means and if there is a solution or any other approach to get it plugged in.If you have any idea on this, we'll appreciate for your reply.

_______________________________________________
protege-user mailing list
[hidden email]
https://mailman.stanford.edu/mailman/listinfo/protege-user
Reply | Threaded
Open this post in threaded view
|

Re: Question about protege swrltab-plugin

Josef Hardi

Hi,

Before you can build the plugin, you need to compile and install these two modules:
1. SWRL-API (https://github.com/protegeproject/swrlapi), and
2. SWRL-API Drools Engine (https://github.com/protegeproject/swrlapi-drools-engine)
 
# git clone https://github.com/protegeproject/swrlapi
# cd swrlapi
# mvn clean install
# cd ..
# git clone https://github.com/protegeproject/swrlapi-drools-engine
# cd swrlapi-drools-engine
# mvn clean install
# cd ..
# cd swrltab-plugin
# mvn clean package

You should be able to build the plugin successfully and get the JAR file in the target folder. However, the bad news is you will get an error message when you install this plugin in the current Protege release :(

The plugin homepage mentioned:  
 "The SWRLTab Plugin has not yet been released. This plugin and related libraries are built using the latest 4.0.2 version of the OWLAPI and the current Protégé 5.0.0 Beta 17 has not yet been updated to use this version. The upcoming Beta 18 release of Protégé will use the latest OWLAPI version. The SWRLTab plugin will be released at the same time."

But the good news is you can use the SWRLTab standalone version :)

# cd swrltab
# mvn clean install
# mvn exec:java

Hope this could help. Cheers!

/Josef



From: protege-user <[hidden email]> on behalf of 大侠 <[hidden email]>
Sent: Friday, October 9, 2015 8:35 PM
To: protege-user
Subject: [protege-user] Question about protege swrltab-plugin
 
To who might read this,
    We are recently engaged in a project that needs to use swrl as a functional part, and we tried to download the protege swrltab-plugin from github, whose link is https://github.com/protegeproject/swrltab-plugin. However erro occurs when we are trying to get it built with Maven, it says could not resolve dependencies for project edu.stanford.swrl: swrltab-plugin: bundle:1.0.0. 
    We don't know what it means and if there is a solution or any other approach to get it plugged in.If you have any idea on this, we'll appreciate for your reply.

_______________________________________________
protege-user mailing list
[hidden email]
https://mailman.stanford.edu/mailman/listinfo/protege-user
Reply | Threaded
Open this post in threaded view
|

Re: Question about protege swrltab-plugin

s.a.s.a.n
Im sorry for asking this but when I try to do this in git shell i get this error :

mvn : The term 'mvn' is not recognized as the name of a cmdlet, function, script file, o
spelling of the name, or if a path was included, verify that the path is correct and try
At line:1 char:1
+ mvn clean install
+ ~~~
    + CategoryInfo          : ObjectNotFound: (mvn:String) [], CommandNotFoundException
    + FullyQualifiedErrorId : CommandNotFoundException
.



what should I do ?

On Mon, Oct 12, 2015 at 8:58 AM, Josef Hardi <[hidden email]> wrote:

Hi,

Before you can build the plugin, you need to compile and install these two modules:
 
# git clone https://github.com/protegeproject/swrlapi
# cd swrlapi
# mvn clean install
# cd ..
# cd swrlapi-drools-engine
# mvn clean install
# cd ..
# cd swrltab-plugin
# mvn clean package

You should be able to build the plugin successfully and get the JAR file in the target folder. However, the bad news is you will get an error message when you install this plugin in the current Protege release :(

The plugin homepage mentioned:  
 "The SWRLTab Plugin has not yet been released. This plugin and related libraries are built using the latest 4.0.2 version of the OWLAPI and the current Protégé 5.0.0 Beta 17 has not yet been updated to use this version. The upcoming Beta 18 release of Protégé will use the latest OWLAPI version. The SWRLTab plugin will be released at the same time."

But the good news is you can use the SWRLTab standalone version :)

# cd swrltab
# mvn clean install
# mvn exec:java

Hope this could help. Cheers!

/Josef



From: protege-user <[hidden email]> on behalf of 大侠 <[hidden email]>
Sent: Friday, October 9, 2015 8:35 PM
To: protege-user
Subject: [protege-user] Question about protege swrltab-plugin
 
To who might read this,
    We are recently engaged in a project that needs to use swrl as a functional part, and we tried to download the protege swrltab-plugin from github, whose link is https://github.com/protegeproject/swrltab-plugin. However erro occurs when we are trying to get it built with Maven, it says could not resolve dependencies for project edu.stanford.swrl: swrltab-plugin: bundle:1.0.0. 
    We don't know what it means and if there is a solution or any other approach to get it plugged in.If you have any idea on this, we'll appreciate for your reply.

_______________________________________________
protege-user mailing list
[hidden email]
https://mailman.stanford.edu/mailman/listinfo/protege-user



_______________________________________________
protege-user mailing list
[hidden email]
https://mailman.stanford.edu/mailman/listinfo/protege-user

Capture.PNG (31K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Question about protege swrltab-plugin

Chris Snyder
That is probably a alias for the Maven build management system. 


Chris Snyder


On Oct 13, 2015, at 2:59 AM, sasan arham <[hidden email]> wrote:

Im sorry for asking this but when I try to do this in git shell i get this error :

mvn : The term 'mvn' is not recognized as the name of a cmdlet, function, script file, o
spelling of the name, or if a path was included, verify that the path is correct and try
At line:1 char:1
+ mvn clean install
+ ~~~
    + CategoryInfo          : ObjectNotFound: (mvn:String) [], CommandNotFoundException
    + FullyQualifiedErrorId : CommandNotFoundException
.



what should I do ?

On Mon, Oct 12, 2015 at 8:58 AM, Josef Hardi <[hidden email]> wrote:

Hi,

Before you can build the plugin, you need to compile and install these two modules:
 
# git clone https://github.com/protegeproject/swrlapi
# cd swrlapi
# mvn clean install
# cd ..
# cd swrlapi-drools-engine
# mvn clean install
# cd ..
# cd swrltab-plugin
# mvn clean package

You should be able to build the plugin successfully and get the JAR file in the target folder. However, the bad news is you will get an error message when you install this plugin in the current Protege release :(

The plugin homepage mentioned:  
 "The SWRLTab Plugin has not yet been released. This plugin and related libraries are built using the latest 4.0.2 version of the OWLAPI and the current Protégé 5.0.0 Beta 17 has not yet been updated to use this version. The upcoming Beta 18 release of Protégé will use the latest OWLAPI version. The SWRLTab plugin will be released at the same time."

But the good news is you can use the SWRLTab standalone version :)

# cd swrltab
# mvn clean install
# mvn exec:java

Hope this could help. Cheers!

/Josef



From: protege-user <[hidden email]> on behalf of 大侠 <[hidden email]>
Sent: Friday, October 9, 2015 8:35 PM
To: protege-user
Subject: [protege-user] Question about protege swrltab-plugin
 
To who might read this,
    We are recently engaged in a project that needs to use swrl as a functional part, and we tried to download the protege swrltab-plugin from github, whose link is https://github.com/protegeproject/swrltab-plugin. However erro occurs when we are trying to get it built with Maven, it says could not resolve dependencies for project edu.stanford.swrl: swrltab-plugin: bundle:1.0.0. 
    We don't know what it means and if there is a solution or any other approach to get it plugged in.If you have any idea on this, we'll appreciate for your reply.

_______________________________________________
protege-user mailing list
[hidden email]
https://mailman.stanford.edu/mailman/listinfo/protege-user


<Capture.PNG>_______________________________________________
protege-user mailing list
[hidden email]
https://mailman.stanford.edu/mailman/listinfo/protege-user


_______________________________________________
protege-user mailing list
[hidden email]
https://mailman.stanford.edu/mailman/listinfo/protege-user
Reply | Threaded
Open this post in threaded view
|

Re: Question about protege swrltab-plugin

Martin O'Connor-2
In reply to this post by s.a.s.a.n

You need Maven installed before you can build the project. See:


Martin

On Oct 12, 2015, at 11:59 PM, sasan arham <[hidden email]> wrote:

Im sorry for asking this but when I try to do this in git shell i get this error :

mvn : The term 'mvn' is not recognized as the name of a cmdlet, function, script file, o
spelling of the name, or if a path was included, verify that the path is correct and try
At line:1 char:1
+ mvn clean install
+ ~~~
    + CategoryInfo          : ObjectNotFound: (mvn:String) [], CommandNotFoundException
    + FullyQualifiedErrorId : CommandNotFoundException
.



what should I do ?

On Mon, Oct 12, 2015 at 8:58 AM, Josef Hardi <[hidden email]> wrote:

Hi,

Before you can build the plugin, you need to compile and install these two modules:
 
# git clone https://github.com/protegeproject/swrlapi
# cd swrlapi
# mvn clean install
# cd ..
# cd swrlapi-drools-engine
# mvn clean install
# cd ..
# cd swrltab-plugin
# mvn clean package

You should be able to build the plugin successfully and get the JAR file in the target folder. However, the bad news is you will get an error message when you install this plugin in the current Protege release :(

The plugin homepage mentioned:  
 "The SWRLTab Plugin has not yet been released. This plugin and related libraries are built using the latest 4.0.2 version of the OWLAPI and the current Protégé 5.0.0 Beta 17 has not yet been updated to use this version. The upcoming Beta 18 release of Protégé will use the latest OWLAPI version. The SWRLTab plugin will be released at the same time."

But the good news is you can use the SWRLTab standalone version :)

# cd swrltab
# mvn clean install
# mvn exec:java

Hope this could help. Cheers!

/Josef



From: protege-user <[hidden email]> on behalf of 大侠 <[hidden email]>
Sent: Friday, October 9, 2015 8:35 PM
To: protege-user
Subject: [protege-user] Question about protege swrltab-plugin
 
To who might read this,
    We are recently engaged in a project that needs to use swrl as a functional part, and we tried to download the protege swrltab-plugin from github, whose link is https://github.com/protegeproject/swrltab-plugin. However erro occurs when we are trying to get it built with Maven, it says could not resolve dependencies for project edu.stanford.swrl: swrltab-plugin: bundle:1.0.0. 
    We don't know what it means and if there is a solution or any other approach to get it plugged in.If you have any idea on this, we'll appreciate for your reply.

_______________________________________________
protege-user mailing list
[hidden email]
https://mailman.stanford.edu/mailman/listinfo/protege-user


<Capture.PNG>_______________________________________________
protege-user mailing list
[hidden email]
https://mailman.stanford.edu/mailman/listinfo/protege-user


_______________________________________________
protege-user mailing list
[hidden email]
https://mailman.stanford.edu/mailman/listinfo/protege-user
Reply | Threaded
Open this post in threaded view
|

Re: Question about protege swrltab-plugin

s.a.s.a.n
I got it , thanks for being Patient and explaining  :)

On Tue, Oct 13, 2015 at 8:02 AM, Martin O'Connor <[hidden email]> wrote:

You need Maven installed before you can build the project. See:


Martin

On Oct 12, 2015, at 11:59 PM, sasan arham <[hidden email]> wrote:

Im sorry for asking this but when I try to do this in git shell i get this error :

mvn : The term 'mvn' is not recognized as the name of a cmdlet, function, script file, o
spelling of the name, or if a path was included, verify that the path is correct and try
At line:1 char:1
+ mvn clean install
+ ~~~
    + CategoryInfo          : ObjectNotFound: (mvn:String) [], CommandNotFoundException
    + FullyQualifiedErrorId : CommandNotFoundException
.



what should I do ?

On Mon, Oct 12, 2015 at 8:58 AM, Josef Hardi <[hidden email]> wrote:

Hi,

Before you can build the plugin, you need to compile and install these two modules:
 
# git clone https://github.com/protegeproject/swrlapi
# cd swrlapi
# mvn clean install
# cd ..
# cd swrlapi-drools-engine
# mvn clean install
# cd ..
# cd swrltab-plugin
# mvn clean package

You should be able to build the plugin successfully and get the JAR file in the target folder. However, the bad news is you will get an error message when you install this plugin in the current Protege release :(

The plugin homepage mentioned:  
 "The SWRLTab Plugin has not yet been released. This plugin and related libraries are built using the latest 4.0.2 version of the OWLAPI and the current Protégé 5.0.0 Beta 17 has not yet been updated to use this version. The upcoming Beta 18 release of Protégé will use the latest OWLAPI version. The SWRLTab plugin will be released at the same time."

But the good news is you can use the SWRLTab standalone version :)

# cd swrltab
# mvn clean install
# mvn exec:java

Hope this could help. Cheers!

/Josef



From: protege-user <[hidden email]> on behalf of 大侠 <[hidden email]>
Sent: Friday, October 9, 2015 8:35 PM
To: protege-user
Subject: [protege-user] Question about protege swrltab-plugin
 
To who might read this,
    We are recently engaged in a project that needs to use swrl as a functional part, and we tried to download the protege swrltab-plugin from github, whose link is https://github.com/protegeproject/swrltab-plugin. However erro occurs when we are trying to get it built with Maven, it says could not resolve dependencies for project edu.stanford.swrl: swrltab-plugin: bundle:1.0.0. 
    We don't know what it means and if there is a solution or any other approach to get it plugged in.If you have any idea on this, we'll appreciate for your reply.

_______________________________________________
protege-user mailing list
[hidden email]
https://mailman.stanford.edu/mailman/listinfo/protege-user


<Capture.PNG>_______________________________________________
protege-user mailing list
[hidden email]
https://mailman.stanford.edu/mailman/listinfo/protege-user


_______________________________________________
protege-user mailing list
[hidden email]
https://mailman.stanford.edu/mailman/listinfo/protege-user



_______________________________________________
protege-user mailing list
[hidden email]
https://mailman.stanford.edu/mailman/listinfo/protege-user