Quantcast

Re: Welcome to the "protege-user" mailing list

classic Classic list List threaded Threaded
11 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Welcome to the "protege-user" mailing list

zlatareva

Hi,

I would greatly appreciate help with the following issue:

I have been working with Protégé 5.1 for some time and everything was great.

At the moment I decided to update to Fact++ 1.6.5 everything went wrong.

I could not open Protégé after restart (suggested to update Fact++). The error

I am getting is that MS C++ libraries are missing and after that the editor will not

open (I am running .dat file). I tried EVERYTHING -- deleting old versions, downloading

new ones, including JRE because I read somewhere about possible java corruption).

I am teaching Sem Web Tech class and very shortly my students will need Protégé

for their project. I am very worried that something like this can happen to them and

I have no clue how to help.

Any suggestions will be greatly appreciated.

THANK YOU SO MUCH! 


Neli P. Zlatareva, PhD
Professor of Computer Science
Department of Computer Science
Central Connecticut State University
New Britain, CT 06050
Phone: (860) 832-2723
Fax: (860) 832-2712
Web site: cs.ccsu.edu/~neli/

From: protege-user <[hidden email]> on behalf of [hidden email] <[hidden email]>
Sent: Saturday, February 18, 2017 9:46:06 AM
To: Zlatareva, Neli (Computer Science)
Subject: Welcome to the "protege-user" mailing list
 
Welcome to the [hidden email] mailing list!

To post to this list, send your message to:

  [hidden email]

General information about the mailing list is at:

  https://na01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fmailman.stanford.edu%2Fmailman%2Flistinfo%2Fprotege-user&data=01%7C01%7Czlatareva%40ccsu.edu%7C63e3288191e14b93786508d4580ce094%7C2329c570b5804223803b427d800e81b6%7C0&sdata=VOYRFvt92vMvqCC5lGE0prd1wp4hwHqtfsrm%2Fu1OKdA%3D&reserved=0

If you ever want to unsubscribe or change your options (eg, switch to
or from digest mode, change your password, etc.), visit your
subscription page at:

  https://na01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fmailman.stanford.edu%2Fmailman%2Foptions%2Fprotege-user%2Fzlatareva%2540ccsu.edu&data=01%7C01%7Czlatareva%40ccsu.edu%7C63e3288191e14b93786508d4580ce094%7C2329c570b5804223803b427d800e81b6%7C0&sdata=A8RPg8wstEfBRet05fml%2Fgn12Oi%2FonLChpKKiE2gWes%3D&reserved=0


You can also make such adjustments via email by sending a message to:

  [hidden email]

with the word `help' in the subject or body (don't include the
quotes), and you will get back a message with instructions.

You must know your password to change your options (including changing
the password, itself) or to unsubscribe without confirmation.  It is:

  opuzecsi

Normally, Mailman will remind you of your lists.stanford.edu mailing
list passwords once every month, although you can disable this if you
prefer.  This reminder will also include instructions on how to
unsubscribe or change your account options.  There is also a button on
your options page that will email your current password to you.

_______________________________________________
protege-user mailing list
[hidden email]
https://mailman.stanford.edu/mailman/listinfo/protege-user
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Problem running Protege 5.1 after updating Fact++

zlatareva


Hi,

I would greatly appreciate help with the following issue:

I have been working with Protégé 5.1 for some time and everything was great.

At the moment I decided to update to Fact++ 1.6.5 everything went wrong.

I could not open Protégé after restart (suggested to update Fact++). The error

I am getting is that MS C++ libraries are missing and after that the editor will not

open (I am running .dat file). I tried EVERYTHING -- deleting old versions, downloading

new ones, including JRE because I read somewhere about possible java corruption).

I am teaching Sem Web Tech class and very shortly my students will need Protégé

for their project. I am very worried that something like this can happen to them and

I have no clue how to help.

Any suggestions will be greatly appreciated.

THANK YOU SO MUCH! 


Neli P. Zlatareva, PhD
Professor of Computer Science
Department of Computer Science
Central Connecticut State University
New Britain, CT 06050
Phone: (860) 832-2723
Fax: (860) 832-2712
Web site: cs.ccsu.edu/~neli



_______________________________________________
protege-user mailing list
[hidden email]
https://mailman.stanford.edu/mailman/listinfo/protege-user
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Problem running Protege 5.1 after updating Fact++

Csongor Nyulas
Administrator
Dear Neli,

I am running Protege 5.1.1 with Fact++ 1.6.5 for a long time now, and I never experienced the things that you describe. So, in order to debug what's going on, we need to understand what is different on your machine compared to ours.

Here are a few questions that hopefully can help us elucidate the mystery:

What OS are you using?
What is the ".dat" file? Maybe you wanted to say ".bat" file (in which case you are probably using Windows)?
Are you by any chance using an virtual machine or some OS emulator?
In the [PROTEGE_INSTALL_DIR]/plugins folder how many files do you have that have the word "fact" in their names? If you have only a jar file, what is the exact name of that file, and how big is it?
If you search all the subfolders of [PROTEGE_INSTALL_DIR], how many ja files do you find that contain the name "fact" in it?
Can you send us the Protege logs?

Csongor


On 02/18/2017 08:00 AM, Zlatareva, Neli (Computer Science) wrote:

Hi,

I would greatly appreciate help with the following issue:

I have been working with Protégé 5.1 for some time and everything was great.

At the moment I decided to update to Fact++ 1.6.5 everything went wrong.

I could not open Protégé after restart (suggested to update Fact++). The error

I am getting is that MS C++ libraries are missing and after that the editor will not

open (I am running .dat file). I tried EVERYTHING -- deleting old versions, downloading

new ones, including JRE because I read somewhere about possible java corruption).

I am teaching Sem Web Tech class and very shortly my students will need Protégé

for their project. I am very worried that something like this can happen to them and

I have no clue how to help.

Any suggestions will be greatly appreciated.

THANK YOU SO MUCH! 


Neli P. Zlatareva, PhD
Professor of Computer Science
Department of Computer Science
Central Connecticut State University
New Britain, CT 06050
Phone: (860) 832-2723
Fax: (860) 832-2712
Web site: cs.ccsu.edu/~neli




_______________________________________________
protege-user mailing list
[hidden email]
https://mailman.stanford.edu/mailman/listinfo/protege-user


_______________________________________________
protege-user mailing list
[hidden email]
https://mailman.stanford.edu/mailman/listinfo/protege-user
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Problem running Protege 5.1 after updating Fact++

zlatareva

Hi Csongor,
thank you so much for your reply -- I just found it buried in my mailbox.
To answer your questions. I run Windows 10 Home – no virtual machine or OS emulator.
As I said in my original call-for-help message, I have been working with Protégé 5.1.0 for some time with NO problems at all. The problem happened when I undated to Fact++ 1.6.5 (originally Protégé came with Fact++ 1.6.4). I use Pellet, but I wanted to check out the new Fact++, so I click update and after closing Protégé for the update to take place, I was never able to open it again. Just to note that I deleted old versions (including Protégé 5.0.0 -- Protege 5.0.0 gives me the same problem) downloaded new ones, same with jre, I tried the platform independent version, etc. – always the same “non-sense” result. So, here is the latest (today's) attempt to download and start Protégé (old downloads deleted).
You are asking about files with “fact” in their names – only one in the bin directory, called maven-artifact, which is a jar file 54 KB.
When I run .bat file this is what happens: (please note that I inserted in this log error messages as I am getting them)

C:\Program Files (x86)\Protege-5.1.0>setlocal
C:\Program Files (x86)\Protege-5.1.0>cd /d C:\Program Files (x86)\Protege-5.1.0\
C:\Program Files (x86)\Protege-5.1.0>jre\bin\java -Xmx500M -Xms200M -Xss16M -XX:CompileCommand=exclude,javax/swing/text/GlyphView,getBreakSpot -DentityExpansionLimit=100000000 -Dlogback.configurationFile=conf/logback-win.xml -Dfile.encoding=utf-8 -Dorg.protege.plugin.dir=plugins -classpath bundles/guava.jar;bundles/logback-classic.jar;bundles/logback-core.jar;bundles/slf4j-api.jar;bin/org.apache.felix.main.jar;bin/protege-launcher.jar org.protege.osgi.framework.Launcher
CompilerOracle: exclude javax/swing/text/GlyphView.getBreakSpot
********************************************************************************
**                                  Protege                                   **
********************************************************************************
----------------- Initialising and Starting the OSGi Framework -----------------
FrameworkFactory Class: org.apache.felix.framework.FrameworkFactory
The OSGi framework has been initialised
------------------------------- Starting Bundles -------------------------------
Starting bundle org.protege.common
Starting bundle org.eclipse.equinox.common
Starting bundle org.eclipse.equinox.supplement
Starting bundle org.eclipse.equinox.registry
Starting bundle org.protege.editor.core.application
Starting bundle org.apache.commons.io
Starting bundle com.google.guava
Not starting bundle com.google.inject.assistedinject explicitly because it is a fragment bundle.
Not starting bundle com.google.inject.multibindings explicitly because it is a fragment bundle.
Starting bundle com.google.inject
Starting bundle org.jsr-305
Starting bundle jul.to.slf4j
Starting bundle log4j.over.slf4j
Starting bundle ch.qos.logback.classic
Starting bundle ch.qos.logback.core
Starting bundle org.apache.servicemix.bundles.aopalliance
Starting bundle org.apache.servicemix.bundles.javax-inject
Starting bundle org.eclipse.equinox.common
Starting bundle org.eclipse.equinox.registry
Starting bundle org.eclipse.equinox.supplement
Starting bundle org.semanticweb.owl.owlapi
Starting bundle org.protege.common
Starting bundle org.protege.editor.core.application
Starting bundle org.protege.editor.owl
Starting bundle slf4j.api
Starting bundle cellfie
Starting bundle code-generation
Starting bundle existentialquery
Starting bundle uk.ac.manchester.cs.owl.explanation
Starting bundle org.protege.ontograf
Starting bundle org.coode.dlquery
Starting bundle org.semanticweb.hermit
Starting bundle org.coode.browser
Starting bundle org.coode.owlviz
Starting bundle org.protege.owl.rdf
Starting bundle org.protege.editor.owl.rdf
Starting bundle swrltab-plugin
Starting bundle com.clarkparsia.protege.plugin.pellet
Starting bundle org.exquisite.protege
Starting bundle org.semanticweb.elk
Starting bundle uk.ac.manchester.cs.owl.factplusplus
The OSGi framework has been started
------------------------------------ Protege -----------------------------------
Protege Desktop
Version 5.1.0, Build

----------------------------------- Platform -----------------------------------
Java: JVM 1.8.0_40-b26  Memory: 466M
Language: en, Country: US
Framework: Apache Software Foundation (1.7)
OS: windows8 (6.3)
Processor: x86-64

------------------------------------ Plugins -----------------------------------
Plugin: Cellfie Protege 5.0+ Plugin (2.1.0)
Plugin: OWL Code Generation Plug-in (2.0.0)
Plugin: Existential Query (2.0.0)
Plugin: Explanation Workbench (3.0.0)
Plugin: OntoGraf (2.0.3)
Plugin: DL Query (4.0.1)
Plugin: HermiT (1.3.8.413)
Plugin: Browser View (OWLDoc) (3.0.3)
Plugin: OWLViz (5.0.3)
Plugin: OWLAPI RDF Library (2.0.2)
Plugin: Protege SPARQL Plugin (2.0.1)
Plugin: SWRLTab Protege 5.0+ Plugin (1.0.3)
Plugin: Pellet Reasoner Plug-in (2.2.0)
Plugin: Ontology Debugger (0.1.2.BETA)
Plugin: ELK Reasoner Protege Plug-in (0.4.3)
Plugin: Factplusplus Plug-in (1.6.5)
Feb 27, 2017 5:35:50 PM java.util.prefs.WindowsPreferences <init>
WARNING: Could not open/create prefs root node Software\JavaSoft\Prefs at root 0x80000002. Windows RegCreateKeyEx(...) returned error code 5.
Creating and setting up empty (default) editor kit
OWL API Version: 4.2.6.20160910-2108
Loading default configuration parameters for class org.semanticweb.elk.reasoner.config.ReasonerConfiguration
Cannot generate ontology catalog for ontology at http://www.semanticweb.org/ioana/ontologies/2017/1/untitled-ontology-13
-------------------------- Generated Diagnosis Model ---------------------------
Ontology: OntologyID(OntologyIRI(<http://www.semanticweb.org/ioana/ontologies/2017/1/untitled-ontology-13>) VersionIRI(<null>))
Generated in 46 ms
0 Possibly Faulty Formulas
0 Correct Formulas
0 Entailed Examples
0 Not-Entailed Examples
--------------------------------------------------------------------------------

THE FOLLOWING ERROR WINDOW POPS UP AT THIS POINT:
MISSING LIBRARIES OR PLATFORM NOT SUPPPORTED
FACT++ REQUIRES PLATFORM SPECIFIC LIBRARIES
WHICH CANNOT BE FOUND
WHEN I CLICK OK THIS WINDOW CLOSES AND THE PROTEGE LOG CONTINUES AS FOLLOWS:


java:102)
          java.lang.Thread.run(Thread.java:745)
    (Listeners should be removed in the plugin dispose method!)
*** WARNING BADLY BEHAVING LISTENER: org.protege.editor.owl.ui.action.AbstractOntologySelectionStrategyAction$$Lambda$59/1677217031 ***
    Possible culprit (trace from when listener was added):
          org.protege.editor.owl.ui.action.AbstractOntologySelectionStrategyAction.initialise(AbstractOntologySelectionStrategyAction.java:47)
          org.protege.editor.owl.ui.action.ImportsClosureOntologyStrategyAction.initialise(ImportsClosureOntologyStrategyAction.java:27)
          org.protege.editor.core.ui.menu.MenuActionPluginJPFImpl.newInstance(MenuActionPluginJPFImpl.java:169)
          org.protege.editor.core.ui.menu.MenuActionPluginJPFImpl.newInstance(MenuActionPluginJPFImpl.java:31)
          org.protege.editor.core.ui.menu.MenuBuilder.buildInnerMenu(MenuBuilder.java:159)
          org.protege.editor.core.ui.menu.MenuBuilder.addMenu(MenuBuilder.java:114)
          org.protege.editor.core.ui.menu.MenuBuilder.buildCompositeMenu(MenuBuilder.java:135)
          org.protege.editor.core.ui.menu.MenuBuilder.addMenu(MenuBuilder.java:106)
          org.protege.editor.core.ui.menu.MenuBuilder.buildMenu(MenuBuilder.java:64)
          org.protege.editor.core.ui.workspace.WorkspaceFrame.createMenuBar(WorkspaceFrame.java:165)
          org.protege.editor.core.ui.workspace.WorkspaceFrame.createUI(WorkspaceFrame.java:137)
          org.protege.editor.core.ui.workspace.WorkspaceFrame.<init>(WorkspaceFrame.java:55)
          org.protege.editor.core.ui.workspace.WorkspaceManager.addWorkspace(WorkspaceManager.java:47)
          org.protege.editor.core.editorkit.EditorKitManager.addEditorKit(EditorKitManager.java:44)
          org.protege.editor.core.ProtegeManager.createAndSetupNewEditorKit(ProtegeManager.java:139)
          org.protege.editor.core.ProtegeManager.createAndSetupNewEditorKit(ProtegeManager.java:129)
          org.protege.editor.core.ProtegeApplication.createAndSetupDefaultEditorKit(ProtegeApplication.java:488)
          org.protege.editor.core.ProtegeApplication.startApplication(ProtegeApplication.java:432)
          org.protege.editor.core.ProtegeApplication.reallyStart(ProtegeApplication.java:109)
          org.protege.editor.core.ProtegeApplication.lambda$start$11(ProtegeApplication.java:90)
          org.protege.editor.core.ProtegeApplication$$Lambda$24/1976931298.frameworkEvent(Unknown Source)
          org.apache.felix.framework.util.EventDispatcher.invokeFrameworkListenerCallback(EventDispatcher.java:836)
          org.apache.felix.framework.util.EventDispatcher.fireEventImmediately(EventDispatcher.java:786)
          org.apache.felix.framework.util.EventDispatcher.run(EventDispatcher.java:1099)
          org.apache.felix.framework.util.EventDispatcher.access$000(EventDispatcher.java:55)
          org.apache.felix.framework.util.EventDispatcher$1.run(EventDispatcher.java:102)
          java.lang.Thread.run(Thread.java:745)
    (Listeners should be removed in the plugin dispose method!)
*** WARNING BADLY BEHAVING LISTENER: org.protege.editor.owl.ui.renderer.menu.AbstractByRendererMenu$$Lambda$57/436590799 ***
    Possible culprit (trace from when listener was added):
          org.protege.editor.owl.ui.renderer.menu.AbstractByRendererMenu.initialise(AbstractByRendererMenu.java:34)
          org.protege.editor.core.ui.menu.MenuActionPluginJPFImpl.newInstance(MenuActionPluginJPFImpl.java:169)
          org.protege.editor.core.ui.menu.MenuActionPluginJPFImpl.newInstance(MenuActionPluginJPFImpl.java:31)
          org.protege.editor.core.ui.menu.MenuBuilder.buildInnerMenu(MenuBuilder.java:159)
          org.protege.editor.core.ui.menu.MenuBuilder.addMenu(MenuBuilder.java:114)
          org.protege.editor.core.ui.menu.MenuBuilder.buildCompositeMenu(MenuBuilder.java:135)
          org.protege.editor.core.ui.menu.MenuBuilder.addMenu(MenuBuilder.java:106)
          org.protege.editor.core.ui.menu.MenuBuilder.buildMenu(MenuBuilder.java:64)
          org.protege.editor.core.ui.workspace.WorkspaceFrame.createMenuBar(WorkspaceFrame.java:165)
          org.protege.editor.core.ui.workspace.WorkspaceFrame.createUI(WorkspaceFrame.java:137)
          org.protege.editor.core.ui.workspace.WorkspaceFrame.<init>(WorkspaceFrame.java:55)
          org.protege.editor.core.ui.workspace.WorkspaceManager.addWorkspace(WorkspaceManager.java:47)
          org.protege.editor.core.editorkit.EditorKitManager.addEditorKit(EditorKitManager.java:44)
          org.protege.editor.core.ProtegeManager.createAndSetupNewEditorKit(ProtegeManager.java:139)
          org.protege.editor.core.ProtegeManager.createAndSetupNewEditorKit(ProtegeManager.java:129)
          org.protege.editor.core.ProtegeApplication.createAndSetupDefaultEditorKit(ProtegeApplication.java:488)
          org.protege.editor.core.ProtegeApplication.startApplication(ProtegeApplication.java:432)
          org.protege.editor.core.ProtegeApplication.reallyStart(ProtegeApplication.java:109)
          org.protege.editor.core.ProtegeApplication.lambda$start$11(ProtegeApplication.java:90)
          org.protege.editor.core.ProtegeApplication$$Lambda$24/1976931298.frameworkEvent(Unknown Source)
          org.apache.felix.framework.util.EventDispatcher.invokeFrameworkListenerCallback(EventDispatcher.java:836)
          org.apache.felix.framework.util.EventDispatcher.fireEventImmediately(EventDispatcher.java:786)
          org.apache.felix.framework.util.EventDispatcher.run(EventDispatcher.java:1099)
          org.apache.felix.framework.util.EventDispatcher.access$000(EventDispatcher.java:55)
          org.apache.felix.framework.util.EventDispatcher$1.run(EventDispatcher.java:102)
          java.lang.Thread.run(Thread.java:745)
    (Listeners should be removed in the plugin dispose method!)
*** WARNING BADLY BEHAVING LISTENER: org.protege.editor.owl.ui.renderer.menu.RenderByProperty$$Lambda$58/1386820222 ***
    Possible culprit (trace from when listener was added):
          org.protege.editor.owl.ui.renderer.menu.RenderByProperty.initialise(RenderByProperty.java:82)
          org.protege.editor.core.ui.menu.MenuActionPluginJPFImpl.newInstance(MenuActionPluginJPFImpl.java:169)
          org.protege.editor.core.ui.menu.MenuActionPluginJPFImpl.newInstance(MenuActionPluginJPFImpl.java:31)
          org.protege.editor.core.ui.menu.MenuBuilder.buildDynamicMenu(MenuBuilder.java:146)
          org.protege.editor.core.ui.menu.MenuBuilder.addMenu(MenuBuilder.java:110)
          org.protege.editor.core.ui.menu.MenuBuilder.buildCompositeMenu(MenuBuilder.java:135)
          org.protege.editor.core.ui.menu.MenuBuilder.addMenu(MenuBuilder.java:106)
          org.protege.editor.core.ui.menu.MenuBuilder.buildMenu(MenuBuilder.java:64)
          org.protege.editor.core.ui.workspace.WorkspaceFrame.createMenuBar(WorkspaceFrame.java:165)
          org.protege.editor.core.ui.workspace.WorkspaceFrame.createUI(WorkspaceFrame.java:137)
          org.protege.editor.core.ui.workspace.WorkspaceFrame.<init>(WorkspaceFrame.java:55)
          org.protege.editor.core.ui.workspace.WorkspaceManager.addWorkspace(WorkspaceManager.java:47)
          org.protege.editor.core.editorkit.EditorKitManager.addEditorKit(EditorKitManager.java:44)
          org.protege.editor.core.ProtegeManager.createAndSetupNewEditorKit(ProtegeManager.java:139)
          org.protege.editor.core.ProtegeManager.createAndSetupNewEditorKit(ProtegeManager.java:129)
          org.protege.editor.core.ProtegeApplication.createAndSetupDefaultEditorKit(ProtegeApplication.java:488)
          org.protege.editor.core.ProtegeApplication.startApplication(ProtegeApplication.java:432)
          org.protege.editor.core.ProtegeApplication.reallyStart(ProtegeApplication.java:109)
          org.protege.editor.core.ProtegeApplication.lambda$start$11(ProtegeApplication.java:90)
          org.protege.editor.core.ProtegeApplication$$Lambda$24/1976931298.frameworkEvent(Unknown Source)
          org.apache.felix.framework.util.EventDispatcher.invokeFrameworkListenerCallback(EventDispatcher.java:836)
          org.apache.felix.framework.util.EventDispatcher.fireEventImmediately(EventDispatcher.java:786)
          org.apache.felix.framework.util.EventDispatcher.run(EventDispatcher.java:1099)
          org.apache.felix.framework.util.EventDispatcher.access$000(EventDispatcher.java:55)
          org.apache.felix.framework.util.EventDispatcher$1.run(EventDispatcher.java:102)
          java.lang.Thread.run(Thread.java:745)
    (Listeners should be removed in the plugin dispose method!)
*** WARNING BADLY BEHAVING LISTENER: org.protege.editor.owl.ui.action.AbstractOntologySelectionStrategyAction$$Lambda$59/1677217031 ***
    Possible culprit (trace from when listener was added):
          org.protege.editor.owl.ui.action.AbstractOntologySelectionStrategyAction.initialise(AbstractOntologySelectionStrategyAction.java:47)
          org.protege.editor.core.ui.menu.MenuActionPluginJPFImpl.newInstance(MenuActionPluginJPFImpl.java:169)
          org.protege.editor.core.ui.menu.MenuActionPluginJPFImpl.newInstance(MenuActionPluginJPFImpl.java:31)
          org.protege.editor.core.ui.menu.MenuBuilder.buildInnerMenu(MenuBuilder.java:159)
          org.protege.editor.core.ui.menu.MenuBuilder.addMenu(MenuBuilder.java:114)
          org.protege.editor.core.ui.menu.MenuBuilder.buildCompositeMenu(MenuBuilder.java:135)
          org.protege.editor.core.ui.menu.MenuBuilder.addMenu(MenuBuilder.java:106)
          org.protege.editor.core.ui.menu.MenuBuilder.buildMenu(MenuBuilder.java:64)
          org.protege.editor.core.ui.workspace.WorkspaceFrame.createMenuBar(WorkspaceFrame.java:165)
          org.protege.editor.core.ui.workspace.WorkspaceFrame.createUI(WorkspaceFrame.java:137)
          org.protege.editor.core.ui.workspace.WorkspaceFrame.<init>(WorkspaceFrame.java:55)
          org.protege.editor.core.ui.workspace.WorkspaceManager.addWorkspace(WorkspaceManager.java:47)
          org.protege.editor.core.editorkit.EditorKitManager.addEditorKit(EditorKitManager.java:44)
          org.protege.editor.core.ProtegeManager.createAndSetupNewEditorKit(ProtegeManager.java:139)
          org.protege.editor.core.ProtegeManager.createAndSetupNewEditorKit(ProtegeManager.java:129)
          org.protege.editor.core.ProtegeApplication.createAndSetupDefaultEditorKit(ProtegeApplication.java:488)
          org.protege.editor.core.ProtegeApplication.startApplication(ProtegeApplication.java:432)
          org.protege.editor.core.ProtegeApplication.reallyStart(ProtegeApplication.java:109)
          org.protege.editor.core.ProtegeApplication.lambda$start$11(ProtegeApplication.java:90)
          org.protege.editor.core.ProtegeApplication$$Lambda$24/1976931298.frameworkEvent(Unknown Source)
          org.apache.felix.framework.util.EventDispatcher.invokeFrameworkListenerCallback(EventDispatcher.java:836)
          org.apache.felix.framework.util.EventDispatcher.fireEventImmediately(EventDispatcher.java:786)
          org.apache.felix.framework.util.EventDispatcher.run(EventDispatcher.java:1099)
          org.apache.felix.framework.util.EventDispatcher.access$000(EventDispatcher.java:55)
          org.apache.felix.framework.util.EventDispatcher$1.run(EventDispatcher.java:102)
          java.lang.Thread.run(Thread.java:745)
    (Listeners should be removed in the plugin dispose method!)
An error was thrown: java.lang.UnsatisfiedLinkError: C:\Users\Evgueni\AppData\Local\Temp\ProtegeCache-e2b80694-f0ed-44e2-905b-9d993353402c\bundle36\version0.0\bundle.jar-lib\0\lib\native\64bit\FaCTPlusPlusJNI.dll: Can't find dependent libraries
org.semanticweb.owlapi.model.OWLRuntimeException: java.lang.UnsatisfiedLinkError: C:\Users\Evgueni\AppData\Local\Temp\ProtegeCache-e2b80694-f0ed-44e2-905b-9d993353402c\bundle36\version0.0\bundle.jar-lib\0\lib\native\64bit\FaCTPlusPlusJNI.dll: Can't find dependent libraries
        at uk.ac.manchester.cs.factplusplus.protege.FaCTPlusPlusFactory.getReasonerFactory(FaCTPlusPlusFactory.java:84) ~[na:na]
        at org.protege.editor.owl.model.inference.ReasonerInfoComparator.compare(ReasonerInfoComparator.java:9) ~[na:na]
        at org.protege.editor.owl.model.inference.ReasonerInfoComparator.compare(ReasonerInfoComparator.java:5) ~[na:na]
        at java.util.TimSort.countRunAndMakeAscending(TimSort.java:351) ~[na:1.8.0_40]
        at java.util.TimSort.sort(TimSort.java:216) ~[na:1.8.0_40]
        at java.util.Arrays.sort(Arrays.java:1512) ~[na:1.8.0_40]
        at java.util.ArrayList.sort(ArrayList.java:1454) ~[na:1.8.0_40]
        at java.util.Collections.sort(Collections.java:175) ~[na:1.8.0_40]
        at org.protege.editor.owl.model.OWLWorkspace.rebuildReasonerMenu(OWLWorkspace.java:565) ~[na:na]
        at org.protege.editor.owl.model.OWLWorkspace.initialiseExtraMenuItems(OWLWorkspace.java:431) ~[na:na]
        at org.protege.editor.core.ui.workspace.WorkspaceFrame.createUI(WorkspaceFrame.java:141) ~[protege-editor-core.jar:na]
        at org.protege.editor.core.ui.workspace.WorkspaceFrame.<init>(WorkspaceFrame.java:55) ~[protege-editor-core.jar:na]
        at org.protege.editor.core.ui.workspace.WorkspaceManager.addWorkspace(WorkspaceManager.java:47) ~[protege-editor-core.jar:na]
        at org.protege.editor.core.editorkit.EditorKitManager.addEditorKit(EditorKitManager.java:44) ~[protege-editor-core.jar:na]
        at org.protege.editor.core.ProtegeManager.createAndSetupNewEditorKit(ProtegeManager.java:139) ~[protege-editor-core.jar:na]
        at org.protege.editor.core.ProtegeManager.createAndSetupNewEditorKit(ProtegeManager.java:129) ~[protege-editor-core.jar:na]
        at org.protege.editor.core.ProtegeApplication.createAndSetupDefaultEditorKit(ProtegeApplication.java:488) [protege-editor-core.jar:na]
        at org.protege.editor.core.ProtegeApplication.startApplication(ProtegeApplication.java:432) [protege-editor-core.jar:na]
        at org.protege.editor.core.ProtegeApplication.reallyStart(ProtegeApplication.java:109) [protege-editor-core.jar:na]
        at org.protege.editor.core.ProtegeApplication.lambda$start$11(ProtegeApplication.java:90) [protege-editor-core.jar:na]
        at org.protege.editor.core.ProtegeApplication$$Lambda$24/1976931298.frameworkEvent(Unknown Source) [protege-editor-core.jar:na]
        at org.apache.felix.framework.util.EventDispatcher.invokeFrameworkListenerCallback(EventDispatcher.java:836) [org.apache.felix.main.jar:na]
        at org.apache.felix.framework.util.EventDispatcher.fireEventImmediately(EventDispatcher.java:786) [org.apache.felix.main.jar:na]
        at org.apache.felix.framework.util.EventDispatcher.run(EventDispatcher.java:1099) [org.apache.felix.main.jar:na]
        at org.apache.felix.framework.util.EventDispatcher.access$000(EventDispatcher.java:55) [org.apache.felix.main.jar:na]
        at org.apache.felix.framework.util.EventDispatcher$1.run(EventDispatcher.java:102) [org.apache.felix.main.jar:na]
        at java.lang.Thread.run(Thread.java:745) [na:1.8.0_40]
Caused by: java.lang.UnsatisfiedLinkError: C:\Users\Evgueni\AppData\Local\Temp\ProtegeCache-e2b80694-f0ed-44e2-905b-9d993353402c\bundle36\version0.0\bundle.jar-lib\0\lib\native\64bit\FaCTPlusPlusJNI.dll: Can't find dependent libraries
        at java.lang.ClassLoader$NativeLibrary.load(Native Method) ~[na:1.8.0_40]
        at java.lang.ClassLoader.loadLibrary0(ClassLoader.java:1937) ~[na:1.8.0_40]
        at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1835) ~[na:1.8.0_40]
        at java.lang.Runtime.loadLibrary0(Runtime.java:870) ~[na:1.8.0_40]
        at java.lang.System.loadLibrary(System.java:1122) ~[na:1.8.0_40]
        at uk.ac.manchester.cs.factplusplus.FaCTPlusPlus.<clinit>(FaCTPlusPlus.java:19) ~[na:na]
        at uk.ac.manchester.cs.factplusplus.protege.FaCTPlusPlusFactory.getReasonerFactory(FaCTPlusPlusFactory.java:75) ~[na:na]
        ... 26 common frames omitted

AT THIS POINT ANOTHER ERROR WINDOW POPS UP which is HUGE, so when I click OK
THIS IS THE LAST I SEE -- then Prorege dies -- the editor never opens.

------------------------------- Auto-update Check ------------------------------
Auto-update last performed: Mon Feb 27 17:08:38 EST 2017
Auto-update has been performed today.  Not performing it again.

THANK YOU so much for your help. It is trully appreciated.
Best regards, Neli


Neli P. Zlatareva, PhD
Professor of Computer Science
Department of Computer Science
Central Connecticut State University
New Britain, CT 06050
Phone: (860) 832-2723
Fax: (860) 832-2712
Web site: cs.ccsu.edu/~neli/

From: protege-user <[hidden email]> on behalf of Csongor Nyulas <[hidden email]>
Sent: Wednesday, February 22, 2017 2:59:44 AM
To: User support for WebProtege and Protege Desktop
Subject: Re: [protege-user] Problem running Protege 5.1 after updating Fact++
 
Dear Neli,

I am running Protege 5.1.1 with Fact++ 1.6.5 for a long time now, and I never experienced the things that you describe. So, in order to debug what's going on, we need to understand what is different on your machine compared to ours.

Here are a few questions that hopefully can help us elucidate the mystery:

What OS are you using?
What is the ".dat" file? Maybe you wanted to say ".bat" file (in which case you are probably using Windows)?
Are you by any chance using an virtual machine or some OS emulator?
In the [PROTEGE_INSTALL_DIR]/plugins folder how many files do you have that have the word "fact" in their names? If you have only a jar file, what is the exact name of that file, and how big is it?
If you search all the subfolders of [PROTEGE_INSTALL_DIR], how many ja files do you find that contain the name "fact" in it?
Can you send us the Protege logs?

Csongor


On 02/18/2017 08:00 AM, Zlatareva, Neli (Computer Science) wrote:

Hi,

I would greatly appreciate help with the following issue:

I have been working with Protégé 5.1 for some time and everything was great.

At the moment I decided to update to Fact++ 1.6.5 everything went wrong.

I could not open Protégé after restart (suggested to update Fact++). The error

I am getting is that MS C++ libraries are missing and after that the editor will not

open (I am running .dat file). I tried EVERYTHING -- deleting old versions, downloading

new ones, including JRE because I read somewhere about possible java corruption).

I am teaching Sem Web Tech class and very shortly my students will need Protégé

for their project. I am very worried that something like this can happen to them and

I have no clue how to help.

Any suggestions will be greatly appreciated.

THANK YOU SO MUCH! 


Neli P. Zlatareva, PhD
Professor of Computer Science
Department of Computer Science
Central Connecticut State University
New Britain, CT 06050
Phone: (860) 832-2723
Fax: (860) 832-2712
Web site: cs.ccsu.edu/~neli




_______________________________________________
protege-user mailing list
[hidden email]
https://mailman.stanford.edu/mailman/listinfo/protege-user


_______________________________________________
protege-user mailing list
[hidden email]
https://mailman.stanford.edu/mailman/listinfo/protege-user
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Problem running Protege 5.1 after updating Fact++

zlatareva
Hi. I am resending this message from February 27 hoping that I will hear back some suggestion to possibly cure my problem running Protégé after updating Fact++.
Thank you so much.
Regards, Neli.

From: Zlatareva, Neli (Computer Science)
Sent: Monday, February 27, 2017 6:11 PM
To: User support for WebProtege and Protege Desktop
Subject: Re: [protege-user] Problem running Protege 5.1 after updating Fact++
 

Hi Csongor,
thank you so much for your reply -- I just found it buried in my mailbox.
To answer your questions. I run Windows 10 Home – no virtual machine or OS emulator.
As I said in my original call-for-help message, I have been working with Protégé 5.1.0 for some time with NO problems at all. The problem happened when I undated to Fact++ 1.6.5 (originally Protégé came with Fact++ 1.6.4). I use Pellet, but I wanted to check out the new Fact++, so I click update and after closing Protégé for the update to take place, I was never able to open it again. Just to note that I deleted old versions (including Protégé 5.0.0 -- Protege 5.0.0 gives me the same problem) downloaded new ones, same with jre, I tried the platform independent version, etc. – always the same “non-sense” result. So, here is the latest (today's) attempt to download and start Protégé (old downloads deleted).
You are asking about files with “fact” in their names – only one in the bin directory, called maven-artifact, which is a jar file 54 KB.
When I run .bat file this is what happens: (please note that I inserted in this log error messages as I am getting them)

C:\Program Files (x86)\Protege-5.1.0>setlocal
C:\Program Files (x86)\Protege-5.1.0>cd /d C:\Program Files (x86)\Protege-5.1.0\
C:\Program Files (x86)\Protege-5.1.0>jre\bin\java -Xmx500M -Xms200M -Xss16M -XX:CompileCommand=exclude,javax/swing/text/GlyphView,getBreakSpot -DentityExpansionLimit=100000000 -Dlogback.configurationFile=conf/logback-win.xml -Dfile.encoding=utf-8 -Dorg.protege.plugin.dir=plugins -classpath bundles/guava.jar;bundles/logback-classic.jar;bundles/logback-core.jar;bundles/slf4j-api.jar;bin/org.apache.felix.main.jar;bin/protege-launcher.jar org.protege.osgi.framework.Launcher
CompilerOracle: exclude javax/swing/text/GlyphView.getBreakSpot
********************************************************************************
**                                  Protege                                   **
********************************************************************************
----------------- Initialising and Starting the OSGi Framework -----------------
FrameworkFactory Class: org.apache.felix.framework.FrameworkFactory
The OSGi framework has been initialised
------------------------------- Starting Bundles -------------------------------
Starting bundle org.protege.common
Starting bundle org.eclipse.equinox.common
Starting bundle org.eclipse.equinox.supplement
Starting bundle org.eclipse.equinox.registry
Starting bundle org.protege.editor.core.application
Starting bundle org.apache.commons.io
Starting bundle com.google.guava
Not starting bundle com.google.inject.assistedinject explicitly because it is a fragment bundle.
Not starting bundle com.google.inject.multibindings explicitly because it is a fragment bundle.
Starting bundle com.google.inject
Starting bundle org.jsr-305
Starting bundle jul.to.slf4j
Starting bundle log4j.over.slf4j
Starting bundle ch.qos.logback.classic
Starting bundle ch.qos.logback.core
Starting bundle org.apache.servicemix.bundles.aopalliance
Starting bundle org.apache.servicemix.bundles.javax-inject
Starting bundle org.eclipse.equinox.common
Starting bundle org.eclipse.equinox.registry
Starting bundle org.eclipse.equinox.supplement
Starting bundle org.semanticweb.owl.owlapi
Starting bundle org.protege.common
Starting bundle org.protege.editor.core.application
Starting bundle org.protege.editor.owl
Starting bundle slf4j.api
Starting bundle cellfie
Starting bundle code-generation
Starting bundle existentialquery
Starting bundle uk.ac.manchester.cs.owl.explanation
Starting bundle org.protege.ontograf
Starting bundle org.coode.dlquery
Starting bundle org.semanticweb.hermit
Starting bundle org.coode.browser
Starting bundle org.coode.owlviz
Starting bundle org.protege.owl.rdf
Starting bundle org.protege.editor.owl.rdf
Starting bundle swrltab-plugin
Starting bundle com.clarkparsia.protege.plugin.pellet
Starting bundle org.exquisite.protege
Starting bundle org.semanticweb.elk
Starting bundle uk.ac.manchester.cs.owl.factplusplus
The OSGi framework has been started
------------------------------------ Protege -----------------------------------
Protege Desktop
Version 5.1.0, Build

----------------------------------- Platform -----------------------------------
Java: JVM 1.8.0_40-b26  Memory: 466M
Language: en, Country: US
Framework: Apache Software Foundation (1.7)
OS: windows8 (6.3)
Processor: x86-64

------------------------------------ Plugins -----------------------------------
Plugin: Cellfie Protege 5.0+ Plugin (2.1.0)
Plugin: OWL Code Generation Plug-in (2.0.0)
Plugin: Existential Query (2.0.0)
Plugin: Explanation Workbench (3.0.0)
Plugin: OntoGraf (2.0.3)
Plugin: DL Query (4.0.1)
Plugin: HermiT (1.3.8.413)
Plugin: Browser View (OWLDoc) (3.0.3)
Plugin: OWLViz (5.0.3)
Plugin: OWLAPI RDF Library (2.0.2)
Plugin: Protege SPARQL Plugin (2.0.1)
Plugin: SWRLTab Protege 5.0+ Plugin (1.0.3)
Plugin: Pellet Reasoner Plug-in (2.2.0)
Plugin: Ontology Debugger (0.1.2.BETA)
Plugin: ELK Reasoner Protege Plug-in (0.4.3)
Plugin: Factplusplus Plug-in (1.6.5)
Feb 27, 2017 5:35:50 PM java.util.prefs.WindowsPreferences <init>
WARNING: Could not open/create prefs root node Software\JavaSoft\Prefs at root 0x80000002. Windows RegCreateKeyEx(...) returned error code 5.
Creating and setting up empty (default) editor kit
OWL API Version: 4.2.6.20160910-2108
Loading default configuration parameters for class org.semanticweb.elk.reasoner.config.ReasonerConfiguration
Cannot generate ontology catalog for ontology at http://www.semanticweb.org/ioana/ontologies/2017/1/untitled-ontology-13
-------------------------- Generated Diagnosis Model ---------------------------
Ontology: OntologyID(OntologyIRI(<http://www.semanticweb.org/ioana/ontologies/2017/1/untitled-ontology-13>) VersionIRI(<null>))
Generated in 46 ms
0 Possibly Faulty Formulas
0 Correct Formulas
0 Entailed Examples
0 Not-Entailed Examples
--------------------------------------------------------------------------------

THE FOLLOWING ERROR WINDOW POPS UP AT THIS POINT:
MISSING LIBRARIES OR PLATFORM NOT SUPPPORTED
FACT++ REQUIRES PLATFORM SPECIFIC LIBRARIES
WHICH CANNOT BE FOUND
WHEN I CLICK OK THIS WINDOW CLOSES AND THE PROTEGE LOG CONTINUES AS FOLLOWS:


java:102)
          java.lang.Thread.run(Thread.java:745)
    (Listeners should be removed in the plugin dispose method!)
*** WARNING BADLY BEHAVING LISTENER: org.protege.editor.owl.ui.action.AbstractOntologySelectionStrategyAction$$Lambda$59/1677217031 ***
    Possible culprit (trace from when listener was added):
          org.protege.editor.owl.ui.action.AbstractOntologySelectionStrategyAction.initialise(AbstractOntologySelectionStrategyAction.java:47)
          org.protege.editor.owl.ui.action.ImportsClosureOntologyStrategyAction.initialise(ImportsClosureOntologyStrategyAction.java:27)
          org.protege.editor.core.ui.menu.MenuActionPluginJPFImpl.newInstance(MenuActionPluginJPFImpl.java:169)
          org.protege.editor.core.ui.menu.MenuActionPluginJPFImpl.newInstance(MenuActionPluginJPFImpl.java:31)
          org.protege.editor.core.ui.menu.MenuBuilder.buildInnerMenu(MenuBuilder.java:159)
          org.protege.editor.core.ui.menu.MenuBuilder.addMenu(MenuBuilder.java:114)
          org.protege.editor.core.ui.menu.MenuBuilder.buildCompositeMenu(MenuBuilder.java:135)
          org.protege.editor.core.ui.menu.MenuBuilder.addMenu(MenuBuilder.java:106)
          org.protege.editor.core.ui.menu.MenuBuilder.buildMenu(MenuBuilder.java:64)
          org.protege.editor.core.ui.workspace.WorkspaceFrame.createMenuBar(WorkspaceFrame.java:165)
          org.protege.editor.core.ui.workspace.WorkspaceFrame.createUI(WorkspaceFrame.java:137)
          org.protege.editor.core.ui.workspace.WorkspaceFrame.<init>(WorkspaceFrame.java:55)
          org.protege.editor.core.ui.workspace.WorkspaceManager.addWorkspace(WorkspaceManager.java:47)
          org.protege.editor.core.editorkit.EditorKitManager.addEditorKit(EditorKitManager.java:44)
          org.protege.editor.core.ProtegeManager.createAndSetupNewEditorKit(ProtegeManager.java:139)
          org.protege.editor.core.ProtegeManager.createAndSetupNewEditorKit(ProtegeManager.java:129)
          org.protege.editor.core.ProtegeApplication.createAndSetupDefaultEditorKit(ProtegeApplication.java:488)
          org.protege.editor.core.ProtegeApplication.startApplication(ProtegeApplication.java:432)
          org.protege.editor.core.ProtegeApplication.reallyStart(ProtegeApplication.java:109)
          org.protege.editor.core.ProtegeApplication.lambda$start$11(ProtegeApplication.java:90)
          org.protege.editor.core.ProtegeApplication$$Lambda$24/1976931298.frameworkEvent(Unknown Source)
          org.apache.felix.framework.util.EventDispatcher.invokeFrameworkListenerCallback(EventDispatcher.java:836)
          org.apache.felix.framework.util.EventDispatcher.fireEventImmediately(EventDispatcher.java:786)
          org.apache.felix.framework.util.EventDispatcher.run(EventDispatcher.java:1099)
          org.apache.felix.framework.util.EventDispatcher.access$000(EventDispatcher.java:55)
          org.apache.felix.framework.util.EventDispatcher$1.run(EventDispatcher.java:102)
          java.lang.Thread.run(Thread.java:745)
    (Listeners should be removed in the plugin dispose method!)
*** WARNING BADLY BEHAVING LISTENER: org.protege.editor.owl.ui.renderer.menu.AbstractByRendererMenu$$Lambda$57/436590799 ***
    Possible culprit (trace from when listener was added):
          org.protege.editor.owl.ui.renderer.menu.AbstractByRendererMenu.initialise(AbstractByRendererMenu.java:34)
          org.protege.editor.core.ui.menu.MenuActionPluginJPFImpl.newInstance(MenuActionPluginJPFImpl.java:169)
          org.protege.editor.core.ui.menu.MenuActionPluginJPFImpl.newInstance(MenuActionPluginJPFImpl.java:31)
          org.protege.editor.core.ui.menu.MenuBuilder.buildInnerMenu(MenuBuilder.java:159)
          org.protege.editor.core.ui.menu.MenuBuilder.addMenu(MenuBuilder.java:114)
          org.protege.editor.core.ui.menu.MenuBuilder.buildCompositeMenu(MenuBuilder.java:135)
          org.protege.editor.core.ui.menu.MenuBuilder.addMenu(MenuBuilder.java:106)
          org.protege.editor.core.ui.menu.MenuBuilder.buildMenu(MenuBuilder.java:64)
          org.protege.editor.core.ui.workspace.WorkspaceFrame.createMenuBar(WorkspaceFrame.java:165)
          org.protege.editor.core.ui.workspace.WorkspaceFrame.createUI(WorkspaceFrame.java:137)
          org.protege.editor.core.ui.workspace.WorkspaceFrame.<init>(WorkspaceFrame.java:55)
          org.protege.editor.core.ui.workspace.WorkspaceManager.addWorkspace(WorkspaceManager.java:47)
          org.protege.editor.core.editorkit.EditorKitManager.addEditorKit(EditorKitManager.java:44)
          org.protege.editor.core.ProtegeManager.createAndSetupNewEditorKit(ProtegeManager.java:139)
          org.protege.editor.core.ProtegeManager.createAndSetupNewEditorKit(ProtegeManager.java:129)
          org.protege.editor.core.ProtegeApplication.createAndSetupDefaultEditorKit(ProtegeApplication.java:488)
          org.protege.editor.core.ProtegeApplication.startApplication(ProtegeApplication.java:432)
          org.protege.editor.core.ProtegeApplication.reallyStart(ProtegeApplication.java:109)
          org.protege.editor.core.ProtegeApplication.lambda$start$11(ProtegeApplication.java:90)
          org.protege.editor.core.ProtegeApplication$$Lambda$24/1976931298.frameworkEvent(Unknown Source)
          org.apache.felix.framework.util.EventDispatcher.invokeFrameworkListenerCallback(EventDispatcher.java:836)
          org.apache.felix.framework.util.EventDispatcher.fireEventImmediately(EventDispatcher.java:786)
          org.apache.felix.framework.util.EventDispatcher.run(EventDispatcher.java:1099)
          org.apache.felix.framework.util.EventDispatcher.access$000(EventDispatcher.java:55)
          org.apache.felix.framework.util.EventDispatcher$1.run(EventDispatcher.java:102)
          java.lang.Thread.run(Thread.java:745)
    (Listeners should be removed in the plugin dispose method!)
*** WARNING BADLY BEHAVING LISTENER: org.protege.editor.owl.ui.renderer.menu.RenderByProperty$$Lambda$58/1386820222 ***
    Possible culprit (trace from when listener was added):
          org.protege.editor.owl.ui.renderer.menu.RenderByProperty.initialise(RenderByProperty.java:82)
          org.protege.editor.core.ui.menu.MenuActionPluginJPFImpl.newInstance(MenuActionPluginJPFImpl.java:169)
          org.protege.editor.core.ui.menu.MenuActionPluginJPFImpl.newInstance(MenuActionPluginJPFImpl.java:31)
          org.protege.editor.core.ui.menu.MenuBuilder.buildDynamicMenu(MenuBuilder.java:146)
          org.protege.editor.core.ui.menu.MenuBuilder.addMenu(MenuBuilder.java:110)
          org.protege.editor.core.ui.menu.MenuBuilder.buildCompositeMenu(MenuBuilder.java:135)
          org.protege.editor.core.ui.menu.MenuBuilder.addMenu(MenuBuilder.java:106)
          org.protege.editor.core.ui.menu.MenuBuilder.buildMenu(MenuBuilder.java:64)
          org.protege.editor.core.ui.workspace.WorkspaceFrame.createMenuBar(WorkspaceFrame.java:165)
          org.protege.editor.core.ui.workspace.WorkspaceFrame.createUI(WorkspaceFrame.java:137)
          org.protege.editor.core.ui.workspace.WorkspaceFrame.<init>(WorkspaceFrame.java:55)
          org.protege.editor.core.ui.workspace.WorkspaceManager.addWorkspace(WorkspaceManager.java:47)
          org.protege.editor.core.editorkit.EditorKitManager.addEditorKit(EditorKitManager.java:44)
          org.protege.editor.core.ProtegeManager.createAndSetupNewEditorKit(ProtegeManager.java:139)
          org.protege.editor.core.ProtegeManager.createAndSetupNewEditorKit(ProtegeManager.java:129)
          org.protege.editor.core.ProtegeApplication.createAndSetupDefaultEditorKit(ProtegeApplication.java:488)
          org.protege.editor.core.ProtegeApplication.startApplication(ProtegeApplication.java:432)
          org.protege.editor.core.ProtegeApplication.reallyStart(ProtegeApplication.java:109)
          org.protege.editor.core.ProtegeApplication.lambda$start$11(ProtegeApplication.java:90)
          org.protege.editor.core.ProtegeApplication$$Lambda$24/1976931298.frameworkEvent(Unknown Source)
          org.apache.felix.framework.util.EventDispatcher.invokeFrameworkListenerCallback(EventDispatcher.java:836)
          org.apache.felix.framework.util.EventDispatcher.fireEventImmediately(EventDispatcher.java:786)
          org.apache.felix.framework.util.EventDispatcher.run(EventDispatcher.java:1099)
          org.apache.felix.framework.util.EventDispatcher.access$000(EventDispatcher.java:55)
          org.apache.felix.framework.util.EventDispatcher$1.run(EventDispatcher.java:102)
          java.lang.Thread.run(Thread.java:745)
    (Listeners should be removed in the plugin dispose method!)
*** WARNING BADLY BEHAVING LISTENER: org.protege.editor.owl.ui.action.AbstractOntologySelectionStrategyAction$$Lambda$59/1677217031 ***
    Possible culprit (trace from when listener was added):
          org.protege.editor.owl.ui.action.AbstractOntologySelectionStrategyAction.initialise(AbstractOntologySelectionStrategyAction.java:47)
          org.protege.editor.core.ui.menu.MenuActionPluginJPFImpl.newInstance(MenuActionPluginJPFImpl.java:169)
          org.protege.editor.core.ui.menu.MenuActionPluginJPFImpl.newInstance(MenuActionPluginJPFImpl.java:31)
          org.protege.editor.core.ui.menu.MenuBuilder.buildInnerMenu(MenuBuilder.java:159)
          org.protege.editor.core.ui.menu.MenuBuilder.addMenu(MenuBuilder.java:114)
          org.protege.editor.core.ui.menu.MenuBuilder.buildCompositeMenu(MenuBuilder.java:135)
          org.protege.editor.core.ui.menu.MenuBuilder.addMenu(MenuBuilder.java:106)
          org.protege.editor.core.ui.menu.MenuBuilder.buildMenu(MenuBuilder.java:64)
          org.protege.editor.core.ui.workspace.WorkspaceFrame.createMenuBar(WorkspaceFrame.java:165)
          org.protege.editor.core.ui.workspace.WorkspaceFrame.createUI(WorkspaceFrame.java:137)
          org.protege.editor.core.ui.workspace.WorkspaceFrame.<init>(WorkspaceFrame.java:55)
          org.protege.editor.core.ui.workspace.WorkspaceManager.addWorkspace(WorkspaceManager.java:47)
          org.protege.editor.core.editorkit.EditorKitManager.addEditorKit(EditorKitManager.java:44)
          org.protege.editor.core.ProtegeManager.createAndSetupNewEditorKit(ProtegeManager.java:139)
          org.protege.editor.core.ProtegeManager.createAndSetupNewEditorKit(ProtegeManager.java:129)
          org.protege.editor.core.ProtegeApplication.createAndSetupDefaultEditorKit(ProtegeApplication.java:488)
          org.protege.editor.core.ProtegeApplication.startApplication(ProtegeApplication.java:432)
          org.protege.editor.core.ProtegeApplication.reallyStart(ProtegeApplication.java:109)
          org.protege.editor.core.ProtegeApplication.lambda$start$11(ProtegeApplication.java:90)
          org.protege.editor.core.ProtegeApplication$$Lambda$24/1976931298.frameworkEvent(Unknown Source)
          org.apache.felix.framework.util.EventDispatcher.invokeFrameworkListenerCallback(EventDispatcher.java:836)
          org.apache.felix.framework.util.EventDispatcher.fireEventImmediately(EventDispatcher.java:786)
          org.apache.felix.framework.util.EventDispatcher.run(EventDispatcher.java:1099)
          org.apache.felix.framework.util.EventDispatcher.access$000(EventDispatcher.java:55)
          org.apache.felix.framework.util.EventDispatcher$1.run(EventDispatcher.java:102)
          java.lang.Thread.run(Thread.java:745)
    (Listeners should be removed in the plugin dispose method!)
An error was thrown: java.lang.UnsatisfiedLinkError: C:\Users\Evgueni\AppData\Local\Temp\ProtegeCache-e2b80694-f0ed-44e2-905b-9d993353402c\bundle36\version0.0\bundle.jar-lib\0\lib\native\64bit\FaCTPlusPlusJNI.dll: Can't find dependent libraries
org.semanticweb.owlapi.model.OWLRuntimeException: java.lang.UnsatisfiedLinkError: C:\Users\Evgueni\AppData\Local\Temp\ProtegeCache-e2b80694-f0ed-44e2-905b-9d993353402c\bundle36\version0.0\bundle.jar-lib\0\lib\native\64bit\FaCTPlusPlusJNI.dll: Can't find dependent libraries
        at uk.ac.manchester.cs.factplusplus.protege.FaCTPlusPlusFactory.getReasonerFactory(FaCTPlusPlusFactory.java:84) ~[na:na]
        at org.protege.editor.owl.model.inference.ReasonerInfoComparator.compare(ReasonerInfoComparator.java:9) ~[na:na]
        at org.protege.editor.owl.model.inference.ReasonerInfoComparator.compare(ReasonerInfoComparator.java:5) ~[na:na]
        at java.util.TimSort.countRunAndMakeAscending(TimSort.java:351) ~[na:1.8.0_40]
        at java.util.TimSort.sort(TimSort.java:216) ~[na:1.8.0_40]
        at java.util.Arrays.sort(Arrays.java:1512) ~[na:1.8.0_40]
        at java.util.ArrayList.sort(ArrayList.java:1454) ~[na:1.8.0_40]
        at java.util.Collections.sort(Collections.java:175) ~[na:1.8.0_40]
        at org.protege.editor.owl.model.OWLWorkspace.rebuildReasonerMenu(OWLWorkspace.java:565) ~[na:na]
        at org.protege.editor.owl.model.OWLWorkspace.initialiseExtraMenuItems(OWLWorkspace.java:431) ~[na:na]
        at org.protege.editor.core.ui.workspace.WorkspaceFrame.createUI(WorkspaceFrame.java:141) ~[protege-editor-core.jar:na]
        at org.protege.editor.core.ui.workspace.WorkspaceFrame.<init>(WorkspaceFrame.java:55) ~[protege-editor-core.jar:na]
        at org.protege.editor.core.ui.workspace.WorkspaceManager.addWorkspace(WorkspaceManager.java:47) ~[protege-editor-core.jar:na]
        at org.protege.editor.core.editorkit.EditorKitManager.addEditorKit(EditorKitManager.java:44) ~[protege-editor-core.jar:na]
        at org.protege.editor.core.ProtegeManager.createAndSetupNewEditorKit(ProtegeManager.java:139) ~[protege-editor-core.jar:na]
        at org.protege.editor.core.ProtegeManager.createAndSetupNewEditorKit(ProtegeManager.java:129) ~[protege-editor-core.jar:na]
        at org.protege.editor.core.ProtegeApplication.createAndSetupDefaultEditorKit(ProtegeApplication.java:488) [protege-editor-core.jar:na]
        at org.protege.editor.core.ProtegeApplication.startApplication(ProtegeApplication.java:432) [protege-editor-core.jar:na]
        at org.protege.editor.core.ProtegeApplication.reallyStart(ProtegeApplication.java:109) [protege-editor-core.jar:na]
        at org.protege.editor.core.ProtegeApplication.lambda$start$11(ProtegeApplication.java:90) [protege-editor-core.jar:na]
        at org.protege.editor.core.ProtegeApplication$$Lambda$24/1976931298.frameworkEvent(Unknown Source) [protege-editor-core.jar:na]
        at org.apache.felix.framework.util.EventDispatcher.invokeFrameworkListenerCallback(EventDispatcher.java:836) [org.apache.felix.main.jar:na]
        at org.apache.felix.framework.util.EventDispatcher.fireEventImmediately(EventDispatcher.java:786) [org.apache.felix.main.jar:na]
        at org.apache.felix.framework.util.EventDispatcher.run(EventDispatcher.java:1099) [org.apache.felix.main.jar:na]
        at org.apache.felix.framework.util.EventDispatcher.access$000(EventDispatcher.java:55) [org.apache.felix.main.jar:na]
        at org.apache.felix.framework.util.EventDispatcher$1.run(EventDispatcher.java:102) [org.apache.felix.main.jar:na]
        at java.lang.Thread.run(Thread.java:745) [na:1.8.0_40]
Caused by: java.lang.UnsatisfiedLinkError: C:\Users\Evgueni\AppData\Local\Temp\ProtegeCache-e2b80694-f0ed-44e2-905b-9d993353402c\bundle36\version0.0\bundle.jar-lib\0\lib\native\64bit\FaCTPlusPlusJNI.dll: Can't find dependent libraries
        at java.lang.ClassLoader$NativeLibrary.load(Native Method) ~[na:1.8.0_40]
        at java.lang.ClassLoader.loadLibrary0(ClassLoader.java:1937) ~[na:1.8.0_40]
        at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1835) ~[na:1.8.0_40]
        at java.lang.Runtime.loadLibrary0(Runtime.java:870) ~[na:1.8.0_40]
        at java.lang.System.loadLibrary(System.java:1122) ~[na:1.8.0_40]
        at uk.ac.manchester.cs.factplusplus.FaCTPlusPlus.<clinit>(FaCTPlusPlus.java:19) ~[na:na]
        at uk.ac.manchester.cs.factplusplus.protege.FaCTPlusPlusFactory.getReasonerFactory(FaCTPlusPlusFactory.java:75) ~[na:na]
        ... 26 common frames omitted

AT THIS POINT ANOTHER ERROR WINDOW POPS UP which is HUGE, so when I click OK
THIS IS THE LAST I SEE -- then Prorege dies -- the editor never opens.

------------------------------- Auto-update Check ------------------------------
Auto-update last performed: Mon Feb 27 17:08:38 EST 2017
Auto-update has been performed today.  Not performing it again.

THANK YOU so much for your help. It is trully appreciated.
Best regards, Neli


Neli P. Zlatareva, PhD
Professor of Computer Science
Department of Computer Science
Central Connecticut State University
New Britain, CT 06050
Phone: (860) 832-2723
Fax: (860) 832-2712
Web site: cs.ccsu.edu/~neli/

From: protege-user <[hidden email]> on behalf of Csongor Nyulas <[hidden email]>
Sent: Wednesday, February 22, 2017 2:59:44 AM
To: User support for WebProtege and Protege Desktop
Subject: Re: [protege-user] Problem running Protege 5.1 after updating Fact++
 
Dear Neli,

I am running Protege 5.1.1 with Fact++ 1.6.5 for a long time now, and I never experienced the things that you describe. So, in order to debug what's going on, we need to understand what is different on your machine compared to ours.

Here are a few questions that hopefully can help us elucidate the mystery:

What OS are you using?
What is the ".dat" file? Maybe you wanted to say ".bat" file (in which case you are probably using Windows)?
Are you by any chance using an virtual machine or some OS emulator?
In the [PROTEGE_INSTALL_DIR]/plugins folder how many files do you have that have the word "fact" in their names? If you have only a jar file, what is the exact name of that file, and how big is it?
If you search all the subfolders of [PROTEGE_INSTALL_DIR], how many ja files do you find that contain the name "fact" in it?
Can you send us the Protege logs?

Csongor


On 02/18/2017 08:00 AM, Zlatareva, Neli (Computer Science) wrote:

Hi,

I would greatly appreciate help with the following issue:

I have been working with Protégé 5.1 for some time and everything was great.

At the moment I decided to update to Fact++ 1.6.5 everything went wrong.

I could not open Protégé after restart (suggested to update Fact++). The error

I am getting is that MS C++ libraries are missing and after that the editor will not

open (I am running .dat file). I tried EVERYTHING -- deleting old versions, downloading

new ones, including JRE because I read somewhere about possible java corruption).

I am teaching Sem Web Tech class and very shortly my students will need Protégé

for their project. I am very worried that something like this can happen to them and

I have no clue how to help.

Any suggestions will be greatly appreciated.

THANK YOU SO MUCH! 


Neli P. Zlatareva, PhD
Professor of Computer Science
Department of Computer Science
Central Connecticut State University
New Britain, CT 06050
Phone: (860) 832-2723
Fax: (860) 832-2712
Web site: cs.ccsu.edu/~neli




_______________________________________________
protege-user mailing list
[hidden email]
https://mailman.stanford.edu/mailman/listinfo/protege-user


_______________________________________________
protege-user mailing list
[hidden email]
https://mailman.stanford.edu/mailman/listinfo/protege-user
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Problem running Protege 5.1 after updating Fact++

Bobbin Teegarden
In reply to this post by zlatareva

After updating to 5.2.0, I’m having the same problem as described by Neli below, but couldn’t find an answer in the mailing list.  Did I miss it?  What is the answer?  Thanks.

 

Bobbin Teegarden

CTO/Chief Architect, OntoAge

Technology Evangelist, No Magic

h/o 425.378.0131

cell 206.979.0196

[hidden email]

alt:  [hidden email]

 

From: protege-user [mailto:[hidden email]] On Behalf Of Zlatareva, Neli (Computer Science)
Sent: Monday, February 27, 2017 3:12 PM
To: User support for WebProtege and Protege Desktop <[hidden email]>
Subject: Re: [protege-user] Problem running Protege 5.1 after updating Fact++

 

Hi Csongor,

thank you so much for your reply -- I just found it buried in my mailbox.
To answer your questions. I run Windows 10 Home – no virtual machine or OS emulator.
As I said in my original call-for-help message, I have been working with Protégé 5.1.0 for some time with NO problems at all. The problem happened when I undated to Fact++ 1.6.5 (originally Protégé came with Fact++ 1.6.4). I use Pellet, but I wanted to check out the new Fact++, so I click update and after closing Protégé for the update to take place, I was never able to open it again. Just to note that I deleted old versions (including Protégé 5.0.0 -- Protege 5.0.0 gives me the same problem) downloaded new ones, same with jre, I tried the platform independent version, etc. – always the same “non-sense” result. So, here is the latest (today's) attempt to download and start Protégé (old downloads deleted).
You are asking about files with “fact” in their names – only one in the bin directory, called maven-artifact, which is a jar file 54 KB.

When I run .bat file this is what happens: (please note that I inserted in this log error messages as I am getting them)

 

C:\Program Files (x86)\Protege-5.1.0>setlocal

C:\Program Files (x86)\Protege-5.1.0>cd /d C:\Program Files (x86)\Protege-5.1.0\

C:\Program Files (x86)\Protege-5.1.0>jre\bin\java -Xmx500M -Xms200M -Xss16M -XX:CompileCommand=exclude,javax/swing/text/GlyphView,getBreakSpot -DentityExpansionLimit=100000000 -Dlogback.configurationFile=conf/logback-win.xml -Dfile.encoding=utf-8 -Dorg.protege.plugin.dir=plugins -classpath bundles/guava.jar;bundles/logback-classic.jar;bundles/logback-core.jar;bundles/slf4j-api.jar;bin/org.apache.felix.main.jar;bin/protege-launcher.jar org.protege.osgi.framework.Launcher
CompilerOracle: exclude javax/swing/text/GlyphView.getBreakSpot
********************************************************************************
**                                  Protege                                   **
********************************************************************************

----------------- Initialising and Starting the OSGi Framework -----------------
FrameworkFactory Class: org.apache.felix.framework.FrameworkFactory

The OSGi framework has been initialised
------------------------------- Starting Bundles -------------------------------
Starting bundle org.protege.common
Starting bundle org.eclipse.equinox.common
Starting bundle org.eclipse.equinox.supplement
Starting bundle org.eclipse.equinox.registry
Starting bundle org.protege.editor.core.application
Starting bundle org.apache.commons.io
Starting bundle com.google.guava
Not starting bundle com.google.inject.assistedinject explicitly because it is a fragment bundle.
Not starting bundle com.google.inject.multibindings explicitly because it is a fragment bundle.
Starting bundle com.google.inject
Starting bundle org.jsr-305
Starting bundle jul.to.slf4j
Starting bundle log4j.over.slf4j
Starting bundle ch.qos.logback.classic
Starting bundle ch.qos.logback.core
Starting bundle org.apache.servicemix.bundles.aopalliance
Starting bundle org.apache.servicemix.bundles.javax-inject
Starting bundle org.eclipse.equinox.common
Starting bundle org.eclipse.equinox.registry
Starting bundle org.eclipse.equinox.supplement
Starting bundle org.semanticweb.owl.owlapi
Starting bundle org.protege.common
Starting bundle org.protege.editor.core.application
Starting bundle org.protege.editor.owl
Starting bundle slf4j.api
Starting bundle cellfie
Starting bundle code-generation
Starting bundle existentialquery
Starting bundle uk.ac.manchester.cs.owl.explanation
Starting bundle org.protege.ontograf
Starting bundle org.coode.dlquery
Starting bundle org.semanticweb.hermit
Starting bundle org.coode.browser
Starting bundle org.coode.owlviz
Starting bundle org.protege.owl.rdf
Starting bundle org.protege.editor.owl.rdf
Starting bundle swrltab-plugin
Starting bundle com.clarkparsia.protege.plugin.pellet
Starting bundle org.exquisite.protege
Starting bundle org.semanticweb.elk
Starting bundle uk.ac.manchester.cs.owl.factplusplus
The OSGi framework has been started
------------------------------------ Protege -----------------------------------

Protege Desktop
Version 5.1.0, Build


----------------------------------- Platform -----------------------------------
Java: JVM 1.8.0_40-b26  Memory: 466M
Language: en, Country: US
Framework: Apache Software Foundation (1.7)
OS: windows8 (6.3)
Processor: x86-64


------------------------------------ Plugins -----------------------------------
Plugin: Cellfie Protege 5.0+ Plugin (2.1.0)
Plugin: OWL Code Generation Plug-in (2.0.0)
Plugin: Existential Query (2.0.0)
Plugin: Explanation Workbench (3.0.0)
Plugin: OntoGraf (2.0.3)
Plugin: DL Query (4.0.1)
Plugin: HermiT (1.3.8.413)
Plugin: Browser View (OWLDoc) (3.0.3)
Plugin: OWLViz (5.0.3)
Plugin: OWLAPI RDF Library (2.0.2)
Plugin: Protege SPARQL Plugin (2.0.1)
Plugin: SWRLTab Protege 5.0+ Plugin (1.0.3)
Plugin: Pellet Reasoner Plug-in (2.2.0)
Plugin: Ontology Debugger (0.1.2.BETA)
Plugin: ELK Reasoner Protege Plug-in (0.4.3)
Plugin: Factplusplus Plug-in (1.6.5)

Feb 27, 2017 5:35:50 PM java.util.prefs.WindowsPreferences <init>
WARNING: Could not open/create prefs root node Software\JavaSoft\Prefs at root 0x80000002. Windows RegCreateKeyEx(...) returned error code 5.
Creating and setting up empty (default) editor kit
OWL API Version: 4.2.6.20160910-2108
Loading default configuration parameters for class org.semanticweb.elk.reasoner.config.ReasonerConfiguration
Cannot generate ontology catalog for ontology at http://www.semanticweb.org/ioana/ontologies/2017/1/untitled-ontology-13
-------------------------- Generated Diagnosis Model ---------------------------
Ontology: OntologyID(OntologyIRI(<http://www.semanticweb.org/ioana/ontologies/2017/1/untitled-ontology-13>) VersionIRI(<null>))
Generated in 46 ms
0 Possibly Faulty Formulas
0 Correct Formulas
0 Entailed Examples
0 Not-Entailed Examples
--------------------------------------------------------------------------------

 

THE FOLLOWING ERROR WINDOW POPS UP AT THIS POINT:

MISSING LIBRARIES OR PLATFORM NOT SUPPPORTED
FACT++ REQUIRES PLATFORM SPECIFIC LIBRARIES
WHICH CANNOT BE FOUND

WHEN I CLICK OK THIS WINDOW CLOSES AND THE PROTEGE LOG CONTINUES AS FOLLOWS:

 


java:102)
          java.lang.Thread.run(Thread.java:745)
    (Listeners should be removed in the plugin dispose method!)
*** WARNING BADLY BEHAVING LISTENER: org.protege.editor.owl.ui.action.AbstractOntologySelectionStrategyAction$$Lambda$59/1677217031 ***
    Possible culprit (trace from when listener was added):
          org.protege.editor.owl.ui.action.AbstractOntologySelectionStrategyAction.initialise(AbstractOntologySelectionStrategyAction.java:47)
          org.protege.editor.owl.ui.action.ImportsClosureOntologyStrategyAction.initialise(ImportsClosureOntologyStrategyAction.java:27)
          org.protege.editor.core.ui.menu.MenuActionPluginJPFImpl.newInstance(MenuActionPluginJPFImpl.java:169)
          org.protege.editor.core.ui.menu.MenuActionPluginJPFImpl.newInstance(MenuActionPluginJPFImpl.java:31)
          org.protege.editor.core.ui.menu.MenuBuilder.buildInnerMenu(MenuBuilder.java:159)
          org.protege.editor.core.ui.menu.MenuBuilder.addMenu(MenuBuilder.java:114)
          org.protege.editor.core.ui.menu.MenuBuilder.buildCompositeMenu(MenuBuilder.java:135)
          org.protege.editor.core.ui.menu.MenuBuilder.addMenu(MenuBuilder.java:106)
          org.protege.editor.core.ui.menu.MenuBuilder.buildMenu(MenuBuilder.java:64)
          org.protege.editor.core.ui.workspace.WorkspaceFrame.createMenuBar(WorkspaceFrame.java:165)
          org.protege.editor.core.ui.workspace.WorkspaceFrame.createUI(WorkspaceFrame.java:137)
          org.protege.editor.core.ui.workspace.WorkspaceFrame.<init>(WorkspaceFrame.java:55)
          org.protege.editor.core.ui.workspace.WorkspaceManager.addWorkspace(WorkspaceManager.java:47)
          org.protege.editor.core.editorkit.EditorKitManager.addEditorKit(EditorKitManager.java:44)
          org.protege.editor.core.ProtegeManager.createAndSetupNewEditorKit(ProtegeManager.java:139)
          org.protege.editor.core.ProtegeManager.createAndSetupNewEditorKit(ProtegeManager.java:129)
          org.protege.editor.core.ProtegeApplication.createAndSetupDefaultEditorKit(ProtegeApplication.java:488)
          org.protege.editor.core.ProtegeApplication.startApplication(ProtegeApplication.java:432)
          org.protege.editor.core.ProtegeApplication.reallyStart(ProtegeApplication.java:109)
          org.protege.editor.core.ProtegeApplication.lambda$start$11(ProtegeApplication.java:90)
          org.protege.editor.core.ProtegeApplication$$Lambda$24/1976931298.frameworkEvent(Unknown Source)
          org.apache.felix.framework.util.EventDispatcher.invokeFrameworkListenerCallback(EventDispatcher.java:836)
          org.apache.felix.framework.util.EventDispatcher.fireEventImmediately(EventDispatcher.java:786)
          org.apache.felix.framework.util.EventDispatcher.run(EventDispatcher.java:1099)
          org.apache.felix.framework.util.EventDispatcher.access$000(EventDispatcher.java:55)
          org.apache.felix.framework.util.EventDispatcher$1.run(EventDispatcher.java:102)
          java.lang.Thread.run(Thread.java:745)
    (Listeners should be removed in the plugin dispose method!)
*** WARNING BADLY BEHAVING LISTENER: org.protege.editor.owl.ui.renderer.menu.AbstractByRendererMenu$$Lambda$57/436590799 ***
    Possible culprit (trace from when listener was added):
          org.protege.editor.owl.ui.renderer.menu.AbstractByRendererMenu.initialise(AbstractByRendererMenu.java:34)
          org.protege.editor.core.ui.menu.MenuActionPluginJPFImpl.newInstance(MenuActionPluginJPFImpl.java:169)
          org.protege.editor.core.ui.menu.MenuActionPluginJPFImpl.newInstance(MenuActionPluginJPFImpl.java:31)
          org.protege.editor.core.ui.menu.MenuBuilder.buildInnerMenu(MenuBuilder.java:159)
          org.protege.editor.core.ui.menu.MenuBuilder.addMenu(MenuBuilder.java:114)
          org.protege.editor.core.ui.menu.MenuBuilder.buildCompositeMenu(MenuBuilder.java:135)
          org.protege.editor.core.ui.menu.MenuBuilder.addMenu(MenuBuilder.java:106)
          org.protege.editor.core.ui.menu.MenuBuilder.buildMenu(MenuBuilder.java:64)
          org.protege.editor.core.ui.workspace.WorkspaceFrame.createMenuBar(WorkspaceFrame.java:165)
          org.protege.editor.core.ui.workspace.WorkspaceFrame.createUI(WorkspaceFrame.java:137)
          org.protege.editor.core.ui.workspace.WorkspaceFrame.<init>(WorkspaceFrame.java:55)
          org.protege.editor.core.ui.workspace.WorkspaceManager.addWorkspace(WorkspaceManager.java:47)
          org.protege.editor.core.editorkit.EditorKitManager.addEditorKit(EditorKitManager.java:44)
          org.protege.editor.core.ProtegeManager.createAndSetupNewEditorKit(ProtegeManager.java:139)
          org.protege.editor.core.ProtegeManager.createAndSetupNewEditorKit(ProtegeManager.java:129)
          org.protege.editor.core.ProtegeApplication.createAndSetupDefaultEditorKit(ProtegeApplication.java:488)
          org.protege.editor.core.ProtegeApplication.startApplication(ProtegeApplication.java:432)
          org.protege.editor.core.ProtegeApplication.reallyStart(ProtegeApplication.java:109)
          org.protege.editor.core.ProtegeApplication.lambda$start$11(ProtegeApplication.java:90)
          org.protege.editor.core.ProtegeApplication$$Lambda$24/1976931298.frameworkEvent(Unknown Source)
          org.apache.felix.framework.util.EventDispatcher.invokeFrameworkListenerCallback(EventDispatcher.java:836)
          org.apache.felix.framework.util.EventDispatcher.fireEventImmediately(EventDispatcher.java:786)
          org.apache.felix.framework.util.EventDispatcher.run(EventDispatcher.java:1099)
          org.apache.felix.framework.util.EventDispatcher.access$000(EventDispatcher.java:55)
          org.apache.felix.framework.util.EventDispatcher$1.run(EventDispatcher.java:102)
          java.lang.Thread.run(Thread.java:745)
    (Listeners should be removed in the plugin dispose method!)
*** WARNING BADLY BEHAVING LISTENER: org.protege.editor.owl.ui.renderer.menu.RenderByProperty$$Lambda$58/1386820222 ***
    Possible culprit (trace from when listener was added):
          org.protege.editor.owl.ui.renderer.menu.RenderByProperty.initialise(RenderByProperty.java:82)
          org.protege.editor.core.ui.menu.MenuActionPluginJPFImpl.newInstance(MenuActionPluginJPFImpl.java:169)
          org.protege.editor.core.ui.menu.MenuActionPluginJPFImpl.newInstance(MenuActionPluginJPFImpl.java:31)
          org.protege.editor.core.ui.menu.MenuBuilder.buildDynamicMenu(MenuBuilder.java:146)
          org.protege.editor.core.ui.menu.MenuBuilder.addMenu(MenuBuilder.java:110)
          org.protege.editor.core.ui.menu.MenuBuilder.buildCompositeMenu(MenuBuilder.java:135)
          org.protege.editor.core.ui.menu.MenuBuilder.addMenu(MenuBuilder.java:106)
          org.protege.editor.core.ui.menu.MenuBuilder.buildMenu(MenuBuilder.java:64)
          org.protege.editor.core.ui.workspace.WorkspaceFrame.createMenuBar(WorkspaceFrame.java:165)
          org.protege.editor.core.ui.workspace.WorkspaceFrame.createUI(WorkspaceFrame.java:137)
          org.protege.editor.core.ui.workspace.WorkspaceFrame.<init>(WorkspaceFrame.java:55)
          org.protege.editor.core.ui.workspace.WorkspaceManager.addWorkspace(WorkspaceManager.java:47)
          org.protege.editor.core.editorkit.EditorKitManager.addEditorKit(EditorKitManager.java:44)
          org.protege.editor.core.ProtegeManager.createAndSetupNewEditorKit(ProtegeManager.java:139)
          org.protege.editor.core.ProtegeManager.createAndSetupNewEditorKit(ProtegeManager.java:129)
          org.protege.editor.core.ProtegeApplication.createAndSetupDefaultEditorKit(ProtegeApplication.java:488)
          org.protege.editor.core.ProtegeApplication.startApplication(ProtegeApplication.java:432)
          org.protege.editor.core.ProtegeApplication.reallyStart(ProtegeApplication.java:109)
          org.protege.editor.core.ProtegeApplication.lambda$start$11(ProtegeApplication.java:90)
          org.protege.editor.core.ProtegeApplication$$Lambda$24/1976931298.frameworkEvent(Unknown Source)
          org.apache.felix.framework.util.EventDispatcher.invokeFrameworkListenerCallback(EventDispatcher.java:836)
          org.apache.felix.framework.util.EventDispatcher.fireEventImmediately(EventDispatcher.java:786)
          org.apache.felix.framework.util.EventDispatcher.run(EventDispatcher.java:1099)
          org.apache.felix.framework.util.EventDispatcher.access$000(EventDispatcher.java:55)
          org.apache.felix.framework.util.EventDispatcher$1.run(EventDispatcher.java:102)
          java.lang.Thread.run(Thread.java:745)
    (Listeners should be removed in the plugin dispose method!)
*** WARNING BADLY BEHAVING LISTENER: org.protege.editor.owl.ui.action.AbstractOntologySelectionStrategyAction$$Lambda$59/1677217031 ***
    Possible culprit (trace from when listener was added):
          org.protege.editor.owl.ui.action.AbstractOntologySelectionStrategyAction.initialise(AbstractOntologySelectionStrategyAction.java:47)
          org.protege.editor.core.ui.menu.MenuActionPluginJPFImpl.newInstance(MenuActionPluginJPFImpl.java:169)
          org.protege.editor.core.ui.menu.MenuActionPluginJPFImpl.newInstance(MenuActionPluginJPFImpl.java:31)
          org.protege.editor.core.ui.menu.MenuBuilder.buildInnerMenu(MenuBuilder.java:159)
          org.protege.editor.core.ui.menu.MenuBuilder.addMenu(MenuBuilder.java:114)
          org.protege.editor.core.ui.menu.MenuBuilder.buildCompositeMenu(MenuBuilder.java:135)
          org.protege.editor.core.ui.menu.MenuBuilder.addMenu(MenuBuilder.java:106)
          org.protege.editor.core.ui.menu.MenuBuilder.buildMenu(MenuBuilder.java:64)
          org.protege.editor.core.ui.workspace.WorkspaceFrame.createMenuBar(WorkspaceFrame.java:165)
          org.protege.editor.core.ui.workspace.WorkspaceFrame.createUI(WorkspaceFrame.java:137)
          org.protege.editor.core.ui.workspace.WorkspaceFrame.<init>(WorkspaceFrame.java:55)
          org.protege.editor.core.ui.workspace.WorkspaceManager.addWorkspace(WorkspaceManager.java:47)
          org.protege.editor.core.editorkit.EditorKitManager.addEditorKit(EditorKitManager.java:44)
          org.protege.editor.core.ProtegeManager.createAndSetupNewEditorKit(ProtegeManager.java:139)
          org.protege.editor.core.ProtegeManager.createAndSetupNewEditorKit(ProtegeManager.java:129)
          org.protege.editor.core.ProtegeApplication.createAndSetupDefaultEditorKit(ProtegeApplication.java:488)
          org.protege.editor.core.ProtegeApplication.startApplication(ProtegeApplication.java:432)
          org.protege.editor.core.ProtegeApplication.reallyStart(ProtegeApplication.java:109)
          org.protege.editor.core.ProtegeApplication.lambda$start$11(ProtegeApplication.java:90)
          org.protege.editor.core.ProtegeApplication$$Lambda$24/1976931298.frameworkEvent(Unknown Source)
          org.apache.felix.framework.util.EventDispatcher.invokeFrameworkListenerCallback(EventDispatcher.java:836)
          org.apache.felix.framework.util.EventDispatcher.fireEventImmediately(EventDispatcher.java:786)
          org.apache.felix.framework.util.EventDispatcher.run(EventDispatcher.java:1099)
          org.apache.felix.framework.util.EventDispatcher.access$000(EventDispatcher.java:55)
          org.apache.felix.framework.util.EventDispatcher$1.run(EventDispatcher.java:102)
          java.lang.Thread.run(Thread.java:745)
    (Listeners should be removed in the plugin dispose method!)

An error was thrown: java.lang.UnsatisfiedLinkError: C:\Users\Evgueni\AppData\Local\Temp\ProtegeCache-e2b80694-f0ed-44e2-905b-9d993353402c\bundle36\version0.0\bundle.jar-lib\0\lib\native\64bit\FaCTPlusPlusJNI.dll: Can't find dependent libraries
org.semanticweb.owlapi.model.OWLRuntimeException: java.lang.UnsatisfiedLinkError: C:\Users\Evgueni\AppData\Local\Temp\ProtegeCache-e2b80694-f0ed-44e2-905b-9d993353402c\bundle36\version0.0\bundle.jar-lib\0\lib\native\64bit\FaCTPlusPlusJNI.dll: Can't find dependent libraries
        at uk.ac.manchester.cs.factplusplus.protege.FaCTPlusPlusFactory.getReasonerFactory(FaCTPlusPlusFactory.java:84) ~[na:na]
        at org.protege.editor.owl.model.inference.ReasonerInfoComparator.compare(ReasonerInfoComparator.java:9) ~[na:na]
        at org.protege.editor.owl.model.inference.ReasonerInfoComparator.compare(ReasonerInfoComparator.java:5) ~[na:na]
        at java.util.TimSort.countRunAndMakeAscending(TimSort.java:351) ~[na:1.8.0_40]
        at java.util.TimSort.sort(TimSort.java:216) ~[na:1.8.0_40]
        at java.util.Arrays.sort(Arrays.java:1512) ~[na:1.8.0_40]
        at java.util.ArrayList.sort(ArrayList.java:1454) ~[na:1.8.0_40]
        at java.util.Collections.sort(Collections.java:175) ~[na:1.8.0_40]
        at org.protege.editor.owl.model.OWLWorkspace.rebuildReasonerMenu(OWLWorkspace.java:565) ~[na:na]
        at org.protege.editor.owl.model.OWLWorkspace.initialiseExtraMenuItems(OWLWorkspace.java:431) ~[na:na]
        at org.protege.editor.core.ui.workspace.WorkspaceFrame.createUI(WorkspaceFrame.java:141) ~[protege-editor-core.jar:na]
        at org.protege.editor.core.ui.workspace.WorkspaceFrame.<init>(WorkspaceFrame.java:55) ~[protege-editor-core.jar:na]
        at org.protege.editor.core.ui.workspace.WorkspaceManager.addWorkspace(WorkspaceManager.java:47) ~[protege-editor-core.jar:na]
        at org.protege.editor.core.editorkit.EditorKitManager.addEditorKit(EditorKitManager.java:44) ~[protege-editor-core.jar:na]
        at org.protege.editor.core.ProtegeManager.createAndSetupNewEditorKit(ProtegeManager.java:139) ~[protege-editor-core.jar:na]
        at org.protege.editor.core.ProtegeManager.createAndSetupNewEditorKit(ProtegeManager.java:129) ~[protege-editor-core.jar:na]
        at org.protege.editor.core.ProtegeApplication.createAndSetupDefaultEditorKit(ProtegeApplication.java:488) [protege-editor-core.jar:na]
        at org.protege.editor.core.ProtegeApplication.startApplication(ProtegeApplication.java:432) [protege-editor-core.jar:na]
        at org.protege.editor.core.ProtegeApplication.reallyStart(ProtegeApplication.java:109) [protege-editor-core.jar:na]
        at org.protege.editor.core.ProtegeApplication.lambda$start$11(ProtegeApplication.java:90) [protege-editor-core.jar:na]
        at org.protege.editor.core.ProtegeApplication$$Lambda$24/1976931298.frameworkEvent(Unknown Source) [protege-editor-core.jar:na]
        at org.apache.felix.framework.util.EventDispatcher.invokeFrameworkListenerCallback(EventDispatcher.java:836) [org.apache.felix.main.jar:na]
        at org.apache.felix.framework.util.EventDispatcher.fireEventImmediately(EventDispatcher.java:786) [org.apache.felix.main.jar:na]
        at org.apache.felix.framework.util.EventDispatcher.run(EventDispatcher.java:1099) [org.apache.felix.main.jar:na]
        at org.apache.felix.framework.util.EventDispatcher.access$000(EventDispatcher.java:55) [org.apache.felix.main.jar:na]
        at org.apache.felix.framework.util.EventDispatcher$1.run(EventDispatcher.java:102) [org.apache.felix.main.jar:na]
        at java.lang.Thread.run(Thread.java:745) [na:1.8.0_40]
Caused by: java.lang.UnsatisfiedLinkError: C:\Users\Evgueni\AppData\Local\Temp\ProtegeCache-e2b80694-f0ed-44e2-905b-9d993353402c\bundle36\version0.0\bundle.jar-lib\0\lib\native\64bit\FaCTPlusPlusJNI.dll: Can't find dependent libraries
        at java.lang.ClassLoader$NativeLibrary.load(Native Method) ~[na:1.8.0_40]
        at java.lang.ClassLoader.loadLibrary0(ClassLoader.java:1937) ~[na:1.8.0_40]
        at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1835) ~[na:1.8.0_40]
        at java.lang.Runtime.loadLibrary0(Runtime.java:870) ~[na:1.8.0_40]
        at java.lang.System.loadLibrary(System.java:1122) ~[na:1.8.0_40]
        at uk.ac.manchester.cs.factplusplus.FaCTPlusPlus.<clinit>(FaCTPlusPlus.java:19) ~[na:na]
        at uk.ac.manchester.cs.factplusplus.protege.FaCTPlusPlusFactory.getReasonerFactory(FaCTPlusPlusFactory.java:75) ~[na:na]
        ... 26 common frames omitted


AT THIS POINT ANOTHER ERROR WINDOW POPS UP which is HUGE, so when I click OK
THIS IS THE LAST I SEE -- then Prorege dies -- the editor never opens.


------------------------------- Auto-update Check ------------------------------
Auto-update last performed: Mon Feb 27 17:08:38 EST 2017
Auto-update has been performed today.  Not performing it again.

 

THANK YOU so much for your help. It is trully appreciated.
Best regards, Neli

 

 

Neli P. Zlatareva, PhD
Professor of Computer Science
Department of Computer Science
Central Connecticut State University
New Britain, CT 06050
Phone: (860) 832-2723
Fax: (860) 832-2712
Web site: cs.ccsu.edu/~neli/


From: protege-user <[hidden email]> on behalf of Csongor Nyulas <[hidden email]>
Sent: Wednesday, February 22, 2017 2:59:44 AM
To: User support for WebProtege and Protege Desktop
Subject: Re: [protege-user] Problem running Protege 5.1 after updating Fact++

 

Dear Neli,

I am running Protege 5.1.1 with Fact++ 1.6.5 for a long time now, and I never experienced the things that you describe. So, in order to debug what's going on, we need to understand what is different on your machine compared to ours.

Here are a few questions that hopefully can help us elucidate the mystery:

What OS are you using?
What is the ".dat" file? Maybe you wanted to say ".bat" file (in which case you are probably using Windows)?
Are you by any chance using an virtual machine or some OS emulator?
In the [PROTEGE_INSTALL_DIR]/plugins folder how many files do you have that have the word "fact" in their names? If you have only a jar file, what is the exact name of that file, and how big is it?
If you search all the subfolders of [PROTEGE_INSTALL_DIR], how many ja files do you find that contain the name "fact" in it?
Can you send us the Protege logs?

Csongor

On 02/18/2017 08:00 AM, Zlatareva, Neli (Computer Science) wrote:


Hi,

I would greatly appreciate help with the following issue:

I have been working with Protégé 5.1 for some time and everything was great.

At the moment I decided to update to Fact++ 1.6.5 everything went wrong.

I could not open Protégé after restart (suggested to update Fact++). The error

I am getting is that MS C++ libraries are missing and after that the editor will not

open (I am running .dat file). I tried EVERYTHING -- deleting old versions, downloading

new ones, including JRE because I read somewhere about possible java corruption).

I am teaching Sem Web Tech class and very shortly my students will need Protégé

for their project. I am very worried that something like this can happen to them and

I have no clue how to help.

Any suggestions will be greatly appreciated.

THANK YOU SO MUCH! 

 

Neli P. Zlatareva, PhD
Professor of Computer Science
Department of Computer Science
Central Connecticut State University
New Britain, CT 06050
Phone: (860) 832-2723
Fax: (860) 832-2712
Web site: cs.ccsu.edu/~neli


 




_______________________________________________
protege-user mailing list
[hidden email]
https://mailman.stanford.edu/mailman/listinfo/protege-user

 


Virus-free. www.avast.com

_______________________________________________
protege-user mailing list
[hidden email]
https://mailman.stanford.edu/mailman/listinfo/protege-user
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Problem running Protege 5.1 after updating Fact++

Csongor Nyulas
Administrator
Hi Bobbin,

I don't think we have had time to debug/solve this issue so far. It is not so easy to come by a Win 10 machine in our department. Protege 5.1.0 AND 5.2.0 seem to work fine with Fact++ 1.6.5 on Macs and Ubuntu machines.

I created an issue for this where we can follow up on it:
https://github.com/protegeproject/protege/issues/638

Do you (and/or Neli) encounter the same problem also with Protege 5.2.0 and Fact++ 1.6.5. on Win 10?

Csongor

On 04/17/2017 04:55 PM, Bobbin Teegarden wrote:

After updating to 5.2.0, I’m having the same problem as described by Neli below, but couldn’t find an answer in the mailing list.  Did I miss it?  What is the answer?  Thanks.

 

Bobbin Teegarden

CTO/Chief Architect, OntoAge

Technology Evangelist, No Magic

h/o 425.378.0131

cell 206.979.0196

[hidden email]

alt:  [hidden email]

 

From: protege-user [[hidden email]] On Behalf Of Zlatareva, Neli (Computer Science)
Sent: Monday, February 27, 2017 3:12 PM
To: User support for WebProtege and Protege Desktop [hidden email]
Subject: Re: [protege-user] Problem running Protege 5.1 after updating Fact++

 

Hi Csongor,

thank you so much for your reply -- I just found it buried in my mailbox.
To answer your questions. I run Windows 10 Home – no virtual machine or OS emulator.
As I said in my original call-for-help message, I have been working with Protégé 5.1.0 for some time with NO problems at all. The problem happened when I undated to Fact++ 1.6.5 (originally Protégé came with Fact++ 1.6.4). I use Pellet, but I wanted to check out the new Fact++, so I click update and after closing Protégé for the update to take place, I was never able to open it again. Just to note that I deleted old versions (including Protégé 5.0.0 -- Protege 5.0.0 gives me the same problem) downloaded new ones, same with jre, I tried the platform independent version, etc. – always the same “non-sense” result. So, here is the latest (today's) attempt to download and start Protégé (old downloads deleted).
You are asking about files with “fact” in their names – only one in the bin directory, called maven-artifact, which is a jar file 54 KB.

When I run .bat file this is what happens: (please note that I inserted in this log error messages as I am getting them)

 

C:\Program Files (x86)\Protege-5.1.0>setlocal

C:\Program Files (x86)\Protege-5.1.0>cd /d C:\Program Files (x86)\Protege-5.1.0\

C:\Program Files (x86)\Protege-5.1.0>jre\bin\java -Xmx500M -Xms200M -Xss16M -XX:CompileCommand=exclude,javax/swing/text/GlyphView,getBreakSpot -DentityExpansionLimit=100000000 -Dlogback.configurationFile=conf/logback-win.xml -Dfile.encoding=utf-8 -Dorg.protege.plugin.dir=plugins -classpath bundles/guava.jar;bundles/logback-classic.jar;bundles/logback-core.jar;bundles/slf4j-api.jar;bin/org.apache.felix.main.jar;bin/protege-launcher.jar org.protege.osgi.framework.Launcher
CompilerOracle: exclude javax/swing/text/GlyphView.getBreakSpot
********************************************************************************
**                                  Protege                                   **
********************************************************************************

----------------- Initialising and Starting the OSGi Framework -----------------
FrameworkFactory Class: org.apache.felix.framework.FrameworkFactory

The OSGi framework has been initialised
------------------------------- Starting Bundles -------------------------------
Starting bundle org.protege.common
Starting bundle org.eclipse.equinox.common
Starting bundle org.eclipse.equinox.supplement
Starting bundle org.eclipse.equinox.registry
Starting bundle org.protege.editor.core.application
Starting bundle org.apache.commons.io
Starting bundle com.google.guava
Not starting bundle com.google.inject.assistedinject explicitly because it is a fragment bundle.
Not starting bundle com.google.inject.multibindings explicitly because it is a fragment bundle.
Starting bundle com.google.inject
Starting bundle org.jsr-305
Starting bundle jul.to.slf4j
Starting bundle log4j.over.slf4j
Starting bundle ch.qos.logback.classic
Starting bundle ch.qos.logback.core
Starting bundle org.apache.servicemix.bundles.aopalliance
Starting bundle org.apache.servicemix.bundles.javax-inject
Starting bundle org.eclipse.equinox.common
Starting bundle org.eclipse.equinox.registry
Starting bundle org.eclipse.equinox.supplement
Starting bundle org.semanticweb.owl.owlapi
Starting bundle org.protege.common
Starting bundle org.protege.editor.core.application
Starting bundle org.protege.editor.owl
Starting bundle slf4j.api
Starting bundle cellfie
Starting bundle code-generation
Starting bundle existentialquery
Starting bundle uk.ac.manchester.cs.owl.explanation
Starting bundle org.protege.ontograf
Starting bundle org.coode.dlquery
Starting bundle org.semanticweb.hermit
Starting bundle org.coode.browser
Starting bundle org.coode.owlviz
Starting bundle org.protege.owl.rdf
Starting bundle org.protege.editor.owl.rdf
Starting bundle swrltab-plugin
Starting bundle com.clarkparsia.protege.plugin.pellet
Starting bundle org.exquisite.protege
Starting bundle org.semanticweb.elk
Starting bundle uk.ac.manchester.cs.owl.factplusplus
The OSGi framework has been started
------------------------------------ Protege -----------------------------------

Protege Desktop
Version 5.1.0, Build


----------------------------------- Platform -----------------------------------
Java: JVM 1.8.0_40-b26  Memory: 466M
Language: en, Country: US
Framework: Apache Software Foundation (1.7)
OS: windows8 (6.3)
Processor: x86-64


------------------------------------ Plugins -----------------------------------
Plugin: Cellfie Protege 5.0+ Plugin (2.1.0)
Plugin: OWL Code Generation Plug-in (2.0.0)
Plugin: Existential Query (2.0.0)
Plugin: Explanation Workbench (3.0.0)
Plugin: OntoGraf (2.0.3)
Plugin: DL Query (4.0.1)
Plugin: HermiT (1.3.8.413)
Plugin: Browser View (OWLDoc) (3.0.3)
Plugin: OWLViz (5.0.3)
Plugin: OWLAPI RDF Library (2.0.2)
Plugin: Protege SPARQL Plugin (2.0.1)
Plugin: SWRLTab Protege 5.0+ Plugin (1.0.3)
Plugin: Pellet Reasoner Plug-in (2.2.0)
Plugin: Ontology Debugger (0.1.2.BETA)
Plugin: ELK Reasoner Protege Plug-in (0.4.3)
Plugin: Factplusplus Plug-in (1.6.5)

Feb 27, 2017 5:35:50 PM java.util.prefs.WindowsPreferences <init>
WARNING: Could not open/create prefs root node Software\JavaSoft\Prefs at root 0x80000002. Windows RegCreateKeyEx(...) returned error code 5.
Creating and setting up empty (default) editor kit
OWL API Version: 4.2.6.20160910-2108
Loading default configuration parameters for class org.semanticweb.elk.reasoner.config.ReasonerConfiguration
Cannot generate ontology catalog for ontology at http://www.semanticweb.org/ioana/ontologies/2017/1/untitled-ontology-13
-------------------------- Generated Diagnosis Model ---------------------------
Ontology: OntologyID(OntologyIRI(<http://www.semanticweb.org/ioana/ontologies/2017/1/untitled-ontology-13>) VersionIRI(<null>))
Generated in 46 ms
0 Possibly Faulty Formulas
0 Correct Formulas
0 Entailed Examples
0 Not-Entailed Examples
--------------------------------------------------------------------------------

 

THE FOLLOWING ERROR WINDOW POPS UP AT THIS POINT:

MISSING LIBRARIES OR PLATFORM NOT SUPPPORTED
FACT++ REQUIRES PLATFORM SPECIFIC LIBRARIES
WHICH CANNOT BE FOUND

WHEN I CLICK OK THIS WINDOW CLOSES AND THE PROTEGE LOG CONTINUES AS FOLLOWS:

 


java:102)
          java.lang.Thread.run(Thread.java:745)
    (Listeners should be removed in the plugin dispose method!)
*** WARNING BADLY BEHAVING LISTENER: org.protege.editor.owl.ui.action.AbstractOntologySelectionStrategyAction$$Lambda$59/1677217031 ***
    Possible culprit (trace from when listener was added):
          org.protege.editor.owl.ui.action.AbstractOntologySelectionStrategyAction.initialise(AbstractOntologySelectionStrategyAction.java:47)
          org.protege.editor.owl.ui.action.ImportsClosureOntologyStrategyAction.initialise(ImportsClosureOntologyStrategyAction.java:27)
          org.protege.editor.core.ui.menu.MenuActionPluginJPFImpl.newInstance(MenuActionPluginJPFImpl.java:169)
          org.protege.editor.core.ui.menu.MenuActionPluginJPFImpl.newInstance(MenuActionPluginJPFImpl.java:31)
          org.protege.editor.core.ui.menu.MenuBuilder.buildInnerMenu(MenuBuilder.java:159)
          org.protege.editor.core.ui.menu.MenuBuilder.addMenu(MenuBuilder.java:114)
          org.protege.editor.core.ui.menu.MenuBuilder.buildCompositeMenu(MenuBuilder.java:135)
          org.protege.editor.core.ui.menu.MenuBuilder.addMenu(MenuBuilder.java:106)
          org.protege.editor.core.ui.menu.MenuBuilder.buildMenu(MenuBuilder.java:64)
          org.protege.editor.core.ui.workspace.WorkspaceFrame.createMenuBar(WorkspaceFrame.java:165)
          org.protege.editor.core.ui.workspace.WorkspaceFrame.createUI(WorkspaceFrame.java:137)
          org.protege.editor.core.ui.workspace.WorkspaceFrame.<init>(WorkspaceFrame.java:55)
          org.protege.editor.core.ui.workspace.WorkspaceManager.addWorkspace(WorkspaceManager.java:47)
          org.protege.editor.core.editorkit.EditorKitManager.addEditorKit(EditorKitManager.java:44)
          org.protege.editor.core.ProtegeManager.createAndSetupNewEditorKit(ProtegeManager.java:139)
          org.protege.editor.core.ProtegeManager.createAndSetupNewEditorKit(ProtegeManager.java:129)
          org.protege.editor.core.ProtegeApplication.createAndSetupDefaultEditorKit(ProtegeApplication.java:488)
          org.protege.editor.core.ProtegeApplication.startApplication(ProtegeApplication.java:432)
          org.protege.editor.core.ProtegeApplication.reallyStart(ProtegeApplication.java:109)
          org.protege.editor.core.ProtegeApplication.lambda$start$11(ProtegeApplication.java:90)
          org.protege.editor.core.ProtegeApplication$$Lambda$24/1976931298.frameworkEvent(Unknown Source)
          org.apache.felix.framework.util.EventDispatcher.invokeFrameworkListenerCallback(EventDispatcher.java:836)
          org.apache.felix.framework.util.EventDispatcher.fireEventImmediately(EventDispatcher.java:786)
          org.apache.felix.framework.util.EventDispatcher.run(EventDispatcher.java:1099)
          org.apache.felix.framework.util.EventDispatcher.access$000(EventDispatcher.java:55)
          org.apache.felix.framework.util.EventDispatcher$1.run(EventDispatcher.java:102)
          java.lang.Thread.run(Thread.java:745)
    (Listeners should be removed in the plugin dispose method!)
*** WARNING BADLY BEHAVING LISTENER: org.protege.editor.owl.ui.renderer.menu.AbstractByRendererMenu$$Lambda$57/436590799 ***
    Possible culprit (trace from when listener was added):
          org.protege.editor.owl.ui.renderer.menu.AbstractByRendererMenu.initialise(AbstractByRendererMenu.java:34)
          org.protege.editor.core.ui.menu.MenuActionPluginJPFImpl.newInstance(MenuActionPluginJPFImpl.java:169)
          org.protege.editor.core.ui.menu.MenuActionPluginJPFImpl.newInstance(MenuActionPluginJPFImpl.java:31)
          org.protege.editor.core.ui.menu.MenuBuilder.buildInnerMenu(MenuBuilder.java:159)
          org.protege.editor.core.ui.menu.MenuBuilder.addMenu(MenuBuilder.java:114)
          org.protege.editor.core.ui.menu.MenuBuilder.buildCompositeMenu(MenuBuilder.java:135)
          org.protege.editor.core.ui.menu.MenuBuilder.addMenu(MenuBuilder.java:106)
          org.protege.editor.core.ui.menu.MenuBuilder.buildMenu(MenuBuilder.java:64)
          org.protege.editor.core.ui.workspace.WorkspaceFrame.createMenuBar(WorkspaceFrame.java:165)
          org.protege.editor.core.ui.workspace.WorkspaceFrame.createUI(WorkspaceFrame.java:137)
          org.protege.editor.core.ui.workspace.WorkspaceFrame.<init>(WorkspaceFrame.java:55)
          org.protege.editor.core.ui.workspace.WorkspaceManager.addWorkspace(WorkspaceManager.java:47)
          org.protege.editor.core.editorkit.EditorKitManager.addEditorKit(EditorKitManager.java:44)
          org.protege.editor.core.ProtegeManager.createAndSetupNewEditorKit(ProtegeManager.java:139)
          org.protege.editor.core.ProtegeManager.createAndSetupNewEditorKit(ProtegeManager.java:129)
          org.protege.editor.core.ProtegeApplication.createAndSetupDefaultEditorKit(ProtegeApplication.java:488)
          org.protege.editor.core.ProtegeApplication.startApplication(ProtegeApplication.java:432)
          org.protege.editor.core.ProtegeApplication.reallyStart(ProtegeApplication.java:109)
          org.protege.editor.core.ProtegeApplication.lambda$start$11(ProtegeApplication.java:90)
          org.protege.editor.core.ProtegeApplication$$Lambda$24/1976931298.frameworkEvent(Unknown Source)
          org.apache.felix.framework.util.EventDispatcher.invokeFrameworkListenerCallback(EventDispatcher.java:836)
          org.apache.felix.framework.util.EventDispatcher.fireEventImmediately(EventDispatcher.java:786)
          org.apache.felix.framework.util.EventDispatcher.run(EventDispatcher.java:1099)
          org.apache.felix.framework.util.EventDispatcher.access$000(EventDispatcher.java:55)
          org.apache.felix.framework.util.EventDispatcher$1.run(EventDispatcher.java:102)
          java.lang.Thread.run(Thread.java:745)
    (Listeners should be removed in the plugin dispose method!)
*** WARNING BADLY BEHAVING LISTENER: org.protege.editor.owl.ui.renderer.menu.RenderByProperty$$Lambda$58/1386820222 ***
    Possible culprit (trace from when listener was added):
          org.protege.editor.owl.ui.renderer.menu.RenderByProperty.initialise(RenderByProperty.java:82)
          org.protege.editor.core.ui.menu.MenuActionPluginJPFImpl.newInstance(MenuActionPluginJPFImpl.java:169)
          org.protege.editor.core.ui.menu.MenuActionPluginJPFImpl.newInstance(MenuActionPluginJPFImpl.java:31)
          org.protege.editor.core.ui.menu.MenuBuilder.buildDynamicMenu(MenuBuilder.java:146)
          org.protege.editor.core.ui.menu.MenuBuilder.addMenu(MenuBuilder.java:110)
          org.protege.editor.core.ui.menu.MenuBuilder.buildCompositeMenu(MenuBuilder.java:135)
          org.protege.editor.core.ui.menu.MenuBuilder.addMenu(MenuBuilder.java:106)
          org.protege.editor.core.ui.menu.MenuBuilder.buildMenu(MenuBuilder.java:64)
          org.protege.editor.core.ui.workspace.WorkspaceFrame.createMenuBar(WorkspaceFrame.java:165)
          org.protege.editor.core.ui.workspace.WorkspaceFrame.createUI(WorkspaceFrame.java:137)
          org.protege.editor.core.ui.workspace.WorkspaceFrame.<init>(WorkspaceFrame.java:55)
          org.protege.editor.core.ui.workspace.WorkspaceManager.addWorkspace(WorkspaceManager.java:47)
          org.protege.editor.core.editorkit.EditorKitManager.addEditorKit(EditorKitManager.java:44)
          org.protege.editor.core.ProtegeManager.createAndSetupNewEditorKit(ProtegeManager.java:139)
          org.protege.editor.core.ProtegeManager.createAndSetupNewEditorKit(ProtegeManager.java:129)
          org.protege.editor.core.ProtegeApplication.createAndSetupDefaultEditorKit(ProtegeApplication.java:488)
          org.protege.editor.core.ProtegeApplication.startApplication(ProtegeApplication.java:432)
          org.protege.editor.core.ProtegeApplication.reallyStart(ProtegeApplication.java:109)
          org.protege.editor.core.ProtegeApplication.lambda$start$11(ProtegeApplication.java:90)
          org.protege.editor.core.ProtegeApplication$$Lambda$24/1976931298.frameworkEvent(Unknown Source)
          org.apache.felix.framework.util.EventDispatcher.invokeFrameworkListenerCallback(EventDispatcher.java:836)
          org.apache.felix.framework.util.EventDispatcher.fireEventImmediately(EventDispatcher.java:786)
          org.apache.felix.framework.util.EventDispatcher.run(EventDispatcher.java:1099)
          org.apache.felix.framework.util.EventDispatcher.access$000(EventDispatcher.java:55)
          org.apache.felix.framework.util.EventDispatcher$1.run(EventDispatcher.java:102)
          java.lang.Thread.run(Thread.java:745)
    (Listeners should be removed in the plugin dispose method!)
*** WARNING BADLY BEHAVING LISTENER: org.protege.editor.owl.ui.action.AbstractOntologySelectionStrategyAction$$Lambda$59/1677217031 ***
    Possible culprit (trace from when listener was added):
          org.protege.editor.owl.ui.action.AbstractOntologySelectionStrategyAction.initialise(AbstractOntologySelectionStrategyAction.java:47)
          org.protege.editor.core.ui.menu.MenuActionPluginJPFImpl.newInstance(MenuActionPluginJPFImpl.java:169)
          org.protege.editor.core.ui.menu.MenuActionPluginJPFImpl.newInstance(MenuActionPluginJPFImpl.java:31)
          org.protege.editor.core.ui.menu.MenuBuilder.buildInnerMenu(MenuBuilder.java:159)
          org.protege.editor.core.ui.menu.MenuBuilder.addMenu(MenuBuilder.java:114)
          org.protege.editor.core.ui.menu.MenuBuilder.buildCompositeMenu(MenuBuilder.java:135)
          org.protege.editor.core.ui.menu.MenuBuilder.addMenu(MenuBuilder.java:106)
          org.protege.editor.core.ui.menu.MenuBuilder.buildMenu(MenuBuilder.java:64)
          org.protege.editor.core.ui.workspace.WorkspaceFrame.createMenuBar(WorkspaceFrame.java:165)
          org.protege.editor.core.ui.workspace.WorkspaceFrame.createUI(WorkspaceFrame.java:137)
          org.protege.editor.core.ui.workspace.WorkspaceFrame.<init>(WorkspaceFrame.java:55)
          org.protege.editor.core.ui.workspace.WorkspaceManager.addWorkspace(WorkspaceManager.java:47)
          org.protege.editor.core.editorkit.EditorKitManager.addEditorKit(EditorKitManager.java:44)
          org.protege.editor.core.ProtegeManager.createAndSetupNewEditorKit(ProtegeManager.java:139)
          org.protege.editor.core.ProtegeManager.createAndSetupNewEditorKit(ProtegeManager.java:129)
          org.protege.editor.core.ProtegeApplication.createAndSetupDefaultEditorKit(ProtegeApplication.java:488)
          org.protege.editor.core.ProtegeApplication.startApplication(ProtegeApplication.java:432)
          org.protege.editor.core.ProtegeApplication.reallyStart(ProtegeApplication.java:109)
          org.protege.editor.core.ProtegeApplication.lambda$start$11(ProtegeApplication.java:90)
          org.protege.editor.core.ProtegeApplication$$Lambda$24/1976931298.frameworkEvent(Unknown Source)
          org.apache.felix.framework.util.EventDispatcher.invokeFrameworkListenerCallback(EventDispatcher.java:836)
          org.apache.felix.framework.util.EventDispatcher.fireEventImmediately(EventDispatcher.java:786)
          org.apache.felix.framework.util.EventDispatcher.run(EventDispatcher.java:1099)
          org.apache.felix.framework.util.EventDispatcher.access$000(EventDispatcher.java:55)
          org.apache.felix.framework.util.EventDispatcher$1.run(EventDispatcher.java:102)
          java.lang.Thread.run(Thread.java:745)
    (Listeners should be removed in the plugin dispose method!)

An error was thrown: java.lang.UnsatisfiedLinkError: C:\Users\Evgueni\AppData\Local\Temp\ProtegeCache-e2b80694-f0ed-44e2-905b-9d993353402c\bundle36\version0.0\bundle.jar-lib\0\lib\native\64bit\FaCTPlusPlusJNI.dll: Can't find dependent libraries
org.semanticweb.owlapi.model.OWLRuntimeException: java.lang.UnsatisfiedLinkError: C:\Users\Evgueni\AppData\Local\Temp\ProtegeCache-e2b80694-f0ed-44e2-905b-9d993353402c\bundle36\version0.0\bundle.jar-lib\0\lib\native\64bit\FaCTPlusPlusJNI.dll: Can't find dependent libraries
        at uk.ac.manchester.cs.factplusplus.protege.FaCTPlusPlusFactory.getReasonerFactory(FaCTPlusPlusFactory.java:84) ~[na:na]
        at org.protege.editor.owl.model.inference.ReasonerInfoComparator.compare(ReasonerInfoComparator.java:9) ~[na:na]
        at org.protege.editor.owl.model.inference.ReasonerInfoComparator.compare(ReasonerInfoComparator.java:5) ~[na:na]
        at java.util.TimSort.countRunAndMakeAscending(TimSort.java:351) ~[na:1.8.0_40]
        at java.util.TimSort.sort(TimSort.java:216) ~[na:1.8.0_40]
        at java.util.Arrays.sort(Arrays.java:1512) ~[na:1.8.0_40]
        at java.util.ArrayList.sort(ArrayList.java:1454) ~[na:1.8.0_40]
        at java.util.Collections.sort(Collections.java:175) ~[na:1.8.0_40]
        at org.protege.editor.owl.model.OWLWorkspace.rebuildReasonerMenu(OWLWorkspace.java:565) ~[na:na]
        at org.protege.editor.owl.model.OWLWorkspace.initialiseExtraMenuItems(OWLWorkspace.java:431) ~[na:na]
        at org.protege.editor.core.ui.workspace.WorkspaceFrame.createUI(WorkspaceFrame.java:141) ~[protege-editor-core.jar:na]
        at org.protege.editor.core.ui.workspace.WorkspaceFrame.<init>(WorkspaceFrame.java:55) ~[protege-editor-core.jar:na]
        at org.protege.editor.core.ui.workspace.WorkspaceManager.addWorkspace(WorkspaceManager.java:47) ~[protege-editor-core.jar:na]
        at org.protege.editor.core.editorkit.EditorKitManager.addEditorKit(EditorKitManager.java:44) ~[protege-editor-core.jar:na]
        at org.protege.editor.core.ProtegeManager.createAndSetupNewEditorKit(ProtegeManager.java:139) ~[protege-editor-core.jar:na]
        at org.protege.editor.core.ProtegeManager.createAndSetupNewEditorKit(ProtegeManager.java:129) ~[protege-editor-core.jar:na]
        at org.protege.editor.core.ProtegeApplication.createAndSetupDefaultEditorKit(ProtegeApplication.java:488) [protege-editor-core.jar:na]
        at org.protege.editor.core.ProtegeApplication.startApplication(ProtegeApplication.java:432) [protege-editor-core.jar:na]
        at org.protege.editor.core.ProtegeApplication.reallyStart(ProtegeApplication.java:109) [protege-editor-core.jar:na]
        at org.protege.editor.core.ProtegeApplication.lambda$start$11(ProtegeApplication.java:90) [protege-editor-core.jar:na]
        at org.protege.editor.core.ProtegeApplication$$Lambda$24/1976931298.frameworkEvent(Unknown Source) [protege-editor-core.jar:na]
        at org.apache.felix.framework.util.EventDispatcher.invokeFrameworkListenerCallback(EventDispatcher.java:836) [org.apache.felix.main.jar:na]
        at org.apache.felix.framework.util.EventDispatcher.fireEventImmediately(EventDispatcher.java:786) [org.apache.felix.main.jar:na]
        at org.apache.felix.framework.util.EventDispatcher.run(EventDispatcher.java:1099) [org.apache.felix.main.jar:na]
        at org.apache.felix.framework.util.EventDispatcher.access$000(EventDispatcher.java:55) [org.apache.felix.main.jar:na]
        at org.apache.felix.framework.util.EventDispatcher$1.run(EventDispatcher.java:102) [org.apache.felix.main.jar:na]
        at java.lang.Thread.run(Thread.java:745) [na:1.8.0_40]
Caused by: java.lang.UnsatisfiedLinkError: C:\Users\Evgueni\AppData\Local\Temp\ProtegeCache-e2b80694-f0ed-44e2-905b-9d993353402c\bundle36\version0.0\bundle.jar-lib\0\lib\native\64bit\FaCTPlusPlusJNI.dll: Can't find dependent libraries
        at java.lang.ClassLoader$NativeLibrary.load(Native Method) ~[na:1.8.0_40]
        at java.lang.ClassLoader.loadLibrary0(ClassLoader.java:1937) ~[na:1.8.0_40]
        at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1835) ~[na:1.8.0_40]
        at java.lang.Runtime.loadLibrary0(Runtime.java:870) ~[na:1.8.0_40]
        at java.lang.System.loadLibrary(System.java:1122) ~[na:1.8.0_40]
        at uk.ac.manchester.cs.factplusplus.FaCTPlusPlus.<clinit>(FaCTPlusPlus.java:19) ~[na:na]
        at uk.ac.manchester.cs.factplusplus.protege.FaCTPlusPlusFactory.getReasonerFactory(FaCTPlusPlusFactory.java:75) ~[na:na]
        ... 26 common frames omitted


AT THIS POINT ANOTHER ERROR WINDOW POPS UP which is HUGE, so when I click OK
THIS IS THE LAST I SEE -- then Prorege dies -- the editor never opens.


------------------------------- Auto-update Check ------------------------------
Auto-update last performed: Mon Feb 27 17:08:38 EST 2017
Auto-update has been performed today.  Not performing it again.

 

THANK YOU so much for your help. It is trully appreciated.
Best regards, Neli

 

 

Neli P. Zlatareva, PhD
Professor of Computer Science
Department of Computer Science
Central Connecticut State University
New Britain, CT 06050
Phone: (860) 832-2723
Fax: (860) 832-2712
Web site: cs.ccsu.edu/~neli/


From: protege-user <[hidden email]> on behalf of Csongor Nyulas <[hidden email]>
Sent: Wednesday, February 22, 2017 2:59:44 AM
To: User support for WebProtege and Protege Desktop
Subject: Re: [protege-user] Problem running Protege 5.1 after updating Fact++

 

Dear Neli,

I am running Protege 5.1.1 with Fact++ 1.6.5 for a long time now, and I never experienced the things that you describe. So, in order to debug what's going on, we need to understand what is different on your machine compared to ours.

Here are a few questions that hopefully can help us elucidate the mystery:

What OS are you using?
What is the ".dat" file? Maybe you wanted to say ".bat" file (in which case you are probably using Windows)?
Are you by any chance using an virtual machine or some OS emulator?
In the [PROTEGE_INSTALL_DIR]/plugins folder how many files do you have that have the word "fact" in their names? If you have only a jar file, what is the exact name of that file, and how big is it?
If you search all the subfolders of [PROTEGE_INSTALL_DIR], how many ja files do you find that contain the name "fact" in it?
Can you send us the Protege logs?

Csongor

On 02/18/2017 08:00 AM, Zlatareva, Neli (Computer Science) wrote:


Hi,

I would greatly appreciate help with the following issue:

I have been working with Protégé 5.1 for some time and everything was great.

At the moment I decided to update to Fact++ 1.6.5 everything went wrong.

I could not open Protégé after restart (suggested to update Fact++). The error

I am getting is that MS C++ libraries are missing and after that the editor will not

open (I am running .dat file). I tried EVERYTHING -- deleting old versions, downloading

new ones, including JRE because I read somewhere about possible java corruption).

I am teaching Sem Web Tech class and very shortly my students will need Protégé

for their project. I am very worried that something like this can happen to them and

I have no clue how to help.

Any suggestions will be greatly appreciated.

THANK YOU SO MUCH! 

 

Neli P. Zlatareva, PhD
Professor of Computer Science
Department of Computer Science
Central Connecticut State University
New Britain, CT 06050
Phone: (860) 832-2723
Fax: (860) 832-2712
Web site: cs.ccsu.edu/~neli


 




_______________________________________________
protege-user mailing list
[hidden email]
https://mailman.stanford.edu/mailman/listinfo/protege-user

 


Virus-free. www.avast.com


_______________________________________________
protege-user mailing list
[hidden email]
https://mailman.stanford.edu/mailman/listinfo/protege-user


_______________________________________________
protege-user mailing list
[hidden email]
https://mailman.stanford.edu/mailman/listinfo/protege-user
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Problem running Protege 5.1 after updating Fact++

Yevgeny Kazakov
I think these instructions helped Neli:


Yevgeny

On Tue, Apr 18, 2017 at 9:42 AM, Csongor Nyulas <[hidden email]> wrote:
Hi Bobbin,

I don't think we have had time to debug/solve this issue so far. It is not so easy to come by a Win 10 machine in our department. Protege 5.1.0 AND 5.2.0 seem to work fine with Fact++ 1.6.5 on Macs and Ubuntu machines.

I created an issue for this where we can follow up on it:
https://github.com/protegeproject/protege/issues/638

Do you (and/or Neli) encounter the same problem also with Protege 5.2.0 and Fact++ 1.6.5. on Win 10?

Csongor


On 04/17/2017 04:55 PM, Bobbin Teegarden wrote:

After updating to 5.2.0, I’m having the same problem as described by Neli below, but couldn’t find an answer in the mailing list.  Did I miss it?  What is the answer?  Thanks.

 

Bobbin Teegarden

CTO/Chief Architect, OntoAge

Technology Evangelist, No Magic

h/o <a href="tel:(425)%20378-0131" value="+14253780131" target="_blank">425.378.0131

cell <a href="tel:(206)%20979-0196" value="+12069790196" target="_blank">206.979.0196

[hidden email]

alt:  [hidden email]

 

From: protege-user [[hidden email]] On Behalf Of Zlatareva, Neli (Computer Science)
Sent: Monday, February 27, 2017 3:12 PM
To: User support for WebProtege and Protege Desktop [hidden email]
Subject: Re: [protege-user] Problem running Protege 5.1 after updating Fact++

 

Hi Csongor,

thank you so much for your reply -- I just found it buried in my mailbox.
To answer your questions. I run Windows 10 Home – no virtual machine or OS emulator.
As I said in my original call-for-help message, I have been working with Protégé 5.1.0 for some time with NO problems at all. The problem happened when I undated to Fact++ 1.6.5 (originally Protégé came with Fact++ 1.6.4). I use Pellet, but I wanted to check out the new Fact++, so I click update and after closing Protégé for the update to take place, I was never able to open it again. Just to note that I deleted old versions (including Protégé 5.0.0 -- Protege 5.0.0 gives me the same problem) downloaded new ones, same with jre, I tried the platform independent version, etc. – always the same “non-sense” result. So, here is the latest (today's) attempt to download and start Protégé (old downloads deleted).
You are asking about files with “fact” in their names – only one in the bin directory, called maven-artifact, which is a jar file 54 KB.

When I run .bat file this is what happens: (please note that I inserted in this log error messages as I am getting them)

 

C:\Program Files (x86)\Protege-5.1.0>setlocal

C:\Program Files (x86)\Protege-5.1.0>cd /d C:\Program Files (x86)\Protege-5.1.0\

C:\Program Files (x86)\Protege-5.1.0>jre\bin\java -Xmx500M -Xms200M -Xss16M -XX:CompileCommand=exclude,javax/swing/text/GlyphView,getBreakSpot -DentityExpansionLimit=100000000 -Dlogback.configurationFile=conf/logback-win.xml -Dfile.encoding=utf-8 -Dorg.protege.plugin.dir=plugins -classpath bundles/guava.jar;bundles/logback-classic.jar;bundles/logback-core.jar;bundles/slf4j-api.jar;bin/org.apache.felix.main.jar;bin/protege-launcher.jar org.protege.osgi.framework.Launcher
CompilerOracle: exclude javax/swing/text/GlyphView.getBreakSpot
********************************************************************************
**                                  Protege                                   **
********************************************************************************

----------------- Initialising and Starting the OSGi Framework -----------------
FrameworkFactory Class: org.apache.felix.framework.FrameworkFactory

The OSGi framework has been initialised
------------------------------- Starting Bundles -------------------------------
Starting bundle org.protege.common
Starting bundle org.eclipse.equinox.common
Starting bundle org.eclipse.equinox.supplement
Starting bundle org.eclipse.equinox.registry
Starting bundle org.protege.editor.core.application
Starting bundle org.apache.commons.io
Starting bundle com.google.guava
Not starting bundle com.google.inject.assistedinject explicitly because it is a fragment bundle.
Not starting bundle com.google.inject.multibindings explicitly because it is a fragment bundle.
Starting bundle com.google.inject
Starting bundle org.jsr-305
Starting bundle jul.to.slf4j
Starting bundle log4j.over.slf4j
Starting bundle ch.qos.logback.classic
Starting bundle ch.qos.logback.core
Starting bundle org.apache.servicemix.bundles.aopalliance
Starting bundle org.apache.servicemix.bundles.javax-inject
Starting bundle org.eclipse.equinox.common
Starting bundle org.eclipse.equinox.registry
Starting bundle org.eclipse.equinox.supplement
Starting bundle org.semanticweb.owl.owlapi
Starting bundle org.protege.common
Starting bundle org.protege.editor.core.application
Starting bundle org.protege.editor.owl
Starting bundle slf4j.api
Starting bundle cellfie
Starting bundle code-generation
Starting bundle existentialquery
Starting bundle uk.ac.manchester.cs.owl.explanation
Starting bundle org.protege.ontograf
Starting bundle org.coode.dlquery
Starting bundle org.semanticweb.hermit
Starting bundle org.coode.browser
Starting bundle org.coode.owlviz
Starting bundle org.protege.owl.rdf
Starting bundle org.protege.editor.owl.rdf
Starting bundle swrltab-plugin
Starting bundle com.clarkparsia.protege.plugin.pellet
Starting bundle org.exquisite.protege
Starting bundle org.semanticweb.elk
Starting bundle uk.ac.manchester.cs.owl.factplusplus
The OSGi framework has been started
------------------------------------ Protege -----------------------------------

Protege Desktop
Version 5.1.0, Build


----------------------------------- Platform -----------------------------------
Java: JVM 1.8.0_40-b26  Memory: 466M
Language: en, Country: US
Framework: Apache Software Foundation (1.7)
OS: windows8 (6.3)
Processor: x86-64


------------------------------------ Plugins -----------------------------------
Plugin: Cellfie Protege 5.0+ Plugin (2.1.0)
Plugin: OWL Code Generation Plug-in (2.0.0)
Plugin: Existential Query (2.0.0)
Plugin: Explanation Workbench (3.0.0)
Plugin: OntoGraf (2.0.3)
Plugin: DL Query (4.0.1)
Plugin: HermiT (1.3.8.413)
Plugin: Browser View (OWLDoc) (3.0.3)
Plugin: OWLViz (5.0.3)
Plugin: OWLAPI RDF Library (2.0.2)
Plugin: Protege SPARQL Plugin (2.0.1)
Plugin: SWRLTab Protege 5.0+ Plugin (1.0.3)
Plugin: Pellet Reasoner Plug-in (2.2.0)
Plugin: Ontology Debugger (0.1.2.BETA)
Plugin: ELK Reasoner Protege Plug-in (0.4.3)
Plugin: Factplusplus Plug-in (1.6.5)

Feb 27, 2017 5:35:50 PM java.util.prefs.WindowsPreferences <init>
WARNING: Could not open/create prefs root node Software\JavaSoft\Prefs at root 0x80000002. Windows RegCreateKeyEx(...) returned error code 5.
Creating and setting up empty (default) editor kit
OWL API Version: 4.2.6.20160910-2108
Loading default configuration parameters for class org.semanticweb.elk.reasoner.config.ReasonerConfiguration
Cannot generate ontology catalog for ontology at http://www.semanticweb.org/ioana/ontologies/2017/1/untitled-ontology-13
-------------------------- Generated Diagnosis Model ---------------------------
Ontology: OntologyID(OntologyIRI(<http://www.semanticweb.org/ioana/ontologies/2017/1/untitled-ontology-13>) VersionIRI(<null>))
Generated in 46 ms
0 Possibly Faulty Formulas
0 Correct Formulas
0 Entailed Examples
0 Not-Entailed Examples
--------------------------------------------------------------------------------

 

THE FOLLOWING ERROR WINDOW POPS UP AT THIS POINT:

MISSING LIBRARIES OR PLATFORM NOT SUPPPORTED
FACT++ REQUIRES PLATFORM SPECIFIC LIBRARIES
WHICH CANNOT BE FOUND

WHEN I CLICK OK THIS WINDOW CLOSES AND THE PROTEGE LOG CONTINUES AS FOLLOWS:

 


java:102)
          java.lang.Thread.run(Thread.java:745)
    (Listeners should be removed in the plugin dispose method!)
*** WARNING BADLY BEHAVING LISTENER: org.protege.editor.owl.ui.action.AbstractOntologySelectionStrategyAction$$Lambda$59/1677217031 ***
    Possible culprit (trace from when listener was added):
          org.protege.editor.owl.ui.action.AbstractOntologySelectionStrategyAction.initialise(AbstractOntologySelectionStrategyAction.java:47)
          org.protege.editor.owl.ui.action.ImportsClosureOntologyStrategyAction.initialise(ImportsClosureOntologyStrategyAction.java:27)
          org.protege.editor.core.ui.menu.MenuActionPluginJPFImpl.newInstance(MenuActionPluginJPFImpl.java:169)
          org.protege.editor.core.ui.menu.MenuActionPluginJPFImpl.newInstance(MenuActionPluginJPFImpl.java:31)
          org.protege.editor.core.ui.menu.MenuBuilder.buildInnerMenu(MenuBuilder.java:159)
          org.protege.editor.core.ui.menu.MenuBuilder.addMenu(MenuBuilder.java:114)
          org.protege.editor.core.ui.menu.MenuBuilder.buildCompositeMenu(MenuBuilder.java:135)
          org.protege.editor.core.ui.menu.MenuBuilder.addMenu(MenuBuilder.java:106)
          org.protege.editor.core.ui.menu.MenuBuilder.buildMenu(MenuBuilder.java:64)
          org.protege.editor.core.ui.workspace.WorkspaceFrame.createMenuBar(WorkspaceFrame.java:165)
          org.protege.editor.core.ui.workspace.WorkspaceFrame.createUI(WorkspaceFrame.java:137)
          org.protege.editor.core.ui.workspace.WorkspaceFrame.<init>(WorkspaceFrame.java:55)
          org.protege.editor.core.ui.workspace.WorkspaceManager.addWorkspace(WorkspaceManager.java:47)
          org.protege.editor.core.editorkit.EditorKitManager.addEditorKit(EditorKitManager.java:44)
          org.protege.editor.core.ProtegeManager.createAndSetupNewEditorKit(ProtegeManager.java:139)
          org.protege.editor.core.ProtegeManager.createAndSetupNewEditorKit(ProtegeManager.java:129)
          org.protege.editor.core.ProtegeApplication.createAndSetupDefaultEditorKit(ProtegeApplication.java:488)
          org.protege.editor.core.ProtegeApplication.startApplication(ProtegeApplication.java:432)
          org.protege.editor.core.ProtegeApplication.reallyStart(ProtegeApplication.java:109)
          org.protege.editor.core.ProtegeApplication.lambda$start$11(ProtegeApplication.java:90)
          org.protege.editor.core.ProtegeApplication$$Lambda$24/1976931298.frameworkEvent(Unknown Source)
          org.apache.felix.framework.util.EventDispatcher.invokeFrameworkListenerCallback(EventDispatcher.java:836)
          org.apache.felix.framework.util.EventDispatcher.fireEventImmediately(EventDispatcher.java:786)
          org.apache.felix.framework.util.EventDispatcher.run(EventDispatcher.java:1099)
          org.apache.felix.framework.util.EventDispatcher.access$000(EventDispatcher.java:55)
          org.apache.felix.framework.util.EventDispatcher$1.run(EventDispatcher.java:102)
          java.lang.Thread.run(Thread.java:745)
    (Listeners should be removed in the plugin dispose method!)
*** WARNING BADLY BEHAVING LISTENER: org.protege.editor.owl.ui.renderer.menu.AbstractByRendererMenu$$Lambda$57/436590799 ***
    Possible culprit (trace from when listener was added):
          org.protege.editor.owl.ui.renderer.menu.AbstractByRendererMenu.initialise(AbstractByRendererMenu.java:34)
          org.protege.editor.core.ui.menu.MenuActionPluginJPFImpl.newInstance(MenuActionPluginJPFImpl.java:169)
          org.protege.editor.core.ui.menu.MenuActionPluginJPFImpl.newInstance(MenuActionPluginJPFImpl.java:31)
          org.protege.editor.core.ui.menu.MenuBuilder.buildInnerMenu(MenuBuilder.java:159)
          org.protege.editor.core.ui.menu.MenuBuilder.addMenu(MenuBuilder.java:114)
          org.protege.editor.core.ui.menu.MenuBuilder.buildCompositeMenu(MenuBuilder.java:135)
          org.protege.editor.core.ui.menu.MenuBuilder.addMenu(MenuBuilder.java:106)
          org.protege.editor.core.ui.menu.MenuBuilder.buildMenu(MenuBuilder.java:64)
          org.protege.editor.core.ui.workspace.WorkspaceFrame.createMenuBar(WorkspaceFrame.java:165)
          org.protege.editor.core.ui.workspace.WorkspaceFrame.createUI(WorkspaceFrame.java:137)
          org.protege.editor.core.ui.workspace.WorkspaceFrame.<init>(WorkspaceFrame.java:55)
          org.protege.editor.core.ui.workspace.WorkspaceManager.addWorkspace(WorkspaceManager.java:47)
          org.protege.editor.core.editorkit.EditorKitManager.addEditorKit(EditorKitManager.java:44)
          org.protege.editor.core.ProtegeManager.createAndSetupNewEditorKit(ProtegeManager.java:139)
          org.protege.editor.core.ProtegeManager.createAndSetupNewEditorKit(ProtegeManager.java:129)
          org.protege.editor.core.ProtegeApplication.createAndSetupDefaultEditorKit(ProtegeApplication.java:488)
          org.protege.editor.core.ProtegeApplication.startApplication(ProtegeApplication.java:432)
          org.protege.editor.core.ProtegeApplication.reallyStart(ProtegeApplication.java:109)
          org.protege.editor.core.ProtegeApplication.lambda$start$11(ProtegeApplication.java:90)
          org.protege.editor.core.ProtegeApplication$$Lambda$24/1976931298.frameworkEvent(Unknown Source)
          org.apache.felix.framework.util.EventDispatcher.invokeFrameworkListenerCallback(EventDispatcher.java:836)
          org.apache.felix.framework.util.EventDispatcher.fireEventImmediately(EventDispatcher.java:786)
          org.apache.felix.framework.util.EventDispatcher.run(EventDispatcher.java:1099)
          org.apache.felix.framework.util.EventDispatcher.access$000(EventDispatcher.java:55)
          org.apache.felix.framework.util.EventDispatcher$1.run(EventDispatcher.java:102)
          java.lang.Thread.run(Thread.java:745)
    (Listeners should be removed in the plugin dispose method!)
*** WARNING BADLY BEHAVING LISTENER: org.protege.editor.owl.ui.renderer.menu.RenderByProperty$$Lambda$58/1386820222 ***
    Possible culprit (trace from when listener was added):
          org.protege.editor.owl.ui.renderer.menu.RenderByProperty.initialise(RenderByProperty.java:82)
          org.protege.editor.core.ui.menu.MenuActionPluginJPFImpl.newInstance(MenuActionPluginJPFImpl.java:169)
          org.protege.editor.core.ui.menu.MenuActionPluginJPFImpl.newInstance(MenuActionPluginJPFImpl.java:31)
          org.protege.editor.core.ui.menu.MenuBuilder.buildDynamicMenu(MenuBuilder.java:146)
          org.protege.editor.core.ui.menu.MenuBuilder.addMenu(MenuBuilder.java:110)
          org.protege.editor.core.ui.menu.MenuBuilder.buildCompositeMenu(MenuBuilder.java:135)
          org.protege.editor.core.ui.menu.MenuBuilder.addMenu(MenuBuilder.java:106)
          org.protege.editor.core.ui.menu.MenuBuilder.buildMenu(MenuBuilder.java:64)
          org.protege.editor.core.ui.workspace.WorkspaceFrame.createMenuBar(WorkspaceFrame.java:165)
          org.protege.editor.core.ui.workspace.WorkspaceFrame.createUI(WorkspaceFrame.java:137)
          org.protege.editor.core.ui.workspace.WorkspaceFrame.<init>(WorkspaceFrame.java:55)
          org.protege.editor.core.ui.workspace.WorkspaceManager.addWorkspace(WorkspaceManager.java:47)
          org.protege.editor.core.editorkit.EditorKitManager.addEditorKit(EditorKitManager.java:44)
          org.protege.editor.core.ProtegeManager.createAndSetupNewEditorKit(ProtegeManager.java:139)
          org.protege.editor.core.ProtegeManager.createAndSetupNewEditorKit(ProtegeManager.java:129)
          org.protege.editor.core.ProtegeApplication.createAndSetupDefaultEditorKit(ProtegeApplication.java:488)
          org.protege.editor.core.ProtegeApplication.startApplication(ProtegeApplication.java:432)
          org.protege.editor.core.ProtegeApplication.reallyStart(ProtegeApplication.java:109)
          org.protege.editor.core.ProtegeApplication.lambda$start$11(ProtegeApplication.java:90)
          org.protege.editor.core.ProtegeApplication$$Lambda$24/1976931298.frameworkEvent(Unknown Source)
          org.apache.felix.framework.util.EventDispatcher.invokeFrameworkListenerCallback(EventDispatcher.java:836)
          org.apache.felix.framework.util.EventDispatcher.fireEventImmediately(EventDispatcher.java:786)
          org.apache.felix.framework.util.EventDispatcher.run(EventDispatcher.java:1099)
          org.apache.felix.framework.util.EventDispatcher.access$000(EventDispatcher.java:55)
          org.apache.felix.framework.util.EventDispatcher$1.run(EventDispatcher.java:102)
          java.lang.Thread.run(Thread.java:745)
    (Listeners should be removed in the plugin dispose method!)
*** WARNING BADLY BEHAVING LISTENER: org.protege.editor.owl.ui.action.AbstractOntologySelectionStrategyAction$$Lambda$59/1677217031 ***
    Possible culprit (trace from when listener was added):
          org.protege.editor.owl.ui.action.AbstractOntologySelectionStrategyAction.initialise(AbstractOntologySelectionStrategyAction.java:47)
          org.protege.editor.core.ui.menu.MenuActionPluginJPFImpl.newInstance(MenuActionPluginJPFImpl.java:169)
          org.protege.editor.core.ui.menu.MenuActionPluginJPFImpl.newInstance(MenuActionPluginJPFImpl.java:31)
          org.protege.editor.core.ui.menu.MenuBuilder.buildInnerMenu(MenuBuilder.java:159)
          org.protege.editor.core.ui.menu.MenuBuilder.addMenu(MenuBuilder.java:114)
          org.protege.editor.core.ui.menu.MenuBuilder.buildCompositeMenu(MenuBuilder.java:135)
          org.protege.editor.core.ui.menu.MenuBuilder.addMenu(MenuBuilder.java:106)
          org.protege.editor.core.ui.menu.MenuBuilder.buildMenu(MenuBuilder.java:64)
          org.protege.editor.core.ui.workspace.WorkspaceFrame.createMenuBar(WorkspaceFrame.java:165)
          org.protege.editor.core.ui.workspace.WorkspaceFrame.createUI(WorkspaceFrame.java:137)
          org.protege.editor.core.ui.workspace.WorkspaceFrame.<init>(WorkspaceFrame.java:55)
          org.protege.editor.core.ui.workspace.WorkspaceManager.addWorkspace(WorkspaceManager.java:47)
          org.protege.editor.core.editorkit.EditorKitManager.addEditorKit(EditorKitManager.java:44)
          org.protege.editor.core.ProtegeManager.createAndSetupNewEditorKit(ProtegeManager.java:139)
          org.protege.editor.core.ProtegeManager.createAndSetupNewEditorKit(ProtegeManager.java:129)
          org.protege.editor.core.ProtegeApplication.createAndSetupDefaultEditorKit(ProtegeApplication.java:488)
          org.protege.editor.core.ProtegeApplication.startApplication(ProtegeApplication.java:432)
          org.protege.editor.core.ProtegeApplication.reallyStart(ProtegeApplication.java:109)
          org.protege.editor.core.ProtegeApplication.lambda$start$11(ProtegeApplication.java:90)
          org.protege.editor.core.ProtegeApplication$$Lambda$24/1976931298.frameworkEvent(Unknown Source)
          org.apache.felix.framework.util.EventDispatcher.invokeFrameworkListenerCallback(EventDispatcher.java:836)
          org.apache.felix.framework.util.EventDispatcher.fireEventImmediately(EventDispatcher.java:786)
          org.apache.felix.framework.util.EventDispatcher.run(EventDispatcher.java:1099)
          org.apache.felix.framework.util.EventDispatcher.access$000(EventDispatcher.java:55)
          org.apache.felix.framework.util.EventDispatcher$1.run(EventDispatcher.java:102)
          java.lang.Thread.run(Thread.java:745)
    (Listeners should be removed in the plugin dispose method!)

An error was thrown: java.lang.UnsatisfiedLinkError: C:\Users\Evgueni\AppData\Local\Temp\ProtegeCache-e2b80694-f0ed-44e2-905b-9d993353402c\bundle36\version0.0\bundle.jar-lib\0\lib\native\64bit\FaCTPlusPlusJNI.dll: Can't find dependent libraries
org.semanticweb.owlapi.model.OWLRuntimeException: java.lang.UnsatisfiedLinkError: C:\Users\Evgueni\AppData\Local\Temp\ProtegeCache-e2b80694-f0ed-44e2-905b-9d993353402c\bundle36\version0.0\bundle.jar-lib\0\lib\native\64bit\FaCTPlusPlusJNI.dll: Can't find dependent libraries
        at uk.ac.manchester.cs.factplusplus.protege.FaCTPlusPlusFactory.getReasonerFactory(FaCTPlusPlusFactory.java:84) ~[na:na]
        at org.protege.editor.owl.model.inference.ReasonerInfoComparator.compare(ReasonerInfoComparator.java:9) ~[na:na]
        at org.protege.editor.owl.model.inference.ReasonerInfoComparator.compare(ReasonerInfoComparator.java:5) ~[na:na]
        at java.util.TimSort.countRunAndMakeAscending(TimSort.java:351) ~[na:1.8.0_40]
        at java.util.TimSort.sort(TimSort.java:216) ~[na:1.8.0_40]
        at java.util.Arrays.sort(Arrays.java:1512) ~[na:1.8.0_40]
        at java.util.ArrayList.sort(ArrayList.java:1454) ~[na:1.8.0_40]
        at java.util.Collections.sort(Collections.java:175) ~[na:1.8.0_40]
        at org.protege.editor.owl.model.OWLWorkspace.rebuildReasonerMenu(OWLWorkspace.java:565) ~[na:na]
        at org.protege.editor.owl.model.OWLWorkspace.initialiseExtraMenuItems(OWLWorkspace.java:431) ~[na:na]
        at org.protege.editor.core.ui.workspace.WorkspaceFrame.createUI(WorkspaceFrame.java:141) ~[protege-editor-core.jar:na]
        at org.protege.editor.core.ui.workspace.WorkspaceFrame.<init>(WorkspaceFrame.java:55) ~[protege-editor-core.jar:na]
        at org.protege.editor.core.ui.workspace.WorkspaceManager.addWorkspace(WorkspaceManager.java:47) ~[protege-editor-core.jar:na]
        at org.protege.editor.core.editorkit.EditorKitManager.addEditorKit(EditorKitManager.java:44) ~[protege-editor-core.jar:na]
        at org.protege.editor.core.ProtegeManager.createAndSetupNewEditorKit(ProtegeManager.java:139) ~[protege-editor-core.jar:na]
        at org.protege.editor.core.ProtegeManager.createAndSetupNewEditorKit(ProtegeManager.java:129) ~[protege-editor-core.jar:na]
        at org.protege.editor.core.ProtegeApplication.createAndSetupDefaultEditorKit(ProtegeApplication.java:488) [protege-editor-core.jar:na]
        at org.protege.editor.core.ProtegeApplication.startApplication(ProtegeApplication.java:432) [protege-editor-core.jar:na]
        at org.protege.editor.core.ProtegeApplication.reallyStart(ProtegeApplication.java:109) [protege-editor-core.jar:na]
        at org.protege.editor.core.ProtegeApplication.lambda$start$11(ProtegeApplication.java:90) [protege-editor-core.jar:na]
        at org.protege.editor.core.ProtegeApplication$$Lambda$24/1976931298.frameworkEvent(Unknown Source) [protege-editor-core.jar:na]
        at org.apache.felix.framework.util.EventDispatcher.invokeFrameworkListenerCallback(EventDispatcher.java:836) [org.apache.felix.main.jar:na]
        at org.apache.felix.framework.util.EventDispatcher.fireEventImmediately(EventDispatcher.java:786) [org.apache.felix.main.jar:na]
        at org.apache.felix.framework.util.EventDispatcher.run(EventDispatcher.java:1099) [org.apache.felix.main.jar:na]
        at org.apache.felix.framework.util.EventDispatcher.access$000(EventDispatcher.java:55) [org.apache.felix.main.jar:na]
        at org.apache.felix.framework.util.EventDispatcher$1.run(EventDispatcher.java:102) [org.apache.felix.main.jar:na]
        at java.lang.Thread.run(Thread.java:745) [na:1.8.0_40]
Caused by: java.lang.UnsatisfiedLinkError: C:\Users\Evgueni\AppData\Local\Temp\ProtegeCache-e2b80694-f0ed-44e2-905b-9d993353402c\bundle36\version0.0\bundle.jar-lib\0\lib\native\64bit\FaCTPlusPlusJNI.dll: Can't find dependent libraries
        at java.lang.ClassLoader$NativeLibrary.load(Native Method) ~[na:1.8.0_40]
        at java.lang.ClassLoader.loadLibrary0(ClassLoader.java:1937) ~[na:1.8.0_40]
        at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1835) ~[na:1.8.0_40]
        at java.lang.Runtime.loadLibrary0(Runtime.java:870) ~[na:1.8.0_40]
        at java.lang.System.loadLibrary(System.java:1122) ~[na:1.8.0_40]
        at uk.ac.manchester.cs.factplusplus.FaCTPlusPlus.<clinit>(FaCTPlusPlus.java:19) ~[na:na]
        at uk.ac.manchester.cs.factplusplus.protege.FaCTPlusPlusFactory.getReasonerFactory(FaCTPlusPlusFactory.java:75) ~[na:na]
        ... 26 common frames omitted


AT THIS POINT ANOTHER ERROR WINDOW POPS UP which is HUGE, so when I click OK
THIS IS THE LAST I SEE -- then Prorege dies -- the editor never opens.


------------------------------- Auto-update Check ------------------------------
Auto-update last performed: Mon Feb 27 17:08:38 EST 2017
Auto-update has been performed today.  Not performing it again.

 

THANK YOU so much for your help. It is trully appreciated.
Best regards, Neli

 

 

Neli P. Zlatareva, PhD
Professor of Computer Science
Department of Computer Science
Central Connecticut State University
New Britain, CT 06050
Phone: <a href="tel:(860)%20832-2723" value="+18608322723" target="_blank">(860) 832-2723
Fax: <a href="tel:(860)%20832-2712" value="+18608322712" target="_blank">(860) 832-2712
Web site: cs.ccsu.edu/~neli/


From: protege-user <[hidden email]> on behalf of Csongor Nyulas <[hidden email]>
Sent: Wednesday, February 22, 2017 2:59:44 AM
To: User support for WebProtege and Protege Desktop
Subject: Re: [protege-user] Problem running Protege 5.1 after updating Fact++

 

Dear Neli,

I am running Protege 5.1.1 with Fact++ 1.6.5 for a long time now, and I never experienced the things that you describe. So, in order to debug what's going on, we need to understand what is different on your machine compared to ours.

Here are a few questions that hopefully can help us elucidate the mystery:

What OS are you using?
What is the ".dat" file? Maybe you wanted to say ".bat" file (in which case you are probably using Windows)?
Are you by any chance using an virtual machine or some OS emulator?
In the [PROTEGE_INSTALL_DIR]/plugins folder how many files do you have that have the word "fact" in their names? If you have only a jar file, what is the exact name of that file, and how big is it?
If you search all the subfolders of [PROTEGE_INSTALL_DIR], how many ja files do you find that contain the name "fact" in it?
Can you send us the Protege logs?

Csongor

On 02/18/2017 08:00 AM, Zlatareva, Neli (Computer Science) wrote:


Hi,

I would greatly appreciate help with the following issue:

I have been working with Protégé 5.1 for some time and everything was great.

At the moment I decided to update to Fact++ 1.6.5 everything went wrong.

I could not open Protégé after restart (suggested to update Fact++). The error

I am getting is that MS C++ libraries are missing and after that the editor will not

open (I am running .dat file). I tried EVERYTHING -- deleting old versions, downloading

new ones, including JRE because I read somewhere about possible java corruption).

I am teaching Sem Web Tech class and very shortly my students will need Protégé

for their project. I am very worried that something like this can happen to them and

I have no clue how to help.

Any suggestions will be greatly appreciated.

THANK YOU SO MUCH! 

 

Neli P. Zlatareva, PhD
Professor of Computer Science
Department of Computer Science
Central Connecticut State University
New Britain, CT 06050
Phone: <a href="tel:(860)%20832-2723" value="+18608322723" target="_blank">(860) 832-2723
Fax: <a href="tel:(860)%20832-2712" value="+18608322712" target="_blank">(860) 832-2712
Web site: cs.ccsu.edu/~neli


 




_______________________________________________
protege-user mailing list
[hidden email]
https://mailman.stanford.edu/mailman/listinfo/protege-user

 


Virus-free. www.avast.com


_______________________________________________
protege-user mailing list
[hidden email]
https://mailman.stanford.edu/mailman/listinfo/protege-user


_______________________________________________
protege-user mailing list
[hidden email]
https://mailman.stanford.edu/mailman/listinfo/protege-user



_______________________________________________
protege-user mailing list
[hidden email]
https://mailman.stanford.edu/mailman/listinfo/protege-user
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Problem running Protege 5.1 after updating Fact++

zlatareva

Hi, just wanted to say that after completely getting rid of everything everywhere related to Fact++ 1.6.5 as Tania suggested (the link below), I am fine with Protégé’s newest versions but of course I do not even try to load Fact++, I work with Pellet.

Thank you.

Regards, Neli.

 

Neli P. Zlatareva, Ph.D

Professor of Computer Science

Central Connecticut State University,

1615 New Britain, CT 06050.

www.cs.ccsu.edu/~neli

 

From: protege-user [mailto:[hidden email]] On Behalf Of Yevgeny Kazakov
Sent: Tuesday, April 18, 2017 4:15 AM
To: User support for WebProtege and Protege Desktop <[hidden email]>
Subject: Re: [protege-user] Problem running Protege 5.1 after updating Fact++

 

I think these instructions helped Neli:

 

 

Yevgeny

 

On Tue, Apr 18, 2017 at 9:42 AM, Csongor Nyulas <[hidden email]> wrote:

Hi Bobbin,

I don't think we have had time to debug/solve this issue so far. It is not so easy to come by a Win 10 machine in our department. Protege 5.1.0 AND 5.2.0 seem to work fine with Fact++ 1.6.5 on Macs and Ubuntu machines.

I created an issue for this where we can follow up on it:
https://github.com/protegeproject/protege/issues/638

Do you (and/or Neli) encounter the same problem also with Protege 5.2.0 and Fact++ 1.6.5. on Win 10?

Csongor

 

On 04/17/2017 04:55 PM, Bobbin Teegarden wrote:

After updating to 5.2.0, I’m having the same problem as described by Neli below, but couldn’t find an answer in the mailing list.  Did I miss it?  What is the answer?  Thanks.

 

Bobbin Teegarden

CTO/Chief Architect, OntoAge

Technology Evangelist, No Magic

h/o <a href="tel:(425)%20378-0131" target="_blank">425.378.0131

cell <a href="tel:(206)%20979-0196" target="_blank">206.979.0196

[hidden email]

alt:  [hidden email]

 

From: protege-user [[hidden email]] On Behalf Of Zlatareva, Neli (Computer Science)
Sent: Monday, February 27, 2017 3:12 PM
To: User support for WebProtege and Protege Desktop [hidden email]
Subject: Re: [protege-user] Problem running Protege 5.1 after updating Fact++

 

Hi Csongor,

thank you so much for your reply -- I just found it buried in my mailbox.
To answer your questions. I run Windows 10 Home – no virtual machine or OS emulator.
As I said in my original call-for-help message, I have been working with Protégé 5.1.0 for some time with NO problems at all. The problem happened when I undated to Fact++ 1.6.5 (originally Protégé came with Fact++ 1.6.4). I use Pellet, but I wanted to check out the new Fact++, so I click update and after closing Protégé for the update to take place, I was never able to open it again. Just to note that I deleted old versions (including Protégé 5.0.0 -- Protege 5.0.0 gives me the same problem) downloaded new ones, same with jre, I tried the platform independent version, etc. – always the same “non-sense” result. So, here is the latest (today's) attempt to download and start Protégé (old downloads deleted).
You are asking about files with “fact” in their names – only one in the bin directory, called maven-artifact, which is a jar file 54 KB.

When I run .bat file this is what happens: (please note that I inserted in this log error messages as I am getting them)

 

C:\Program Files (x86)\Protege-5.1.0>setlocal

C:\Program Files (x86)\Protege-5.1.0>cd /d C:\Program Files (x86)\Protege-5.1.0\

C:\Program Files (x86)\Protege-5.1.0>jre\bin\java -Xmx500M -Xms200M -Xss16M -XX:CompileCommand=exclude,javax/swing/text/GlyphView,getBreakSpot -DentityExpansionLimit=100000000 -Dlogback.configurationFile=conf/logback-win.xml -Dfile.encoding=utf-8 -Dorg.protege.plugin.dir=plugins -classpath bundles/guava.jar;bundles/logback-classic.jar;bundles/logback-core.jar;bundles/slf4j-api.jar;bin/org.apache.felix.main.jar;bin/protege-launcher.jar org.protege.osgi.framework.Launcher
CompilerOracle: exclude javax/swing/text/GlyphView.getBreakSpot
********************************************************************************
**                                  Protege                                   **
********************************************************************************

----------------- Initialising and Starting the OSGi Framework -----------------
FrameworkFactory Class: org.apache.felix.framework.FrameworkFactory

The OSGi framework has been initialised
------------------------------- Starting Bundles -------------------------------
Starting bundle org.protege.common
Starting bundle org.eclipse.equinox.common
Starting bundle org.eclipse.equinox.supplement
Starting bundle org.eclipse.equinox.registry
Starting bundle org.protege.editor.core.application
Starting bundle org.apache.commons.io
Starting bundle com.google.guava
Not starting bundle com.google.inject.assistedinject explicitly because it is a fragment bundle.
Not starting bundle com.google.inject.multibindings explicitly because it is a fragment bundle.
Starting bundle com.google.inject
Starting bundle org.jsr-305
Starting bundle jul.to.slf4j
Starting bundle log4j.over.slf4j
Starting bundle ch.qos.logback.classic
Starting bundle ch.qos.logback.core
Starting bundle org.apache.servicemix.bundles.aopalliance
Starting bundle org.apache.servicemix.bundles.javax-inject
Starting bundle org.eclipse.equinox.common
Starting bundle org.eclipse.equinox.registry
Starting bundle org.eclipse.equinox.supplement
Starting bundle org.semanticweb.owl.owlapi
Starting bundle org.protege.common
Starting bundle org.protege.editor.core.application
Starting bundle org.protege.editor.owl
Starting bundle slf4j.api
Starting bundle cellfie
Starting bundle code-generation
Starting bundle existentialquery
Starting bundle uk.ac.manchester.cs.owl.explanation
Starting bundle org.protege.ontograf
Starting bundle org.coode.dlquery
Starting bundle org.semanticweb.hermit
Starting bundle org.coode.browser
Starting bundle org.coode.owlviz
Starting bundle org.protege.owl.rdf
Starting bundle org.protege.editor.owl.rdf
Starting bundle swrltab-plugin
Starting bundle com.clarkparsia.protege.plugin.pellet
Starting bundle org.exquisite.protege
Starting bundle org.semanticweb.elk
Starting bundle uk.ac.manchester.cs.owl.factplusplus
The OSGi framework has been started
------------------------------------ Protege -----------------------------------

Protege Desktop
Version 5.1.0, Build


----------------------------------- Platform -----------------------------------
Java: JVM 1.8.0_40-b26  Memory: 466M
Language: en, Country: US
Framework: Apache Software Foundation (1.7)
OS: windows8 (6.3)
Processor: x86-64


------------------------------------ Plugins -----------------------------------
Plugin: Cellfie Protege 5.0+ Plugin (2.1.0)
Plugin: OWL Code Generation Plug-in (2.0.0)
Plugin: Existential Query (2.0.0)
Plugin: Explanation Workbench (3.0.0)
Plugin: OntoGraf (2.0.3)
Plugin: DL Query (4.0.1)
Plugin: HermiT (1.3.8.413)
Plugin: Browser View (OWLDoc) (3.0.3)
Plugin: OWLViz (5.0.3)
Plugin: OWLAPI RDF Library (2.0.2)
Plugin: Protege SPARQL Plugin (2.0.1)
Plugin: SWRLTab Protege 5.0+ Plugin (1.0.3)
Plugin: Pellet Reasoner Plug-in (2.2.0)
Plugin: Ontology Debugger (0.1.2.BETA)
Plugin: ELK Reasoner Protege Plug-in (0.4.3)
Plugin: Factplusplus Plug-in (1.6.5)

Feb 27, 2017 5:35:50 PM java.util.prefs.WindowsPreferences <init>
WARNING: Could not open/create prefs root node Software\JavaSoft\Prefs at root 0x80000002. Windows RegCreateKeyEx(...) returned error code 5.
Creating and setting up empty (default) editor kit
OWL API Version: 4.2.6.20160910-2108
Loading default configuration parameters for class org.semanticweb.elk.reasoner.config.ReasonerConfiguration
Cannot generate ontology catalog for ontology at http://www.semanticweb.org/ioana/ontologies/2017/1/untitled-ontology-13
-------------------------- Generated Diagnosis Model ---------------------------
Ontology: OntologyID(OntologyIRI(<http://www.semanticweb.org/ioana/ontologies/2017/1/untitled-ontology-13>) VersionIRI(<null>))
Generated in 46 ms
0 Possibly Faulty Formulas
0 Correct Formulas
0 Entailed Examples
0 Not-Entailed Examples
--------------------------------------------------------------------------------

 

THE FOLLOWING ERROR WINDOW POPS UP AT THIS POINT:

MISSING LIBRARIES OR PLATFORM NOT SUPPPORTED
FACT++ REQUIRES PLATFORM SPECIFIC LIBRARIES
WHICH CANNOT BE FOUND

WHEN I CLICK OK THIS WINDOW CLOSES AND THE PROTEGE LOG CONTINUES AS FOLLOWS:

 


java:102)
          java.lang.Thread.run(Thread.java:745)
    (Listeners should be removed in the plugin dispose method!)
*** WARNING BADLY BEHAVING LISTENER: org.protege.editor.owl.ui.action.AbstractOntologySelectionStrategyAction$$Lambda$59/1677217031 ***
    Possible culprit (trace from when listener was added):
          org.protege.editor.owl.ui.action.AbstractOntologySelectionStrategyAction.initialise(AbstractOntologySelectionStrategyAction.java:47)
          org.protege.editor.owl.ui.action.ImportsClosureOntologyStrategyAction.initialise(ImportsClosureOntologyStrategyAction.java:27)
          org.protege.editor.core.ui.menu.MenuActionPluginJPFImpl.newInstance(MenuActionPluginJPFImpl.java:169)
          org.protege.editor.core.ui.menu.MenuActionPluginJPFImpl.newInstance(MenuActionPluginJPFImpl.java:31)
          org.protege.editor.core.ui.menu.MenuBuilder.buildInnerMenu(MenuBuilder.java:159)
          org.protege.editor.core.ui.menu.MenuBuilder.addMenu(MenuBuilder.java:114)
          org.protege.editor.core.ui.menu.MenuBuilder.buildCompositeMenu(MenuBuilder.java:135)
          org.protege.editor.core.ui.menu.MenuBuilder.addMenu(MenuBuilder.java:106)
          org.protege.editor.core.ui.menu.MenuBuilder.buildMenu(MenuBuilder.java:64)
          org.protege.editor.core.ui.workspace.WorkspaceFrame.createMenuBar(WorkspaceFrame.java:165)
          org.protege.editor.core.ui.workspace.WorkspaceFrame.createUI(WorkspaceFrame.java:137)
          org.protege.editor.core.ui.workspace.WorkspaceFrame.<init>(WorkspaceFrame.java:55)
          org.protege.editor.core.ui.workspace.WorkspaceManager.addWorkspace(WorkspaceManager.java:47)
          org.protege.editor.core.editorkit.EditorKitManager.addEditorKit(EditorKitManager.java:44)
          org.protege.editor.core.ProtegeManager.createAndSetupNewEditorKit(ProtegeManager.java:139)
          org.protege.editor.core.ProtegeManager.createAndSetupNewEditorKit(ProtegeManager.java:129)
          org.protege.editor.core.ProtegeApplication.createAndSetupDefaultEditorKit(ProtegeApplication.java:488)
          org.protege.editor.core.ProtegeApplication.startApplication(ProtegeApplication.java:432)
          org.protege.editor.core.ProtegeApplication.reallyStart(ProtegeApplication.java:109)
          org.protege.editor.core.ProtegeApplication.lambda$start$11(ProtegeApplication.java:90)
          org.protege.editor.core.ProtegeApplication$$Lambda$24/1976931298.frameworkEvent(Unknown Source)
          org.apache.felix.framework.util.EventDispatcher.invokeFrameworkListenerCallback(EventDispatcher.java:836)
          org.apache.felix.framework.util.EventDispatcher.fireEventImmediately(EventDispatcher.java:786)
          org.apache.felix.framework.util.EventDispatcher.run(EventDispatcher.java:1099)
          org.apache.felix.framework.util.EventDispatcher.access$000(EventDispatcher.java:55)
          org.apache.felix.framework.util.EventDispatcher$1.run(EventDispatcher.java:102)
          java.lang.Thread.run(Thread.java:745)
    (Listeners should be removed in the plugin dispose method!)
*** WARNING BADLY BEHAVING LISTENER: org.protege.editor.owl.ui.renderer.menu.AbstractByRendererMenu$$Lambda$57/436590799 ***
    Possible culprit (trace from when listener was added):
          org.protege.editor.owl.ui.renderer.menu.AbstractByRendererMenu.initialise(AbstractByRendererMenu.java:34)
          org.protege.editor.core.ui.menu.MenuActionPluginJPFImpl.newInstance(MenuActionPluginJPFImpl.java:169)
          org.protege.editor.core.ui.menu.MenuActionPluginJPFImpl.newInstance(MenuActionPluginJPFImpl.java:31)
          org.protege.editor.core.ui.menu.MenuBuilder.buildInnerMenu(MenuBuilder.java:159)
          org.protege.editor.core.ui.menu.MenuBuilder.addMenu(MenuBuilder.java:114)
          org.protege.editor.core.ui.menu.MenuBuilder.buildCompositeMenu(MenuBuilder.java:135)
          org.protege.editor.core.ui.menu.MenuBuilder.addMenu(MenuBuilder.java:106)
          org.protege.editor.core.ui.menu.MenuBuilder.buildMenu(MenuBuilder.java:64)
          org.protege.editor.core.ui.workspace.WorkspaceFrame.createMenuBar(WorkspaceFrame.java:165)
          org.protege.editor.core.ui.workspace.WorkspaceFrame.createUI(WorkspaceFrame.java:137)
          org.protege.editor.core.ui.workspace.WorkspaceFrame.<init>(WorkspaceFrame.java:55)
          org.protege.editor.core.ui.workspace.WorkspaceManager.addWorkspace(WorkspaceManager.java:47)
          org.protege.editor.core.editorkit.EditorKitManager.addEditorKit(EditorKitManager.java:44)
          org.protege.editor.core.ProtegeManager.createAndSetupNewEditorKit(ProtegeManager.java:139)
          org.protege.editor.core.ProtegeManager.createAndSetupNewEditorKit(ProtegeManager.java:129)
          org.protege.editor.core.ProtegeApplication.createAndSetupDefaultEditorKit(ProtegeApplication.java:488)
          org.protege.editor.core.ProtegeApplication.startApplication(ProtegeApplication.java:432)
          org.protege.editor.core.ProtegeApplication.reallyStart(ProtegeApplication.java:109)
          org.protege.editor.core.ProtegeApplication.lambda$start$11(ProtegeApplication.java:90)
          org.protege.editor.core.ProtegeApplication$$Lambda$24/1976931298.frameworkEvent(Unknown Source)
          org.apache.felix.framework.util.EventDispatcher.invokeFrameworkListenerCallback(EventDispatcher.java:836)
          org.apache.felix.framework.util.EventDispatcher.fireEventImmediately(EventDispatcher.java:786)
          org.apache.felix.framework.util.EventDispatcher.run(EventDispatcher.java:1099)
          org.apache.felix.framework.util.EventDispatcher.access$000(EventDispatcher.java:55)
          org.apache.felix.framework.util.EventDispatcher$1.run(EventDispatcher.java:102)
          java.lang.Thread.run(Thread.java:745)
    (Listeners should be removed in the plugin dispose method!)
*** WARNING BADLY BEHAVING LISTENER: org.protege.editor.owl.ui.renderer.menu.RenderByProperty$$Lambda$58/1386820222 ***
    Possible culprit (trace from when listener was added):
          org.protege.editor.owl.ui.renderer.menu.RenderByProperty.initialise(RenderByProperty.java:82)
          org.protege.editor.core.ui.menu.MenuActionPluginJPFImpl.newInstance(MenuActionPluginJPFImpl.java:169)
          org.protege.editor.core.ui.menu.MenuActionPluginJPFImpl.newInstance(MenuActionPluginJPFImpl.java:31)
          org.protege.editor.core.ui.menu.MenuBuilder.buildDynamicMenu(MenuBuilder.java:146)
          org.protege.editor.core.ui.menu.MenuBuilder.addMenu(MenuBuilder.java:110)
          org.protege.editor.core.ui.menu.MenuBuilder.buildCompositeMenu(MenuBuilder.java:135)
          org.protege.editor.core.ui.menu.MenuBuilder.addMenu(MenuBuilder.java:106)
          org.protege.editor.core.ui.menu.MenuBuilder.buildMenu(MenuBuilder.java:64)
          org.protege.editor.core.ui.workspace.WorkspaceFrame.createMenuBar(WorkspaceFrame.java:165)
          org.protege.editor.core.ui.workspace.WorkspaceFrame.createUI(WorkspaceFrame.java:137)
          org.protege.editor.core.ui.workspace.WorkspaceFrame.<init>(WorkspaceFrame.java:55)
          org.protege.editor.core.ui.workspace.WorkspaceManager.addWorkspace(WorkspaceManager.java:47)
          org.protege.editor.core.editorkit.EditorKitManager.addEditorKit(EditorKitManager.java:44)
          org.protege.editor.core.ProtegeManager.createAndSetupNewEditorKit(ProtegeManager.java:139)
          org.protege.editor.core.ProtegeManager.createAndSetupNewEditorKit(ProtegeManager.java:129)
          org.protege.editor.core.ProtegeApplication.createAndSetupDefaultEditorKit(ProtegeApplication.java:488)
          org.protege.editor.core.ProtegeApplication.startApplication(ProtegeApplication.java:432)
          org.protege.editor.core.ProtegeApplication.reallyStart(ProtegeApplication.java:109)
          org.protege.editor.core.ProtegeApplication.lambda$start$11(ProtegeApplication.java:90)
          org.protege.editor.core.ProtegeApplication$$Lambda$24/1976931298.frameworkEvent(Unknown Source)
          org.apache.felix.framework.util.EventDispatcher.invokeFrameworkListenerCallback(EventDispatcher.java:836)
          org.apache.felix.framework.util.EventDispatcher.fireEventImmediately(EventDispatcher.java:786)
          org.apache.felix.framework.util.EventDispatcher.run(EventDispatcher.java:1099)
          org.apache.felix.framework.util.EventDispatcher.access$000(EventDispatcher.java:55)
          org.apache.felix.framework.util.EventDispatcher$1.run(EventDispatcher.java:102)
          java.lang.Thread.run(Thread.java:745)
    (Listeners should be removed in the plugin dispose method!)
*** WARNING BADLY BEHAVING LISTENER: org.protege.editor.owl.ui.action.AbstractOntologySelectionStrategyAction$$Lambda$59/1677217031 ***
    Possible culprit (trace from when listener was added):
          org.protege.editor.owl.ui.action.AbstractOntologySelectionStrategyAction.initialise(AbstractOntologySelectionStrategyAction.java:47)
          org.protege.editor.core.ui.menu.MenuActionPluginJPFImpl.newInstance(MenuActionPluginJPFImpl.java:169)
          org.protege.editor.core.ui.menu.MenuActionPluginJPFImpl.newInstance(MenuActionPluginJPFImpl.java:31)
          org.protege.editor.core.ui.menu.MenuBuilder.buildInnerMenu(MenuBuilder.java:159)
          org.protege.editor.core.ui.menu.MenuBuilder.addMenu(MenuBuilder.java:114)
          org.protege.editor.core.ui.menu.MenuBuilder.buildCompositeMenu(MenuBuilder.java:135)
          org.protege.editor.core.ui.menu.MenuBuilder.addMenu(MenuBuilder.java:106)
          org.protege.editor.core.ui.menu.MenuBuilder.buildMenu(MenuBuilder.java:64)
          org.protege.editor.core.ui.workspace.WorkspaceFrame.createMenuBar(WorkspaceFrame.java:165)
          org.protege.editor.core.ui.workspace.WorkspaceFrame.createUI(WorkspaceFrame.java:137)
          org.protege.editor.core.ui.workspace.WorkspaceFrame.<init>(WorkspaceFrame.java:55)
          org.protege.editor.core.ui.workspace.WorkspaceManager.addWorkspace(WorkspaceManager.java:47)
          org.protege.editor.core.editorkit.EditorKitManager.addEditorKit(EditorKitManager.java:44)
          org.protege.editor.core.ProtegeManager.createAndSetupNewEditorKit(ProtegeManager.java:139)
          org.protege.editor.core.ProtegeManager.createAndSetupNewEditorKit(ProtegeManager.java:129)
          org.protege.editor.core.ProtegeApplication.createAndSetupDefaultEditorKit(ProtegeApplication.java:488)
          org.protege.editor.core.ProtegeApplication.startApplication(ProtegeApplication.java:432)
          org.protege.editor.core.ProtegeApplication.reallyStart(ProtegeApplication.java:109)
          org.protege.editor.core.ProtegeApplication.lambda$start$11(ProtegeApplication.java:90)
          org.protege.editor.core.ProtegeApplication$$Lambda$24/1976931298.frameworkEvent(Unknown Source)
          org.apache.felix.framework.util.EventDispatcher.invokeFrameworkListenerCallback(EventDispatcher.java:836)
          org.apache.felix.framework.util.EventDispatcher.fireEventImmediately(EventDispatcher.java:786)
          org.apache.felix.framework.util.EventDispatcher.run(EventDispatcher.java:1099)
          org.apache.felix.framework.util.EventDispatcher.access$000(EventDispatcher.java:55)
          org.apache.felix.framework.util.EventDispatcher$1.run(EventDispatcher.java:102)
          java.lang.Thread.run(Thread.java:745)
    (Listeners should be removed in the plugin dispose method!)

An error was thrown: java.lang.UnsatisfiedLinkError: C:\Users\Evgueni\AppData\Local\Temp\ProtegeCache-e2b80694-f0ed-44e2-905b-9d993353402c\bundle36\version0.0\bundle.jar-lib\0\lib\native\64bit\FaCTPlusPlusJNI.dll: Can't find dependent libraries
org.semanticweb.owlapi.model.OWLRuntimeException: java.lang.UnsatisfiedLinkError: C:\Users\Evgueni\AppData\Local\Temp\ProtegeCache-e2b80694-f0ed-44e2-905b-9d993353402c\bundle36\version0.0\bundle.jar-lib\0\lib\native\64bit\FaCTPlusPlusJNI.dll: Can't find dependent libraries
        at uk.ac.manchester.cs.factplusplus.protege.FaCTPlusPlusFactory.getReasonerFactory(FaCTPlusPlusFactory.java:84) ~[na:na]
        at org.protege.editor.owl.model.inference.ReasonerInfoComparator.compare(ReasonerInfoComparator.java:9) ~[na:na]
        at org.protege.editor.owl.model.inference.ReasonerInfoComparator.compare(ReasonerInfoComparator.java:5) ~[na:na]
        at java.util.TimSort.countRunAndMakeAscending(TimSort.java:351) ~[na:1.8.0_40]
        at java.util.TimSort.sort(TimSort.java:216) ~[na:1.8.0_40]
        at java.util.Arrays.sort(Arrays.java:1512) ~[na:1.8.0_40]
        at java.util.ArrayList.sort(ArrayList.java:1454) ~[na:1.8.0_40]
        at java.util.Collections.sort(Collections.java:175) ~[na:1.8.0_40]
        at org.protege.editor.owl.model.OWLWorkspace.rebuildReasonerMenu(OWLWorkspace.java:565) ~[na:na]
        at org.protege.editor.owl.model.OWLWorkspace.initialiseExtraMenuItems(OWLWorkspace.java:431) ~[na:na]
        at org.protege.editor.core.ui.workspace.WorkspaceFrame.createUI(WorkspaceFrame.java:141) ~[protege-editor-core.jar:na]
        at org.protege.editor.core.ui.workspace.WorkspaceFrame.<init>(WorkspaceFrame.java:55) ~[protege-editor-core.jar:na]
        at org.protege.editor.core.ui.workspace.WorkspaceManager.addWorkspace(WorkspaceManager.java:47) ~[protege-editor-core.jar:na]
        at org.protege.editor.core.editorkit.EditorKitManager.addEditorKit(EditorKitManager.java:44) ~[protege-editor-core.jar:na]
        at org.protege.editor.core.ProtegeManager.createAndSetupNewEditorKit(ProtegeManager.java:139) ~[protege-editor-core.jar:na]
        at org.protege.editor.core.ProtegeManager.createAndSetupNewEditorKit(ProtegeManager.java:129) ~[protege-editor-core.jar:na]
        at org.protege.editor.core.ProtegeApplication.createAndSetupDefaultEditorKit(ProtegeApplication.java:488) [protege-editor-core.jar:na]
        at org.protege.editor.core.ProtegeApplication.startApplication(ProtegeApplication.java:432) [protege-editor-core.jar:na]
        at org.protege.editor.core.ProtegeApplication.reallyStart(ProtegeApplication.java:109) [protege-editor-core.jar:na]
        at org.protege.editor.core.ProtegeApplication.lambda$start$11(ProtegeApplication.java:90) [protege-editor-core.jar:na]
        at org.protege.editor.core.ProtegeApplication$$Lambda$24/1976931298.frameworkEvent(Unknown Source) [protege-editor-core.jar:na]
        at org.apache.felix.framework.util.EventDispatcher.invokeFrameworkListenerCallback(EventDispatcher.java:836) [org.apache.felix.main.jar:na]
        at org.apache.felix.framework.util.EventDispatcher.fireEventImmediately(EventDispatcher.java:786) [org.apache.felix.main.jar:na]
        at org.apache.felix.framework.util.EventDispatcher.run(EventDispatcher.java:1099) [org.apache.felix.main.jar:na]
        at org.apache.felix.framework.util.EventDispatcher.access$000(EventDispatcher.java:55) [org.apache.felix.main.jar:na]
        at org.apache.felix.framework.util.EventDispatcher$1.run(EventDispatcher.java:102) [org.apache.felix.main.jar:na]
        at java.lang.Thread.run(Thread.java:745) [na:1.8.0_40]
Caused by: java.lang.UnsatisfiedLinkError: C:\Users\Evgueni\AppData\Local\Temp\ProtegeCache-e2b80694-f0ed-44e2-905b-9d993353402c\bundle36\version0.0\bundle.jar-lib\0\lib\native\64bit\FaCTPlusPlusJNI.dll: Can't find dependent libraries
        at java.lang.ClassLoader$NativeLibrary.load(Native Method) ~[na:1.8.0_40]
        at java.lang.ClassLoader.loadLibrary0(ClassLoader.java:1937) ~[na:1.8.0_40]
        at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1835) ~[na:1.8.0_40]
        at java.lang.Runtime.loadLibrary0(Runtime.java:870) ~[na:1.8.0_40]
        at java.lang.System.loadLibrary(System.java:1122) ~[na:1.8.0_40]
        at uk.ac.manchester.cs.factplusplus.FaCTPlusPlus.<clinit>(FaCTPlusPlus.java:19) ~[na:na]
        at uk.ac.manchester.cs.factplusplus.protege.FaCTPlusPlusFactory.getReasonerFactory(FaCTPlusPlusFactory.java:75) ~[na:na]
        ... 26 common frames omitted


AT THIS POINT ANOTHER ERROR WINDOW POPS UP which is HUGE, so when I click OK
THIS IS THE LAST I SEE -- then Prorege dies -- the editor never opens.


------------------------------- Auto-update Check ------------------------------
Auto-update last performed: Mon Feb 27 17:08:38 EST 2017
Auto-update has been performed today.  Not performing it again.

 

THANK YOU so much for your help. It is trully appreciated.
Best regards, Neli

 

 

Neli P. Zlatareva, PhD
Professor of Computer Science
Department of Computer Science
Central Connecticut State University
New Britain, CT 06050
Phone: <a href="tel:(860)%20832-2723" target="_blank">(860) 832-2723
Fax: <a href="tel:(860)%20832-2712" target="_blank">(860) 832-2712
Web site: cs.ccsu.edu/~neli/


From: protege-user <[hidden email]> on behalf of Csongor Nyulas <[hidden email]>
Sent: Wednesday, February 22, 2017 2:59:44 AM
To: User support for WebProtege and Protege Desktop
Subject: Re: [protege-user] Problem running Protege 5.1 after updating Fact++

 

Dear Neli,

I am running Protege 5.1.1 with Fact++ 1.6.5 for a long time now, and I never experienced the things that you describe. So, in order to debug what's going on, we need to understand what is different on your machine compared to ours.

Here are a few questions that hopefully can help us elucidate the mystery:

What OS are you using?
What is the ".dat" file? Maybe you wanted to say ".bat" file (in which case you are probably using Windows)?
Are you by any chance using an virtual machine or some OS emulator?
In the [PROTEGE_INSTALL_DIR]/plugins folder how many files do you have that have the word "fact" in their names? If you have only a jar file, what is the exact name of that file, and how big is it?
If you search all the subfolders of [PROTEGE_INSTALL_DIR], how many ja files do you find that contain the name "fact" in it?
Can you send us the Protege logs?

Csongor

On 02/18/2017 08:00 AM, Zlatareva, Neli (Computer Science) wrote:


Hi,

I would greatly appreciate help with the following issue:

I have been working with Protégé 5.1 for some time and everything was great.

At the moment I decided to update to Fact++ 1.6.5 everything went wrong.

I could not open Protégé after restart (suggested to update Fact++). The error

I am getting is that MS C++ libraries are missing and after that the editor will not

open (I am running .dat file). I tried EVERYTHING -- deleting old versions, downloading

new ones, including JRE because I read somewhere about possible java corruption).

I am teaching Sem Web Tech class and very shortly my students will need Protégé

for their project. I am very worried that something like this can happen to them and

I have no clue how to help.

Any suggestions will be greatly appreciated.

THANK YOU SO MUCH! 

 

Neli P. Zlatareva, PhD
Professor of Computer Science
Department of Computer Science
Central Connecticut State University
New Britain, CT 06050
Phone: <a href="tel:(860)%20832-2723" target="_blank">(860) 832-2723
Fax: <a href="tel:(860)%20832-2712" target="_blank">(860) 832-2712
Web site: cs.ccsu.edu/~neli


 



_______________________________________________
protege-user mailing list
[hidden email]
https://mailman.stanford.edu/mailman/listinfo/protege-user

 

 

Virus-free. www.avast.com

 

_______________________________________________
protege-user mailing list
[hidden email]
https://mailman.stanford.edu/mailman/listinfo/protege-user

 


_______________________________________________
protege-user mailing list
[hidden email]
https://mailman.stanford.edu/mailman/listinfo/protege-user

 


_______________________________________________
protege-user mailing list
[hidden email]
https://mailman.stanford.edu/mailman/listinfo/protege-user
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Problem running Protege 5.1 after updating Fact++

Bobbin Teegarden
In reply to this post by Csongor Nyulas

Hi Csongor,

 

I tired pulling the latest uk.ac.manchester.cs.owl.factplusplus.jar down from the bitbucket website, putting it in Plugins, and running Protégé 5.0.0 again, and got the same response:

“FaCT++ requires platform specific libraries which cannot be found. Supported platforms are OS X, Windows, and Linux.”

 

Then the OWL Runtime Exception:

“org.semanticweb.owlapi.model.OWLRuntimeException: java.lang.UnsatisfiedLinkError: C:\Users\bobbinteegarden\AppData\Local\Temp\ProtegeCache-a18b6e68-14b6-4b61-8bcb-5830192b79d3\bundle32\version0.0\bundle.jar-lib\0\lib\native\64bit\FaCTPlusPlusJNI.dll: Can't find dependent libraries

                at uk.ac.manchester.cs.factplusplus.protege.FaCTPlusPlusFactory.getReasonerFactory(FaCTPlusPlusFactory.java:84)

                at org.protege.editor.owl.model.inference.ReasonerInfoComparator.compare(ReasonerInfoComparator.java:9)

                at org.protege.editor.owl.model.inference.ReasonerInfoComparator.compare(ReasonerInfoComparator.java:5)

                at java.util.TimSort.binarySort(TimSort.java:292)

                at java.util.TimSort.sort(TimSort.java:217)

                at java.util.Arrays.sort(Arrays.java:1512)

                at java.util.ArrayList.sort(ArrayList.java:1454)

                at java.util.Collections.sort(Collections.java:175)

                at org.protege.editor.owl.model.OWLWorkspace.rebuildReasonerMenu(OWLWorkspace.java:558)

                at org.protege.editor.owl.model.OWLWorkspace.initialiseExtraMenuItems(OWLWorkspace.java:434)

                at org.protege.editor.core.ui.workspace.WorkspaceFrame.createUI(WorkspaceFrame.java:140)

                at org.protege.editor.core.ui.workspace.WorkspaceFrame.<init>(WorkspaceFrame.java:54)

                at org.protege.editor.core.ui.workspace.WorkspaceManager.addWorkspace(WorkspaceManager.java:47)

                at org.protege.editor.core.editorkit.EditorKitManager.addEditorKit(EditorKitManager.java:44)

                at org.protege.editor.core.ProtegeManager.createAndSetupNewEditorKit(ProtegeManager.java:139)

                at org.protege.editor.core.ProtegeManager.createAndSetupNewEditorKit(ProtegeManager.java:129)

                at org.protege.editor.core.ProtegeApplication.createAndSetupDefaultEditorKit(ProtegeApplication.java:470)

                at org.protege.editor.core.ProtegeApplication.startApplication(ProtegeApplication.java:414)

                at org.protege.editor.core.ProtegeApplication.reallyStart(ProtegeApplication.java:108)

                at org.protege.editor.core.ProtegeApplication.lambda$start$8(ProtegeApplication.java:89)

                at org.protege.editor.core.ProtegeApplication$$Lambda$24/96190402.frameworkEvent(Unknown Source)

                at org.apache.felix.framework.util.EventDispatcher.invokeFrameworkListenerCallback(EventDispatcher.java:836)

                at org.apache.felix.framework.util.EventDispatcher.fireEventImmediately(EventDispatcher.java:786)

                at org.apache.felix.framework.util.EventDispatcher.run(EventDispatcher.java:1099)

                at org.apache.felix.framework.util.EventDispatcher.access$000(EventDispatcher.java:55)

                at org.apache.felix.framework.util.EventDispatcher$1.run(EventDispatcher.java:102)

                at java.lang.Thread.run(Thread.java:745)

Caused by: java.lang.UnsatisfiedLinkError: C:\Users\bobbinteegarden\AppData\Local\Temp\ProtegeCache-a18b6e68-14b6-4b61-8bcb-5830192b79d3\bundle32\version0.0\bundle.jar-lib\0\lib\native\64bit\FaCTPlusPlusJNI.dll: Can't find dependent libraries

                at java.lang.ClassLoader$NativeLibrary.load(Native Method)

                at java.lang.ClassLoader.loadLibrary0(ClassLoader.java:1937)

                at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1835)”

… and it goes from there.

 

Protégé 4.3 still runs just fine on my system, but I need the later version of Protégé for FIBO work.  Last time I tried with 5.2.0 also, I got the same result.

I pulled the latest FACT++ from here, and I assume it’s the latest:  https://bitbucket.org/dtsarkov/factplusplus/downloads/ .

Thanks!

 

Bobbin Teegarden

CTO/Chief Architect, OntoAge

Technology Evangelist, No Magic

h/o 425.378.0131

cell 206.979.0196

[hidden email]

alt:  [hidden email]

 

From: protege-user [mailto:[hidden email]] On Behalf Of Csongor Nyulas
Sent: Tuesday, April 18, 2017 12:42 AM
To: User support for WebProtege and Protege Desktop <[hidden email]>
Subject: Re: [protege-user] Problem running Protege 5.1 after updating Fact++

 

Hi Bobbin,

I don't think we have had time to debug/solve this issue so far. It is not so easy to come by a Win 10 machine in our department. Protege 5.1.0 AND 5.2.0 seem to work fine with Fact++ 1.6.5 on Macs and Ubuntu machines.

I created an issue for this where we can follow up on it:
https://github.com/protegeproject/protege/issues/638

Do you (and/or Neli) encounter the same problem also with Protege 5.2.0 and Fact++ 1.6.5. on Win 10?

Csongor

On 04/17/2017 04:55 PM, Bobbin Teegarden wrote:

After updating to 5.2.0, I’m having the same problem as described by Neli below, but couldn’t find an answer in the mailing list.  Did I miss it?  What is the answer?  Thanks.

 

Bobbin Teegarden

CTO/Chief Architect, OntoAge

Technology Evangelist, No Magic

h/o 425.378.0131

cell 206.979.0196

[hidden email]

alt:  [hidden email]

 

From: protege-user [[hidden email]] On Behalf Of Zlatareva, Neli (Computer Science)
Sent: Monday, February 27, 2017 3:12 PM
To: User support for WebProtege and Protege Desktop [hidden email]
Subject: Re: [protege-user] Problem running Protege 5.1 after updating Fact++

 

Hi Csongor,

thank you so much for your reply -- I just found it buried in my mailbox.
To answer your questions. I run Windows 10 Home – no virtual machine or OS emulator.
As I said in my original call-for-help message, I have been working with Protégé 5.1.0 for some time with NO problems at all. The problem happened when I undated to Fact++ 1.6.5 (originally Protégé came with Fact++ 1.6.4). I use Pellet, but I wanted to check out the new Fact++, so I click update and after closing Protégé for the update to take place, I was never able to open it again. Just to note that I deleted old versions (including Protégé 5.0.0 -- Protege 5.0.0 gives me the same problem) downloaded new ones, same with jre, I tried the platform independent version, etc. – always the same “non-sense” result. So, here is the latest (today's) attempt to download and start Protégé (old downloads deleted).
You are asking about files with “fact” in their names – only one in the bin directory, called maven-artifact, which is a jar file 54 KB.

When I run .bat file this is what happens: (please note that I inserted in this log error messages as I am getting them)

 

C:\Program Files (x86)\Protege-5.1.0>setlocal

C:\Program Files (x86)\Protege-5.1.0>cd /d C:\Program Files (x86)\Protege-5.1.0\

C:\Program Files (x86)\Protege-5.1.0>jre\bin\java -Xmx500M -Xms200M -Xss16M -XX:CompileCommand=exclude,javax/swing/text/GlyphView,getBreakSpot -DentityExpansionLimit=100000000 -Dlogback.configurationFile=conf/logback-win.xml -Dfile.encoding=utf-8 -Dorg.protege.plugin.dir=plugins -classpath bundles/guava.jar;bundles/logback-classic.jar;bundles/logback-core.jar;bundles/slf4j-api.jar;bin/org.apache.felix.main.jar;bin/protege-launcher.jar org.protege.osgi.framework.Launcher
CompilerOracle: exclude javax/swing/text/GlyphView.getBreakSpot
********************************************************************************
**                                  Protege                                   **
********************************************************************************

----------------- Initialising and Starting the OSGi Framework -----------------
FrameworkFactory Class: org.apache.felix.framework.FrameworkFactory

The OSGi framework has been initialised
------------------------------- Starting Bundles -------------------------------
Starting bundle org.protege.common
Starting bundle org.eclipse.equinox.common
Starting bundle org.eclipse.equinox.supplement
Starting bundle org.eclipse.equinox.registry
Starting bundle org.protege.editor.core.application
Starting bundle org.apache.commons.io
Starting bundle com.google.guava
Not starting bundle com.google.inject.assistedinject explicitly because it is a fragment bundle.
Not starting bundle com.google.inject.multibindings explicitly because it is a fragment bundle.
Starting bundle com.google.inject
Starting bundle org.jsr-305
Starting bundle jul.to.slf4j
Starting bundle log4j.over.slf4j
Starting bundle ch.qos.logback.classic
Starting bundle ch.qos.logback.core
Starting bundle org.apache.servicemix.bundles.aopalliance
Starting bundle org.apache.servicemix.bundles.javax-inject
Starting bundle org.eclipse.equinox.common
Starting bundle org.eclipse.equinox.registry
Starting bundle org.eclipse.equinox.supplement
Starting bundle org.semanticweb.owl.owlapi
Starting bundle org.protege.common
Starting bundle org.protege.editor.core.application
Starting bundle org.protege.editor.owl
Starting bundle slf4j.api
Starting bundle cellfie
Starting bundle code-generation
Starting bundle existentialquery
Starting bundle uk.ac.manchester.cs.owl.explanation
Starting bundle org.protege.ontograf
Starting bundle org.coode.dlquery
Starting bundle org.semanticweb.hermit
Starting bundle org.coode.browser
Starting bundle org.coode.owlviz
Starting bundle org.protege.owl.rdf
Starting bundle org.protege.editor.owl.rdf
Starting bundle swrltab-plugin
Starting bundle com.clarkparsia.protege.plugin.pellet
Starting bundle org.exquisite.protege
Starting bundle org.semanticweb.elk
Starting bundle uk.ac.manchester.cs.owl.factplusplus
The OSGi framework has been started
------------------------------------ Protege -----------------------------------

Protege Desktop
Version 5.1.0, Build


----------------------------------- Platform -----------------------------------
Java: JVM 1.8.0_40-b26  Memory: 466M
Language: en, Country: US
Framework: Apache Software Foundation (1.7)
OS: windows8 (6.3)
Processor: x86-64


------------------------------------ Plugins -----------------------------------
Plugin: Cellfie Protege 5.0+ Plugin (2.1.0)
Plugin: OWL Code Generation Plug-in (2.0.0)
Plugin: Existential Query (2.0.0)
Plugin: Explanation Workbench (3.0.0)
Plugin: OntoGraf (2.0.3)
Plugin: DL Query (4.0.1)
Plugin: HermiT (1.3.8.413)
Plugin: Browser View (OWLDoc) (3.0.3)
Plugin: OWLViz (5.0.3)
Plugin: OWLAPI RDF Library (2.0.2)
Plugin: Protege SPARQL Plugin (2.0.1)
Plugin: SWRLTab Protege 5.0+ Plugin (1.0.3)
Plugin: Pellet Reasoner Plug-in (2.2.0)
Plugin: Ontology Debugger (0.1.2.BETA)
Plugin: ELK Reasoner Protege Plug-in (0.4.3)
Plugin: Factplusplus Plug-in (1.6.5)

Feb 27, 2017 5:35:50 PM java.util.prefs.WindowsPreferences <init>
WARNING: Could not open/create prefs root node Software\JavaSoft\Prefs at root 0x80000002. Windows RegCreateKeyEx(...) returned error code 5.
Creating and setting up empty (default) editor kit
OWL API Version: 4.2.6.20160910-2108
Loading default configuration parameters for class org.semanticweb.elk.reasoner.config.ReasonerConfiguration
Cannot generate ontology catalog for ontology at http://www.semanticweb.org/ioana/ontologies/2017/1/untitled-ontology-13
-------------------------- Generated Diagnosis Model ---------------------------
Ontology: OntologyID(OntologyIRI(<http://www.semanticweb.org/ioana/ontologies/2017/1/untitled-ontology-13>) VersionIRI(<null>))
Generated in 46 ms
0 Possibly Faulty Formulas
0 Correct Formulas
0 Entailed Examples
0 Not-Entailed Examples
--------------------------------------------------------------------------------

 

THE FOLLOWING ERROR WINDOW POPS UP AT THIS POINT:

MISSING LIBRARIES OR PLATFORM NOT SUPPPORTED
FACT++ REQUIRES PLATFORM SPECIFIC LIBRARIES
WHICH CANNOT BE FOUND

WHEN I CLICK OK THIS WINDOW CLOSES AND THE PROTEGE LOG CONTINUES AS FOLLOWS:

 


java:102)
          java.lang.Thread.run(Thread.java:745)
    (Listeners should be removed in the plugin dispose method!)
*** WARNING BADLY BEHAVING LISTENER: org.protege.editor.owl.ui.action.AbstractOntologySelectionStrategyAction$$Lambda$59/1677217031 ***
    Possible culprit (trace from when listener was added):
          org.protege.editor.owl.ui.action.AbstractOntologySelectionStrategyAction.initialise(AbstractOntologySelectionStrategyAction.java:47)
          org.protege.editor.owl.ui.action.ImportsClosureOntologyStrategyAction.initialise(ImportsClosureOntologyStrategyAction.java:27)
          org.protege.editor.core.ui.menu.MenuActionPluginJPFImpl.newInstance(MenuActionPluginJPFImpl.java:169)
          org.protege.editor.core.ui.menu.MenuActionPluginJPFImpl.newInstance(MenuActionPluginJPFImpl.java:31)
          org.protege.editor.core.ui.menu.MenuBuilder.buildInnerMenu(MenuBuilder.java:159)
          org.protege.editor.core.ui.menu.MenuBuilder.addMenu(MenuBuilder.java:114)
          org.protege.editor.core.ui.menu.MenuBuilder.buildCompositeMenu(MenuBuilder.java:135)
          org.protege.editor.core.ui.menu.MenuBuilder.addMenu(MenuBuilder.java:106)
          org.protege.editor.core.ui.menu.MenuBuilder.buildMenu(MenuBuilder.java:64)
          org.protege.editor.core.ui.workspace.WorkspaceFrame.createMenuBar(WorkspaceFrame.java:165)
          org.protege.editor.core.ui.workspace.WorkspaceFrame.createUI(WorkspaceFrame.java:137)
          org.protege.editor.core.ui.workspace.WorkspaceFrame.<init>(WorkspaceFrame.java:55)
          org.protege.editor.core.ui.workspace.WorkspaceManager.addWorkspace(WorkspaceManager.java:47)
          org.protege.editor.core.editorkit.EditorKitManager.addEditorKit(EditorKitManager.java:44)
          org.protege.editor.core.ProtegeManager.createAndSetupNewEditorKit(ProtegeManager.java:139)
          org.protege.editor.core.ProtegeManager.createAndSetupNewEditorKit(ProtegeManager.java:129)
          org.protege.editor.core.ProtegeApplication.createAndSetupDefaultEditorKit(ProtegeApplication.java:488)
          org.protege.editor.core.ProtegeApplication.startApplication(ProtegeApplication.java:432)
          org.protege.editor.core.ProtegeApplication.reallyStart(ProtegeApplication.java:109)
          org.protege.editor.core.ProtegeApplication.lambda$start$11(ProtegeApplication.java:90)
          org.protege.editor.core.ProtegeApplication$$Lambda$24/1976931298.frameworkEvent(Unknown Source)
          org.apache.felix.framework.util.EventDispatcher.invokeFrameworkListenerCallback(EventDispatcher.java:836)
          org.apache.felix.framework.util.EventDispatcher.fireEventImmediately(EventDispatcher.java:786)
          org.apache.felix.framework.util.EventDispatcher.run(EventDispatcher.java:1099)
          org.apache.felix.framework.util.EventDispatcher.access$000(EventDispatcher.java:55)
          org.apache.felix.framework.util.EventDispatcher$1.run(EventDispatcher.java:102)
          java.lang.Thread.run(Thread.java:745)
    (Listeners should be removed in the plugin dispose method!)
*** WARNING BADLY BEHAVING LISTENER: org.protege.editor.owl.ui.renderer.menu.AbstractByRendererMenu$$Lambda$57/436590799 ***
    Possible culprit (trace from when listener was added):
          org.protege.editor.owl.ui.renderer.menu.AbstractByRendererMenu.initialise(AbstractByRendererMenu.java:34)
          org.protege.editor.core.ui.menu.MenuActionPluginJPFImpl.newInstance(MenuActionPluginJPFImpl.java:169)
          org.protege.editor.core.ui.menu.MenuActionPluginJPFImpl.newInstance(MenuActionPluginJPFImpl.java:31)
          org.protege.editor.core.ui.menu.MenuBuilder.buildInnerMenu(MenuBuilder.java:159)
          org.protege.editor.core.ui.menu.MenuBuilder.addMenu(MenuBuilder.java:114)
          org.protege.editor.core.ui.menu.MenuBuilder.buildCompositeMenu(MenuBuilder.java:135)
          org.protege.editor.core.ui.menu.MenuBuilder.addMenu(MenuBuilder.java:106)
          org.protege.editor.core.ui.menu.MenuBuilder.buildMenu(MenuBuilder.java:64)
          org.protege.editor.core.ui.workspace.WorkspaceFrame.createMenuBar(WorkspaceFrame.java:165)
          org.protege.editor.core.ui.workspace.WorkspaceFrame.createUI(WorkspaceFrame.java:137)
          org.protege.editor.core.ui.workspace.WorkspaceFrame.<init>(WorkspaceFrame.java:55)
          org.protege.editor.core.ui.workspace.WorkspaceManager.addWorkspace(WorkspaceManager.java:47)
          org.protege.editor.core.editorkit.EditorKitManager.addEditorKit(EditorKitManager.java:44)
          org.protege.editor.core.ProtegeManager.createAndSetupNewEditorKit(ProtegeManager.java:139)
          org.protege.editor.core.ProtegeManager.createAndSetupNewEditorKit(ProtegeManager.java:129)
          org.protege.editor.core.ProtegeApplication.createAndSetupDefaultEditorKit(ProtegeApplication.java:488)
          org.protege.editor.core.ProtegeApplication.startApplication(ProtegeApplication.java:432)
          org.protege.editor.core.ProtegeApplication.reallyStart(ProtegeApplication.java:109)
          org.protege.editor.core.ProtegeApplication.lambda$start$11(ProtegeApplication.java:90)
          org.protege.editor.core.ProtegeApplication$$Lambda$24/1976931298.frameworkEvent(Unknown Source)
          org.apache.felix.framework.util.EventDispatcher.invokeFrameworkListenerCallback(EventDispatcher.java:836)
          org.apache.felix.framework.util.EventDispatcher.fireEventImmediately(EventDispatcher.java:786)
          org.apache.felix.framework.util.EventDispatcher.run(EventDispatcher.java:1099)
          org.apache.felix.framework.util.EventDispatcher.access$000(EventDispatcher.java:55)
          org.apache.felix.framework.util.EventDispatcher$1.run(EventDispatcher.java:102)
          java.lang.Thread.run(Thread.java:745)
    (Listeners should be removed in the plugin dispose method!)
*** WARNING BADLY BEHAVING LISTENER: org.protege.editor.owl.ui.renderer.menu.RenderByProperty$$Lambda$58/1386820222 ***
    Possible culprit (trace from when listener was added):
          org.protege.editor.owl.ui.renderer.menu.RenderByProperty.initialise(RenderByProperty.java:82)
          org.protege.editor.core.ui.menu.MenuActionPluginJPFImpl.newInstance(MenuActionPluginJPFImpl.java:169)
          org.protege.editor.core.ui.menu.MenuActionPluginJPFImpl.newInstance(MenuActionPluginJPFImpl.java:31)
          org.protege.editor.core.ui.menu.MenuBuilder.buildDynamicMenu(MenuBuilder.java:146)
          org.protege.editor.core.ui.menu.MenuBuilder.addMenu(MenuBuilder.java:110)
          org.protege.editor.core.ui.menu.MenuBuilder.buildCompositeMenu(MenuBuilder.java:135)
          org.protege.editor.core.ui.menu.MenuBuilder.addMenu(MenuBuilder.java:106)
          org.protege.editor.core.ui.menu.MenuBuilder.buildMenu(MenuBuilder.java:64)
          org.protege.editor.core.ui.workspace.WorkspaceFrame.createMenuBar(WorkspaceFrame.java:165)
          org.protege.editor.core.ui.workspace.WorkspaceFrame.createUI(WorkspaceFrame.java:137)
          org.protege.editor.core.ui.workspace.WorkspaceFrame.<init>(WorkspaceFrame.java:55)
          org.protege.editor.core.ui.workspace.WorkspaceManager.addWorkspace(WorkspaceManager.java:47)
          org.protege.editor.core.editorkit.EditorKitManager.addEditorKit(EditorKitManager.java:44)
          org.protege.editor.core.ProtegeManager.createAndSetupNewEditorKit(ProtegeManager.java:139)
          org.protege.editor.core.ProtegeManager.createAndSetupNewEditorKit(ProtegeManager.java:129)
          org.protege.editor.core.ProtegeApplication.createAndSetupDefaultEditorKit(ProtegeApplication.java:488)
          org.protege.editor.core.ProtegeApplication.startApplication(ProtegeApplication.java:432)
          org.protege.editor.core.ProtegeApplication.reallyStart(ProtegeApplication.java:109)
          org.protege.editor.core.ProtegeApplication.lambda$start$11(ProtegeApplication.java:90)
          org.protege.editor.core.ProtegeApplication$$Lambda$24/1976931298.frameworkEvent(Unknown Source)
          org.apache.felix.framework.util.EventDispatcher.invokeFrameworkListenerCallback(EventDispatcher.java:836)
          org.apache.felix.framework.util.EventDispatcher.fireEventImmediately(EventDispatcher.java:786)
          org.apache.felix.framework.util.EventDispatcher.run(EventDispatcher.java:1099)
          org.apache.felix.framework.util.EventDispatcher.access$000(EventDispatcher.java:55)
          org.apache.felix.framework.util.EventDispatcher$1.run(EventDispatcher.java:102)
          java.lang.Thread.run(Thread.java:745)
    (Listeners should be removed in the plugin dispose method!)
*** WARNING BADLY BEHAVING LISTENER: org.protege.editor.owl.ui.action.AbstractOntologySelectionStrategyAction$$Lambda$59/1677217031 ***
    Possible culprit (trace from when listener was added):
          org.protege.editor.owl.ui.action.AbstractOntologySelectionStrategyAction.initialise(AbstractOntologySelectionStrategyAction.java:47)
          org.protege.editor.core.ui.menu.MenuActionPluginJPFImpl.newInstance(MenuActionPluginJPFImpl.java:169)
          org.protege.editor.core.ui.menu.MenuActionPluginJPFImpl.newInstance(MenuActionPluginJPFImpl.java:31)
          org.protege.editor.core.ui.menu.MenuBuilder.buildInnerMenu(MenuBuilder.java:159)
          org.protege.editor.core.ui.menu.MenuBuilder.addMenu(MenuBuilder.java:114)
          org.protege.editor.core.ui.menu.MenuBuilder.buildCompositeMenu(MenuBuilder.java:135)
          org.protege.editor.core.ui.menu.MenuBuilder.addMenu(MenuBuilder.java:106)
          org.protege.editor.core.ui.menu.MenuBuilder.buildMenu(MenuBuilder.java:64)
          org.protege.editor.core.ui.workspace.WorkspaceFrame.createMenuBar(WorkspaceFrame.java:165)
          org.protege.editor.core.ui.workspace.WorkspaceFrame.createUI(WorkspaceFrame.java:137)
          org.protege.editor.core.ui.workspace.WorkspaceFrame.<init>(WorkspaceFrame.java:55)
          org.protege.editor.core.ui.workspace.WorkspaceManager.addWorkspace(WorkspaceManager.java:47)
          org.protege.editor.core.editorkit.EditorKitManager.addEditorKit(EditorKitManager.java:44)
          org.protege.editor.core.ProtegeManager.createAndSetupNewEditorKit(ProtegeManager.java:139)
          org.protege.editor.core.ProtegeManager.createAndSetupNewEditorKit(ProtegeManager.java:129)
          org.protege.editor.core.ProtegeApplication.createAndSetupDefaultEditorKit(ProtegeApplication.java:488)
          org.protege.editor.core.ProtegeApplication.startApplication(ProtegeApplication.java:432)
          org.protege.editor.core.ProtegeApplication.reallyStart(ProtegeApplication.java:109)
          org.protege.editor.core.ProtegeApplication.lambda$start$11(ProtegeApplication.java:90)
          org.protege.editor.core.ProtegeApplication$$Lambda$24/1976931298.frameworkEvent(Unknown Source)
          org.apache.felix.framework.util.EventDispatcher.invokeFrameworkListenerCallback(EventDispatcher.java:836)
          org.apache.felix.framework.util.EventDispatcher.fireEventImmediately(EventDispatcher.java:786)
          org.apache.felix.framework.util.EventDispatcher.run(EventDispatcher.java:1099)
          org.apache.felix.framework.util.EventDispatcher.access$000(EventDispatcher.java:55)
          org.apache.felix.framework.util.EventDispatcher$1.run(EventDispatcher.java:102)
          java.lang.Thread.run(Thread.java:745)
    (Listeners should be removed in the plugin dispose method!)

An error was thrown: java.lang.UnsatisfiedLinkError: C:\Users\Evgueni\AppData\Local\Temp\ProtegeCache-e2b80694-f0ed-44e2-905b-9d993353402c\bundle36\version0.0\bundle.jar-lib\0\lib\native\64bit\FaCTPlusPlusJNI.dll: Can't find dependent libraries
org.semanticweb.owlapi.model.OWLRuntimeException: java.lang.UnsatisfiedLinkError: C:\Users\Evgueni\AppData\Local\Temp\ProtegeCache-e2b80694-f0ed-44e2-905b-9d993353402c\bundle36\version0.0\bundle.jar-lib\0\lib\native\64bit\FaCTPlusPlusJNI.dll: Can't find dependent libraries
        at uk.ac.manchester.cs.factplusplus.protege.FaCTPlusPlusFactory.getReasonerFactory(FaCTPlusPlusFactory.java:84) ~[na:na]
        at org.protege.editor.owl.model.inference.ReasonerInfoComparator.compare(ReasonerInfoComparator.java:9) ~[na:na]
        at org.protege.editor.owl.model.inference.ReasonerInfoComparator.compare(ReasonerInfoComparator.java:5) ~[na:na]
        at java.util.TimSort.countRunAndMakeAscending(TimSort.java:351) ~[na:1.8.0_40]
        at java.util.TimSort.sort(TimSort.java:216) ~[na:1.8.0_40]
        at java.util.Arrays.sort(Arrays.java:1512) ~[na:1.8.0_40]
        at java.util.ArrayList.sort(ArrayList.java:1454) ~[na:1.8.0_40]
        at java.util.Collections.sort(Collections.java:175) ~[na:1.8.0_40]
        at org.protege.editor.owl.model.OWLWorkspace.rebuildReasonerMenu(OWLWorkspace.java:565) ~[na:na]
        at org.protege.editor.owl.model.OWLWorkspace.initialiseExtraMenuItems(OWLWorkspace.java:431) ~[na:na]
        at org.protege.editor.core.ui.workspace.WorkspaceFrame.createUI(WorkspaceFrame.java:141) ~[protege-editor-core.jar:na]
        at org.protege.editor.core.ui.workspace.WorkspaceFrame.<init>(WorkspaceFrame.java:55) ~[protege-editor-core.jar:na]
        at org.protege.editor.core.ui.workspace.WorkspaceManager.addWorkspace(WorkspaceManager.java:47) ~[protege-editor-core.jar:na]
        at org.protege.editor.core.editorkit.EditorKitManager.addEditorKit(EditorKitManager.java:44) ~[protege-editor-core.jar:na]
        at org.protege.editor.core.ProtegeManager.createAndSetupNewEditorKit(ProtegeManager.java:139) ~[protege-editor-core.jar:na]
        at org.protege.editor.core.ProtegeManager.createAndSetupNewEditorKit(ProtegeManager.java:129) ~[protege-editor-core.jar:na]
        at org.protege.editor.core.ProtegeApplication.createAndSetupDefaultEditorKit(ProtegeApplication.java:488) [protege-editor-core.jar:na]
        at org.protege.editor.core.ProtegeApplication.startApplication(ProtegeApplication.java:432) [protege-editor-core.jar:na]
        at org.protege.editor.core.ProtegeApplication.reallyStart(ProtegeApplication.java:109) [protege-editor-core.jar:na]
        at org.protege.editor.core.ProtegeApplication.lambda$start$11(ProtegeApplication.java:90) [protege-editor-core.jar:na]
        at org.protege.editor.core.ProtegeApplication$$Lambda$24/1976931298.frameworkEvent(Unknown Source) [protege-editor-core.jar:na]
        at org.apache.felix.framework.util.EventDispatcher.invokeFrameworkListenerCallback(EventDispatcher.java:836) [org.apache.felix.main.jar:na]
        at org.apache.felix.framework.util.EventDispatcher.fireEventImmediately(EventDispatcher.java:786) [org.apache.felix.main.jar:na]
        at org.apache.felix.framework.util.EventDispatcher.run(EventDispatcher.java:1099) [org.apache.felix.main.jar:na]
        at org.apache.felix.framework.util.EventDispatcher.access$000(EventDispatcher.java:55) [org.apache.felix.main.jar:na]
        at org.apache.felix.framework.util.EventDispatcher$1.run(EventDispatcher.java:102) [org.apache.felix.main.jar:na]
        at java.lang.Thread.run(Thread.java:745) [na:1.8.0_40]
Caused by: java.lang.UnsatisfiedLinkError: C:\Users\Evgueni\AppData\Local\Temp\ProtegeCache-e2b80694-f0ed-44e2-905b-9d993353402c\bundle36\version0.0\bundle.jar-lib\0\lib\native\64bit\FaCTPlusPlusJNI.dll: Can't find dependent libraries
        at java.lang.ClassLoader$NativeLibrary.load(Native Method) ~[na:1.8.0_40]
        at java.lang.ClassLoader.loadLibrary0(ClassLoader.java:1937) ~[na:1.8.0_40]
        at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1835) ~[na:1.8.0_40]
        at java.lang.Runtime.loadLibrary0(Runtime.java:870) ~[na:1.8.0_40]
        at java.lang.System.loadLibrary(System.java:1122) ~[na:1.8.0_40]
        at uk.ac.manchester.cs.factplusplus.FaCTPlusPlus.<clinit>(FaCTPlusPlus.java:19) ~[na:na]
        at uk.ac.manchester.cs.factplusplus.protege.FaCTPlusPlusFactory.getReasonerFactory(FaCTPlusPlusFactory.java:75) ~[na:na]
        ... 26 common frames omitted


AT THIS POINT ANOTHER ERROR WINDOW POPS UP which is HUGE, so when I click OK
THIS IS THE LAST I SEE -- then Prorege dies -- the editor never opens.


------------------------------- Auto-update Check ------------------------------
Auto-update last performed: Mon Feb 27 17:08:38 EST 2017
Auto-update has been performed today.  Not performing it again.

 

THANK YOU so much for your help. It is trully appreciated.
Best regards, Neli

 

 

Neli P. Zlatareva, PhD
Professor of Computer Science
Department of Computer Science
Central Connecticut State University
New Britain, CT 06050
Phone: (860) 832-2723
Fax: (860) 832-2712
Web site: cs.ccsu.edu/~neli/


From: protege-user <[hidden email]> on behalf of Csongor Nyulas <[hidden email]>
Sent: Wednesday, February 22, 2017 2:59:44 AM
To: User support for WebProtege and Protege Desktop
Subject: Re: [protege-user] Problem running Protege 5.1 after updating Fact++

 

Dear Neli,

I am running Protege 5.1.1 with Fact++ 1.6.5 for a long time now, and I never experienced the things that you describe. So, in order to debug what's going on, we need to understand what is different on your machine compared to ours.

Here are a few questions that hopefully can help us elucidate the mystery:

What OS are you using?
What is the ".dat" file? Maybe you wanted to say ".bat" file (in which case you are probably using Windows)?
Are you by any chance using an virtual machine or some OS emulator?
In the [PROTEGE_INSTALL_DIR]/plugins folder how many files do you have that have the word "fact" in their names? If you have only a jar file, what is the exact name of that file, and how big is it?
If you search all the subfolders of [PROTEGE_INSTALL_DIR], how many ja files do you find that contain the name "fact" in it?
Can you send us the Protege logs?

Csongor


On 02/18/2017 08:00 AM, Zlatareva, Neli (Computer Science) wrote:


Hi,

I would greatly appreciate help with the following issue:

I have been working with Protégé 5.1 for some time and everything was great.

At the moment I decided to update to Fact++ 1.6.5 everything went wrong.

I could not open Protégé after restart (suggested to update Fact++). The error

I am getting is that MS C++ libraries are missing and after that the editor will not

open (I am running .dat file). I tried EVERYTHING -- deleting old versions, downloading

new ones, including JRE because I read somewhere about possible java corruption).

I am teaching Sem Web Tech class and very shortly my students will need Protégé

for their project. I am very worried that something like this can happen to them and

I have no clue how to help.

Any suggestions will be greatly appreciated.

THANK YOU SO MUCH! 

 

Neli P. Zlatareva, PhD
Professor of Computer Science
Department of Computer Science
Central Connecticut State University
New Britain, CT 06050
Phone: (860) 832-2723
Fax: (860) 832-2712
Web site: cs.ccsu.edu/~neli


 





_______________________________________________
protege-user mailing list
[hidden email]
https://mailman.stanford.edu/mailman/listinfo/protege-user

 

 

Virus-free. www.avast.com




_______________________________________________
protege-user mailing list
[hidden email]
https://mailman.stanford.edu/mailman/listinfo/protege-user

 


Virus-free. www.avast.com

_______________________________________________
protege-user mailing list
[hidden email]
https://mailman.stanford.edu/mailman/listinfo/protege-user
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Problem running Protege 5.1 after updating Fact++

Csongor Nyulas
Administrator
Try using the auto-update mechanism in Protege 5.2 (Files --> Check for plugins...) to get the latest version of Fact++ 1.6.5 (Important: make sure to remove Fact++ from the plugins directory first). That should work.
Protege 5.1 and earlier does not seem to work with this latest version of Fact++, at least on certain operating systems.

Csongor


On 04/18/2017 02:33 PM, Bobbin Teegarden wrote:

Hi Csongor,

 

I tired pulling the latest uk.ac.manchester.cs.owl.factplusplus.jar down from the bitbucket website, putting it in Plugins, and running Protégé 5.0.0 again, and got the same response:

“FaCT++ requires platform specific libraries which cannot be found. Supported platforms are OS X, Windows, and Linux.”

 

Then the OWL Runtime Exception:

“org.semanticweb.owlapi.model.OWLRuntimeException: java.lang.UnsatisfiedLinkError: C:\Users\bobbinteegarden\AppData\Local\Temp\ProtegeCache-a18b6e68-14b6-4b61-8bcb-5830192b79d3\bundle32\version0.0\bundle.jar-lib\0\lib\native\64bit\FaCTPlusPlusJNI.dll: Can't find dependent libraries

                at uk.ac.manchester.cs.factplusplus.protege.FaCTPlusPlusFactory.getReasonerFactory(FaCTPlusPlusFactory.java:84)

                at org.protege.editor.owl.model.inference.ReasonerInfoComparator.compare(ReasonerInfoComparator.java:9)

                at org.protege.editor.owl.model.inference.ReasonerInfoComparator.compare(ReasonerInfoComparator.java:5)

                at java.util.TimSort.binarySort(TimSort.java:292)

                at java.util.TimSort.sort(TimSort.java:217)

                at java.util.Arrays.sort(Arrays.java:1512)

                at java.util.ArrayList.sort(ArrayList.java:1454)

                at java.util.Collections.sort(Collections.java:175)

                at org.protege.editor.owl.model.OWLWorkspace.rebuildReasonerMenu(OWLWorkspace.java:558)

                at org.protege.editor.owl.model.OWLWorkspace.initialiseExtraMenuItems(OWLWorkspace.java:434)

                at org.protege.editor.core.ui.workspace.WorkspaceFrame.createUI(WorkspaceFrame.java:140)

                at org.protege.editor.core.ui.workspace.WorkspaceFrame.<init>(WorkspaceFrame.java:54)

                at org.protege.editor.core.ui.workspace.WorkspaceManager.addWorkspace(WorkspaceManager.java:47)

                at org.protege.editor.core.editorkit.EditorKitManager.addEditorKit(EditorKitManager.java:44)

                at org.protege.editor.core.ProtegeManager.createAndSetupNewEditorKit(ProtegeManager.java:139)

                at org.protege.editor.core.ProtegeManager.createAndSetupNewEditorKit(ProtegeManager.java:129)

                at org.protege.editor.core.ProtegeApplication.createAndSetupDefaultEditorKit(ProtegeApplication.java:470)

                at org.protege.editor.core.ProtegeApplication.startApplication(ProtegeApplication.java:414)

                at org.protege.editor.core.ProtegeApplication.reallyStart(ProtegeApplication.java:108)

                at org.protege.editor.core.ProtegeApplication.lambda$start$8(ProtegeApplication.java:89)

                at org.protege.editor.core.ProtegeApplication$$Lambda$24/96190402.frameworkEvent(Unknown Source)

                at org.apache.felix.framework.util.EventDispatcher.invokeFrameworkListenerCallback(EventDispatcher.java:836)

                at org.apache.felix.framework.util.EventDispatcher.fireEventImmediately(EventDispatcher.java:786)

                at org.apache.felix.framework.util.EventDispatcher.run(EventDispatcher.java:1099)

                at org.apache.felix.framework.util.EventDispatcher.access$000(EventDispatcher.java:55)

                at org.apache.felix.framework.util.EventDispatcher$1.run(EventDispatcher.java:102)

                at java.lang.Thread.run(Thread.java:745)

Caused by: java.lang.UnsatisfiedLinkError: C:\Users\bobbinteegarden\AppData\Local\Temp\ProtegeCache-a18b6e68-14b6-4b61-8bcb-5830192b79d3\bundle32\version0.0\bundle.jar-lib\0\lib\native\64bit\FaCTPlusPlusJNI.dll: Can't find dependent libraries

                at java.lang.ClassLoader$NativeLibrary.load(Native Method)

                at java.lang.ClassLoader.loadLibrary0(ClassLoader.java:1937)

                at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1835)”

… and it goes from there.

 

Protégé 4.3 still runs just fine on my system, but I need the later version of Protégé for FIBO work.  Last time I tried with 5.2.0 also, I got the same result.

I pulled the latest FACT++ from here, and I assume it’s the latest:  https://bitbucket.org/dtsarkov/factplusplus/downloads/ .

Thanks!

 

Bobbin Teegarden

CTO/Chief Architect, OntoAge

Technology Evangelist, No Magic

h/o 425.378.0131

cell 206.979.0196

[hidden email]

alt:  [hidden email]

 

From: protege-user [[hidden email]] On Behalf Of Csongor Nyulas
Sent: Tuesday, April 18, 2017 12:42 AM
To: User support for WebProtege and Protege Desktop [hidden email]
Subject: Re: [protege-user] Problem running Protege 5.1 after updating Fact++

 

Hi Bobbin,

I don't think we have had time to debug/solve this issue so far. It is not so easy to come by a Win 10 machine in our department. Protege 5.1.0 AND 5.2.0 seem to work fine with Fact++ 1.6.5 on Macs and Ubuntu machines.

I created an issue for this where we can follow up on it:
https://github.com/protegeproject/protege/issues/638

Do you (and/or Neli) encounter the same problem also with Protege 5.2.0 and Fact++ 1.6.5. on Win 10?

Csongor

On 04/17/2017 04:55 PM, Bobbin Teegarden wrote:

After updating to 5.2.0, I’m having the same problem as described by Neli below, but couldn’t find an answer in the mailing list.  Did I miss it?  What is the answer?  Thanks.

 

Bobbin Teegarden

CTO/Chief Architect, OntoAge

Technology Evangelist, No Magic

h/o 425.378.0131

cell 206.979.0196

[hidden email]

alt:  [hidden email]

 

From: protege-user [[hidden email]] On Behalf Of Zlatareva, Neli (Computer Science)
Sent: Monday, February 27, 2017 3:12 PM
To: User support for WebProtege and Protege Desktop [hidden email]
Subject: Re: [protege-user] Problem running Protege 5.1 after updating Fact++

 

Hi Csongor,

thank you so much for your reply -- I just found it buried in my mailbox.
To answer your questions. I run Windows 10 Home – no virtual machine or OS emulator.
As I said in my original call-for-help message, I have been working with Protégé 5.1.0 for some time with NO problems at all. The problem happened when I undated to Fact++ 1.6.5 (originally Protégé came with Fact++ 1.6.4). I use Pellet, but I wanted to check out the new Fact++, so I click update and after closing Protégé for the update to take place, I was never able to open it again. Just to note that I deleted old versions (including Protégé 5.0.0 -- Protege 5.0.0 gives me the same problem) downloaded new ones, same with jre, I tried the platform independent version, etc. – always the same “non-sense” result. So, here is the latest (today's) attempt to download and start Protégé (old downloads deleted).
You are asking about files with “fact” in their names – only one in the bin directory, called maven-artifact, which is a jar file 54 KB.

When I run .bat file this is what happens: (please note that I inserted in this log error messages as I am getting them)

 

C:\Program Files (x86)\Protege-5.1.0>setlocal

C:\Program Files (x86)\Protege-5.1.0>cd /d C:\Program Files (x86)\Protege-5.1.0\

C:\Program Files (x86)\Protege-5.1.0>jre\bin\java -Xmx500M -Xms200M -Xss16M -XX:CompileCommand=exclude,javax/swing/text/GlyphView,getBreakSpot -DentityExpansionLimit=100000000 -Dlogback.configurationFile=conf/logback-win.xml -Dfile.encoding=utf-8 -Dorg.protege.plugin.dir=plugins -classpath bundles/guava.jar;bundles/logback-classic.jar;bundles/logback-core.jar;bundles/slf4j-api.jar;bin/org.apache.felix.main.jar;bin/protege-launcher.jar org.protege.osgi.framework.Launcher
CompilerOracle: exclude javax/swing/text/GlyphView.getBreakSpot
********************************************************************************
**                                  Protege                                   **
********************************************************************************

----------------- Initialising and Starting the OSGi Framework -----------------
FrameworkFactory Class: org.apache.felix.framework.FrameworkFactory

The OSGi framework has been initialised
------------------------------- Starting Bundles -------------------------------
Starting bundle org.protege.common
Starting bundle org.eclipse.equinox.common
Starting bundle org.eclipse.equinox.supplement
Starting bundle org.eclipse.equinox.registry
Starting bundle org.protege.editor.core.application
Starting bundle org.apache.commons.io
Starting bundle com.google.guava
Not starting bundle com.google.inject.assistedinject explicitly because it is a fragment bundle.
Not starting bundle com.google.inject.multibindings explicitly because it is a fragment bundle.
Starting bundle com.google.inject
Starting bundle org.jsr-305
Starting bundle jul.to.slf4j
Starting bundle log4j.over.slf4j
Starting bundle ch.qos.logback.classic
Starting bundle ch.qos.logback.core
Starting bundle org.apache.servicemix.bundles.aopalliance
Starting bundle org.apache.servicemix.bundles.javax-inject
Starting bundle org.eclipse.equinox.common
Starting bundle org.eclipse.equinox.registry
Starting bundle org.eclipse.equinox.supplement
Starting bundle org.semanticweb.owl.owlapi
Starting bundle org.protege.common
Starting bundle org.protege.editor.core.application
Starting bundle org.protege.editor.owl
Starting bundle slf4j.api
Starting bundle cellfie
Starting bundle code-generation
Starting bundle existentialquery
Starting bundle uk.ac.manchester.cs.owl.explanation
Starting bundle org.protege.ontograf
Starting bundle org.coode.dlquery
Starting bundle org.semanticweb.hermit
Starting bundle org.coode.browser
Starting bundle org.coode.owlviz
Starting bundle org.protege.owl.rdf
Starting bundle org.protege.editor.owl.rdf
Starting bundle swrltab-plugin
Starting bundle com.clarkparsia.protege.plugin.pellet
Starting bundle org.exquisite.protege
Starting bundle org.semanticweb.elk
Starting bundle uk.ac.manchester.cs.owl.factplusplus
The OSGi framework has been started
------------------------------------ Protege -----------------------------------

Protege Desktop
Version 5.1.0, Build


----------------------------------- Platform -----------------------------------
Java: JVM 1.8.0_40-b26  Memory: 466M
Language: en, Country: US
Framework: Apache Software Foundation (1.7)
OS: windows8 (6.3)
Processor: x86-64


------------------------------------ Plugins -----------------------------------
Plugin: Cellfie Protege 5.0+ Plugin (2.1.0)
Plugin: OWL Code Generation Plug-in (2.0.0)
Plugin: Existential Query (2.0.0)
Plugin: Explanation Workbench (3.0.0)
Plugin: OntoGraf (2.0.3)
Plugin: DL Query (4.0.1)
Plugin: HermiT (1.3.8.413)
Plugin: Browser View (OWLDoc) (3.0.3)
Plugin: OWLViz (5.0.3)
Plugin: OWLAPI RDF Library (2.0.2)
Plugin: Protege SPARQL Plugin (2.0.1)
Plugin: SWRLTab Protege 5.0+ Plugin (1.0.3)
Plugin: Pellet Reasoner Plug-in (2.2.0)
Plugin: Ontology Debugger (0.1.2.BETA)
Plugin: ELK Reasoner Protege Plug-in (0.4.3)
Plugin: Factplusplus Plug-in (1.6.5)

Feb 27, 2017 5:35:50 PM java.util.prefs.WindowsPreferences <init>
WARNING: Could not open/create prefs root node Software\JavaSoft\Prefs at root 0x80000002. Windows RegCreateKeyEx(...) returned error code 5.
Creating and setting up empty (default) editor kit
OWL API Version: 4.2.6.20160910-2108
Loading default configuration parameters for class org.semanticweb.elk.reasoner.config.ReasonerConfiguration
Cannot generate ontology catalog for ontology at http://www.semanticweb.org/ioana/ontologies/2017/1/untitled-ontology-13
-------------------------- Generated Diagnosis Model ---------------------------
Ontology: OntologyID(OntologyIRI(<http://www.semanticweb.org/ioana/ontologies/2017/1/untitled-ontology-13>) VersionIRI(<null>))
Generated in 46 ms
0 Possibly Faulty Formulas
0 Correct Formulas
0 Entailed Examples
0 Not-Entailed Examples
--------------------------------------------------------------------------------

 

THE FOLLOWING ERROR WINDOW POPS UP AT THIS POINT:

MISSING LIBRARIES OR PLATFORM NOT SUPPPORTED
FACT++ REQUIRES PLATFORM SPECIFIC LIBRARIES
WHICH CANNOT BE FOUND

WHEN I CLICK OK THIS WINDOW CLOSES AND THE PROTEGE LOG CONTINUES AS FOLLOWS:

 


java:102)
          java.lang.Thread.run(Thread.java:745)
    (Listeners should be removed in the plugin dispose method!)
*** WARNING BADLY BEHAVING LISTENER: org.protege.editor.owl.ui.action.AbstractOntologySelectionStrategyAction$$Lambda$59/1677217031 ***
    Possible culprit (trace from when listener was added):
          org.protege.editor.owl.ui.action.AbstractOntologySelectionStrategyAction.initialise(AbstractOntologySelectionStrategyAction.java:47)
          org.protege.editor.owl.ui.action.ImportsClosureOntologyStrategyAction.initialise(ImportsClosureOntologyStrategyAction.java:27)
          org.protege.editor.core.ui.menu.MenuActionPluginJPFImpl.newInstance(MenuActionPluginJPFImpl.java:169)
          org.protege.editor.core.ui.menu.MenuActionPluginJPFImpl.newInstance(MenuActionPluginJPFImpl.java:31)
          org.protege.editor.core.ui.menu.MenuBuilder.buildInnerMenu(MenuBuilder.java:159)
          org.protege.editor.core.ui.menu.MenuBuilder.addMenu(MenuBuilder.java:114)
          org.protege.editor.core.ui.menu.MenuBuilder.buildCompositeMenu(MenuBuilder.java:135)
          org.protege.editor.core.ui.menu.MenuBuilder.addMenu(MenuBuilder.java:106)
          org.protege.editor.core.ui.menu.MenuBuilder.buildMenu(MenuBuilder.java:64)
          org.protege.editor.core.ui.workspace.WorkspaceFrame.createMenuBar(WorkspaceFrame.java:165)
          org.protege.editor.core.ui.workspace.WorkspaceFrame.createUI(WorkspaceFrame.java:137)
          org.protege.editor.core.ui.workspace.WorkspaceFrame.<init>(WorkspaceFrame.java:55)
          org.protege.editor.core.ui.workspace.WorkspaceManager.addWorkspace(WorkspaceManager.java:47)
          org.protege.editor.core.editorkit.EditorKitManager.addEditorKit(EditorKitManager.java:44)
          org.protege.editor.core.ProtegeManager.createAndSetupNewEditorKit(ProtegeManager.java:139)
          org.protege.editor.core.ProtegeManager.createAndSetupNewEditorKit(ProtegeManager.java:129)
          org.protege.editor.core.ProtegeApplication.createAndSetupDefaultEditorKit(ProtegeApplication.java:488)
          org.protege.editor.core.ProtegeApplication.startApplication(ProtegeApplication.java:432)
          org.protege.editor.core.ProtegeApplication.reallyStart(ProtegeApplication.java:109)
          org.protege.editor.core.ProtegeApplication.lambda$start$11(ProtegeApplication.java:90)
          org.protege.editor.core.ProtegeApplication$$Lambda$24/1976931298.frameworkEvent(Unknown Source)
          org.apache.felix.framework.util.EventDispatcher.invokeFrameworkListenerCallback(EventDispatcher.java:836)
          org.apache.felix.framework.util.EventDispatcher.fireEventImmediately(EventDispatcher.java:786)
          org.apache.felix.framework.util.EventDispatcher.run(EventDispatcher.java:1099)
          org.apache.felix.framework.util.EventDispatcher.access$000(EventDispatcher.java:55)
          org.apache.felix.framework.util.EventDispatcher$1.run(EventDispatcher.java:102)
          java.lang.Thread.run(Thread.java:745)
    (Listeners should be removed in the plugin dispose method!)
*** WARNING BADLY BEHAVING LISTENER: org.protege.editor.owl.ui.renderer.menu.AbstractByRendererMenu$$Lambda$57/436590799 ***
    Possible culprit (trace from when listener was added):
          org.protege.editor.owl.ui.renderer.menu.AbstractByRendererMenu.initialise(AbstractByRendererMenu.java:34)
          org.protege.editor.core.ui.menu.MenuActionPluginJPFImpl.newInstance(MenuActionPluginJPFImpl.java:169)
          org.protege.editor.core.ui.menu.MenuActionPluginJPFImpl.newInstance(MenuActionPluginJPFImpl.java:31)
          org.protege.editor.core.ui.menu.MenuBuilder.buildInnerMenu(MenuBuilder.java:159)
          org.protege.editor.core.ui.menu.MenuBuilder.addMenu(MenuBuilder.java:114)
          org.protege.editor.core.ui.menu.MenuBuilder.buildCompositeMenu(MenuBuilder.java:135)
          org.protege.editor.core.ui.menu.MenuBuilder.addMenu(MenuBuilder.java:106)
          org.protege.editor.core.ui.menu.MenuBuilder.buildMenu(MenuBuilder.java:64)
          org.protege.editor.core.ui.workspace.WorkspaceFrame.createMenuBar(WorkspaceFrame.java:165)
          org.protege.editor.core.ui.workspace.WorkspaceFrame.createUI(WorkspaceFrame.java:137)
          org.protege.editor.core.ui.workspace.WorkspaceFrame.<init>(WorkspaceFrame.java:55)
          org.protege.editor.core.ui.workspace.WorkspaceManager.addWorkspace(WorkspaceManager.java:47)
          org.protege.editor.core.editorkit.EditorKitManager.addEditorKit(EditorKitManager.java:44)
          org.protege.editor.core.ProtegeManager.createAndSetupNewEditorKit(ProtegeManager.java:139)
          org.protege.editor.core.ProtegeManager.createAndSetupNewEditorKit(ProtegeManager.java:129)
          org.protege.editor.core.ProtegeApplication.createAndSetupDefaultEditorKit(ProtegeApplication.java:488)
          org.protege.editor.core.ProtegeApplication.startApplication(ProtegeApplication.java:432)
          org.protege.editor.core.ProtegeApplication.reallyStart(ProtegeApplication.java:109)
          org.protege.editor.core.ProtegeApplication.lambda$start$11(ProtegeApplication.java:90)
          org.protege.editor.core.ProtegeApplication$$Lambda$24/1976931298.frameworkEvent(Unknown Source)
          org.apache.felix.framework.util.EventDispatcher.invokeFrameworkListenerCallback(EventDispatcher.java:836)
          org.apache.felix.framework.util.EventDispatcher.fireEventImmediately(EventDispatcher.java:786)
          org.apache.felix.framework.util.EventDispatcher.run(EventDispatcher.java:1099)
          org.apache.felix.framework.util.EventDispatcher.access$000(EventDispatcher.java:55)
          org.apache.felix.framework.util.EventDispatcher$1.run(EventDispatcher.java:102)
          java.lang.Thread.run(Thread.java:745)
    (Listeners should be removed in the plugin dispose method!)
*** WARNING BADLY BEHAVING LISTENER: org.protege.editor.owl.ui.renderer.menu.RenderByProperty$$Lambda$58/1386820222 ***
    Possible culprit (trace from when listener was added):
          org.protege.editor.owl.ui.renderer.menu.RenderByProperty.initialise(RenderByProperty.java:82)
          org.protege.editor.core.ui.menu.MenuActionPluginJPFImpl.newInstance(MenuActionPluginJPFImpl.java:169)
          org.protege.editor.core.ui.menu.MenuActionPluginJPFImpl.newInstance(MenuActionPluginJPFImpl.java:31)
          org.protege.editor.core.ui.menu.MenuBuilder.buildDynamicMenu(MenuBuilder.java:146)
          org.protege.editor.core.ui.menu.MenuBuilder.addMenu(MenuBuilder.java:110)
          org.protege.editor.core.ui.menu.MenuBuilder.buildCompositeMenu(MenuBuilder.java:135)
          org.protege.editor.core.ui.menu.MenuBuilder.addMenu(MenuBuilder.java:106)
          org.protege.editor.core.ui.menu.MenuBuilder.buildMenu(MenuBuilder.java:64)
          org.protege.editor.core.ui.workspace.WorkspaceFrame.createMenuBar(WorkspaceFrame.java:165)
          org.protege.editor.core.ui.workspace.WorkspaceFrame.createUI(WorkspaceFrame.java:137)
          org.protege.editor.core.ui.workspace.WorkspaceFrame.<init>(WorkspaceFrame.java:55)
          org.protege.editor.core.ui.workspace.WorkspaceManager.addWorkspace(WorkspaceManager.java:47)
          org.protege.editor.core.editorkit.EditorKitManager.addEditorKit(EditorKitManager.java:44)
          org.protege.editor.core.ProtegeManager.createAndSetupNewEditorKit(ProtegeManager.java:139)
          org.protege.editor.core.ProtegeManager.createAndSetupNewEditorKit(ProtegeManager.java:129)
          org.protege.editor.core.ProtegeApplication.createAndSetupDefaultEditorKit(ProtegeApplication.java:488)
          org.protege.editor.core.ProtegeApplication.startApplication(ProtegeApplication.java:432)
          org.protege.editor.core.ProtegeApplication.reallyStart(ProtegeApplication.java:109)
          org.protege.editor.core.ProtegeApplication.lambda$start$11(ProtegeApplication.java:90)
          org.protege.editor.core.ProtegeApplication$$Lambda$24/1976931298.frameworkEvent(Unknown Source)
          org.apache.felix.framework.util.EventDispatcher.invokeFrameworkListenerCallback(EventDispatcher.java:836)
          org.apache.felix.framework.util.EventDispatcher.fireEventImmediately(EventDispatcher.java:786)
          org.apache.felix.framework.util.EventDispatcher.run(EventDispatcher.java:1099)
          org.apache.felix.framework.util.EventDispatcher.access$000(EventDispatcher.java:55)
          org.apache.felix.framework.util.EventDispatcher$1.run(EventDispatcher.java:102)
          java.lang.Thread.run(Thread.java:745)
    (Listeners should be removed in the plugin dispose method!)
*** WARNING BADLY BEHAVING LISTENER: org.protege.editor.owl.ui.action.AbstractOntologySelectionStrategyAction$$Lambda$59/1677217031 ***
    Possible culprit (trace from when listener was added):
          org.protege.editor.owl.ui.action.AbstractOntologySelectionStrategyAction.initialise(AbstractOntologySelectionStrategyAction.java:47)
          org.protege.editor.core.ui.menu.MenuActionPluginJPFImpl.newInstance(MenuActionPluginJPFImpl.java:169)
          org.protege.editor.core.ui.menu.MenuActionPluginJPFImpl.newInstance(MenuActionPluginJPFImpl.java:31)
          org.protege.editor.core.ui.menu.MenuBuilder.buildInnerMenu(MenuBuilder.java:159)
          org.protege.editor.core.ui.menu.MenuBuilder.addMenu(MenuBuilder.java:114)
          org.protege.editor.core.ui.menu.MenuBuilder.buildCompositeMenu(MenuBuilder.java:135)
          org.protege.editor.core.ui.menu.MenuBuilder.addMenu(MenuBuilder.java:106)
          org.protege.editor.core.ui.menu.MenuBuilder.buildMenu(MenuBuilder.java:64)
          org.protege.editor.core.ui.workspace.WorkspaceFrame.createMenuBar(WorkspaceFrame.java:165)
          org.protege.editor.core.ui.workspace.WorkspaceFrame.createUI(WorkspaceFrame.java:137)
          org.protege.editor.core.ui.workspace.WorkspaceFrame.<init>(WorkspaceFrame.java:55)
          org.protege.editor.core.ui.workspace.WorkspaceManager.addWorkspace(WorkspaceManager.java:47)
          org.protege.editor.core.editorkit.EditorKitManager.addEditorKit(EditorKitManager.java:44)
          org.protege.editor.core.ProtegeManager.createAndSetupNewEditorKit(ProtegeManager.java:139)
          org.protege.editor.core.ProtegeManager.createAndSetupNewEditorKit(ProtegeManager.java:129)
          org.protege.editor.core.ProtegeApplication.createAndSetupDefaultEditorKit(ProtegeApplication.java:488)
          org.protege.editor.core.ProtegeApplication.startApplication(ProtegeApplication.java:432)
          org.protege.editor.core.ProtegeApplication.reallyStart(ProtegeApplication.java:109)
          org.protege.editor.core.ProtegeApplication.lambda$start$11(ProtegeApplication.java:90)
          org.protege.editor.core.ProtegeApplication$$Lambda$24/1976931298.frameworkEvent(Unknown Source)
          org.apache.felix.framework.util.EventDispatcher.invokeFrameworkListenerCallback(EventDispatcher.java:836)
          org.apache.felix.framework.util.EventDispatcher.fireEventImmediately(EventDispatcher.java:786)
          org.apache.felix.framework.util.EventDispatcher.run(EventDispatcher.java:1099)
          org.apache.felix.framework.util.EventDispatcher.access$000(EventDispatcher.java:55)
          org.apache.felix.framework.util.EventDispatcher$1.run(EventDispatcher.java:102)
          java.lang.Thread.run(Thread.java:745)
    (Listeners should be removed in the plugin dispose method!)

An error was thrown: java.lang.UnsatisfiedLinkError: C:\Users\Evgueni\AppData\Local\Temp\ProtegeCache-e2b80694-f0ed-44e2-905b-9d993353402c\bundle36\version0.0\bundle.jar-lib\0\lib\native\64bit\FaCTPlusPlusJNI.dll: Can't find dependent libraries
org.semanticweb.owlapi.model.OWLRuntimeException: java.lang.UnsatisfiedLinkError: C:\Users\Evgueni\AppData\Local\Temp\ProtegeCache-e2b80694-f0ed-44e2-905b-9d993353402c\bundle36\version0.0\bundle.jar-lib\0\lib\native\64bit\FaCTPlusPlusJNI.dll: Can't find dependent libraries
        at uk.ac.manchester.cs.factplusplus.protege.FaCTPlusPlusFactory.getReasonerFactory(FaCTPlusPlusFactory.java:84) ~[na:na]
        at org.protege.editor.owl.model.inference.ReasonerInfoComparator.compare(ReasonerInfoComparator.java:9) ~[na:na]
        at org.protege.editor.owl.model.inference.ReasonerInfoComparator.compare(ReasonerInfoComparator.java:5) ~[na:na]
        at java.util.TimSort.countRunAndMakeAscending(TimSort.java:351) ~[na:1.8.0_40]
        at java.util.TimSort.sort(TimSort.java:216) ~[na:1.8.0_40]
        at java.util.Arrays.sort(Arrays.java:1512) ~[na:1.8.0_40]
        at java.util.ArrayList.sort(ArrayList.java:1454) ~[na:1.8.0_40]
        at java.util.Collections.sort(Collections.java:175) ~[na:1.8.0_40]
        at org.protege.editor.owl.model.OWLWorkspace.rebuildReasonerMenu(OWLWorkspace.java:565) ~[na:na]
        at org.protege.editor.owl.model.OWLWorkspace.initialiseExtraMenuItems(OWLWorkspace.java:431) ~[na:na]
        at org.protege.editor.core.ui.workspace.WorkspaceFrame.createUI(WorkspaceFrame.java:141) ~[protege-editor-core.jar:na]
        at org.protege.editor.core.ui.workspace.WorkspaceFrame.<init>(WorkspaceFrame.java:55) ~[protege-editor-core.jar:na]
        at org.protege.editor.core.ui.workspace.WorkspaceManager.addWorkspace(WorkspaceManager.java:47) ~[protege-editor-core.jar:na]
        at org.protege.editor.core.editorkit.EditorKitManager.addEditorKit(EditorKitManager.java:44) ~[protege-editor-core.jar:na]
        at org.protege.editor.core.ProtegeManager.createAndSetupNewEditorKit(ProtegeManager.java:139) ~[protege-editor-core.jar:na]
        at org.protege.editor.core.ProtegeManager.createAndSetupNewEditorKit(ProtegeManager.java:129) ~[protege-editor-core.jar:na]
        at org.protege.editor.core.ProtegeApplication.createAndSetupDefaultEditorKit(ProtegeApplication.java:488) [protege-editor-core.jar:na]
        at org.protege.editor.core.ProtegeApplication.startApplication(ProtegeApplication.java:432) [protege-editor-core.jar:na]
        at org.protege.editor.core.ProtegeApplication.reallyStart(ProtegeApplication.java:109) [protege-editor-core.jar:na]
        at org.protege.editor.core.ProtegeApplication.lambda$start$11(ProtegeApplication.java:90) [protege-editor-core.jar:na]
        at org.protege.editor.core.ProtegeApplication$$Lambda$24/1976931298.frameworkEvent(Unknown Source) [protege-editor-core.jar:na]
        at org.apache.felix.framework.util.EventDispatcher.invokeFrameworkListenerCallback(EventDispatcher.java:836) [org.apache.felix.main.jar:na]
        at org.apache.felix.framework.util.EventDispatcher.fireEventImmediately(EventDispatcher.java:786) [org.apache.felix.main.jar:na]
        at org.apache.felix.framework.util.EventDispatcher.run(EventDispatcher.java:1099) [org.apache.felix.main.jar:na]
        at org.apache.felix.framework.util.EventDispatcher.access$000(EventDispatcher.java:55) [org.apache.felix.main.jar:na]
        at org.apache.felix.framework.util.EventDispatcher$1.run(EventDispatcher.java:102) [org.apache.felix.main.jar:na]
        at java.lang.Thread.run(Thread.java:745) [na:1.8.0_40]
Caused by: java.lang.UnsatisfiedLinkError: C:\Users\Evgueni\AppData\Local\Temp\ProtegeCache-e2b80694-f0ed-44e2-905b-9d993353402c\bundle36\version0.0\bundle.jar-lib\0\lib\native\64bit\FaCTPlusPlusJNI.dll: Can't find dependent libraries
        at java.lang.ClassLoader$NativeLibrary.load(Native Method) ~[na:1.8.0_40]
        at java.lang.ClassLoader.loadLibrary0(ClassLoader.java:1937) ~[na:1.8.0_40]
        at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1835) ~[na:1.8.0_40]
        at java.lang.Runtime.loadLibrary0(Runtime.java:870) ~[na:1.8.0_40]
        at java.lang.System.loadLibrary(System.java:1122) ~[na:1.8.0_40]
        at uk.ac.manchester.cs.factplusplus.FaCTPlusPlus.<clinit>(FaCTPlusPlus.java:19) ~[na:na]
        at uk.ac.manchester.cs.factplusplus.protege.FaCTPlusPlusFactory.getReasonerFactory(FaCTPlusPlusFactory.java:75) ~[na:na]
        ... 26 common frames omitted


AT THIS POINT ANOTHER ERROR WINDOW POPS UP which is HUGE, so when I click OK
THIS IS THE LAST I SEE -- then Prorege dies -- the editor never opens.


------------------------------- Auto-update Check ------------------------------
Auto-update last performed: Mon Feb 27 17:08:38 EST 2017
Auto-update has been performed today.  Not performing it again.

 

THANK YOU so much for your help. It is trully appreciated.
Best regards, Neli

 

 

Neli P. Zlatareva, PhD
Professor of Computer Science
Department of Computer Science
Central Connecticut State University
New Britain, CT 06050
Phone: (860) 832-2723
Fax: (860) 832-2712
Web site: cs.ccsu.edu/~neli/


From: protege-user <[hidden email]> on behalf of Csongor Nyulas <[hidden email]>
Sent: Wednesday, February 22, 2017 2:59:44 AM
To: User support for WebProtege and Protege Desktop
Subject: Re: [protege-user] Problem running Protege 5.1 after updating Fact++

 

Dear Neli,

I am running Protege 5.1.1 with Fact++ 1.6.5 for a long time now, and I never experienced the things that you describe. So, in order to debug what's going on, we need to understand what is different on your machine compared to ours.

Here are a few questions that hopefully can help us elucidate the mystery:

What OS are you using?
What is the ".dat" file? Maybe you wanted to say ".bat" file (in which case you are probably using Windows)?
Are you by any chance using an virtual machine or some OS emulator?
In the [PROTEGE_INSTALL_DIR]/plugins folder how many files do you have that have the word "fact" in their names? If you have only a jar file, what is the exact name of that file, and how big is it?
If you search all the subfolders of [PROTEGE_INSTALL_DIR], how many ja files do you find that contain the name "fact" in it?
Can you send us the Protege logs?

Csongor


On 02/18/2017 08:00 AM, Zlatareva, Neli (Computer Science) wrote:


Hi,

I would greatly appreciate help with the following issue:

I have been working with Protégé 5.1 for some time and everything was great.

At the moment I decided to update to Fact++ 1.6.5 everything went wrong.

I could not open Protégé after restart (suggested to update Fact++). The error

I am getting is that MS C++ libraries are missing and after that the editor will not

open (I am running .dat file). I tried EVERYTHING -- deleting old versions, downloading

new ones, including JRE because I read somewhere about possible java corruption).

I am teaching Sem Web Tech class and very shortly my students will need Protégé

for their project. I am very worried that something like this can happen to them and

I have no clue how to help.

Any suggestions will be greatly appreciated.

THANK YOU SO MUCH! 

 

Neli P. Zlatareva, PhD
Professor of Computer Science
Department of Computer Science
Central Connecticut State University
New Britain, CT 06050
Phone: (860) 832-2723
Fax: (860) 832-2712
Web site: cs.ccsu.edu/~neli


 





_______________________________________________
protege-user mailing list
[hidden email]
https://mailman.stanford.edu/mailman/listinfo/protege-user

 

 

Virus-free. www.avast.com




_______________________________________________
protege-user mailing list
[hidden email]
https://mailman.stanford.edu/mailman/listinfo/protege-user

 


Virus-free. www.avast.com


_______________________________________________
protege-user mailing list
[hidden email]
https://mailman.stanford.edu/mailman/listinfo/protege-user


_______________________________________________
protege-user mailing list
[hidden email]
https://mailman.stanford.edu/mailman/listinfo/protege-user
Loading...