Render by label whose lang is neither "Null" nor "en"

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

Render by label whose lang is neither "Null" nor "en"

Anne Laure Jousse
Hi,
I have been using Protege for a while (version 5.2) I have always installed the new plugins as soon as they are offered to installation.
Since a few weeks, I have noticed that the rendering by labels in the class hierarchy doesn’t work if my label has a language other than “en” (lang:en). The only way to continue displaying the labels in the hierarchy is if they have “en” or nothing in the lang field.

One of my colleagues hasn’t installed the latest plugins and everything works fine on her computer, i.e., the labels are displayed in the class hierarchy even if they are French labels.

This is a big problem for us.
I hope there will be a solution to this problem.

Best regards,

Anne-Laure Jousse
_______________________________________________
protege-user mailing list
[hidden email]
https://mailman.stanford.edu/mailman/listinfo/protege-user
Reply | Threaded
Open this post in threaded view
|

Re: Render by label whose lang is neither "Null" nor "en"

Matthew Horridge-2
Administrator
Hi Anne-Laure,

It’s worth double checking your settings.  Make sure that “Render by annotation property” is selected in the Preferences -> Renderer tab.


Next click on “Configure…”

In the dialog that appears make sure that you have rdfs:label listed and then, in the box below make sure that you have languages listed in the order of preference e.g.  “fr, en, !”  The “!” means use any available language if none of the others match.


Please double check the above and get back to us.

Cheers,

Matthew



On 19 Dec 2017, at 20:56, Anne Laure Jousse <[hidden email]> wrote:

Hi,
I have been using Protege for a while (version 5.2) I have always installed the new plugins as soon as they are offered to installation.
Since a few weeks, I have noticed that the rendering by labels in the class hierarchy doesn’t work if my label has a language other than “en” (lang:en). The only way to continue displaying the labels in the hierarchy is if they have “en” or nothing in the lang field.

One of my colleagues hasn’t installed the latest plugins and everything works fine on her computer, i.e., the labels are displayed in the class hierarchy even if they are French labels.

This is a big problem for us.
I hope there will be a solution to this problem.

Best regards,

Anne-Laure Jousse
_______________________________________________
protege-user mailing list
[hidden email]
https://mailman.stanford.edu/mailman/listinfo/protege-user


_______________________________________________
protege-user mailing list
[hidden email]
https://mailman.stanford.edu/mailman/listinfo/protege-user
Reply | Threaded
Open this post in threaded view
|

Re: Render by label whose lang is neither "Null" nor "en"

Anne Laure Jousse
Hi Matthew,
Thank you very much for this answer, which has solved my problem !
Those parameters were probably erased during an update (plugin installation ?).
Anyways, thank you again !

Anne-Laure Jousse



On Dec 19, 2017, at 5:59 PM, Matthew Horridge <[hidden email]> wrote:

Hi Anne-Laure,

It’s worth double checking your settings.  Make sure that “Render by annotation property” is selected in the Preferences -> Renderer tab.

<PastedGraphic-3.png>

Next click on “Configure…”

In the dialog that appears make sure that you have rdfs:label listed and then, in the box below make sure that you have languages listed in the order of preference e.g.  “fr, en, !”  The “!” means use any available language if none of the others match.

<PastedGraphic-4.png>

Please double check the above and get back to us.

Cheers,

Matthew



On 19 Dec 2017, at 20:56, Anne Laure Jousse <[hidden email]> wrote:

Hi,
I have been using Protege for a while (version 5.2) I have always installed the new plugins as soon as they are offered to installation.
Since a few weeks, I have noticed that the rendering by labels in the class hierarchy doesn’t work if my label has a language other than “en” (lang:en). The only way to continue displaying the labels in the hierarchy is if they have “en” or nothing in the lang field.

One of my colleagues hasn’t installed the latest plugins and everything works fine on her computer, i.e., the labels are displayed in the class hierarchy even if they are French labels.

This is a big problem for us.
I hope there will be a solution to this problem.

Best regards,

Anne-Laure Jousse
_______________________________________________
protege-user mailing list
[hidden email]
https://mailman.stanford.edu/mailman/listinfo/protege-user

_______________________________________________
protege-user mailing list
[hidden email]
https://mailman.stanford.edu/mailman/listinfo/protege-user


_______________________________________________
protege-user mailing list
[hidden email]
https://mailman.stanford.edu/mailman/listinfo/protege-user
Reply | Threaded
Open this post in threaded view
|

Re: Render by label whose lang is neither "Null" nor "en"

Matthew Horridge-2
Administrator
Hi Anne-Laure,

You’re welcome.  If you’ve reset the preferences at some point then these settings will have been wiped out.  Anyway, I’m glad this fixed the problem.

Cheers,

Matthew

On 20 Dec 2017, at 13:32, Anne Laure Jousse <[hidden email]> wrote:

Hi Matthew,
Thank you very much for this answer, which has solved my problem !
Those parameters were probably erased during an update (plugin installation ?).
Anyways, thank you again !

Anne-Laure Jousse



On Dec 19, 2017, at 5:59 PM, Matthew Horridge <[hidden email]> wrote:

Hi Anne-Laure,

It’s worth double checking your settings.  Make sure that “Render by annotation property” is selected in the Preferences -> Renderer tab.

<PastedGraphic-3.png>

Next click on “Configure…”

In the dialog that appears make sure that you have rdfs:label listed and then, in the box below make sure that you have languages listed in the order of preference e.g.  “fr, en, !”  The “!” means use any available language if none of the others match.

<PastedGraphic-4.png>

Please double check the above and get back to us.

Cheers,

Matthew



On 19 Dec 2017, at 20:56, Anne Laure Jousse <[hidden email]> wrote:

Hi,
I have been using Protege for a while (version 5.2) I have always installed the new plugins as soon as they are offered to installation.
Since a few weeks, I have noticed that the rendering by labels in the class hierarchy doesn’t work if my label has a language other than “en” (lang:en). The only way to continue displaying the labels in the hierarchy is if they have “en” or nothing in the lang field.

One of my colleagues hasn’t installed the latest plugins and everything works fine on her computer, i.e., the labels are displayed in the class hierarchy even if they are French labels.

This is a big problem for us.
I hope there will be a solution to this problem.

Best regards,

Anne-Laure Jousse
_______________________________________________
protege-user mailing list
[hidden email]
https://mailman.stanford.edu/mailman/listinfo/protege-user

_______________________________________________
protege-user mailing list
[hidden email]
https://mailman.stanford.edu/mailman/listinfo/protege-user

_______________________________________________
protege-user mailing list
[hidden email]
https://mailman.stanford.edu/mailman/listinfo/protege-user


_______________________________________________
protege-user mailing list
[hidden email]
https://mailman.stanford.edu/mailman/listinfo/protege-user