SQWRL Bag

classic Classic list List threaded Threaded
11 messages Options
Reply | Threaded
Open this post in threaded view
|

SQWRL Bag

jgalan
Hi

I have a problem when executing a SQWRL query, using the bag operator, this
is the query:

sqwrl:makeBag(?bag, "1"^^xsd:integer) ^ sqwrl:makeBag(?bag,
"2"^^xsd:integer) ^ sqwrl:makeBag(?bag, "3"^^xsd:integer)˚sqwrl:element(?el,
?bag) -> sqwrl:select(?el)

The problem is that at the time of running this query gives me the message:

SQWRL query S3 did not generate any result.

but the result should be: 1,2,3



--
Sent from: http://protege-project.136.n4.nabble.com/Protege-User-f4659818.html
_______________________________________________
protege-user mailing list
[hidden email]
https://mailman.stanford.edu/mailman/listinfo/protege-user
Reply | Threaded
Open this post in threaded view
|

Re: SQWRL Bag

Martin O'Connor-2

Can you make sure you are using the latest Protege 5.2 and version 2.0.5 of the SWRLTab plugin.

You can updated to the latest SWRLTab plugin via the File->Check for plugins… menu item.

Martin

> On Oct 24, 2017, at 7:09 PM, jgalan <[hidden email]> wrote:
>
> Hi
>
> I have a problem when executing a SQWRL query, using the bag operator, this
> is the query:
>
> sqwrl:makeBag(?bag, "1"^^xsd:integer) ^ sqwrl:makeBag(?bag,
> "2"^^xsd:integer) ^ sqwrl:makeBag(?bag, "3"^^xsd:integer)˚sqwrl:element(?el,
> ?bag) -> sqwrl:select(?el)
>
> The problem is that at the time of running this query gives me the message:
>
> SQWRL query S3 did not generate any result.
>
> but the result should be: 1,2,3
>
>
>
> --
> Sent from: http://protege-project.136.n4.nabble.com/Protege-User-f4659818.html
> _______________________________________________
> protege-user mailing list
> [hidden email]
> https://mailman.stanford.edu/mailman/listinfo/protege-user

_______________________________________________
protege-user mailing list
[hidden email]
https://mailman.stanford.edu/mailman/listinfo/protege-user
Reply | Threaded
Open this post in threaded view
|

Re: SQWRL Bag

jgalan
This post was updated on .
Yes I have the version of Protege 5.2.0 and the version of SQWRLTab 2.0.5, but
I get the "SQWRL query S3 did not generate any result." message when running
the query.



--
Sent from: http://protege-project.136.n4.nabble.com/Protege-User-f4659818.html
_______________________________________________
protege-user mailing list
protege-user@lists.stanford.edu
https://mailman.stanford.edu/mailman/listinfo/protege-user
Reply | Threaded
Open this post in threaded view
|

Re: SQWRL Bag

Csongor Nyulas
Administrator
This works for me. I get back 3 results (1, 2 and 3) as expected.

I think you need a ˚ at the beginning of your rule, but the SQWRL query
editor seems to add this automatically if you forget to add it.

Csongor


On 10/25/2017 06:22 AM, jgalan wrote:

> If I have the version of Protege 5.2.0 and the version of SQWRLTab 2.0.5, but
> I get the "SQWRL query S3 did not generate any result." message when running
> the query.
>
>
>
> --
> Sent from: http://protege-project.136.n4.nabble.com/Protege-User-f4659818.html
> _______________________________________________
> protege-user mailing list
> [hidden email]
> https://mailman.stanford.edu/mailman/listinfo/protege-user


_______________________________________________
protege-user mailing list
[hidden email]
https://mailman.stanford.edu/mailman/listinfo/protege-user
Reply | Threaded
Open this post in threaded view
|

Re: SQWRL Bag

jgalan
Yes SQWRL query editor add a ˚ at the beginning automatically, but the result
is:

SQWRL query S3 did not generate any result.



--
Sent from: http://protege-project.136.n4.nabble.com/Protege-User-f4659818.html
_______________________________________________
protege-user mailing list
[hidden email]
https://mailman.stanford.edu/mailman/listinfo/protege-user
Reply | Threaded
Open this post in threaded view
|

Re: SQWRL Bag

Martin O'Connor-2

Also works out-of-the-box for for me.




Can you post your About Protege dialog showing the SWRLTab version. 


Martin

On Oct 26, 2017, at 6:08 AM, jgalan <[hidden email]> wrote:

Yes SQWRL query editor add a ˚ at the beginning automatically, but the result
is:

SQWRL query S3 did not generate any result.



--
Sent from: http://protege-project.136.n4.nabble.com/Protege-User-f4659818.html
_______________________________________________
protege-user mailing list
[hidden email]
https://mailman.stanford.edu/mailman/listinfo/protege-user


_______________________________________________
protege-user mailing list
[hidden email]
https://mailman.stanford.edu/mailman/listinfo/protege-user
Reply | Threaded
Open this post in threaded view
|

Re: SQWRL Bag

jgalan
Reply | Threaded
Open this post in threaded view
|

Re: SQWRL Bag

Csongor Nyulas
Administrator
Can you open S3, and copy (again) everything that is in that query. The
only thing I can think of, is that you are not running any more:

   .  sqwrl:makeBag(?bag, 1) ^ sqwrl:makeBag(?bag, 2) ^
sqwrl:makeBag(?bag, 3)  .  sqwrl:element(?el, ?bag) -> sqwrl:select(?el)

Csongor


On 10/27/2017 06:16 AM, jgalan wrote:

> The execution does't work for me:
> <http://protege-project.136.n4.nabble.com/file/t376666/2017-10-27_08-10-48.png>
>
>
> My About Protege dialog with the SWRLTab version is the latest:
> <http://protege-project.136.n4.nabble.com/file/t376666/2017-10-27_08-11-33.png>
>
>
>
> --
> Sent from: http://protege-project.136.n4.nabble.com/Protege-User-f4659818.html
> _______________________________________________
> protege-user mailing list
> [hidden email]
> https://mailman.stanford.edu/mailman/listinfo/protege-user


_______________________________________________
protege-user mailing list
[hidden email]
https://mailman.stanford.edu/mailman/listinfo/protege-user
Reply | Threaded
Open this post in threaded view
|

Re: SQWRL Bag

jgalan
I don't know what was the problem, when trying with the version of Protege
5.2 in Windows 10 the result of SQWRL was query S1 did not generate any
result, but when I tested the same query in Protege 5.2 in CentOs it worked
correctly.

<http://protege-project.136.n4.nabble.com/file/t376666/2017-10-31_16-12-20.png>



--
Sent from: http://protege-project.136.n4.nabble.com/Protege-User-f4659818.html
_______________________________________________
protege-user mailing list
[hidden email]
https://mailman.stanford.edu/mailman/listinfo/protege-user
Reply | Threaded
Open this post in threaded view
|

Re: SQWRL Bag

Martin O'Connor-2

Thanks for the update. I will try to dig up a Windows machine to test.

Martin

> On Oct 31, 2017, at 2:17 PM, jgalan <[hidden email]> wrote:
>
> I don't know what was the problem, when trying with the version of Protege
> 5.2 in Windows 10 the result of SQWRL was query S1 did not generate any
> result, but when I tested the same query in Protege 5.2 in CentOs it worked
> correctly.
>
> <http://protege-project.136.n4.nabble.com/file/t376666/2017-10-31_16-12-20.png>
>
>
>
> --
> Sent from: http://protege-project.136.n4.nabble.com/Protege-User-f4659818.html
> _______________________________________________
> protege-user mailing list
> [hidden email]
> https://mailman.stanford.edu/mailman/listinfo/protege-user


_______________________________________________
protege-user mailing list
[hidden email]
https://mailman.stanford.edu/mailman/listinfo/protege-user
Reply | Threaded
Open this post in threaded view
|

Re: SQWRL Bag

Csongor Nyulas
Administrator
I would be VERY surprised if this would have something to do with the OS.
Are you sure, jgalan, that you used the exact same query and the exact same versions of Protege and SWRLTab plug-in in both OS?

Csongor

On 10/31/2017 04:16 PM, Martin O'Connor wrote:
Thanks for the update. I will try to dig up a Windows machine to test.

Martin

On Oct 31, 2017, at 2:17 PM, jgalan [hidden email] wrote:

I don't know what was the problem, when trying with the version of Protege
5.2 in Windows 10 the result of SQWRL was query S1 did not generate any
result, but when I tested the same query in Protege 5.2 in CentOs it worked
correctly.

<http://protege-project.136.n4.nabble.com/file/t376666/2017-10-31_16-12-20.png> 



--
Sent from: http://protege-project.136.n4.nabble.com/Protege-User-f4659818.html
_______________________________________________
protege-user mailing list
[hidden email]
https://mailman.stanford.edu/mailman/listinfo/protege-user

_______________________________________________
protege-user mailing list
[hidden email]
https://mailman.stanford.edu/mailman/listinfo/protege-user


_______________________________________________
protege-user mailing list
[hidden email]
https://mailman.stanford.edu/mailman/listinfo/protege-user