Snapshot 18

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

Snapshot 18

grantpax
Does snapshot 18 build for anyone? It doesn’t for me.

[INFO] ------------------------------------------------------------------------
[INFO] Reactor Summary:
[INFO] 
[INFO] Protege Desktop .................................... SUCCESS [  0.239 s]
[INFO] Protege Common ..................................... FAILURE [  4.194 s]
[INFO] Protege Editor Core ................................ SKIPPED
[INFO] Protege Editor OWL ................................. SKIPPED
[INFO] Protege Base ....................................... SKIPPED
[INFO] Protege Desktop Distribution ....................... SKIPPED
[INFO] ------------------------------------------------------------------------
[INFO] BUILD FAILURE
[INFO] ------------------------------------------------------------------------
[INFO] Total time: 5.462 s
[INFO] Finished at: 2015-03-20T08:12:59-04:00
[INFO] Final Memory: 10M/81M
[INFO] ------------------------------------------------------------------------
[ERROR] Failed to execute goal org.apache.maven.plugins:maven-compiler-plugin:3.0:compile (default-compile) on project org.protege.common: Fatal error compiling: invalid target release: 1.7 -> [Help 1]


_______________________________________________
protege-dev mailing list
[hidden email]
https://mailman.stanford.edu/mailman/listinfo/protege-dev
Reply | Threaded
Open this post in threaded view
|

Re: Snapshot 18

Simon Spero-2

I would guess that you (or maven) are trying to compile using jdk 1.6. Quite possibly you are using a Mac. Maven had special case default jdk detection that is very good at picking up the old apple JDK.

Try explicitly setting JAVA_HOME to point to 1.7 or 1.8 (but not 1.9 because OSGI)

If you are on a Mac, try

export JAVA_HOME=`/usr/libexec/java_home -v 1.8`

Simon

On Mar 20, 2015 10:10 AM, "Grant Pax" <[hidden email]> wrote:
Does snapshot 18 build for anyone? It doesn’t for me.

[INFO] ------------------------------------------------------------------------
[INFO] Reactor Summary:
[INFO] 
[INFO] Protege Desktop .................................... SUCCESS [  0.239 s]
[INFO] Protege Common ..................................... FAILURE [  4.194 s]
[INFO] Protege Editor Core ................................ SKIPPED
[INFO] Protege Editor OWL ................................. SKIPPED
[INFO] Protege Base ....................................... SKIPPED
[INFO] Protege Desktop Distribution ....................... SKIPPED
[INFO] ------------------------------------------------------------------------
[INFO] BUILD FAILURE
[INFO] ------------------------------------------------------------------------
[INFO] Total time: 5.462 s
[INFO] Finished at: 2015-03-20T08:12:59-04:00
[INFO] Final Memory: 10M/81M
[INFO] ------------------------------------------------------------------------
[ERROR] Failed to execute goal org.apache.maven.plugins:maven-compiler-plugin:3.0:compile (default-compile) on project org.protege.common: Fatal error compiling: invalid target release: 1.7 -> [Help 1]


_______________________________________________
protege-dev mailing list
[hidden email]
https://mailman.stanford.edu/mailman/listinfo/protege-dev


_______________________________________________
protege-dev mailing list
[hidden email]
https://mailman.stanford.edu/mailman/listinfo/protege-dev
Reply | Threaded
Open this post in threaded view
|

Re: Snapshot 18

grantpax
That was it. Sorry. I should have checked the JDK version before bothering anyone.

Thanks.

On Mar 20, 2015, at 4:56 PM, Simon Spero <[hidden email]> wrote:

I would guess that you (or maven) are trying to compile using jdk 1.6. Quite possibly you are using a Mac. Maven had special case default jdk detection that is very good at picking up the old apple JDK.

Try explicitly setting JAVA_HOME to point to 1.7 or 1.8 (but not 1.9 because OSGI)

If you are on a Mac, try

export JAVA_HOME=`/usr/libexec/java_home -v 1.8`

Simon

On Mar 20, 2015 10:10 AM, "Grant Pax" <[hidden email]> wrote:
Does snapshot 18 build for anyone? It doesn’t for me.

[INFO] ------------------------------------------------------------------------
[INFO] Reactor Summary:
[INFO] 
[INFO] Protege Desktop .................................... SUCCESS [  0.239 s]
[INFO] Protege Common ..................................... FAILURE [  4.194 s]
[INFO] Protege Editor Core ................................ SKIPPED
[INFO] Protege Editor OWL ................................. SKIPPED
[INFO] Protege Base ....................................... SKIPPED
[INFO] Protege Desktop Distribution ....................... SKIPPED
[INFO] ------------------------------------------------------------------------
[INFO] BUILD FAILURE
[INFO] ------------------------------------------------------------------------
[INFO] Total time: 5.462 s
[INFO] Finished at: 2015-03-20T08:12:59-04:00
[INFO] Final Memory: 10M/81M
[INFO] ------------------------------------------------------------------------
[ERROR] Failed to execute goal org.apache.maven.plugins:maven-compiler-plugin:3.0:compile (default-compile) on project org.protege.common: Fatal error compiling: invalid target release: 1.7 -> [Help 1]


_______________________________________________
protege-dev mailing list
[hidden email]
https://mailman.stanford.edu/mailman/listinfo/protege-dev

_______________________________________________
protege-dev mailing list
[hidden email]
https://mailman.stanford.edu/mailman/listinfo/protege-dev


_______________________________________________
protege-dev mailing list
[hidden email]
https://mailman.stanford.edu/mailman/listinfo/protege-dev
Reply | Threaded
Open this post in threaded view
|

Re: Snapshot 18

Simon Spero-2

It's a maven Trap! Worth having in the searchable archives.

See:
https://jira.codehaus.org/plugins/servlet/mobile#issue/MNG-5686

And the earlier:

https://jira.codehaus.org/plugins/servlet/mobile#issue/MNG-4226

On Mar 22, 2015 7:54 AM, "Grant Pax" <[hidden email]> wrote:
That was it. Sorry. I should have checked the JDK version before bothering anyone.

Thanks.

On Mar 20, 2015, at 4:56 PM, Simon Spero <[hidden email]> wrote:

I would guess that you (or maven) are trying to compile using jdk 1.6. Quite possibly you are using a Mac. Maven had special case default jdk detection that is very good at picking up the old apple JDK.

Try explicitly setting JAVA_HOME to point to 1.7 or 1.8 (but not 1.9 because OSGI)

If you are on a Mac, try

export JAVA_HOME=`/usr/libexec/java_home -v 1.8`

Simon

On Mar 20, 2015 10:10 AM, "Grant Pax" <[hidden email]> wrote:
Does snapshot 18 build for anyone? It doesn’t for me.

[INFO] ------------------------------------------------------------------------
[INFO] Reactor Summary:
[INFO] 
[INFO] Protege Desktop .................................... SUCCESS [  0.239 s]
[INFO] Protege Common ..................................... FAILURE [  4.194 s]
[INFO] Protege Editor Core ................................ SKIPPED
[INFO] Protege Editor OWL ................................. SKIPPED
[INFO] Protege Base ....................................... SKIPPED
[INFO] Protege Desktop Distribution ....................... SKIPPED
[INFO] ------------------------------------------------------------------------
[INFO] BUILD FAILURE
[INFO] ------------------------------------------------------------------------
[INFO] Total time: 5.462 s
[INFO] Finished at: 2015-03-20T08:12:59-04:00
[INFO] Final Memory: 10M/81M
[INFO] ------------------------------------------------------------------------
[ERROR] Failed to execute goal org.apache.maven.plugins:maven-compiler-plugin:3.0:compile (default-compile) on project org.protege.common: Fatal error compiling: invalid target release: 1.7 -> [Help 1]


_______________________________________________
protege-dev mailing list
[hidden email]
https://mailman.stanford.edu/mailman/listinfo/protege-dev

_______________________________________________
protege-dev mailing list
[hidden email]
https://mailman.stanford.edu/mailman/listinfo/protege-dev


_______________________________________________
protege-dev mailing list
[hidden email]
https://mailman.stanford.edu/mailman/listinfo/protege-dev


_______________________________________________
protege-dev mailing list
[hidden email]
https://mailman.stanford.edu/mailman/listinfo/protege-dev