UI problem - can't add views

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

UI problem - can't add views

Rich Morin
Here is a real show-stopper I've uncovered.  I'm using P4 (build
113) on a pair of multi-core Intel Macs, under Mac OS X 10.5.8
with all the latest Apple updates.

After starting up P4, I select (say) the "View > Ontology Views >
DL Metrics" menu item.  This should add a double circle to my
cursor, allowing me to position the new view in the current tab.

On my MacBook, this is just what happens.  On my Mac Pro, the
cursor doesn't change and no UI changes take place.  So, I can't
add views.

Looking in the highest-numbered log file on the Mac Pro, I see
no indication of a reported error (just a lot of INFO messages).
Is there something else I should try?

-r
--
http://www.cfcl.com/rdm            Rich Morin
http://www.cfcl.com/rdm/resume     [hidden email]
http://www.cfcl.com/rdm/weblog     +1 650-873-7841

Technical editing and writing, programming, and web development
_______________________________________________
p4-feedback mailing list
[hidden email]
https://mailman.stanford.edu/mailman/listinfo/p4-feedback
Reply | Threaded
Open this post in threaded view
|

Re: UI problem - can't add views

Timothy Redmond

One thing that you could try is to remove the java preferences file.  
On os x machines this is located at

        ~/Library/Preferences/com.apple.java.util.prefs.plist

Protege will forget your configuration (favorite fonts, recently  
accessed ontologies, etc) but this should not be too hard to restore.


-Timothy

On Sep 18, 2009, at 3:48 PM, Rich Morin wrote:

> Here is a real show-stopper I've uncovered.  I'm using P4 (build
> 113) on a pair of multi-core Intel Macs, under Mac OS X 10.5.8
> with all the latest Apple updates.
>
> After starting up P4, I select (say) the "View > Ontology Views >
> DL Metrics" menu item.  This should add a double circle to my
> cursor, allowing me to position the new view in the current tab.
>
> On my MacBook, this is just what happens.  On my Mac Pro, the
> cursor doesn't change and no UI changes take place.  So, I can't
> add views.
>
> Looking in the highest-numbered log file on the Mac Pro, I see
> no indication of a reported error (just a lot of INFO messages).
> Is there something else I should try?
>
> -r
> --
> http://www.cfcl.com/rdm            Rich Morin
> http://www.cfcl.com/rdm/resume     [hidden email]
> http://www.cfcl.com/rdm/weblog     +1 650-873-7841
>
> Technical editing and writing, programming, and web development
> _______________________________________________
> p4-feedback mailing list
> [hidden email]
> https://mailman.stanford.edu/mailman/listinfo/p4-feedback

_______________________________________________
p4-feedback mailing list
[hidden email]
https://mailman.stanford.edu/mailman/listinfo/p4-feedback
Reply | Threaded
Open this post in threaded view
|

Re: UI problem - can't add views

Rich Morin
At 08:57 -0700 9/21/09, Timothy Redmond wrote:
> ... remove the java preferences file.

After moving the file and running P4, I was able to add a new
view.  So, as an experiment, I moved the file back into place
and tried again.  Peculiarly, P4 still worked OK.  So, I'm no
longer stuck, but I'm still a bit confused.

I'll keep an eye on it and report any related behavior...

-r
--
http://www.cfcl.com/rdm            Rich Morin
http://www.cfcl.com/rdm/resume     [hidden email]
http://www.cfcl.com/rdm/weblog     +1 650-873-7841

Technical editing and writing, programming, and web development
_______________________________________________
p4-feedback mailing list
[hidden email]
https://mailman.stanford.edu/mailman/listinfo/p4-feedback