Wiew > Render by prefixed name problem with special characters in IRI

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Wiew > Render by prefixed name problem with special characters in IRI

Jos Lehmann-2

Hi there

 

I have individuals in an ontology with IRIs that contain special characters (e.g, § and &).

 

With option:    Wiew > Render by IRI short name (Id)    these names are displayed correctly.

   Ex: ...owl#F§S_P_S_S    is correctly displayed as    F§S_P_S_S

 

With the option:    Wiew > Render by prefixed name    these names are displayed incorrectly.

   Ex: ...owl#F§S_P_S_S    is incorrectly displayed as    prefix: S_P_S_S

 

Cheers, Jos

 


_______________________________________________
protege-user mailing list
[hidden email]
https://mailman.stanford.edu/mailman/listinfo/protege-user
Reply | Threaded
Open this post in threaded view
|

Re: Wiew > Render by prefixed name problem with special characters in IRI

Matthew Horridge-2
Administrator
Hi Jos,

This has been fixed and the fix will be available in the next release.

For more details see this issue: 


Cheers,

Matthew




On 15 Nov 2017, at 02:39, Jos Lehmann <[hidden email]> wrote:

Hi there
 
I have individuals in an ontology with IRIs that contain special characters (e.g, § and &).
 
With option:    Wiew > Render by IRI short name (Id)    these names are displayed correctly.
   Ex: ...owl#F§S_P_S_S    is correctly displayed as    F§S_P_S_S
 
With the option:    Wiew > Render by prefixed name    these names are displayed incorrectly.
   Ex: ...owl#F§S_P_S_S    is incorrectly displayed as    prefix: S_P_S_S
 
Cheers, Jos
 
_______________________________________________
protege-user mailing list
[hidden email]
https://mailman.stanford.edu/mailman/listinfo/protege-user


_______________________________________________
protege-user mailing list
[hidden email]
https://mailman.stanford.edu/mailman/listinfo/protege-user