error on ontology

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

error on ontology

Bohms, H.M. (Michel)

When I download an ontology from a build105 server and upload again on a build106 server I get errors.

Any idea?

 

 

Actual ont at: http://www.modelservers.org/public/ontologies/root-ontology.owl

Thx Michel

 

 

Dr. ir. H.M. (Michel) Böhms
Sr. Research Scientist
Technical Sciences

T +31 (0)88 866 31 07
M +31 (0)63 038 12 20
[hidden email]

Location
Disclaimer
 

 

 


_______________________________________________
webprotege-feedback mailing list
[hidden email]
https://mailman.stanford.edu/mailman/listinfo/webprotege-feedback
Reply | Threaded
Open this post in threaded view
|

Re: error on ontology

Matthew Horridge-2
Administrator
<base href="x-msg://380/">The file contains some characters which cause problems during parsing.

In the line

This type is used to indicate that the B-spline curve represents a part of a curve of some sppeci c form

There is a 0xC character in the word sppecic between the i and the last c.  You can't see it because it isn't a printable character.  Delete this character (in a text editor) and the resulting ontology is fine.

Do you have any idea where this could have come from?

Cheers,

Matthew





On 30 Sep 2013, at 09:46, "Bohms, H.M. (Michel)" <[hidden email]> wrote:

When I download an ontology from a build105 server and upload again on a build106 server I get errors.
Any idea?
 
 
Thx Michel
 
 
Dr. ir. H.M. (Michel) Böhms
Sr. Research Scientist
Technical Sciences
T +31 (0)88 866 31 07
M +31 (0)63 038 12 20
[hidden email]
 
 
_______________________________________________
webprotege-feedback mailing list
[hidden email]
https://mailman.stanford.edu/mailman/listinfo/webprotege-feedback


_______________________________________________
webprotege-feedback mailing list
[hidden email]
https://mailman.stanford.edu/mailman/listinfo/webprotege-feedback
Reply | Threaded
Open this post in threaded view
|

Re: error on ontology

Bohms, H.M. (Michel)
<base href="x-msg://380/">

I see it (now also via the tree)

Strange thing is: it was on a server already (http://bw-dssv13.bwk.tue.nl:8080/webprotege/#Edit:projectId=771f3abd-b739-443a-99ec-808994757806) so it once uploaded ok….

 

After correction of this string after download still not ok so I will get back to the source generator…….

 

Thx Michel

 

 

Dr. ir. H.M. (Michel) Böhms
Sr. Research Scientist
Technical Sciences

T +31 (0)88 866 31 07
M +31 (0)63 038 12 20
[hidden email]

Location
Disclaimer
 

 

 

From: [hidden email] [mailto:[hidden email]] On Behalf Of Matthew Horridge
Sent: maandag 30 september 2013 18:16
To: [hidden email]
Subject: Re: [webprotege-feedback] error on ontology

 

The file contains some characters which cause problems during parsing.

 

In the line

 

This type is used to indicate that the B-spline curve represents a part of a curve of some sppeci
c form

 

There is a 0xC character in the word sppecic between the i and the last c.  You can't see it because it isn't a printable character.  Delete this character (in a text editor) and the resulting ontology is fine.

 

Do you have any idea where this could have come from?

 

Cheers,

 

Matthew

 

 

 

 

 

On 30 Sep 2013, at 09:46, "Bohms, H.M. (Michel)" <[hidden email]> wrote:



When I download an ontology from a build105 server and upload again on a build106 server I get errors.

Any idea?

 

 

Thx Michel

 

 

Dr. ir. H.M. (Michel) Böhms
Sr. Research Scientist
Technical Sciences

T +31 (0)88 866 31 07
M +31 (0)63 038 12 20
[hidden email]

 

 

_______________________________________________
webprotege-feedback mailing list
[hidden email]
https://mailman.stanford.edu/mailman/listinfo/webprotege-feedback

 


_______________________________________________
webprotege-feedback mailing list
[hidden email]
https://mailman.stanford.edu/mailman/listinfo/webprotege-feedback
Reply | Threaded
Open this post in threaded view
|

Re: error on ontology

Bohms, H.M. (Michel)
In reply to this post by Matthew Horridge-2
<base href="x-msg://380/">

Moreover…corrected file uploaded after fine on my local (windows) machine

Error persist when uploading to our linux machine (both b106)

(so I guess some differences in treatment of special characters between wondows and linux..?)

 

ErrorLog on linux says:

 

 

 

 

Dr. ir. H.M. (Michel) Böhms
Sr. Research Scientist
Technical Sciences

T +31 (0)88 866 31 07
M +31 (0)63 038 12 20
[hidden email]

Location
Disclaimer
 

 

 

From: [hidden email] [mailto:[hidden email]] On Behalf Of Matthew Horridge
Sent: maandag 30 september 2013 18:16
To: [hidden email]
Subject: Re: [webprotege-feedback] error on ontology

 

The file contains some characters which cause problems during parsing.

 

In the line

 

This type is used to indicate that the B-spline curve represents a part of a curve of some sppeci
c form

 

There is a 0xC character in the word sppecic between the i and the last c.  You can't see it because it isn't a printable character.  Delete this character (in a text editor) and the resulting ontology is fine.

 

Do you have any idea where this could have come from?

 

Cheers,

 

Matthew

 

 

 

 

 

On 30 Sep 2013, at 09:46, "Bohms, H.M. (Michel)" <[hidden email]> wrote:



When I download an ontology from a build105 server and upload again on a build106 server I get errors.

Any idea?

 

 

Thx Michel

 

 

Dr. ir. H.M. (Michel) Böhms
Sr. Research Scientist
Technical Sciences

T +31 (0)88 866 31 07
M +31 (0)63 038 12 20
[hidden email]

 

 

_______________________________________________
webprotege-feedback mailing list
[hidden email]
https://mailman.stanford.edu/mailman/listinfo/webprotege-feedback

 


_______________________________________________
webprotege-feedback mailing list
[hidden email]
https://mailman.stanford.edu/mailman/listinfo/webprotege-feedback
Reply | Threaded
Open this post in threaded view
|

Re: error on ontology

Bohms, H.M. (Michel)
In reply to this post by Matthew Horridge-2
<base href="x-msg://380/">

The log file

 

Problem seems:

 

Message: Service method 'public abstract edu.stanford.bmir.protege.web.shared.project.ProjectDetails edu.stanford.bmir.protege.web.client.rpc.ProjectManagerService.createNewProject(edu.stanford.bmir.protege.web.client.rpc.data.NewProjectSettings) throws edu.stanford.bmir.protege.web.client.rpc.data.NotSignedInException,edu.stanford.bmir.protege.web.shared.project.ProjectAlreadyRegisteredException,edu.stanford.bmir.protege.web.shared.project.ProjectDocumentExistsException' threw an unexpected exception: java.lang.OutOfMemoryError: Java heap space

 

Please advice

 

current setting: # local config settings

JAVA_OPTS="-Xms5000m -Xmx13000m

 

 

 

Ps see also the error:

“Problem emailing message There was an error sending email to  [hidden email]. Message: Could not connect to SMTP host: smtp.googlemail.com, port: 465”

 

 

Dr. ir. H.M. (Michel) Böhms
Sr. Research Scientist
Technical Sciences

T +31 (0)88 866 31 07
M +31 (0)63 038 12 20
[hidden email]

Location
Disclaimer
 

 

 

From: Bohms, H.M. (Michel)
Sent: dinsdag 1 oktober 2013 11:46
To: [hidden email]
Subject: RE: [webprotege-feedback] error on ontology

 

Moreover…corrected file uploaded after fine on my local (windows) machine

Error persist when uploading to our linux machine (both b106)

(so I guess some differences in treatment of special characters between wondows and linux..?)

 

ErrorLog on linux says:

 

 

 

 

Dr. ir. H.M. (Michel) Böhms
Sr. Research Scientist
Technical Sciences

T +31 (0)88 866 31 07
M +31 (0)63 038 12 20
[hidden email]

Location
Disclaimer
 

 

 

From: [hidden email] [[hidden email]] On Behalf Of Matthew Horridge
Sent: maandag 30 september 2013 18:16
To: [hidden email]
Subject: Re: [webprotege-feedback] error on ontology

 

The file contains some characters which cause problems during parsing.

 

In the line

 

This type is used to indicate that the B-spline curve represents a part of a curve of some sppeci
c form

 

There is a 0xC character in the word sppecic between the i and the last c.  You can't see it because it isn't a printable character.  Delete this character (in a text editor) and the resulting ontology is fine.

 

Do you have any idea where this could have come from?

 

Cheers,

 

Matthew

 

 

 

 

 

On 30 Sep 2013, at 09:46, "Bohms, H.M. (Michel)" <[hidden email]> wrote:

 

When I download an ontology from a build105 server and upload again on a build106 server I get errors.

Any idea?

 

 

Thx Michel

 

 

Dr. ir. H.M. (Michel) Böhms
Sr. Research Scientist
Technical Sciences

T +31 (0)88 866 31 07
M +31 (0)63 038 12 20
[hidden email]

 

 

_______________________________________________
webprotege-feedback mailing list
[hidden email]
https://mailman.stanford.edu/mailman/listinfo/webprotege-feedback

 


_______________________________________________
webprotege-feedback mailing list
[hidden email]
https://mailman.stanford.edu/mailman/listinfo/webprotege-feedback

catalina.2013-10-01.log (13K) Download Attachment