inquiry about CompGuide editor plugin

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

inquiry about CompGuide editor plugin

LI Haiming

Hello,

 

Is there anyone who had experience in CompGuide editor plugin?

 

https://protegewiki.stanford.edu/wiki/CompGuide_Editor says there was a version 1.0 ever released in 2017. According to the wiki page, CompGuide Editor 1.0 works with Protégé 4.3.

 

However we now have Protégé 5.5.0 as the latest version.

 

So questions:

1.     Is there a newer version of CompGuide editor?

2.     What is the latest status/progress of CompGuide editor? Is it still active?

3.     For Protégé 5.5.0, is CompGuide editor 1.0 workable? I tried but seems CompGuide Wizard does not work. Not sure if it is caused by incompatibility or my misconfiguration?

 

Looking forward a positive advice.

Thanks.

 

Haiming LI

 


_______________________________________________
protege-user mailing list
[hidden email]
https://mailman.stanford.edu/mailman/listinfo/protege-user
Reply | Threaded
Open this post in threaded view
|

Re: inquiry about CompGuide editor plugin

samsontu
Hi,

On Sep 18, 2019, at 8:39 AM, LI Haiming <[hidden email]> wrote:
 
Is there anyone who had experience in CompGuide editor plugin?

I have no experience using CompGuide, but I took a look out of professional curiosity.
 
https://protegewiki.stanford.edu/wiki/CompGuide_Editor says there was a version 1.0 ever released in 2017. According to the wiki page, CompGuide Editor 1.0 works with Protégé 4.3.
 
However we now have Protégé 5.5.0 as the latest version.
 
So questions:
1.     Is there a newer version of CompGuide editor?

Apparently no. There is only one commit in the ComGuide GitHub repository.

2.     What is the latest status/progress of CompGuide editor? Is it still active?

You should contact the developer, whose email is available at


3.     For Protégé 5.5.0, is CompGuide editor 1.0 workable? I tried but seems CompGuide Wizard does not work. Not sure if it is caused by incompatibility or my misconfiguration?

The cguide code throws an exception upon opening the tab. My conclusion is that the editor doesn’t work in Protege 5.5.

With best regards,
Samson


_______________________________________________
protege-user mailing list
[hidden email]
https://mailman.stanford.edu/mailman/listinfo/protege-user

smime.p7s (1K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: inquiry about CompGuide editor plugin

LI Haiming
In reply to this post by LI Haiming

Professor TU, Thank you for your response.

 

This is to close this thread. I Just like to share a further try on CompGuide 1.0 with Protege 4.3.

 

I managed to install Protege 4.3 from https://protege.stanford.edu/download/protege/4.3/installanywhere/Web_Installers/.

Then put org.di.uminho.cguide.menu.jar from the github, under ...\Protege_4.3\plugins\.

 

When selecting CGuide from menu->Window->Tab->CGuide Editor, i still get below exception.

 

####

Plugin: Cajun Visualization Plugin (1.0.0.2013_04_15_0104)

Plugin: Dlquery (1.1.0.2013_04_15_0104)

Plugin: OWLViz (4.1.2.2013_04_15_0103)

Plugin: CGuide Plugin (1.0.0.2016_09_29_0349)

Plugin: Protege OWL Code Generation (1.1.0.2013_04_15_0104)

Plugin: OWL Diff Tool (1.0.0.2013_04_15_0104)

Plugin: The Protege 4 OWL Editor (4.3.0.b304_2013_04_15_0103)

Plugin: Protege SPARQL Plugin (1.0.0.2013_04_15_0104)

Plugin: Explanation Workbench (1.0.0.2013_04_15_0104)

Plugin: OntoGraf Plug-in (1.0.1.2013_04_15_0104)

Plugin: OWL Diff Library (1.0.0.2013_04_15_0104)

Plugin: OWLAPI-RDF Library (1.0.0.2013_04_15_0104)

Plugin: HermiT Reasoner (1.3.7)

Plugin: The OWL API (3.4.2.2012_12_05)

Plugin: Factplusplus Plug-in (1.6.2)

     Cajun Visualization Plugin Plugin has no plugin.xml resource

        OWLAPI-RDF Library Plugin has no plugin.xml resource

2019-9-19 12:47:10 java.util.prefs.WindowsPreferences <init>

璀﹀憡: Could not open/create prefs root node Software\JavaSoft\Prefs at root 0x80000002. Windows RegCreateKeyEx(...) returned error code 5.

Using OWL API version 3.4.2

Rebuilding entity indices...

... rebuilt in 6 ms

Setting active ontology to OntologyID(OntologyIRI(<http://www.semanticweb.org/haimingli/ontologies/2019/8/untitled-ontology-19>))

Rebuilding entity indices...

... rebuilt in 1 ms

... active ontology changed

Cannot generate ontology catalog for ontology at http://www.semanticweb.org/haimingli/ontologies/2019/8/untitled-ontology-19

Setting active ontology to OntologyID(OntologyIRI(<http://www.semanticweb.org/haimingli/ontologies/2019/8/untitled-ontology-19>))

Rebuilding entity indices...

... rebuilt in 1 ms

... active ontology changed

Error logged

java.lang.UnsupportedClassVersionError: org/di/uminho/cguide/menu/ViewComponent : Unsupported major.minor version 52.0

        at java.lang.ClassLoader.defineClass1(Native Method)

        at java.lang.ClassLoader.defineClassCond(Unknown Source)

        at java.lang.ClassLoader.defineClass(Unknown Source)

        at org.apache.felix.framework.BundleWiringImpl$BundleClassLoader.findClass(BundleWiringImpl.java:2128)

        at org.apache.felix.framework.BundleWiringImpl.findClassOrResourceByDelegation(BundleWiringImpl.java:1432)

        at org.apache.felix.framework.BundleWiringImpl.access$400(BundleWiringImpl.java:72)

        at org.apache.felix.framework.BundleWiringImpl$BundleClassLoader.loadClass(BundleWiringImpl.java:1843)

        at java.lang.ClassLoader.loadClass(Unknown Source)

        at org.apache.felix.framework.Felix.loadBundleClass(Felix.java:1723)

####


_______________________________________________
protege-user mailing list
[hidden email]
https://mailman.stanford.edu/mailman/listinfo/protege-user
Reply | Threaded
Open this post in threaded view
|

inquiry about CompGuide editor plugin

LI Haiming
In reply to this post by LI Haiming

Professor TU, Thank you for your response.

 

This is to close this thread. I Just like to share a further try on CompGuide 1.0 with Protege 4.3.

 

I managed to install Protege 4.3 from https://protege.stanford.edu/download/protege/4.3/installanywhere/Web_Installers/.

Then put org.di.uminho.cguide.menu.jar from the github, under ...\Protege_4.3\plugins\.

 

When selecting CGuide from menu->Window->Tab->CGuide Editor, i still get below exception.

 

####

Plugin: Cajun Visualization Plugin (1.0.0.2013_04_15_0104)

Plugin: Dlquery (1.1.0.2013_04_15_0104)

Plugin: OWLViz (4.1.2.2013_04_15_0103)

Plugin: CGuide Plugin (1.0.0.2016_09_29_0349)

Plugin: Protege OWL Code Generation (1.1.0.2013_04_15_0104)

Plugin: OWL Diff Tool (1.0.0.2013_04_15_0104)

Plugin: The Protege 4 OWL Editor (4.3.0.b304_2013_04_15_0103)

Plugin: Protege SPARQL Plugin (1.0.0.2013_04_15_0104)

Plugin: Explanation Workbench (1.0.0.2013_04_15_0104)

Plugin: OntoGraf Plug-in (1.0.1.2013_04_15_0104)

Plugin: OWL Diff Library (1.0.0.2013_04_15_0104)

Plugin: OWLAPI-RDF Library (1.0.0.2013_04_15_0104)

Plugin: HermiT Reasoner (1.3.7)

Plugin: The OWL API (3.4.2.2012_12_05)

Plugin: Factplusplus Plug-in (1.6.2)

     Cajun Visualization Plugin Plugin has no plugin.xml resource

        OWLAPI-RDF Library Plugin has no plugin.xml resource

2019-9-19 12:47:10 java.util.prefs.WindowsPreferences <init>

璀﹀憡: Could not open/create prefs root node Software\JavaSoft\Prefs at root 0x80000002. Windows RegCreateKeyEx(...) returned error code 5.

Using OWL API version 3.4.2

Rebuilding entity indices...

... rebuilt in 6 ms

Setting active ontology to OntologyID(OntologyIRI(<http://www.semanticweb.org/haimingli/ontologies/2019/8/untitled-ontology-19>))

Rebuilding entity indices...

... rebuilt in 1 ms

... active ontology changed

Cannot generate ontology catalog for ontology at http://www.semanticweb.org/haimingli/ontologies/2019/8/untitled-ontology-19

Setting active ontology to OntologyID(OntologyIRI(<http://www.semanticweb.org/haimingli/ontologies/2019/8/untitled-ontology-19>))

Rebuilding entity indices...

... rebuilt in 1 ms

... active ontology changed

Error logged

java.lang.UnsupportedClassVersionError: org/di/uminho/cguide/menu/ViewComponent : Unsupported major.minor version 52.0

        at java.lang.ClassLoader.defineClass1(Native Method)

        at java.lang.ClassLoader.defineClassCond(Unknown Source)

        at java.lang.ClassLoader.defineClass(Unknown Source)

        at org.apache.felix.framework.BundleWiringImpl$BundleClassLoader.findClass(BundleWiringImpl.java:2128)

        at org.apache.felix.framework.BundleWiringImpl.findClassOrResourceByDelegation(BundleWiringImpl.java:1432)

        at org.apache.felix.framework.BundleWiringImpl.access$400(BundleWiringImpl.java:72)

        at org.apache.felix.framework.BundleWiringImpl$BundleClassLoader.loadClass(BundleWiringImpl.java:1843)

        at java.lang.ClassLoader.loadClass(Unknown Source)

        at org.apache.felix.framework.Felix.loadBundleClass(Felix.java:1723)

####


_______________________________________________
protege-user mailing list
[hidden email]
https://mailman.stanford.edu/mailman/listinfo/protege-user
Reply | Threaded
Open this post in threaded view
|

Re: inquiry about CompGuide editor plugin

Lorenz Buehmann

Protege 4.x is Java 7, you tried it with Java 8.

On 19.09.19 13:46, LI Haiming wrote:
Unsupported major.minor version 52.0

_______________________________________________
protege-user mailing list
[hidden email]
https://mailman.stanford.edu/mailman/listinfo/protege-user