[protege-owl] Problem with OS X protege

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

[protege-owl] Problem with OS X protege

Adam M. Goldstein
Hello all! This is my first post to the list . . .

I have been having a problem with the mac version of protege. What  
happens is that saving the file becomes slower and slower, sometimes  
taking several minutes at 100% processor load. Then, when I open the  
file again, the back end of it is cut off, meaning that it will not  
open properly without my fixing certain tags by hand, and also, much  
of the file is lost.

As well, after running the program for a while, it slows down  
considerably, taking 15-30 seconds to draw the windows.

This is all working on the pizza tutorial, so it's not as though I am  
doing something extreme.

OS is 10.4.8, on a macbook pro. I have whatever the stock install of  
java is; I wouldn't even really know how to get more information on  
that. Protege is 3.2.

Any ideas about what to do? Anyone else with this kind of problem?

-Adam
--
Dr. Adam M. Goldstein
amgoldstein <at> mac <dot> com
http://homepage.mac.com/amgoldstein



_______________________________________________
protege-owl mailing list
[hidden email]
https://mailman.stanford.edu/mailman/listinfo/protege-owl

Instructions for unsubscribing: http://protege.stanford.edu/doc/faq.html#01a.03 
Reply | Threaded
Open this post in threaded view
|

Re: [protege-owl] Problem with OS X protege

Doug Holmes
Hello Adam,
        By way of introducing some sort of confidence, I've been using  
Protégé on two Macs for the last three years and have not seen this  
sort of problem [or any significant problems, for that matter].  Have  
you installed the "full" version for Mac OSX? If not, I suggest you  
do that.  I also think you'll like the "Mac OS X" Look and Feel  
[ Windows | Look and Feel | Mac OS X].  Possibly you need to increase  
the memory for the JVM. For that, see:
http://protege.cim3.net/cgi-bin/wiki.pl?ScalabilityAndTuning
http://protege.cim3.net/cgi-bin/wiki.pl?SettingHeapSize
Otherwise, I'm out of ideas ...
Good luck,
Doug

On Jan 22, 2007, at 4:13 PM, Adam M. Goldstein wrote:

> Hello all! This is my first post to the list . . .
>
> I have been having a problem with the mac version of protege. What
> happens is that saving the file becomes slower and slower, sometimes
> taking several minutes at 100% processor load. Then, when I open the
> file again, the back end of it is cut off, meaning that it will not
> open properly without my fixing certain tags by hand, and also, much
> of the file is lost.
>
> As well, after running the program for a while, it slows down
> considerably, taking 15-30 seconds to draw the windows.
>
> This is all working on the pizza tutorial, so it's not as though I am
> doing something extreme.
>
> OS is 10.4.8, on a macbook pro. I have whatever the stock install of
> java is; I wouldn't even really know how to get more information on
> that. Protege is 3.2.
>
> Any ideas about what to do? Anyone else with this kind of problem?
>
> -Adam
> --
> Dr. Adam M. Goldstein
> amgoldstein <at> mac <dot> com
> http://homepage.mac.com/amgoldstein
>
>
>
> _______________________________________________
> protege-owl mailing list
> [hidden email]
> https://mailman.stanford.edu/mailman/listinfo/protege-owl
>
> Instructions for unsubscribing: http://protege.stanford.edu/doc/ 
> faq.html#01a.03
>

_______________________________________________
protege-owl mailing list
[hidden email]
https://mailman.stanford.edu/mailman/listinfo/protege-owl

Instructions for unsubscribing: http://protege.stanford.edu/doc/faq.html#01a.03 
Reply | Threaded
Open this post in threaded view
|

Re: [protege-owl] Problem with OS X protege

Thomas Russ

On Jan 22, 2007, at 5:18 PM, Doug Holmes wrote:

>  Possibly you need to increase
> the memory for the JVM. For that, see:
> http://protege.cim3.net/cgi-bin/wiki.pl?ScalabilityAndTuning
> http://protege.cim3.net/cgi-bin/wiki.pl?SettingHeapSize
> Otherwise, I'm out of ideas ...

I'm almost certain that this is the source of the problem.

I find that I always need to increase the size of the JVM memory  
parameters each time I upgrade Protege on my Mac.

I think that the configuration that currently is distributed uses  
ludicrously low values for starting heap ( 9 MB IIRC) and maximum  
heap size ( 64 MB?).

My suggestion to users is to increase these sizes a lot.  I would  
hope that the Protege build could be changed to increase these  
parameters as well, especially the maximum size.  Performance when  
memory is short is very sluggish, which reflects poorly on the tool.  
And losing data when the save crashes due to lack of memory  
undermines user confidence.

-Tom.


_______________________________________________
protege-owl mailing list
[hidden email]
https://mailman.stanford.edu/mailman/listinfo/protege-owl

Instructions for unsubscribing: http://protege.stanford.edu/doc/faq.html#01a.03 
Reply | Threaded
Open this post in threaded view
|

Re: [protege-owl] Problem with OS X protege

Adam M. Goldstein
In reply to this post by Doug Holmes
On Jan 22, 2007, at 8:18 PM, Doug Holmes wrote:

> Hello Adam,
> By way of introducing some sort of confidence, I've been using
> Protégé on two Macs for the last three years and have not seen this
> sort of problem [or any significant problems, for that matter].  Have
> you installed the "full" version for Mac OSX? If not, I suggest you
> do that.  I also think you'll like the "Mac OS X" Look and Feel
> [ Windows | Look and Feel | Mac OS X].  Possibly you need to increase
> the memory for the JVM. For that, see:
> http://protege.cim3.net/cgi-bin/wiki.pl?ScalabilityAndTuning
> http://protege.cim3.net/cgi-bin/wiki.pl?SettingHeapSize
> Otherwise, I'm out of ideas ...
> Good luck,
> Doug
>


Doug,

Thanks for the quick response and positive report. Hunting around in  
the console logs and google led me to the memory problem. To be on  
the safe side I am uninstalling and re-installing the full version,  
although it seems to me that that ought'nt to be necessary.

thanks for the links---I will report back to the list with my results.

> On Jan 22, 2007, at 4:13 PM, Adam M. Goldstein wrote:
>
>> Hello all! This is my first post to the list . . .
>>
>> I have been having a problem with the mac version of protege. What
>> happens is that saving the file becomes slower and slower, sometimes
>> taking several minutes at 100% processor load. Then, when I open the
>> file again, the back end of it is cut off, meaning that it will not
>> open properly without my fixing certain tags by hand, and also, much
>> of the file is lost.
>>
>> As well, after running the program for a while, it slows down
>> considerably, taking 15-30 seconds to draw the windows.
>>
>> This is all working on the pizza tutorial, so it's not as though I am
>> doing something extreme.
>>
>> OS is 10.4.8, on a macbook pro. I have whatever the stock install of
>> java is; I wouldn't even really know how to get more information on
>> that. Protege is 3.2.
>>
>> Any ideas about what to do? Anyone else with this kind of problem?
>>
>> -Adam
>> --
>> Dr. Adam M. Goldstein
>> amgoldstein <at> mac <dot> com
>> http://homepage.mac.com/amgoldstein
>>
>>
>>
>> _______________________________________________
>> protege-owl mailing list
>> [hidden email]
>> https://mailman.stanford.edu/mailman/listinfo/protege-owl
>>
>> Instructions for unsubscribing: http://protege.stanford.edu/doc/
>> faq.html#01a.03
>>
>
> _______________________________________________
> protege-owl mailing list
> [hidden email]
> https://mailman.stanford.edu/mailman/listinfo/protege-owl
>
> Instructions for unsubscribing: http://protege.stanford.edu/doc/ 
> faq.html#01a.03

--
Dr. Adam M. Goldstein
amgoldstein <at> mac <dot> com
http://homepage.mac.com/amgoldstein



_______________________________________________
protege-owl mailing list
[hidden email]
https://mailman.stanford.edu/mailman/listinfo/protege-owl

Instructions for unsubscribing: http://protege.stanford.edu/doc/faq.html#01a.03 
Reply | Threaded
Open this post in threaded view
|

Re: [protege-owl] Problem with OS X protege

Adam M. Goldstein
In reply to this post by Doug Holmes
On Jan 22, 2007, at 8:18 PM, Doug Holmes wrote:

> Hello Adam,
> By way of introducing some sort of confidence, I've been using
> Protégé on two Macs for the last three years and have not seen this
> sort of problem [or any significant problems, for that matter].  Have
> you installed the "full" version for Mac OSX? If not, I suggest you
> do that.  I also think you'll like the "Mac OS X" Look and Feel
> [ Windows | Look and Feel | Mac OS X].  Possibly you need to increase
> the memory for the JVM. For that, see:
> http://protege.cim3.net/cgi-bin/wiki.pl?ScalabilityAndTuning
> http://protege.cim3.net/cgi-bin/wiki.pl?SettingHeapSize
> Otherwise, I'm out of ideas ...
> Good luck,
> Doug
>

I followed the instructions in these links and upped the minimum  
memory to 27 MB and the max to 285 MB, thereby tripling both.  
Performance is significantly increased. The gene ontology term  
database loaded up right away; it had hardly started up at all  
before. Let's hope it sticks.

Also I installed the "Full" version ("everything" option). Before I  
had only the "OWL" option.

Thanks Doug and Thomas.

-Adam


> On Jan 22, 2007, at 4:13 PM, Adam M. Goldstein wrote:
>
>> Hello all! This is my first post to the list . . .
>>
>> I have been having a problem with the mac version of protege. What
>> happens is that saving the file becomes slower and slower, sometimes
>> taking several minutes at 100% processor load. Then, when I open the
>> file again, the back end of it is cut off, meaning that it will not
>> open properly without my fixing certain tags by hand, and also, much
>> of the file is lost.
>>
>> As well, after running the program for a while, it slows down
>> considerably, taking 15-30 seconds to draw the windows.
>>
>> This is all working on the pizza tutorial, so it's not as though I am
>> doing something extreme.
>>
>> OS is 10.4.8, on a macbook pro. I have whatever the stock install of
>> java is; I wouldn't even really know how to get more information on
>> that. Protege is 3.2.
>>
>> Any ideas about what to do? Anyone else with this kind of problem?
>>
>> -Adam
>> --
>> Dr. Adam M. Goldstein
>> amgoldstein <at> mac <dot> com
>> http://homepage.mac.com/amgoldstein
>>
>>
>>
>> _______________________________________________
>> protege-owl mailing list
>> [hidden email]
>> https://mailman.stanford.edu/mailman/listinfo/protege-owl
>>
>> Instructions for unsubscribing: http://protege.stanford.edu/doc/
>> faq.html#01a.03
>>
>
> _______________________________________________
> protege-owl mailing list
> [hidden email]
> https://mailman.stanford.edu/mailman/listinfo/protege-owl
>
> Instructions for unsubscribing: http://protege.stanford.edu/doc/ 
> faq.html#01a.03

--
Dr. Adam M. Goldstein
amgoldstein <at> mac <dot> com
http://homepage.mac.com/amgoldstein



_______________________________________________
protege-owl mailing list
[hidden email]
https://mailman.stanford.edu/mailman/listinfo/protege-owl

Instructions for unsubscribing: http://protege.stanford.edu/doc/faq.html#01a.03