protege4 build 53

classic Classic list List threaded Threaded
10 messages Options
Reply | Threaded
Open this post in threaded view
|

protege4 build 53

mixalisfot
I am looking for an older version of protege.
Specifically version 4 build 53. The older version that i found in downloads area of standford is build 56
but i need immediately the former build.

I am really sorry for any inconvenience but i would appreciated if you
could send me or provided me with a link or email that i have to refer.
Reply | Threaded
Open this post in threaded view
|

Re: protege4 build 53

Jennifer Vendetti
Administrator
mixalisfot wrote:
> I am looking for an older version of protege.  Specifically version 4 build 53. The older version that i found in downloads
> area of standford is build 56 but i need immediately the former build.
>  

Usually we are good about keeping backup copies of old release and beta
builds (and sometimes even alphas), but I can't find this one.  I think
this was before we even had a platform independent installer and were
just posting ZIP files.

Nick - any possibility you have a copy of this build somewhere at
Manchester?

Jennifer

_______________________________________________
p4-feedback mailing list
[hidden email]
https://mailman.stanford.edu/mailman/listinfo/p4-feedback
Reply | Threaded
Open this post in threaded view
|

Re: protege4 build 53

mixalisfot
I am using the latest versions of protege to build ontologies. However i found a tutorial and some plugins that from a researcher that run without errors only in the version 4 alpha build 53. For this reason i didn't backup older versions. His version uses pelet reasoner and an owl api that the other versions of protege lead to java errors. I am looking for this version because i want to complete my phd thesis with one chapter on semantic web and specifically on protege.

Thank you very much.

On Wed, Jul 15, 2009 at 2:40 AM, Jennifer Vendetti <[hidden email]> wrote:
mixalisfot wrote:
I am looking for an older version of protege.  Specifically version 4 build 53. The older version that i found in downloads
area of standford is build 56 but i need immediately the former build.
 

Usually we are good about keeping backup copies of old release and beta builds (and sometimes even alphas), but I can't find this one.  I think this was before we even had a platform independent installer and were just posting ZIP files.

Nick - any possibility you have a copy of this build somewhere at Manchester?

Jennifer


_______________________________________________
p4-feedback mailing list
[hidden email]
https://mailman.stanford.edu/mailman/listinfo/p4-feedback


_______________________________________________
p4-feedback mailing list
[hidden email]
https://mailman.stanford.edu/mailman/listinfo/p4-feedback
Reply | Threaded
Open this post in threaded view
|

Re: protege4 build 53

mixalisfot
nobody????




mixalisfot wrote
I am using the latest versions of protege to build ontologies. However i
found a tutorial and some plugins that from a researcher that run without
errors only in the version 4 alpha build 53. For this reason i didn't backup
older versions. His version uses pelet reasoner and an owl api that the
other versions of protege lead to java errors. I am looking for this version
because i want to complete my phd thesis with one chapter on semantic web
and specifically on protege.

Thank you very much.

On Wed, Jul 15, 2009 at 2:40 AM, Jennifer Vendetti <vendetti@stanford.edu>wrote:

> mixalisfot wrote:
>
>> I am looking for an older version of protege.  Specifically version 4
>> build 53. The older version that i found in downloads
>> area of standford is build 56 but i need immediately the former build.
>>
>>
>
> Usually we are good about keeping backup copies of old release and beta
> builds (and sometimes even alphas), but I can't find this one.  I think this
> was before we even had a platform independent installer and were just
> posting ZIP files.
>
> Nick - any possibility you have a copy of this build somewhere at
> Manchester?
>
> Jennifer
>
>
> _______________________________________________
> p4-feedback mailing list
> p4-feedback@lists.stanford.edu
> https://mailman.stanford.edu/mailman/listinfo/p4-feedback
>

_______________________________________________
p4-feedback mailing list
p4-feedback@lists.stanford.edu
https://mailman.stanford.edu/mailman/listinfo/p4-feedback
Reply | Threaded
Open this post in threaded view
|

Re: protege4 build 53

Nick Drummond
Afraid not. That is a very old version.
What plugin is it? Does the researcher who wrote it not have a version?

Nick

2009/7/21 mixalisfot <[hidden email]>:

>
> nobody????
>
>
>
>
>
> mixalisfot wrote:
>>
>> I am using the latest versions of protege to build ontologies. However i
>> found a tutorial and some plugins that from a researcher that run without
>> errors only in the version 4 alpha build 53. For this reason i didn't
>> backup
>> older versions. His version uses pelet reasoner and an owl api that the
>> other versions of protege lead to java errors. I am looking for this
>> version
>> because i want to complete my phd thesis with one chapter on semantic web
>> and specifically on protege.
>>
>> Thank you very much.
>>
>> On Wed, Jul 15, 2009 at 2:40 AM, Jennifer Vendetti
>> <[hidden email]>wrote:
>>
>>> mixalisfot wrote:
>>>
>>>> I am looking for an older version of protege.  Specifically version 4
>>>> build 53. The older version that i found in downloads
>>>> area of standford is build 56 but i need immediately the former build.
>>>>
>>>>
>>>
>>> Usually we are good about keeping backup copies of old release and beta
>>> builds (and sometimes even alphas), but I can't find this one.  I think
>>> this
>>> was before we even had a platform independent installer and were just
>>> posting ZIP files.
>>>
>>> Nick - any possibility you have a copy of this build somewhere at
>>> Manchester?
>>>
>>> Jennifer
>>>
>>>
>>> _______________________________________________
>>> p4-feedback mailing list
>>> [hidden email]
>>> https://mailman.stanford.edu/mailman/listinfo/p4-feedback
>>>
>>
>> _______________________________________________
>> p4-feedback mailing list
>> [hidden email]
>> https://mailman.stanford.edu/mailman/listinfo/p4-feedback
>>
>>
>
> --
> View this message in context: http://www.nabble.com/protege4-build-53-tp24467296p24579134.html
> Sent from the Protege - Protege 4 Feedback mailing list archive at Nabble.com.
>
> _______________________________________________
> p4-feedback mailing list
> [hidden email]
> https://mailman.stanford.edu/mailman/listinfo/p4-feedback
>
_______________________________________________
p4-feedback mailing list
[hidden email]
https://mailman.stanford.edu/mailman/listinfo/p4-feedback
Reply | Threaded
Open this post in threaded view
|

Re: protege4 build 53

mixalisfot
it is a plugin made by hand in java...The author doesn't have anymore this version.

The error i get with the build 56 when i activate pellet as a reasoner (for this reason i want 53) is the following:

Error 1 Logged at Wed Jul 22 17:41:24 EEST 2009
InconsistentOntologyException: Cannot do reasoning with inconsistent ontologies!
    org.mindswap.pellet.KnowledgeBase.ensureConsistency(KnowledgeBase.java:1595)
    org.mindswap.pellet.KnowledgeBase.classify(KnowledgeBase.java:1600)
    org.mindswap.pellet.owlapi.Reasoner.classify(Reasoner.java:256)
    com.owldl.pellet.PelletReasonerWrapper.classify(PelletReasonerWrapper.java:63)
    org.protege.editor.owl.model.inference.OWLReasonerManagerImpl$1.run(OWLReasonerManagerImpl.java:237)
    java.lang.Thread.run(Unknown Source)


As a picture when i incorporated the plugin and i tried to push the only one button that the plugin has but nothing change at all.



Nick Drummond wrote
Afraid not. That is a very old version.
What plugin is it? Does the researcher who wrote it not have a version?

Nick

2009/7/21 mixalisfot <mixalisfot@gmail.com>:
>
> nobody????
>
>
>
>
>
> mixalisfot wrote:
>>
>> I am using the latest versions of protege to build ontologies. However i
>> found a tutorial and some plugins that from a researcher that run without
>> errors only in the version 4 alpha build 53. For this reason i didn't
>> backup
>> older versions. His version uses pelet reasoner and an owl api that the
>> other versions of protege lead to java errors. I am looking for this
>> version
>> because i want to complete my phd thesis with one chapter on semantic web
>> and specifically on protege.
>>
>> Thank you very much.
>>
>> On Wed, Jul 15, 2009 at 2:40 AM, Jennifer Vendetti
>> <vendetti@stanford.edu>wrote:
>>
>>> mixalisfot wrote:
>>>
>>>> I am looking for an older version of protege.  Specifically version 4
>>>> build 53. The older version that i found in downloads
>>>> area of standford is build 56 but i need immediately the former build.
>>>>
>>>>
>>>
>>> Usually we are good about keeping backup copies of old release and beta
>>> builds (and sometimes even alphas), but I can't find this one.  I think
>>> this
>>> was before we even had a platform independent installer and were just
>>> posting ZIP files.
>>>
>>> Nick - any possibility you have a copy of this build somewhere at
>>> Manchester?
>>>
>>> Jennifer
>>>
>>>
>>> _______________________________________________
>>> p4-feedback mailing list
>>> p4-feedback@lists.stanford.edu
>>> https://mailman.stanford.edu/mailman/listinfo/p4-feedback
>>>
>>
>> _______________________________________________
>> p4-feedback mailing list
>> p4-feedback@lists.stanford.edu
>> https://mailman.stanford.edu/mailman/listinfo/p4-feedback
>>
>>
>
> --
> View this message in context: http://www.nabble.com/protege4-build-53-tp24467296p24579134.html
> Sent from the Protege - Protege 4 Feedback mailing list archive at Nabble.com.
>
> _______________________________________________
> p4-feedback mailing list
> p4-feedback@lists.stanford.edu
> https://mailman.stanford.edu/mailman/listinfo/p4-feedback
>
_______________________________________________
p4-feedback mailing list
p4-feedback@lists.stanford.edu
https://mailman.stanford.edu/mailman/listinfo/p4-feedback
Reply | Threaded
Open this post in threaded view
|

Re: protege4 build 53

Rinke Hoekstra-4
Hi,

This is not a problem with the plugin, but with your ontology: it is  
inconsistent.

Try whether the plugin works for a very tiny and simple ontology?

-Rinke

On 22 jul 2009, at 16:46, mixalisfot wrote:

>
> it is a plugin made by hand in java...The author doesn't have  
> anymore this
> version.
>
> The error i get with the build 56 when i activate pellet as a  
> reasoner (for
> this reason i want 53) is the following:
>
> Error 1 Logged at Wed Jul 22 17:41:24 EEST 2009
> InconsistentOntologyException: Cannot do reasoning with inconsistent
> ontologies!
>
> org
> .mindswap.pellet.KnowledgeBase.ensureConsistency(KnowledgeBase.java:
> 1595)
>    org.mindswap.pellet.KnowledgeBase.classify(KnowledgeBase.java:1600)
>    org.mindswap.pellet.owlapi.Reasoner.classify(Reasoner.java:256)
>
> com
> .owldl
> .pellet.PelletReasonerWrapper.classify(PelletReasonerWrapper.java:63)
>
> org.protege.editor.owl.model.inference.OWLReasonerManagerImpl
> $1.run(OWLReasonerManagerImpl.java:237)
>    java.lang.Thread.run(Unknown Source)
>
>
> As a picture when i incorporated the plugin and i tried to push the  
> only one
> button that the plugin has but nothing change at all.
>
>
>
>
> Nick Drummond wrote:
>>
>> Afraid not. That is a very old version.
>> What plugin is it? Does the researcher who wrote it not have a  
>> version?
>>
>> Nick
>>
>> 2009/7/21 mixalisfot <[hidden email]>:
>>>
>>> nobody????
>>>
>>>
>>>
>>>
>>>
>>> mixalisfot wrote:
>>>>
>>>> I am using the latest versions of protege to build ontologies.  
>>>> However i
>>>> found a tutorial and some plugins that from a researcher that run
>>>> without
>>>> errors only in the version 4 alpha build 53. For this reason i  
>>>> didn't
>>>> backup
>>>> older versions. His version uses pelet reasoner and an owl api  
>>>> that the
>>>> other versions of protege lead to java errors. I am looking for  
>>>> this
>>>> version
>>>> because i want to complete my phd thesis with one chapter on  
>>>> semantic
>>>> web
>>>> and specifically on protege.
>>>>
>>>> Thank you very much.
>>>>
>>>> On Wed, Jul 15, 2009 at 2:40 AM, Jennifer Vendetti
>>>> <[hidden email]>wrote:
>>>>
>>>>> mixalisfot wrote:
>>>>>
>>>>>> I am looking for an older version of protege.  Specifically  
>>>>>> version 4
>>>>>> build 53. The older version that i found in downloads
>>>>>> area of standford is build 56 but i need immediately the former  
>>>>>> build.
>>>>>>
>>>>>>
>>>>>
>>>>> Usually we are good about keeping backup copies of old release  
>>>>> and beta
>>>>> builds (and sometimes even alphas), but I can't find this one.  
>>>>> I think
>>>>> this
>>>>> was before we even had a platform independent installer and were  
>>>>> just
>>>>> posting ZIP files.
>>>>>
>>>>> Nick - any possibility you have a copy of this build somewhere at
>>>>> Manchester?
>>>>>
>>>>> Jennifer
>>>>>
>>>>>
>>>>> _______________________________________________
>>>>> p4-feedback mailing list
>>>>> [hidden email]
>>>>> https://mailman.stanford.edu/mailman/listinfo/p4-feedback
>>>>>
>>>>
>>>> _______________________________________________
>>>> p4-feedback mailing list
>>>> [hidden email]
>>>> https://mailman.stanford.edu/mailman/listinfo/p4-feedback
>>>>
>>>>
>>>
>>> --
>>> View this message in context:
>>> http://www.nabble.com/protege4-build-53-tp24467296p24579134.html
>>> Sent from the Protege - Protege 4 Feedback mailing list archive at
>>> Nabble.com.
>>>
>>> _______________________________________________
>>> p4-feedback mailing list
>>> [hidden email]
>>> https://mailman.stanford.edu/mailman/listinfo/p4-feedback
>>>
>> _______________________________________________
>> p4-feedback mailing list
>> [hidden email]
>> https://mailman.stanford.edu/mailman/listinfo/p4-feedback
>>
>>
>
> --
> View this message in context: http://www.nabble.com/protege4-build-53-tp24467296p24607891.html
> Sent from the Protege - Protege 4 Feedback mailing list archive at  
> Nabble.com.
>
> _______________________________________________
> p4-feedback mailing list
> [hidden email]
> https://mailman.stanford.edu/mailman/listinfo/p4-feedback



---
Drs Rinke Hoekstra

Leibniz Center for Law      |  AI Department
Faculty of Law              |  Faculty of Sciences
Universiteit van Amsterdam  |  Vrije Universiteit
Kloveniersburgwal 48        |  De Boelelaan 1081a
1012 CX  Amsterdam          |  1081 HV Amsterdam
+31-(0)20-5253499           |  +31-(0)20-5987752
[hidden email]             |  [hidden email]

Homepage: http://www.leibnizcenter.org/users/rinke





_______________________________________________
p4-feedback mailing list
[hidden email]
https://mailman.stanford.edu/mailman/listinfo/p4-feedback
Reply | Threaded
Open this post in threaded view
|

Re: protege4 build 53

mixalisfot
ok i tried

the errors are the following

Error 17 Logged at Thu Jul 23 13:13:59 EEST 2009
NoClassDefFoundError: org/mindswap/pellet/owlapi/AxiomConverter
    revisor.Contraction.kernelMips(Contraction.java:226)
    revisor.Contraction.mips(Contraction.java:115)
    revisor.Revision.revision(Revision.java:69)
    revisor.ui.RevisionView.getAxioms(RevisionView.java:38)
    revisor.ui.KernelAction.actionPerformed(KernelAction.java:65)
    javax.swing.AbstractButton.fireActionPerformed(AbstractButton.java:2012)
    javax.swing.AbstractButton$Handler.actionPerformed(AbstractButton.java:2335)
    javax.swing.DefaultButtonModel.fireActionPerformed(DefaultButtonModel.java:404)
    javax.swing.DefaultButtonModel.setPressed(DefaultButtonModel.java:259)
    javax.swing.plaf.basic.BasicButtonListener.mouseReleased(BasicButtonListener.java:253)
    java.awt.Component.processMouseEvent(Component.java:6106)
    javax.swing.JComponent.processMouseEvent(JComponent.java:3276)
    java.awt.Component.processEvent(Component.java:5871)
    java.awt.Container.processEvent(Container.java:2105)
    java.awt.Component.dispatchEventImpl(Component.java:4467)
    java.awt.Container.dispatchEventImpl(Container.java:2163)
    java.awt.Component.dispatchEvent(Component.java:4293)
    java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4461)
    java.awt.LightweightDispatcher.processMouseEvent(Container.java:4125)
    java.awt.LightweightDispatcher.dispatchEvent(Container.java:4055)
    java.awt.Container.dispatchEventImpl(Container.java:2149)
    java.awt.Window.dispatchEventImpl(Window.java:2478)
    java.awt.Component.dispatchEvent(Component.java:4293)
    java.awt.EventQueue.dispatchEvent(EventQueue.java:604)
    java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:275)
    java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:200)
    java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:190)
    java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:185)
    java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:177)
    java.awt.EventDispatchThread.run(EventDispatchThread.java:138)



Rinke Hoekstra-4 wrote
Hi,

This is not a problem with the plugin, but with your ontology: it is  
inconsistent.

Try whether the plugin works for a very tiny and simple ontology?

-Rinke

On 22 jul 2009, at 16:46, mixalisfot wrote:

>
> it is a plugin made by hand in java...The author doesn't have  
> anymore this
> version.
>
> The error i get with the build 56 when i activate pellet as a  
> reasoner (for
> this reason i want 53) is the following:
>
> Error 1 Logged at Wed Jul 22 17:41:24 EEST 2009
> InconsistentOntologyException: Cannot do reasoning with inconsistent
> ontologies!
>
> org
> .mindswap.pellet.KnowledgeBase.ensureConsistency(KnowledgeBase.java:
> 1595)
>    org.mindswap.pellet.KnowledgeBase.classify(KnowledgeBase.java:1600)
>    org.mindswap.pellet.owlapi.Reasoner.classify(Reasoner.java:256)
>
> com
> .owldl
> .pellet.PelletReasonerWrapper.classify(PelletReasonerWrapper.java:63)
>
> org.protege.editor.owl.model.inference.OWLReasonerManagerImpl
> $1.run(OWLReasonerManagerImpl.java:237)
>    java.lang.Thread.run(Unknown Source)
>
>
> As a picture when i incorporated the plugin and i tried to push the  
> only one
> button that the plugin has but nothing change at all.
>
>
>
>
> Nick Drummond wrote:
>>
>> Afraid not. That is a very old version.
>> What plugin is it? Does the researcher who wrote it not have a  
>> version?
>>
>> Nick
>>
>> 2009/7/21 mixalisfot <mixalisfot@gmail.com>:
>>>
>>> nobody????
>>>
>>>
>>>
>>>
>>>
>>> mixalisfot wrote:
>>>>
>>>> I am using the latest versions of protege to build ontologies.  
>>>> However i
>>>> found a tutorial and some plugins that from a researcher that run
>>>> without
>>>> errors only in the version 4 alpha build 53. For this reason i  
>>>> didn't
>>>> backup
>>>> older versions. His version uses pelet reasoner and an owl api  
>>>> that the
>>>> other versions of protege lead to java errors. I am looking for  
>>>> this
>>>> version
>>>> because i want to complete my phd thesis with one chapter on  
>>>> semantic
>>>> web
>>>> and specifically on protege.
>>>>
>>>> Thank you very much.
>>>>
>>>> On Wed, Jul 15, 2009 at 2:40 AM, Jennifer Vendetti
>>>> <vendetti@stanford.edu>wrote:
>>>>
>>>>> mixalisfot wrote:
>>>>>
>>>>>> I am looking for an older version of protege.  Specifically  
>>>>>> version 4
>>>>>> build 53. The older version that i found in downloads
>>>>>> area of standford is build 56 but i need immediately the former  
>>>>>> build.
>>>>>>
>>>>>>
>>>>>
>>>>> Usually we are good about keeping backup copies of old release  
>>>>> and beta
>>>>> builds (and sometimes even alphas), but I can't find this one.  
>>>>> I think
>>>>> this
>>>>> was before we even had a platform independent installer and were  
>>>>> just
>>>>> posting ZIP files.
>>>>>
>>>>> Nick - any possibility you have a copy of this build somewhere at
>>>>> Manchester?
>>>>>
>>>>> Jennifer
>>>>>
>>>>>
>>>>> _______________________________________________
>>>>> p4-feedback mailing list
>>>>> p4-feedback@lists.stanford.edu
>>>>> https://mailman.stanford.edu/mailman/listinfo/p4-feedback
>>>>>
>>>>
>>>> _______________________________________________
>>>> p4-feedback mailing list
>>>> p4-feedback@lists.stanford.edu
>>>> https://mailman.stanford.edu/mailman/listinfo/p4-feedback
>>>>
>>>>
>>>
>>> --
>>> View this message in context:
>>> http://www.nabble.com/protege4-build-53-tp24467296p24579134.html
>>> Sent from the Protege - Protege 4 Feedback mailing list archive at
>>> Nabble.com.
>>>
>>> _______________________________________________
>>> p4-feedback mailing list
>>> p4-feedback@lists.stanford.edu
>>> https://mailman.stanford.edu/mailman/listinfo/p4-feedback
>>>
>> _______________________________________________
>> p4-feedback mailing list
>> p4-feedback@lists.stanford.edu
>> https://mailman.stanford.edu/mailman/listinfo/p4-feedback
>>
>>
>
> --
> View this message in context: http://www.nabble.com/protege4-build-53-tp24467296p24607891.html
> Sent from the Protege - Protege 4 Feedback mailing list archive at  
> Nabble.com.
>
> _______________________________________________
> p4-feedback mailing list
> p4-feedback@lists.stanford.edu
> https://mailman.stanford.edu/mailman/listinfo/p4-feedback



---
Drs Rinke Hoekstra

Leibniz Center for Law      |  AI Department
Faculty of Law              |  Faculty of Sciences
Universiteit van Amsterdam  |  Vrije Universiteit
Kloveniersburgwal 48        |  De Boelelaan 1081a
1012 CX  Amsterdam          |  1081 HV Amsterdam
+31-(0)20-5253499           |  +31-(0)20-5987752
hoekstra@uva.nl             |  hoekstra@few.vu.nl

Homepage: http://www.leibnizcenter.org/users/rinke





_______________________________________________
p4-feedback mailing list
p4-feedback@lists.stanford.edu
https://mailman.stanford.edu/mailman/listinfo/p4-feedback
Reply | Threaded
Open this post in threaded view
|

Re: protege4 build 53

Nick Drummond
Hi,

It is possible that you just need a very old version of pellet.
But the likelyhood is this will have lots of bugs not present in the
current release.

The oldest pellet libraries I can find on the svn are at [1]. You
could try a checkout of these but I can't guarantee anything.

I assume the plugin developer is not able to update the plugin to the
most recent codebase?

Nick


[1] http://smi-protege.stanford.edu/svn/protege4/protege-standalone/trunk/plugins/com.owldl.pellet/lib/?rev=6541


2009/7/23 mixalisfot <[hidden email]>:

>
> ok i tried
>
> the errors are the following
>
> Error 17 Logged at Thu Jul 23 13:13:59 EEST 2009
> NoClassDefFoundError: org/mindswap/pellet/owlapi/AxiomConverter
>    revisor.Contraction.kernelMips(Contraction.java:226)
>    revisor.Contraction.mips(Contraction.java:115)
>    revisor.Revision.revision(Revision.java:69)
>    revisor.ui.RevisionView.getAxioms(RevisionView.java:38)
>    revisor.ui.KernelAction.actionPerformed(KernelAction.java:65)
>    javax.swing.AbstractButton.fireActionPerformed(AbstractButton.java:2012)
>
> javax.swing.AbstractButton$Handler.actionPerformed(AbstractButton.java:2335)
>
> javax.swing.DefaultButtonModel.fireActionPerformed(DefaultButtonModel.java:404)
>    javax.swing.DefaultButtonModel.setPressed(DefaultButtonModel.java:259)
>
> javax.swing.plaf.basic.BasicButtonListener.mouseReleased(BasicButtonListener.java:253)
>    java.awt.Component.processMouseEvent(Component.java:6106)
>    javax.swing.JComponent.processMouseEvent(JComponent.java:3276)
>    java.awt.Component.processEvent(Component.java:5871)
>    java.awt.Container.processEvent(Container.java:2105)
>    java.awt.Component.dispatchEventImpl(Component.java:4467)
>    java.awt.Container.dispatchEventImpl(Container.java:2163)
>    java.awt.Component.dispatchEvent(Component.java:4293)
>    java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4461)
>    java.awt.LightweightDispatcher.processMouseEvent(Container.java:4125)
>    java.awt.LightweightDispatcher.dispatchEvent(Container.java:4055)
>    java.awt.Container.dispatchEventImpl(Container.java:2149)
>    java.awt.Window.dispatchEventImpl(Window.java:2478)
>    java.awt.Component.dispatchEvent(Component.java:4293)
>    java.awt.EventQueue.dispatchEvent(EventQueue.java:604)
>
> java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:275)
>
> java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:200)
>
> java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:190)
>    java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:185)
>    java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:177)
>    java.awt.EventDispatchThread.run(EventDispatchThread.java:138)
>
>
>
>
> Rinke Hoekstra-4 wrote:
>>
>> Hi,
>>
>> This is not a problem with the plugin, but with your ontology: it is
>> inconsistent.
>>
>> Try whether the plugin works for a very tiny and simple ontology?
>>
>> -Rinke
>>
>> On 22 jul 2009, at 16:46, mixalisfot wrote:
>>
>>>
>>> it is a plugin made by hand in java...The author doesn't have
>>> anymore this
>>> version.
>>>
>>> The error i get with the build 56 when i activate pellet as a
>>> reasoner (for
>>> this reason i want 53) is the following:
>>>
>>> Error 1 Logged at Wed Jul 22 17:41:24 EEST 2009
>>> InconsistentOntologyException: Cannot do reasoning with inconsistent
>>> ontologies!
>>>
>>> org
>>> .mindswap.pellet.KnowledgeBase.ensureConsistency(KnowledgeBase.java:
>>> 1595)
>>>    org.mindswap.pellet.KnowledgeBase.classify(KnowledgeBase.java:1600)
>>>    org.mindswap.pellet.owlapi.Reasoner.classify(Reasoner.java:256)
>>>
>>> com
>>> .owldl
>>> .pellet.PelletReasonerWrapper.classify(PelletReasonerWrapper.java:63)
>>>
>>> org.protege.editor.owl.model.inference.OWLReasonerManagerImpl
>>> $1.run(OWLReasonerManagerImpl.java:237)
>>>    java.lang.Thread.run(Unknown Source)
>>>
>>>
>>> As a picture when i incorporated the plugin and i tried to push the
>>> only one
>>> button that the plugin has but nothing change at all.
>>>
>>>
>>>
>>>
>>> Nick Drummond wrote:
>>>>
>>>> Afraid not. That is a very old version.
>>>> What plugin is it? Does the researcher who wrote it not have a
>>>> version?
>>>>
>>>> Nick
>>>>
>>>> 2009/7/21 mixalisfot <[hidden email]>:
>>>>>
>>>>> nobody????
>>>>>
>>>>>
>>>>>
>>>>>
>>>>>
>>>>> mixalisfot wrote:
>>>>>>
>>>>>> I am using the latest versions of protege to build ontologies.
>>>>>> However i
>>>>>> found a tutorial and some plugins that from a researcher that run
>>>>>> without
>>>>>> errors only in the version 4 alpha build 53. For this reason i
>>>>>> didn't
>>>>>> backup
>>>>>> older versions. His version uses pelet reasoner and an owl api
>>>>>> that the
>>>>>> other versions of protege lead to java errors. I am looking for
>>>>>> this
>>>>>> version
>>>>>> because i want to complete my phd thesis with one chapter on
>>>>>> semantic
>>>>>> web
>>>>>> and specifically on protege.
>>>>>>
>>>>>> Thank you very much.
>>>>>>
>>>>>> On Wed, Jul 15, 2009 at 2:40 AM, Jennifer Vendetti
>>>>>> <[hidden email]>wrote:
>>>>>>
>>>>>>> mixalisfot wrote:
>>>>>>>
>>>>>>>> I am looking for an older version of protege.  Specifically
>>>>>>>> version 4
>>>>>>>> build 53. The older version that i found in downloads
>>>>>>>> area of standford is build 56 but i need immediately the former
>>>>>>>> build.
>>>>>>>>
>>>>>>>>
>>>>>>>
>>>>>>> Usually we are good about keeping backup copies of old release
>>>>>>> and beta
>>>>>>> builds (and sometimes even alphas), but I can't find this one.
>>>>>>> I think
>>>>>>> this
>>>>>>> was before we even had a platform independent installer and were
>>>>>>> just
>>>>>>> posting ZIP files.
>>>>>>>
>>>>>>> Nick - any possibility you have a copy of this build somewhere at
>>>>>>> Manchester?
>>>>>>>
>>>>>>> Jennifer
>>>>>>>
>>>>>>>
>>>>>>> _______________________________________________
>>>>>>> p4-feedback mailing list
>>>>>>> [hidden email]
>>>>>>> https://mailman.stanford.edu/mailman/listinfo/p4-feedback
>>>>>>>
>>>>>>
>>>>>> _______________________________________________
>>>>>> p4-feedback mailing list
>>>>>> [hidden email]
>>>>>> https://mailman.stanford.edu/mailman/listinfo/p4-feedback
>>>>>>
>>>>>>
>>>>>
>>>>> --
>>>>> View this message in context:
>>>>> http://www.nabble.com/protege4-build-53-tp24467296p24579134.html
>>>>> Sent from the Protege - Protege 4 Feedback mailing list archive at
>>>>> Nabble.com.
>>>>>
>>>>> _______________________________________________
>>>>> p4-feedback mailing list
>>>>> [hidden email]
>>>>> https://mailman.stanford.edu/mailman/listinfo/p4-feedback
>>>>>
>>>> _______________________________________________
>>>> p4-feedback mailing list
>>>> [hidden email]
>>>> https://mailman.stanford.edu/mailman/listinfo/p4-feedback
>>>>
>>>>
>>>
>>> --
>>> View this message in context:
>>> http://www.nabble.com/protege4-build-53-tp24467296p24607891.html
>>> Sent from the Protege - Protege 4 Feedback mailing list archive at
>>> Nabble.com.
>>>
>>> _______________________________________________
>>> p4-feedback mailing list
>>> [hidden email]
>>> https://mailman.stanford.edu/mailman/listinfo/p4-feedback
>>
>>
>>
>> ---
>> Drs Rinke Hoekstra
>>
>> Leibniz Center for Law      |  AI Department
>> Faculty of Law              |  Faculty of Sciences
>> Universiteit van Amsterdam  |  Vrije Universiteit
>> Kloveniersburgwal 48        |  De Boelelaan 1081a
>> 1012 CX  Amsterdam          |  1081 HV Amsterdam
>> +31-(0)20-5253499           |  +31-(0)20-5987752
>> [hidden email]             |  [hidden email]
>>
>> Homepage: http://www.leibnizcenter.org/users/rinke
>>
>>
>>
>>
>>
>> _______________________________________________
>> p4-feedback mailing list
>> [hidden email]
>> https://mailman.stanford.edu/mailman/listinfo/p4-feedback
>>
>>
>
> --
> View this message in context: http://www.nabble.com/protege4-build-53-tp24467296p24622935.html
> Sent from the Protege - Protege 4 Feedback mailing list archive at Nabble.com.
>
> _______________________________________________
> p4-feedback mailing list
> [hidden email]
> https://mailman.stanford.edu/mailman/listinfo/p4-feedback
>
_______________________________________________
p4-feedback mailing list
[hidden email]
https://mailman.stanford.edu/mailman/listinfo/p4-feedback
Reply | Threaded
Open this post in threaded view
|

Re: protege4 build 53

mixalisfot
hi

it's still impossible. The errors remain. The developer told me (in an old conversation) that the only way to fix the problem is to find the version 53. He couldn't help me anymore (update the plugin). This plugin refers to the ontology revision (supported with belief change methods).

michael

On Sat, Oct 10, 2009 at 12:46 AM, Nick Drummond (via Nabble) <[hidden email]> wrote:
Hi,

It is possible that you just need a very old version of pellet.
But the likelyhood is this will have lots of bugs not present in the
current release.

The oldest pellet libraries I can find on the svn are at [1]. You
could try a checkout of these but I can't guarantee anything.

I assume the plugin developer is not able to update the plugin to the
most recent codebase?

Nick


[1] http://smi-protege.stanford.edu/svn/protege4/protege-standalone/trunk/plugins/com.owldl.pellet/lib/?rev=6541


2009/7/23 mixalisfot <[hidden email]>:

>
> ok i tried
>
> the errors are the following
>
> Error 17 Logged at Thu Jul 23 13:13:59 EEST 2009
> NoClassDefFoundError: org/mindswap/pellet/owlapi/AxiomConverter
>    revisor.Contraction.kernelMips(Contraction.java:226)
>    revisor.Contraction.mips(Contraction.java:115)
>    revisor.Revision.revision(Revision.java:69)
>    revisor.ui.RevisionView.getAxioms(RevisionView.java:38)
>    revisor.ui.KernelAction.actionPerformed(KernelAction.java:65)
>    javax.swing.AbstractButton.fireActionPerformed(AbstractButton.java:2012)
>
> javax.swing.AbstractButton$Handler.actionPerformed(AbstractButton.java:2335)
>
> javax.swing.DefaultButtonModel.fireActionPerformed(DefaultButtonModel.java:404)
>    javax.swing.DefaultButtonModel.setPressed(DefaultButtonModel.java:259)
>
> javax.swing.plaf.basic.BasicButtonListener.mouseReleased(BasicButtonListener.java:253)
>    java.awt.Component.processMouseEvent(Component.java:6106)
>    javax.swing.JComponent.processMouseEvent(JComponent.java:3276)
>    java.awt.Component.processEvent(Component.java:5871)
>    java.awt.Container.processEvent(Container.java:2105)
>    java.awt.Component.dispatchEventImpl(Component.java:4467)
>    java.awt.Container.dispatchEventImpl(Container.java:2163)
>    java.awt.Component.dispatchEvent(Component.java:4293)
>    java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4461)
>    java.awt.LightweightDispatcher.processMouseEvent(Container.java:4125)
>    java.awt.LightweightDispatcher.dispatchEvent(Container.java:4055)
>    java.awt.Container.dispatchEventImpl(Container.java:2149)
>    java.awt.Window.dispatchEventImpl(Window.java:2478)
>    java.awt.Component.dispatchEvent(Component.java:4293)
>    java.awt.EventQueue.dispatchEvent(EventQueue.java:604)
>
> java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:275)
>
> java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:200)
>
> java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:190)
>    java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:185)
>    java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:177)
>    java.awt.EventDispatchThread.run(EventDispatchThread.java:138)
>

>
>
>
> Rinke Hoekstra-4 wrote:
>>
>> Hi,
>>
>> This is not a problem with the plugin, but with your ontology: it is
>> inconsistent.
>>
>> Try whether the plugin works for a very tiny and simple ontology?
>>
>> -Rinke
>>
>> On 22 jul 2009, at 16:46, mixalisfot wrote:
>>
>>>
>>> it is a plugin made by hand in java...The author doesn't have
>>> anymore this
>>> version.
>>>
>>> The error i get with the build 56 when i activate pellet as a
>>> reasoner (for
>>> this reason i want 53) is the following:
>>>
>>> Error 1 Logged at Wed Jul 22 17:41:24 EEST 2009
>>> InconsistentOntologyException: Cannot do reasoning with inconsistent
>>> ontologies!
>>>
>>> org
>>> .mindswap.pellet.KnowledgeBase.ensureConsistency(KnowledgeBase.java:
>>> 1595)
>>>    org.mindswap.pellet.KnowledgeBase.classify(KnowledgeBase.java:1600)
>>>    org.mindswap.pellet.owlapi.Reasoner.classify(Reasoner.java:256)
>>>
>>> com
>>> .owldl
>>> .pellet.PelletReasonerWrapper.classify(PelletReasonerWrapper.java:63)
>>>
>>> org.protege.editor.owl.model.inference.OWLReasonerManagerImpl
>>> $1.run(OWLReasonerManagerImpl.java:237)
>>>    java.lang.Thread.run(Unknown Source)
>>>
>>>
>>> As a picture when i incorporated the plugin and i tried to push the
>>> only one
>>> button that the plugin has but nothing change at all.
>>>
>>>
>>>
>>>
>>> Nick Drummond wrote:
>>>>
>>>> Afraid not. That is a very old version.
>>>> What plugin is it? Does the researcher who wrote it not have a
>>>> version?
>>>>
>>>> Nick
>>>>
>>>> 2009/7/21 mixalisfot <[hidden email]>:
>>>>>
>>>>> nobody????
>>>>>
>>>>>
>>>>>
>>>>>
>>>>>
>>>>> mixalisfot wrote:
>>>>>>
>>>>>> I am using the latest versions of protege to build ontologies.
>>>>>> However i
>>>>>> found a tutorial and some plugins that from a researcher that run
>>>>>> without
>>>>>> errors only in the version 4 alpha build 53. For this reason i
>>>>>> didn't
>>>>>> backup
>>>>>> older versions. His version uses pelet reasoner and an owl api
>>>>>> that the
>>>>>> other versions of protege lead to java errors. I am looking for
>>>>>> this
>>>>>> version
>>>>>> because i want to complete my phd thesis with one chapter on
>>>>>> semantic
>>>>>> web
>>>>>> and specifically on protege.
>>>>>>
>>>>>> Thank you very much.
>>>>>>
>>>>>> On Wed, Jul 15, 2009 at 2:40 AM, Jennifer Vendetti
>>>>>> <[hidden email]>wrote:
>>>>>>
>>>>>>> mixalisfot wrote:
>>>>>>>
>>>>>>>> I am looking for an older version of protege.  Specifically
>>>>>>>> version 4
>>>>>>>> build 53. The older version that i found in downloads
>>>>>>>> area of standford is build 56 but i need immediately the former
>>>>>>>> build.
>>>>>>>>
>>>>>>>>
>>>>>>>
>>>>>>> Usually we are good about keeping backup copies of old release
>>>>>>> and beta
>>>>>>> builds (and sometimes even alphas), but I can't find this one.
>>>>>>> I think
>>>>>>> this
>>>>>>> was before we even had a platform independent installer and were
>>>>>>> just
>>>>>>> posting ZIP files.
>>>>>>>
>>>>>>> Nick - any possibility you have a copy of this build somewhere at
>>>>>>> Manchester?
>>>>>>>
>>>>>>> Jennifer
>>>>>>>
>>>>>>>
>>>>>>> _______________________________________________
>>>>>>> p4-feedback mailing list
>>>>>>> [hidden email]
>>>>>>> https://mailman.stanford.edu/mailman/listinfo/p4-feedback
>>>>>>>
>>>>>>
>>>>>> _______________________________________________
>>>>>> p4-feedback mailing list
>>>>>> [hidden email]
>>>>>> https://mailman.stanford.edu/mailman/listinfo/p4-feedback
>>>>>>
>>>>>>
>>>>>
>>>>> --
>>>>> View this message in context:
>>>>> http://www.nabble.com/protege4-build-53-tp24467296p24579134.html
>>>>> Sent from the Protege - Protege 4 Feedback mailing list archive at
>>>>> Nabble.com.
>>>>>
>>>>> _______________________________________________
>>>>> p4-feedback mailing list
>>>>> [hidden email]
>>>>> https://mailman.stanford.edu/mailman/listinfo/p4-feedback
>>>>>
>>>> _______________________________________________
>>>> p4-feedback mailing list
>>>> [hidden email]
>>>> https://mailman.stanford.edu/mailman/listinfo/p4-feedback
>>>>
>>>>
>>>
>>> --
>>> View this message in context:
>>> http://www.nabble.com/protege4-build-53-tp24467296p24607891.html
>>> Sent from the Protege - Protege 4 Feedback mailing list archive at
>>> Nabble.com.
>>>
>>> _______________________________________________
>>> p4-feedback mailing list
>>> [hidden email]
>>> https://mailman.stanford.edu/mailman/listinfo/p4-feedback
>>
>>
>>
>> ---
>> Drs Rinke Hoekstra
>>
>> Leibniz Center for Law      |  AI Department
>> Faculty of Law              |  Faculty of Sciences
>> Universiteit van Amsterdam  |  Vrije Universiteit
>> Kloveniersburgwal 48        |  De Boelelaan 1081a
>> 1012 CX  Amsterdam          |  1081 HV Amsterdam
>> +31-(0)20-5253499           |  +31-(0)20-5987752
>> [hidden email]             |  [hidden email]
>>
>> Homepage: http://www.leibnizcenter.org/users/rinke
>>
>>
>>
>>
>>
>> _______________________________________________
>> p4-feedback mailing list
>> [hidden email]
>> https://mailman.stanford.edu/mailman/listinfo/p4-feedback
>>
>>
>
> --
> View this message in context: http://www.nabble.com/protege4-build-53-tp24467296p24622935.html

> Sent from the Protege - Protege 4 Feedback mailing list archive at Nabble.com.
>
> _______________________________________________
> p4-feedback mailing list
> [hidden email]
> https://mailman.stanford.edu/mailman/listinfo/p4-feedback
>
_______________________________________________
p4-feedback mailing list
[hidden email]
https://mailman.stanford.edu/mailman/listinfo/p4-feedback



View message @ http://n4.nabble.com/protege4-build-53-tp22770p22778.html
To unsubscribe from Re: protege4 build 53, click here.