svn check out Protege4.1.0

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

svn check out Protege4.1.0

wenxinhu
Hello! I want to build Protege4.1.0 in eclipse. I've checked out protege project from here: http://smi-protege.stanford.edu/repos/protege/protege4/ide/eclipse/protege4.1/trunk/ But then after building the project the version of the protegeLauncher is 4.3.0. How can i get the correct version of 4.1.0? Anyone can help me ? Thanks a lot!!!
Reply | Threaded
Open this post in threaded view
|

Re: svn check out Protege4.1.0

Matthew Horridge-2
Administrator
Hi,

Is there a reason why you want to build such an old version of Protege?  You should use 5.2.0 if possible.  Instructions for building in eclipse can be found here:


Cheers,

Matthew




On 5 Jun 2017, at 11:11, wenxinhu <[hidden email]> wrote:

Hello! I want to build Protege4.1.0 in eclipse. I've checked out protege
project from here:
http://smi-protege.stanford.edu/repos/protege/protege4/ide/eclipse/protege4.1/trunk/
<http://smi-protege.stanford.edu/repos/protege/protege4/ide/eclipse/protege4.1/trunk/>  
But then after building the project the version of the protegeLauncher is
4.3.0. How can i get the correct version of 4.1.0? Anyone can help me ?
Thanks a lot!!!



--
View this message in context: http://protege-project.136.n4.nabble.com/svn-check-out-Protege4-1-0-tp4668714.html
Sent from the Protege Developer mailing list archive at Nabble.com.
_______________________________________________
protege-dev mailing list
[hidden email]
https://mailman.stanford.edu/mailman/listinfo/protege-dev


_______________________________________________
protege-dev mailing list
[hidden email]
https://mailman.stanford.edu/mailman/listinfo/protege-dev
Reply | Threaded
Open this post in threaded view
|

Re: svn check out Protege4.1.0

wenxinhu
Thanks for your reply. I want to use the Plugin Skoseditor to build SKOS-Vocabulary and it's only perfectly compatible with version4.1.0.
So maybe it's possible to build 4.2.0 in eclipse? Thanks a lot!
Reply | Threaded
Open this post in threaded view
|

Re: svn check out Protege4.1.0

Tania Tudorache


Do you want to change the plugin source code or just build the plugin?


In any case here are some developer documentation for Protege 4.1 including building instructions:

https://protegewiki.stanford.edu/wiki/Protege4DevDocs


If you follow the instructions for building in Eclipse (https://protegewiki.stanford.edu/wiki/CompileProtege4InEclipseFromSvn) you will see that there are tags in the SVN for particular releases, including 4.1.


Good luck!

Tania




From: protege-dev <[hidden email]> on behalf of wenxinhu <[hidden email]>
Sent: Tuesday, June 6, 2017 10:57:07 PM
To: [hidden email]
Subject: Re: [protege-dev] svn check out Protege4.1.0
 
Thanks for your reply. I want to use the Plugin Skoseditor to build
SKOS-Vocabulary and it's only perfectly compatible with version4.1.0.
So maybe it's possible to build 4.2.0 in eclipse? Thanks a lot!



--
View this message in context: http://protege-project.136.n4.nabble.com/svn-check-out-Protege4-1-0-tp4668714p4668733.html
Sent from the Protege Developer mailing list archive at Nabble.com.
_______________________________________________
protege-dev mailing list
[hidden email]
https://mailman.stanford.edu/mailman/listinfo/protege-dev

_______________________________________________
protege-dev mailing list
[hidden email]
https://mailman.stanford.edu/mailman/listinfo/protege-dev